IP : 串行隧道 (STUN)

在BSTUN中建立异步协议隧道配置示例

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

专用和本地异步协议不直接地支持与任何Cisco实施。然而, Block Serial Tunnel (BSTUN)异步通用建立隧道能提供有限能力建立隧道此数据。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档中的信息基于以下软件和硬件版本:

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

背景信息

异步协议例如通信的Diebold's TC500对金钱ATM或从PC的隧道超级终端到另一个PC没有直接支持或实施在Cisco IOS ï ¿  ½。因为名称暗示,这是有若干功能传送此种数据的一个通用的实施。这叫作BSTUN异步通用,并且要求IBM或企业IOS功能集。

BSTUN异步通用最初设计传送从安全设备的单向,小数据包到报告的设备。BSTUN异步通用,然而,能运载交互式数据流。实质上,此实施附加到本地,异步设备并且接收数据到serial interfaces然后到存储器缓冲区。周期地,缓冲的数据然后被封装到TCP数据包并且发送给被解封装并且发送到异步设备附加在远程站点的BSTUN对等体。

BSTUN异步通用是一单纯化的操作。路由器没有功能配置有开始帧(SOF),末端帧(EOF),或者异步协议的编址模式的知识。如果帧的地址部分是在每帧,是一字节长,并且是帧的相同地点,则asp address-offset命令在哪里可以发出指定到路由器查找在帧的地址,作为实例后在本文。在许多情况下,然而,将没有地址部分包含到协议。不了解异步协议建筑意味着路由器无法辩明从其他的单个数据包,如果他们没有在时间之前分离。大约40毫秒要求在9600位/秒的帧之间提供路由器足够的时间适当地辩明从别的一数据包。路由器看到一个数据流到它里是serial interfaces然后包裹此数据到TCP。没有路由器能做出路由决策根据流入的帧的所有单个方面的可能性。因此, BSTUN异步通用必须是物理的设计的那么仅一个设备随员到路由器串行接口。没有本地确认功能。local-ack BSTUN支持IBM3270仅双同步协议的。

配置

本部分提供有关如何配置本文档所述功能的信息。

网络图

本文档使用此图所示的网络设置。

/image/gif/paws/41983/bstun_41983-A.gif

两仅供PC使用Microsoft的超级终端或在一个PCs位置能是连接到Cisco路由器的控制台端口。这些配置示例代表从路由器实现的配置不以前配置在实验室情形,并且显示需要的配置的相关部分。配置假设一9600 bit/sec的这些, 8N1连接。

配置

本文使用在此部分显示的配置。

  • 主要路由器(Cisco 1700路由器)

  • 远程路由器(Cisco 3640路由器)

  • 主要路由器(Cisco 3600路由器)

  • 远程#1 (Cisco 1700路由器)

  • 远程#2 (Cisco 1700路由器)

主要路由器(Cisco 1700路由器)
main#show running-config 
Building configuration...
.
.
.
ip subnet-zero
bstun peer-name 10.1.1.1
bstun protocol-group 1 async-generic
interface loopback0
   ip address 10.1.1.1 255.0.0.0
interface serial0
   physical-layer async
   encapsulation bstun
   asp role secondary
   bstun group 1
   bstun route all tcp 30.1.1.1
interface serial1
   ip address 20.1.1.1 255.0.0.0
ip route 0.0.0.0 0.0.0.0 20.1.1.2
line 1
   speed 9600
   databits 8
   parity none
   stopbits 1
.
.
.
!
end

远程路由器(Cisco 3640路由器)
REMOTE#show running-config 
Building configuration...
bstun peer-name 30.1.1.1.
bstun protocol-group 1 async-generic
interface loopback 0
   ip address 30.1.1.1
interface ethernet1/0
   shutdown
interface serial 2/0
   physical-layer async
   encapsulation bstun
   asp role primary
   bstun group 1
   bstun route all tcp 10.1.1.1
   
interface serial 2/1
   ip address 20.1.1.2 255.0.0.0
ip route 0.0.0.0 0.0.0.0 20.1.1.1
line 65
   speed 9600
   parity none
   databits 8
   stopbits 1
.
.
!
end

注意: 当您发出physical-layer async命令在serial interfaces时, TTY线路分配到serial interfaces。此TTY线路定义是数据位、停止位、奇偶校验和速度配置的地方。这是确定哪条的公式线路对应与哪serial interfaces。

line-= (slot- x 32) + interface- + 1

show line在远程路由器配置输出中在最右端列指示对应的线路行号。Serial2/0由线路65代表,并且此链路的物理定义配置在线路65下

REMOTE#sh line 
   Tty Typ     Tx/Rx        A Modem  Roty AccO AccI   Uses   Noise  Overruns   Int 
*    0 CTY                      -        -          -        -        -          0           0         0/0           - 
    65 TTY   9600/9600  -        -          -        -        -      0           0         0/0     Se2/0 
   129 AUX 9600/9600  -        -          -        -        -        0           0         0/0       - 
   130 VTY                     -        -          -        -        -          0           0         0/0       - 
   131 VTY                     -        -          -        -        -          0           0         0/0       - 
   132 VTY                     -        -          -        -        -          0           0         0/0       - 
   133 VTY                     -        -          -        -        -          0           0         0/0       - 
   134 VTY                     -        -          -        -        -          0           0         0/0       - 

Line(s) not in async mode -or- with no hardware support: 
1-64, 66-128 

在此方案中, Tandem与远程ATM设备联络。在此配置示例中,异步协议运行一份4800个7E2协议,并且主要路由器连接对TANDEM是3600系列路由器到远程1700系列路由器。请参阅此网络图。

bstun_41983-B.gif

主要路由器(Cisco 3600路由器)
main#show running-config 
Building configuration...
bstun peer-name 10.1.1.1.
bstun protocol-group 1 async-generic
bstun protocol-group 2 async-generic
interface loopback 0
   ip address 10.1.1.1
interface serial1/0
   encapsulation frame-relay
interface serial 1/0.1 point-to-point
   ip address 20.1.1.1 255.255.255.0
   frame-relay interface-dlci 100
interface serial 1/0.2 point-to-point
   ip address 20.2.1.1 255.255.255.0
   frame-relay interface-dlci 200
interface serial 2/0
   physical-layer async
   encapsulation bstun
   asp role secondary
   bstun group 1
   bstun route all tcp 30.1.1.1
   
interface serial 2/1
 physical-layer async
   encapsulation bstun
   asp role secondary
   bstun group 2
   bstun route all tcp 30.2.1.1
   
ip route 30.2.1.0 255.255.0.0 20.2.1.2
ip route 0.0.0.0 0.0.0.0 20.1.1.2
line 65
   speed 4800
   parity even
   databits 7
   stopbits 1
.
line 66
   speed 4800
   parity even
   databits 7
   stopbits 1
.
!
end

远程#1 (Cisco 1700路由器)
REMOTE1#show running-config 
Building configuration...
bstun peer-name 30.1.1.1
bstun protocol-group 1 async-generic
interface loopback0
   ip address 30.1.1.1 255.255.0.0
interface serial0
   physical-layer async
   encapsulation bstun
   asp role primary
   bstun group 1
   bstun route all tcp 10.1.1.1
interface serial1
   encapsulation frame-relay
interface serial1.1 point-to-point
   ip address 20.1.1.2 255.255.255.0
   frame-relay interface-dlci 100
ip route 0.0.0.0 0.0.0.0 20.1.1.1
line 1
   speed 4800
   databits 7
   parity even
   stopbits 2
.
.
.
!
end

远程#2 (Cisco 1700路由器)
REMOTE2#show running-config
Building configuration...
bstun peer-name 30.2.1.1
bstun protocol-group 2 async-generic
interface loopback0
   ip address 30.2.1.1 255.255.0.0
interface serial0
   physical-layer async
   encapsulation bstun
   asp role primary
   bstun group 2
   bstun route all tcp 10.1.1.1
interface serial1
   encapsulation frame-relay
interface serial1.1 point-to-point
   ip address 20.2.1.2 255.255.255.0
   frame-relay interface-dlci 100
ip route 0.0.0.0 0.0.0.0 20.2.1.1
line 1
   speed 4800
   databits 7
   parity even
   stopbits 2
.
.
.
!
end

验证

当前没有可用于此配置的验证过程。

故障排除

bstun route all tcp命令发出时, BSTUN收到数据包到serial interfaces,封装它,并且发送此TCP数据包到远程路由器。TCP数据包接收在远程路由器并且是已解封的。数据在serial interfaces被派出。如果此连接不工作,必须用debug asp packet首先验证流入的数据。您看到在serial interfaces的路由器接收的数据。因为路由器没有协议建筑和变化根据异步协议,没有提供示例调试。路由器看到的数据流必须匹配什么由设备发送。如果它不配比非常可能速度、数据位、奇偶校验或者停止位没有配置匹配设备。如果数据没有接收,这可以是实际情形。

如果数据在serial interfaces接收,请发出show bstun命令为了显示,如果连接开放或已关闭。打开状态用传送的仅数据包指示TCP发送给远程BSTUN对等体。这时,如果IP配置和工作正常,从本地BSTUN对等名称的IP地址的ping测试对远程BSTUN对等名称IP地址的验证。如果PING测试是成功的,则在远程,请发出debug asp packet命令为了确定数据包是否接收并且发送在serial interfaces上到异步设备。

完成这些步骤为了排除故障。

  1. 验证数据接收到主机路由器用debug asp packet命令

  2. 保证与ping测试来源补充ping的IP连通性从bstun对等名称IP地址到远程BSTUN对等名称的远程IP地址。

  3. 在远程,请验证数据包被发送到远程设备用debug asp packet命令

  4. 如果异步协议有在发送的数据包包含的一个地址对路由器,发出asp offset-address命令在接口下用相应地址在数据包包含的适当的字节编号与可以是有利的。此的默认值例如是0。,如果数据包是01C1ABCDEF, C1是地址, serial interfaces可以用asp offset-address 01命令配置。有时,这允许路由器识别数据包并且增加可能性路由器处理数据作为一成帧的数据包和不正数据流。


相关信息


Document ID: 41983