IP : IP 组播

如何实施集合点的一个过滤策略

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 27 日) | 反馈


目录


简介

本文解释如何实现集合点的(RP)一个过滤策略在动态RP配置应用的组播环境的RP Mapping Agent (自动RP)。

先决条件

要求

尝试进行此配置之前,请确保满足以下要求:

  • 基本的了解独立于协议的组播(PIM)

使用的组件

作为一参考请使用此图表在本文中:

/image/gif/paws/41680/rp_announce_02.gif

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

自动RP

自动RP是动态方法学习每个路由器的RP信息在网络。当您通过IP组播时,分配所有组对RP信息这达到。

所有支持PIM的路由器自动地参加给他们获得所有组对RP映射信息的Cisco RP发现组(224.0.1.40)。呼叫RP Mapping Agent的实体分配此信息。Mapping Agent参加另一组— Cisco RP宣布组(224.0.1.39)。RP在定期组播消息通告的所有候选瞄准了RP宣布组地址。

Mapping Agent听所有RP候选通告并且构件与信息的一个表。如果几个RP为组播组范围宣布, Mapping Agent只选择一— RP用最高的IP地址。使用RP发现消息,它然后通告RP到网络的所有PIM路由器。Mapping Agent发送此信息每60秒(默认设置)。

过滤RP地址

您能使用ip pim rp-announce-filter rp-list access-list group-list access-list命令过滤某些组播组的某些RP。

如果配置在Mapping Agent, ip pim rp-announce-filter rp-list access-list group-list access-list命令只有含义。RP列表access-list定义了access-list,如果允许,为在group-list access-list命令指定的组播范围接受的候选RP。

注意: 小心地请使用此命令。由RP列表匹配的RP (允许由permit语句)有Group-list过滤的他们的组播组。拒绝的RP (由明确或隐式拒绝)不是受他们的组播组支配过滤并且“盲人”是已接受作为所有的候选RP他们的组。换句话说,由RP列表允许仅的RP有Group-list过滤的他们的多播组。其他RP接受,不用考试。

其他RP宣布过滤器是需要的有效过滤接受,不用考试的RP。过滤示例部分澄清此步骤。

过滤示例

在Components Used部分的图表中, R2和R4宣布作为候选RP通过RP发现消息发布此信息)的这些组的(:

  • 224.1.0.1

  • 224.1.0.2

  • 224.1.0.3

R3只配置作为Mapping Agent并且收集此信息,构件其表,并且发送对R6的一个RP地址,是仅一个支持PIM的路由器。中间系统对中间系统(IS-IS)用于此示例作为单播路由协议,但是其他协议将运作。PIM稀疏密集模式是组的224.0.1.39和224.0.1.40需要的接收组播信息没有有为那些组配置的RP。换句话说,如果没有已知RP,稀疏密集模式运作类似密集模式。当RP知道时,稀疏密集模式使用RP通告的组。

R2 配置

hostname R2

ip multicast-routing

interface Loopback0
 ip address 50.0.0.2 255.255.255.255
 ip router isis
 ip pim sparse-dense mode

interface Serial3/0
 ip address 10.2.0.2 255.255.255.0
 ip router isis
 ip pim sparse-dense mode

router isis 
 net 49.0002.0000.0000.0002.00

ip pim send-rp-announce Loopback0 scope 16 group-list groupB
!         
!         
ip access-list standard groupB
 permit 224.1.0.1
 permit 224.1.0.2
 permit 224.1.0.3

R4配置

hostname R4

ip multicast-routing

interface Loopback0
 ip address 50.0.0.4 255.255.255.255
 ip router isis
 ip pim sparse-dense mode

interface Serial3/0
 ip address 10.3.0.4 255.255.255.0
 ip router isis
 ip pim sparse-dense mode

router isis 
 net 49.0002.0000.0000.0004.00

ip pim send-rp-announce Loopback0 scope 16 group-list groupA
!         
!         
ip access-list standard groupA
 permit 224.1.0.1
 permit 224.1.0.2
 permit 224.1.0.3

R3 配置

hostname R3

ip multicast-routing

interface Loopback0
 ip address 50.0.0.3 255.255.255.255
 ip router isis
 ip pim sparse-dense mode

interface Ethernet1/0.1
 encapsulation dot1Q 65
 ip address 65.0.0.3 255.255.255.0
 ip router isis 
 ip pim sparse-dense-mode

interface Serial2/0
 ip address 10.2.0.3 255.255.255.0
 ip router isis 
 ip pim sparse-dense-mode

interface Serial3/0
 ip address 10.3.0.3 255.255.255.0
 ip router isis 
 ip pim sparse-dense-mode

router isis 
 net 49.0002.0000.0000.0003.00

R6配置

hostname R6

ip multicast-routing

interface Loopback0
 ip address 50.0.0.6 255.255.255.255
 ip router isis
 
interface Ethernet1/0.1
 encapsulation dot1Q 65
 ip address 65.0.0.6 255.255.255.0
 ip router isis 
 ip pim sparse-dense-mode

router isis 
 net 49.0002.0000.0000.0006.00

如果要过滤R4,因为的可能的RP任何那些组和只有R2作为工作的RP,请配置RP宣布在R3的过滤器:

ip pim rp-announce-filter rp-list filtering-RP group-list filtering-group
!         
!         
ip access-list standard filtering-RP
 permit 50.0.0.2
 deny    50.0.0.4


!--- ACL "filtering-RP" specifically allows R2 and explicitly denies R4.


ip access-list standard filtering-group
 permit 224.1.0.1
 permit 224.1.0.2
 permit 224.1.0.3

然后,清除当前组对RP关联,请发出clear ip pim rp-mapping命令在R3和R6。

然而,如果查看R6,您能看到信息不是什么您期待:

R6#show ip pim rp mapping 
PIM Group-to-RP Mappings

Group(s) 224.1.0.1/32
  RP 50.0.0.4 (?), v2v1

!--- RP is R4

    Info source: 65.0.0.3 (?), elected via Auto-RP
         Uptime: 00:00:02, expires: 00:02:55
Group(s) 224.1.0.2/32
  RP 50.0.0.4 (?), v2v1

!--- RP is R4

    Info source: 65.0.0.3 (?), elected via Auto-RP
         Uptime: 00:00:02, expires: 00:02:55
Group(s) 224.1.0.3/32
  RP 50.0.0.4 (?), v2v1

!--- RP is R4

    Info source: 65.0.0.3 (?), elected via Auto-RP
         Uptime: 00:00:02, expires: 00:02:55

如果查看R3,您能看到过滤实际上没有被执行:

R3# show ip pim rp mapping
PIM Group-to-RP Mappings
This system is an RP-mapping agent

!--- This line confirms that R3 is configured as the mapping agent.


Group(s) 224.1.0.1/32
  RP 50.0.0.4 (?), v2v1

!--- No filtering has taken effect.

    Info source: 50.0.0.4 (?), elected via Auto-RP

!--- R4 is elected because it has a higher IP address.

         Uptime: 00:09:06, expires: 00:02:53
  RP 50.0.0.2 (?), v2v1
    Info source: 50.0.0.2 (?), via Auto-RP
         Uptime: 00:09:29, expires: 00:02:27
Group(s) 224.1.0.2/32
  RP 50.0.0.4 (?), v2v1
    Info source: 50.0.0.4 (?), elected via Auto-RP
         Uptime: 00:09:06, expires: 00:02:51
  RP 50.0.0.2 (?), v2v1
    Info source: 50.0.0.2 (?), via Auto-RP
         Uptime: 00:09:29, expires: 00:02:27
Group(s) 224.1.0.3/32
  RP 50.0.0.4 (?), v2v1
    Info source: 50.0.0.4 (?), elected via Auto-RP
         Uptime: 00:09:06, expires: 00:02:51
  RP 50.0.0.2 (?), v2v1
    Info source: 50.0.0.2 (?), via Auto-RP
         Uptime: 00:09:29, expires: 00:02:28

R4地址特别地拒绝,并且不是受其组播组支配任何过滤—由Mapping Agent “盲人”接受。Mapping Agent选择根据最高的IP地址的一个RP (在本例中, 50.0.0.4)然后寄此信息给R6。

配置另一个RP宣布允许R4并且拒绝所有其组为了有效过滤R4地址的过滤器:

ip pim rp-announce-filter rp-list filtering-R4 group-list filtering-groupR4

ip access-list standard filtering-R4
 permit 50.0.0.4
ip access-list standard filtering-groupR4
 deny   any

如果查看R3并且启用debug ip pim auto-rp命令,当您接收RP宣布从R4的消息,您能看到这些消息:

R3#
*Apr 30 09:09:06.651: Auto-RP(0): Received RP-announce, from 50.0.0.4, RP_cnt 1, ht 181
*Apr 30 09:09:06.651: Auto-RP(0): Filtered 224.1.0.1/32 for RP 50.0.0.4
*Apr 30 09:09:06.651: Auto-RP(0): Filtered 224.1.0.3/32 for RP 50.0.0.4
*Apr 30 09:09:06.651: Auto-RP(0): Filtered 224.1.0.2/32 for RP 50.0.0.4
*Apr 30 09:09:06.651: Auto-RP(0): Received RP-announce, from 50.0.0.4, RP_cnt 1, ht 181
*Apr 30 09:09:06.651: Auto-RP(0): Filtered 224.1.0.1/32 for RP 50.0.0.4
*Apr 30 09:09:06.651: Auto-RP(0): Filtered 224.1.0.3/32 for RP 50.0.0.4
*Apr 30 09:09:06.651: Auto-RP(0): Filtered 224.1.0.2/32 for RP 50.0.0.4

然后,当您查看组对RP表时,您能只看到R2 :

R3#show ip pim rp mapping 
PIM Group-to-RP Mappings
This system is an RP-mapping agent

Group(s) 224.1.0.1/32
  RP 50.0.0.2 (?), v2v1
    Info source: 50.0.0.2 (?), elected via Auto-RP
         Uptime: 00:00:04, expires: 00:02:52
Group(s) 224.1.0.2/32
  RP 50.0.0.2 (?), v2v1
    Info source: 50.0.0.2 (?), elected via Auto-RP
         Uptime: 00:00:04, expires: 00:02:54
Group(s) 224.1.0.3/32
  RP 50.0.0.2 (?), v2v1
    Info source: 50.0.0.2 (?), elected via Auto-RP
         Uptime: 00:00:04, expires: 00:02:55

最后,如果要有R2作为224.1.0.1的RP和R4作为224.1.0.2和224.1.0.3的RP,您有此配置在R3 :

hostname R3

ip multicast-routing

interface Loopback0
 ip address 50.0.0.3 255.255.255.255
 ip router isis
 ip pim sparse-dense mode

interface Ethernet1/0.1
 encapsulation dot1Q 65
 ip address 65.0.0.3 255.255.255.0
 ip router isis
 ip pim sparse-dense-mode

interface Serial2/0
 ip address 10.2.0.3 255.255.255.0
 ip router isis
 ip pim sparse-dense-mode

interface Serial3/0
 ip address 10.3.0.3 255.255.255.0
 ip router isis
 ip pim sparse-dense-mode

router isis
 net 49.0002.0000.0000.0003.00

ip pim rp-announce-filter rp-list filtering-RP2 group-list filtering-group2
ip pim rp-announce-filter rp-list filtering-RP4 group-list filtering-group4
!        
!        
ip access-list standard filtering-RP2
 permit 50.0.0.2

ip access-list standard filtering-RP4
 permit 50.0.0.4

ip access-list standard filtering-group2
 permit 224.1.0.1

ip access-list standard filtering-group4
 permit 224.1.0.2
 permit 224.1.0.3

验证

当前没有可用于此配置的验证过程。

故障排除

目前没有针对此配置的故障排除信息。


相关信息


Document ID: 41680