宽带电缆 : 电缆调制解调器终端系统 (CMTS)

ubr7100在桥接模式的一体化配置

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 22 日) | 反馈


目录


简介

本文为Cisco UBR7100有线调制解调器终端系统(CMTS)提供作为动态主机配置协议(DHCP)、每日定时(ToD)和TFTP server的一配置示例。使用在CMTS的命令行界面(CLI)它也解释如何创建了有线电缆数据服务接口规范(DOCSIS)配置文件。当CMTS在桥接模式时,配置此配置叫作“Cisco CMTS的一体化配置”。目前ubr7100平台是唯一的CMTS平台该支持桥接。

先决条件

要求

本文读者必须有桥接、DOCSIS、DHCP、ToD和TFTP协议基本的了解。

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • Cisco UBR7100电缆调制解调器终端系统(CMTS)

  • 符合DOCSIS的有线调制解调器

  • Cisco IOS�软件版本12.1(7)EC或以上

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

说明

符合DOCSIS的有线调制解调器要求对服务器的三种类型的访问为了顺利地来联机。

多数有线电视运营商使用Cisco网络认证(CNR)作为DHCP、域名服务器(DNS)和TFTP服务器。ToD服务器不是CNR的部分。使用的ToD服务器取决于平台有线电视运营商的系统。ToD应该是兼容leavingcisco.comRFC-868 -。对于UNIX系统,它在Solaris包括;确保只是必要的,在/etc目录的inetd.conf文件包含这些线路:

# Time service is used for clock synchronization.
#
time    stream  tcp     nowait  root    internal
time    dgram   udp     wait    root    internal

对于Windows,最常用的软件是灰色软体leavingcisco.com

此表显示不同的服务器功能被添加了到CMTS的Cisco IOS软件版本:

服务器功能 Cisco IOS 软件版本
DHCP 12.0(1)T
ToD 12.0(4)XI
TFTP 11.0 (所有平台)

本文解释这些功能中的每一个。包含所有这些功能在CMTS的配置呼叫CMTS的“一体化配置”。使用此配置,您不需要任何另外的服务器测试您的电缆装置和提供高速互联网访问。

配置驻留在CMTS的DOCSIS配置文件而不是TFTP server也是可能的。根据版本注释,您需要至少Cisco IOS软件版本12.1(2)ec1使用此功能。

虽然此“一体化配置”为实验室环境、初始测试,小部署和排除故障是非常方便的,不是可扩展支持一个非常大数目的电缆调制解调器。不因此推荐您在可操作的电缆装置中使用此配置与电缆调制解调器的大部署。

思科技术支持工程师经常使用此配置排除变量,当排除故障电缆问题时。

路由和桥接操作

Cisco UBR7100系列路由器支持这些操作模式:

  • 路由模式—路由操作是Cisco CMTS路由器的典型的默认模式。数据包在每个接口被发送的它提供Cisco IOS软件路由功能广泛领域,例如DHCP服务器和控制。

  • 透明桥接模式—在电缆接口和端口适配器接口之间的桥接操作没有用于DOCSIS CMTS安装典型地由于潜在的性能和安全问题。然而,桥接是非常有效在CMTS环境用用户预定设备(CPE)设备有限数量—正如在一个典型的multidwelling单元(MDU)或多住户单元(MTU)环境—,特别是如果CMTS替换现有桥接网络。

集成路由与桥接 (IRB)

集成路由和桥接(IRB)操作允许在网络或主机的一特定分段的内桥接,也允许那些主机连接到在其他的设备,路由的网络,而不必使用独立路由器互联两网络。

注意: 支持透明桥接和IRB操作,只有当使用Cisco IOS软件版本12.1(7)EC和以后。关于在透明桥接的完整详细信息和IRB操作,请参阅在Cisco IOS Bridging的桥接章节和IBM网络配置指南、在Cisco.com的版本12.1,联机和文档CD-ROM。

网桥组虚拟接口

ubr7100_config_bridge_1.gif

由于桥接在数据链路层运行,并且路由在网络层运行,他们跟随不同的协议配置型号。而每个路由接口代表明显的网络,采取基本IP型号为例,所有网桥接口将属于同一网络。

在IRB中,当一份特定协议在网桥组中时,桥接并且路由网桥组虚拟接口介绍避免混淆协议配置型号。

网桥组虚拟接口是不支持桥接的一个正常路由接口,但是代表其对应的网桥组对路由接口。它有适用于对应的网桥组的所有网络层属性(例如网络层地址和过滤器)。分配给此虚拟接口的接口编号对应于此虚拟接口所表示的网桥组。此编号是虚拟接口与网桥组之间的关联。

当您启用一份给的协议的路由在网桥组虚拟接口时,数据包来自路由接口,但是注定为在桥接域的一台主机路由对网桥组虚拟接口和转发对对应的网桥接口。所有流量路由对网桥组虚拟接口转发给对应的网桥组作为桥接流量。在网桥接口接收的所有可路由的流量路由对其他路由接口,好象来自直接地网桥组虚拟接口。

要接收可路由的到达数据包在网桥接口,但是注定为路由接口或收到路由信息包,网桥组虚拟接口必须也有相应地址。MAC地址和网络地址如此分配到网桥组虚拟接口:

  • 网桥组虚拟接口“在网桥组中借用” MAC地址其中一个网桥接口关联与网桥组虚拟接口。

  • 要路由和桥接一份给的协议在同一个网桥组中,您必须配置协议的网络层属性在网桥组虚拟接口的。

  • 在网桥接口不应该配置协议属性,并且桥接属性在网桥组虚拟接口不可以配置。

由于只可以有代表网桥组的一网桥组虚拟接口—,并且网桥组可以为几个不同的封装方法配置的由不同的介质类型做成—您可能需要配置与要求的特定的封装方法的网桥组虚拟接口正确地转换数据包。

在CMTS的Cisco IOS DHCP服务

运行Cisco IOS软件版本12.0(1)T的Cisco路由器或以后有行动能力作为DHCP服务器。此DHCP服务可能配置提供DHCP租约给电缆调制解调器和CPE,例如PCs和工作站。

有一最小值设置电缆调制解调器典型地要求为了来联机的DHCP选项:

  • IP地址(DHCP信息包头的yiaddr字段)

  • 子网掩码(DHCP选项1)

  • 从Greenwich Mean Time (GMT)抵消的本地时间以秒钟(DHCP选项2)

  • 默认路由器(DHCP选项3)

  • ToD服务器(DHCP选项4)的IP地址

  • 日志服务器(DHCP选项7)

  • TFTP server (DHCP信息包头的siaddr字段的) IP地址

  • DOCSIS配置文件(DHCP信息包头的文件字段的)名称

  • DHCP租用时光以秒钟(DHCP选项51)

在路由器中,那些选项可以用这些命令配置:

!
ip dhcp pool cm-platinum
 network 10.1.4.0 255.255.255.0
 bootfile platinum.cm
 next-server 10.1.4.1
 default-router 10.1.4.1
 option 7 ip 10.1.4.1
 option 4 ip 10.1.4.1
 option 2 hex ffff.8f80
 lease 7 0 10
!

这些是那些命令中的每一的说明:

  • DHCP池—定义了有线调制解调器范围的名称(cm-platinum)。

  • 网络—提供IP地址和子网掩码(DHCP选项1)。

  • bootfile —提供,在这种情况下,是platinum.cm的引导程序文件名。

  • 下一个服务器—指定,在这种情况下,是在接口c4/0的主IP地址的TFTP服务器IP地址。

  • 默认路由器—定义了,在这种情况下,是主要接口IP地址c4/0的默认网关(DHCP选项3)。

  • 选项7 —定义了日志服务器DHCP选项。

  • 选项4 —提供ToD服务器IP地址(主要接口IP地址c4/0)。

  • 选项2 —为GMT提供时间偏移选项– 8个小时(– 8个小时等于– 28800秒,等于在十六进制数的ffff.8f80)。

    注意: 得知更多如何变换抵销时间十进制值到十六进制,参考如何计算DHCP选项的2 (时间偏移)十六进制值

  • 租期—设置租用时间(7天、0个小时, 10分钟)。

对于CPE设备,这些选项是要求的最低顺利地运行:

  • IP地址(DHCP信息包头的yiaddr字段)

  • 子网掩码(DHCP选项1)

  • 默认路由器(DHCP选项3)

  • 一个或更多DNS (DHCP选项6)的IP地址

  • 域名(DHCP选项15)

  • DHCP租用时光以秒钟(DHCP选项51)

在路由器中,那些选项可以用这些命令配置:

! 
ip dhcp pool pcs-irb

!--- The scope for the hosts.

   network 172.16.29.0 255.255.255.224

!--- The IP address and mask for the hosts.

   next-server 172.16.29.1

!--- TFTP server; in this case, the secondary address is used.

   default-router 172.16.29.1
   dns-server 172.16.30.2

!--- DNS server (which is not configured on the CMTS).

   domain-name cisco.com
   lease 7 0 10
!

进一步的 DHCP 服务器功能

这些是可以从Cisco IOS软件DHCP服务器使用的一些其它特性:

  • IP DHCP ping —在租期功能前的Ping,保证DHCP服务器不发出已经是在使用中的IP地址的租期。

  • IP DHCP数据库-一项功能,存储DHCP捆绑在外部数据库中,为了在CMTS重新通电期间维护MAC地址到IP地址的关系。

  • 显示IP DHCP —可以用于监控DHCP服务器的操作的命令组。

  • debug ip dhcp server —可以用于排除故障DHCP服务器的操作的命令组。

所有这些额外的功能和功能在Cisco IOS DHCP服务器文档的Cisco IOS软件DHCP服务器功能版本笔记描述。

Cisco IOS TFTP服务

在有线调制解调器尝试联系ToD服务器后,继续与TFTP server联系为了下载DOCSIS配置文件。如果一个二进制DOCSIS配置文件可以复制到在Cisco CMTS的一个闪存设备那么路由器能作为该文件的一TFTP server。

这是下载DOCSIS配置文件的步骤到flash:

  1. 发出ping命令的此保证CMTS能到达DOCSIS配置文件查找的服务器。

    Ubr7111# ping 172.16.30.2
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 172.16.30.2, timeout is 2 seconds:
    
    !--- Output suppressed.
    
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
  2. 复制文件(在这种情况下,它呼叫silver.cm)到CMTS的闪存。

    Ubr7111# copy tftp flash
    
    Address or name of remote host []? 172.16.30.2
    Source filename []? silver.cm
    Destination filename [silver.cm]?
    
    Accessing tftp://172.16.30.2/silver.cm...
    Loading silver.cm from 172.16.30.2 (via Ethernet2/0): !
    [OK - 76/4096 bytes]
    
    76 bytes copied in 0.152 secs
  3. 检查闪存并且验证文件的大小正确,使用dir命令

    Ubr7111# dir
    
    Directory of disk0:/
    
       1  -rw-          74   Feb 13 2001 16:14:26  silver.cm
       2  -rw-    10035464   Feb 14 2001 15:44:20  ubr7100-ik1s-mz.121-11b.EC.bin
    
    47890432 bytes total (17936384 bytes free)
  4. 要启用在CMTS的TFTP服务,请发出此in命令全局配置模式:

    tftp-server slot0:silver.cm alias silver.cm
    
  5. 通过检查确认步骤4这些线路在配置里:

    !
    tftp-server slot0:silver.cm alias silver.cm
    tftp-server server
    !

关于一TFTP server的配置的更多信息在路由器的,参考另外的文件传输功能命令文档。

Cisco IOS ToD服务

在有线调制解调器成功地获取一DHCP租用后,然后尝试联系ToD服务器。运行Cisco IOS软件版本12.0(4)XI的Cisco CMTS产品或以后能提供RFC 868leavingcisco.com ToD服务。

常见的误解是电缆调制解调器需要使用来联机的ToD服务是同在Cisco路由器通常配置的网络时间协议(NTP)服务一样。NTP服务和ToD服务是不兼容的。电缆调制解调器不能与Ntp server对话。当电缆调制解调器必须尝试联系ToD服务器作为联机时的进程的部分来,调制解调器兼容与DOCSIS 1.0无线电频率干涉(RFI)规格的最新的版本仍然进行来联机,即使ToD服务器不可能被到达。

根据规格的多数最近版本,如果有线调制解调器无法联系ToD服务器然后它可以继续联机的进程来。它应该,然而,周期地设法联系ToD服务器,直到是成功的。DOCSIS 1.0 RFI规格的更早版本要求,如果有线调制解调器不可能联系ToD服务器,然后调制解调器不可能来联机。知道是重要的运行老固件的电缆调制解调器可能遵照规格的此早版本。

注意: 一些供应商电缆调制解调器与Cisco IOS软件ToD服务不兼容。如果这些调制解调器与DOCSIS 1.0 RFI规格的多数最新版本是兼容的那么他们应该继续来联机尽管。此互操作性问题由Cisco Bug ID CSCdt24107 (仅限注册用户)解决。

要配置在Cisco CMTS的ToD,请发出这些global命令:

service udp-small-servers max-servers no-limit
!
cable time-server
!

内部 DOCSIS 配置文件生成器

运行Cisco IOS软件版本12.1(2)EC的Cisco CMTS产品或以后(在EC版本系列)可以配置生成和内部地存储DOCSIS配置文件。因为拿走需求访问一个外部DOCSIS配置文件生成工具,如此执行是有用的。使用内部配置工具时,当DOCSIS配置文件创建,文件通过TFTP自动地变为联机。此外,在直接地连接的线缆接口的仅电缆调制解调器能下载这些配置文件。

这些配置示例显示两个DOCSIS配置文件的创建。

第一呼叫disable.cm,允许有线调制解调器来联机,但是防止已连接CPE设备访问服务提供商的网络。在这种情况下,有拒绝访问命令。注意下行和上行速度在这种情况下是1 Kbps,并且最大突发大小是1600个字节。

cable config-file disable.cm
   access-denied
   service-class 1 max-upstream 1
   service-class 1 max-downstream 1600
   timestamp
!

有线电视运营商使用此disable.cm DOCSIS配置文件拒绝对CPE的访问在有线调制解调器背后,当仍然允许有线调制解调器来联机时。使用在CNR的过滤选项卡这是更有效的方式拒绝CPE服务比,不允许有线调制解调器来联机:有线调制解调器重复设法来联机并且浪费带宽。

show cable modem命令发出时,电缆调制解调器用此DOCSIS配置文件显示此输出:

Cable1/0/U0 10  online(d)  2287  0.50  6  0  10.1.4.65  0010.7bed.9b45

本文的高级配置部分的验证提示给予关于此输出的更多详细信息。联机的状态(d)意味着电缆调制解调器联机,但是访问拒绝。

在第二示例中,呼叫platinum.cm的DOCSIS配置文件创建。在这种情况下,最大上行值是1 Mbps,保证上行值是100 Kbps,最大下行是10 Mbps,并且允许将连接的30个CPE设备。

cable config-file platinum.cm
   service-class 1 max-upstream 1000
   service-class 1 guaranteed-upstream 100
   service-class 1 max-downstream 10000
   service-class 1 max-burst 1600
   cpe max 30
   timestamp
!

注意,当配置在CMTS时的DOCSIS配置文件,您不需要语句TFTP server slot0:platinum.cm别名platinum.cm,因为没有在内存存储的.cm文件;它在配置内驻留。

在内部DOCSIS配置文件工具的更详细的资料可以在本文Cisco CMTS配置命令找到。

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 有关本文档所用命令的详细信息,请使用命令查找工具仅限注册用户)。

网络图

一典型的实验室设置拓扑在此镜像显示:

/image/gif/paws/29243/ubr7100_config_bridge_2.gif

配置

本文档使用以下配置:

ubr7100 CMTS平台仅支持此配置。

支持一体化配置,包括DOCSIS配置文件的配置的Cisco IOS软件版本,是Cisco IOS软件版本12.1(2)EC和随后的EC培训版本。在此配置方面使用的Cisco IOS软件系列是ubr7100-ik1s-mz.121-11b.EC.bin。

基本一体化配置

到目前为止此配置汇总解释的所有片段。它有两个DHCP范围:一电缆调制解调器的和另一个主机的在电缆调制解调器背后。

一个DOCSIS配置文件创建,呼叫platinum.cm。此文件应用对呼叫的DHCP池cm-platinum。另一个DOCSIS配置文件,呼叫disabled.cm,当时没有应用对任何东西。

注释用蓝色用蓝色,在相关命令以后。一体化配置命令在粗体

基本一体化配置
ubr7100# show run
Building configuration...
 
Current configuration : 3511 bytes
!
! Last configuration change at 01:12:37 PST Mon Sep 3 2001
!
version 12.1
no service pad
service timestamps debug datetime msec localtime

!--- Provides useful timestamps on all log messages.

service timestamps log datetime localtime
no service password-encryption
service linenumber
service udp-small-servers max-servers no-limit

!--- Supports a large number of modems or hosts attaching quickly.

 
!
hostname ubr7111
!
boot system flash disk0:ubr7100-ik1s-mz.121-11b.EC.bin
!
cable spectrum-group 3 frequency 40800000
no cable qos permission create
no cable qos permission update
cable qos permission modems
cable timeserver

!---  Allows cable modems to obtain ToD from the uBR7100.

!
cable config-file platinum.cm
 service-class 1 max-upstream 128
 service-class 1 guaranteed-upstream 10
 service-class 1 max-downstream 10000
 service-class 1 max-burst 1600
 cpe max 8
 timestamp
!
clock timezone PST -9
clock calendar-valid
ip subnet-zero
no ip routing

!--- Disables routing on the CMTS.

no ip domain-lookup

!--- Prevents the CMTS from looking up domain names or attempting 
!--- to connect to machines (for example, when mistyping commands).

ip host ubr7111 172.16.26.103
ip domain-name cisco.com
ip name-server 171.68.10.70
ip name-server 171.69.2.132
ip name-server 171.68.200.250
no ip dhcp relay information check
 
ip dhcp excluded-address 10.45.50.1 10.45.50.5
!
ip dhcp pool cm-platinum

!--- Name of the DHCP pool. This scope is for the cable modems attached 
!--- to interface cable 4/0.

   network 10.1.4.0 255.255.255.0

!--- Pool of addresses for scope modems-c1/0.

   bootfile platinum.cm

!--- DOCSIS configuration file name associated with this pool.

   next-server 10.1.4.1

!--- IP address of the TFTP server which sends the boot file.

   default-router 10.1.4.1

!--- Default gateway for cable modems; necessary to get DOCSIS files.

   option 7 ip 10.1.4.1

!--- Log Server DHCP option.

   option 4 ip 10.1.4.1

!--- ToD server IP address.

   option 2 hex ffff.8f80

!--- Time offset for ToD, in seconds (HEX), from GMT.
!--- Pacific Standard Time offset from GMT = –28,000 seconds = ffff.8f80

   lease 7 0 10

!--- Lease 7 days 0 hours 10 minutes.

! 
ip dhcp pool pcs-irb

!--- Name of the DHCP pool. This scope is for the CPE attached to
!--- the cable modems that are connected to interface cable 1/0.

   network 172.16.29.0 255.255.255.0

!--- Pool of addresses for scope pcs-c4 (associated with the secondary address).

   next-server 172.16.29.1
   default-router 172.16.29.1
   dns-server 172.16.29.1
   domain-name cisco.com
   lease 7 0 10
!
ip ssh time-out 120
ip ssh authentication-retries 3
!
!
!
!
!
bridge irb
!
!
interface FastEthernet0/0
 ip address 14.66.1.2 255.255.255.0
 no ip route-cache
 no ip mroute-cache
 no keepalive
 duplex half
 speed auto
 no cdp enable
 bridge-group 1
 bridge-group 1 spanning-disabled
!
interface FastEthernet0/1
 ip address 14.66.1.2 255.255.255.0
 no ip route-cache
 no ip mroute-cache
 shutdown
 duplex auto
 speed 10
 no cdp enable
 bridge-group 1
 bridge-group 1 spanning-disabled
!
interface Cable1/0
 ip address 14.66.1.2 255.255.255.0
 no ip route-cache
 no ip mroute-cache
 load-interval 30
 no keepalive
 cable packet-cache
 cable downstream annex B
 cable downstream modulation 256qam
 cable downstream interleave-depth 32
 cable downstream frequency 525000000
 no cable downstream rf-shutdown
 cable downstream rf-power 55
 cable upstream 0 frequency 17808000
 cable upstream 0 power-level 0
 cable upstream 0 channel-width 3200000
 no cable upstream 0 shutdown
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 spanning-disabled
!
interface BVI1
 ip address 10.1.4.1 255.255.255.0
!
ip default-gateway 14.66.1.1
ip classless
no ip http server
!
no cdp run
bridge 1 protocol ieee
 bridge 1 route ip
alias exec scm show cable modem
!
line con 0
 exec-timeout 0 0
 privilege level 15
 length 0
line aux 0
line vty 0 4
 privilege level 15
 no login
line vty 5 15
 login
!
end

基本配置验证提示

本部分所提供的信息可用于确认您的配置是否正常工作。

命令输出解释程序仅限注册用户)(OIT) 支持某些 show 命令。使用 OIT 可查看对 show 命令输出的分析。

  1. 确保Cisco IOS软件版本支持命令通过发出show version命令

  2. 验证DOCSIS配置文件在闪存。

    Ubr7111# dir
    
    Directory of disk0:/
     
        1  -rw-          74   Feb 13 2001 16:14:26  silver.cm
        2  -rw-    10035464   Feb 14 2001 15:44:20  ubr7100-ik1s-mz.121-11b.EC.bin
     
    47890432 bytes total (17936384 bytes free)

    注意: 使用DOCSIS CPE Configurator工具,文件silver.cm被创建了。对于在CMTS配置里被创建的platinum.cm文件,您不需要语句TFTP server slot0:platinum.cm别名platinum.cm,因为没有.cm文件;它在配置内驻留。

  3. 验证电缆调制解调器通过发出show cable modem命令是联机。

    Ubr7111# show interface cable 1/0 modem 0
    
    SID   Priv bits  Type      State     IP address    method    MAC address
    75    00         host      unknown   172.16.29.2   static    00c0.4f97.61c5
    75    00         modem     up        10.1.4.2      dhcp      0010.7bed.9b23
    76    00         modem     up        10.1.4.3      dhcp      0002.fdfa.0a63
    77    00         host      unknown   172.16.29.3   dhcp      00a0.243c.eff5
    77    00         modem     up        10.1.4.5      dhcp      0010.7bed.9b45
    78    00         modem     up        10.1.4.4      dhcp      0004.2752.ddd5
    79    00         modem     up        10.1.4.6      dhcp      0002.1685.b5db
    80    00         modem     up        10.1.4.7      dhcp      0001.64ff.e47d

    注意所有电缆调制解调器联机。那个连接对接口电缆1/0/U0在网络10.1.4.0。您能从配置看到他们的IP地址从呼叫的DHCP池被采取cm-platinum

    并且请注意有MAC地址的0010.7bed.9b230010.7bed.9b45电缆调制解调器有在他们后的CPE。那些电缆调制解调器来联机与默认桥接配置。那些PCs配置与DHCP,以便他们能从网络获得他们的IP地址。

    Ubr7111# show interface cable 1/0 modem 0
    
    SID   Priv bits  Type      State     IP address    method    MAC address
    75    00         host      unknown   172.16.29.2   static    00c0.4f97.61c5
    75    00         modem     up        10.1.4.2      dhcp      0010.7bed.9b23
    76    00         modem     up        10.1.4.3      dhcp      0002.fdfa.0a63
    77    00         host      unknown   172.16.29.3   dhcp      00a0.243c.eff5
    77    00         modem     up        10.1.4.5      dhcp      0010.7bed.9b45
    78    00         modem     up        10.1.4.4      dhcp      0004.2752.ddd5
    79    00         modem     up        10.1.4.6      dhcp      0002.1685.b5db
    80    00         modem     up        10.1.4.7      dhcp      0001.64ff.e47d

    此屏幕画面显示那些PCs从池获得IP地址呼叫pcs-c4

    ubr7100_config_bridge_3.gif

    您能从此PC也看到TCP/IP设置设自动地获取IP地址。

    ubr7100_config_bridge_4.gif

高级一体化配置

此部分提供介入DHCP池的层级功能的更加复杂的配置示例。方式DHCP池层级工作是所有DHCP池用是另一个池的网络号的一子集的网络号继承所有该其他池特性。这保存在DHCP服务器配置的重复。如果,然而,同一个项目用一个不同的参数完成,则参数覆盖。此示例显示有呼叫platinum.cm和此池的一子集的启动文件的一个常规池有呼叫disable.cm的启动文件的。

除在基本示例创建的DHCP池之外,有两电缆调制解调器的特殊需求。

首先,有线调制解调器0010.7bed.9b45是拒绝访问;它授权IP地址,但是不来联机。创建此池:

ip dhcp pool cm-0010.7bed.9b45
   host 10.1.4.65 255.255.255.0
   client-identifier 0100.107b.ed9b.45
   bootfile disable.cm

此配置示例多数显著的特点是您指定特殊DHCP池对应于单个有线调制解调器MAC地址的部分。这样规格允许DHCP服务器发送唯一DHCP选项到这些调制解调器。要指定特定有线调制解调器,使用client-identifier参数。client-identifier必须设置到01,跟随由条目对应设备的MAC地址。01对应于DHCP硬件类型的以太网。

注意: 当更改调制解调器的时配置文件,您必须实行这些步骤保证有线调制解调器手工获得配置的参数:

  1. 通过发出clear ip dhcp binding ip address命令收拾IP DHCP绑定表。

  2. 重置有线调制解调器有问题的通过发出clear cable modem mac address res命令

其次,有线调制解调器0010.7bed.9b23也有一个特殊需求:它获得一不同的服务质量(QoS)。所以,如此部分配置所显示,一不同的启动文件关联对范围, :

ip dhcp pool cm-0010.7bed.9b23
   host 10.1.4.66 255.255.255.0
   client-identifier 0100.107b.ed9b.23
   bootfile silver.cm
!

当配置特定电缆调制解调器的时DHCP池,它总是良好的做法给予一相关名称。并且,因为一个特定IP地址分配到使用host命令的池,您必须发出global命令IP DHCP排除10.1.4.60 10.1.4.70。此命令在此范围告诉DHCP不使用地址。

高级配置验证提示

此配置的验证着重电缆调制解调器获得的服务,特别是0010.7bed.9b450010.7bed.9b23。您一定肯定他们得到他们手工配置和服务的地址。

测试的第一件事是0010.7bed.9b45来联机,但是服务拒绝。发出show cable modem命令

7246VXR# show cable modem

Interface   Prim Online     Timing Rec    QoS CPE IP address      MAC address
            Sid  State      Offset Power
Cable4/0/U0 7    online     2813    0.00  7   0   10.1.4.7        0002.1685.b5db
Cable4/0/U0 8    online     2809    0.25  7   0   10.1.4.10       0002.fdfa.0a63
Cable4/0/U0 9    online     2288   -0.25  5   1   10.1.4.66       0010.7bed.9b23
Cable4/0/U0 10   online(d)  2287    0.50  6   0   10.1.4.65       0010.7bed.9b45
Cable4/0/U0 11   online     2809   -0.50  7   0   10.1.4.6        0001.64ff.e47d
Cable4/0/U0 12   online     2812   -0.50  7   0   10.1.4.9        0004.2752.ddd5

注意这些事实:

  • 有线调制解调器0010.7bed.9b23获得了IP地址10.4.1.66,在范围cm-0010.7bed.9b23上指定。有计算机附加对它,并且从池pcs-c4获得其IP地址。

  • 有线调制解调器0010.7bed.9b23有不同的QoS。

  • 有线调制解调器0010.7bed.9b45获得了IP地址10.1.4.65,在范围cm-0010.7bed.9b45上指定计算机附加对它;因为那服务拒绝, CPE值,然而,是0

  • 0010.7bed.9b45的在线状态联机(d),因此意味着有线调制解调器来联机,但是对有线网络的访问拒绝。

    考虑从在有线调制解调器发出的debug cable mac log verbose命令的此输出:

    21:52:16:  78736.550 CMAC_LOG_RESET_RANGING_ABORTED              
    21:52:16:  78736.554 CMAC_LOG_STATE_CHANGE                       reset_interface_state
    21:52:16:  78736.558 CMAC_LOG_STATE_CHANGE                       reset_hardware_state
    21:52:17:  78737.024 CMAC_LOG_STATE_CHANGE                       wait_for_link_up_state
    21:52:17:  78737.028 CMAC_LOG_DRIVER_INIT_IDB_RESET              0x082B9CA8
    21:52:17:  78737.032 CMAC_LOG_LINK_DOWN                          
    21:52:17:  78737.034 CMAC_LOG_LINK_UP                            
    21:52:17:  78737.040 CMAC_LOG_STATE_CHANGE                       ds_channel_scanning_state
    21:52:17: %LINEPROTO-5-UPDOWN: Line protocol on Interface cable-modem0, changed state to down
    21:52:18:  78738.386 CMAC_LOG_UCD_MSG_RCVD                       1
    21:52:19:  78739.698 CMAC_LOG_DS_64QAM_LOCK_ACQUIRED             747000000
    21:52:19:  78739.702 CMAC_LOG_DS_CHANNEL_SCAN_COMPLETED          
    21:52:19:  78739.704 CMAC_LOG_STATE_CHANGE                       wait_ucd_state
    21:52:20:  78740.368 CMAC_LOG_UCD_MSG_RCVD                       1
    21:52:22:  78742.396 CMAC_LOG_UCD_MSG_RCVD                       1
    21:52:22:  78742.398 CMAC_LOG_ALL_UCDS_FOUND                     
    21:52:22:  78742.402 CMAC_LOG_STATE_CHANGE                       wait_map_state
    21:52:22:  78742.406 CMAC_LOG_FOUND_US_CHANNEL                   1
    21:52:24:  78744.412 CMAC_LOG_UCD_MSG_RCVD                       1
    21:52:24:  78744.416 CMAC_LOG_UCD_NEW_US_FREQUENCY               39984000
    21:52:24:  78744.420 CMAC_LOG_SLOT_SIZE_CHANGED                  8
    21:52:24:  78744.500 CMAC_LOG_UCD_UPDATED                        
    21:52:24:  78744.560 CMAC_LOG_MAP_MSG_RCVD                       
    21:52:24:  78744.564 CMAC_LOG_INITIAL_RANGING_MINISLOTS          41
    21:52:24:  78744.566 CMAC_LOG_STATE_CHANGE                       ranging_1_state
    21:52:24:  78744.570 CMAC_LOG_RANGING_OFFSET_SET_TO              9610
    21:52:24:  78744.574 CMAC_LOG_POWER_LEVEL_IS                     55.0  dBmV (commanded)
    21:52:24:  78744.578 CMAC_LOG_STARTING_RANGING                   
    21:52:24:  78744.580 CMAC_LOG_RANGING_BACKOFF_SET                0
    21:52:24:  78744.586 CMAC_LOG_RNG_REQ_QUEUED                     0
    21:52:24:  78744.622 CMAC_LOG_RNG_REQ_TRANSMITTED                
    21:52:24:  78744.626 CMAC_LOG_RNG_RSP_MSG_RCVD                   
    21:52:24:  78744.628 CMAC_LOG_RNG_RSP_SID_ASSIGNED               10
    21:52:24:  78744.632 CMAC_LOG_ADJUST_RANGING_OFFSET              2286
    21:52:24:  78744.636 CMAC_LOG_RANGING_OFFSET_SET_TO              11896
    21:52:24:  78744.638 CMAC_LOG_STATE_CHANGE                       ranging_2_state
    21:52:24:  78744.644 CMAC_LOG_RNG_REQ_QUEUED                     10
    21:52:25:  78745.654 CMAC_LOG_RNG_REQ_TRANSMITTED                
    21:52:25:  78745.658 CMAC_LOG_RNG_RSP_MSG_RCVD                   
    21:52:25:  78745.660 CMAC_LOG_RANGING_SUCCESS                    
    21:52:25:  78745.680 CMAC_LOG_STATE_CHANGE                       dhcp_state
    21:52:25:  78745.820 CMAC_LOG_DHCP_ASSIGNED_IP_ADDRESS           10.1.4.65
    21:52:25:  78745.824 CMAC_LOG_DHCP_TFTP_SERVER_ADDRESS           10.1.4.1
    21:52:25:  78745.826 CMAC_LOG_DHCP_TOD_SERVER_ADDRESS            10.1.4.1
    21:52:25:  78745.830 CMAC_LOG_DHCP_SET_GATEWAY_ADDRESS           
    21:52:25:  78745.834 CMAC_LOG_DHCP_TZ_OFFSET                     -28800
    21:52:25:  78745.836 CMAC_LOG_DHCP_CONFIG_FILE_NAME              disable.cm
    21:52:25:  78745.840 CMAC_LOG_DHCP_ERROR_ACQUIRING_SEC_SVR_ADDR  
    21:52:25:  78745.846 CMAC_LOG_DHCP_COMPLETE                      
    21:52:25:  78745.968 CMAC_LOG_STATE_CHANGE                       establish_tod_state
    21:52:25:  78745.978 CMAC_LOG_TOD_REQUEST_SENT                   
    21:52:26:  78746.010 CMAC_LOG_TOD_REPLY_RECEIVED                 3192525217
    21:52:26:  78746.018 CMAC_LOG_TOD_COMPLETE                       
    21:52:26:  78746.020 CMAC_LOG_STATE_CHANGE                       security_association_state
    21:52:26:  78746.024 CMAC_LOG_SECURITY_BYPASSED                  
    21:52:26:  78746.028 CMAC_LOG_STATE_CHANGE                       configuration_file_state
    21:52:26:  78746.030 CMAC_LOG_LOADING_CONFIG_FILE                disable.cm
    21:52:26: %LINEPROTO-5-UPDOWN: Line protocol on Interface cable-modem0, changed state to up
    21:52:27:  78747.064 CMAC_LOG_CONFIG_FILE_PROCESS_COMPLETE       
    21:52:27:  78747.066 CMAC_LOG_STATE_CHANGE                       registration_state
    21:52:27:  78747.070 CMAC_LOG_REG_REQ_MSG_QUEUED                 
    21:52:27:  78747.076 CMAC_LOG_REG_REQ_TRANSMITTED                
    21:52:27:  78747.080 CMAC_LOG_REG_RSP_MSG_RCVD                   
    21:52:27:  78747.082 CMAC_LOG_COS_ASSIGNED_SID                   1/10
    21:52:27:  78747.088 CMAC_LOG_RNG_REQ_QUEUED                     10
    21:52:27:  78747.090 CMAC_LOG_NETWORK_ACCESS_DENIED
    21:52:27:  78747.094 CMAC_LOG_REGISTRATION_OK                    
    21:52:27:  78747.096 CMAC_LOG_STATE_CHANGE                       establish_privacy_state
    21:52:27:  78747.100 CMAC_LOG_PRIVACY_NOT_CONFIGURED             
    21:52:27:  78747.102 CMAC_LOG_STATE_CHANGE                       maintenance_state
    21:52:31:  78751.122 CMAC_LOG_RNG_REQ_TRANSMITTED                
    21:52:31:  78751.124 CMAC_LOG_RNG_RSP_MSG_RCVD                   
    21:52:37:  78757.164 CMAC_LOG_RNG_REQ_TRANSMITTED                
    21:52:37:  78757.168 CMAC_LOG_RNG_RSP_MSG_RCVD                   
    21:52:43:  78763.206 CMAC_LOG_RNG_REQ_TRANSMITTED                
    21:52:43:  78763.210 CMAC_LOG_RNG_RSP_MSG_RCVD                   
    21:52:49:  78769.250 CMAC_LOG_RNG_REQ_TRANSMITTED                
    21:52:49:  78769.252 CMAC_LOG_RNG_RSP_MSG_RCVD

    此调试输出显示网络访问拒绝

Ubr7100# show cable modem detail

Interface   SID  MAC address    Max CPE  Concatenation  Rx SNR
Cable1/0/U0 7    0002.1685.b5db 10       yes            33.52
Cable1/0/U0 8    0002.fdfa.0a63 10       yes            33.24
Cable1/0/U0 9    0010.7bed.9b23 1        no             33.29
Cable1/0/U0 10   0010.7bed.9b45 1        no             33.23
Cable1/0/U0 11   0001.64ff.e47d 10       yes            33.20
Cable1/0/U0 12   0004.2752.ddd5 10       yes            33.44

注意电缆调制解调器的最大数量CPE有特殊范围的是1和其余是10。如果看到范围platinum.cm的配置,安排10 CPE指定;另一方面,范围disable.cm有指定的only1 CPE。预先配置的DOCSIS配置文件silver.cm也有指定的only1 CPE。

Ubr7111# show interface cable 1/0 modem 0

SID   Priv bits  Type      State     IP address    method    MAC address
7     00         modem     up        10.1.4.7      dhcp      0002.1685.b5db
8     00         modem     up        10.1.4.10     dhcp      0002.fdfa.0a63
9     00         host      unknown   172.16.29.2   static    00c0.4f97.61c5
9     00         modem     up        10.1.4.66     dhcp      0010.7bed.9b23
10    00         modem     up        10.1.4.65     dhcp      0010.7bed.9b45
11    00         modem     up        10.1.4.6      dhcp      0001.64ff.e47d
12    00         modem     up        10.1.4.9      dhcp      0004.2752.ddd5

要验证电缆调制解调器获得正确级别服务,请发出show cable qos profile命令

Ubr7111# show cable qos profile

ID  Prio Max       Guarantee Max        Max   TOS  TOS   Create  B     IP prec.
         upstream  upstream  downstream tx    mask value by      priv  rate
         bandwidth bandwidth bandwidth  burst                    enab  enab
1   0    0         0         0          0     0x0  0x0   cmts(r) no    no
2   0    64000     0         1000000    0     0x0  0x0   cmts(r) no    no
3   7    31200     31200     0          0     0x0  0x0   cmts    yes   no
4   7    87200     87200     0          0     0x0  0x0   cmts    yes   no
5   4    64000     0         512000     0     0x0  0x0   cm      no    no
6   0    1000      0         1600000    0     0x0  0x0   cm      no    no
7   0    128000    10000     10000000   1600  0x0  0x0   cm      no    no
8   0    0         0         0          0     0x0  0x0   mgmt    no    no
10  0    0         0         0          0     0x0  0x0   mgmt    no    no
12  0    0         100000000 0          0     0x0  0x0   mgmt    no    no

注意QoS ID 7匹配在platinum.cm的配置:

cable config-file platinum.cm
 service-class 1 max-upstream 128
 service-class 1 guaranteed-upstream 10
 service-class 1 max-downstream 10000
 service-class 1 max-burst 1600
 cpe max 10
 timestamp

同样发生与disable.cm DOCSIS配置:

Ubr7111# show ip dhcp binding

IP address       Hardware address        Lease expiration        Type
10.1.4.6         0100.0164.ffe4.7d       Mar 08 2001 07:58 AM    Automatic
10.1.4.7         0100.0216.85b5.db       Mar 08 2001 07:58 AM    Automatic
10.1.4.9         0100.0427.52dd.d5       Mar 08 2001 07:58 AM    Automatic
10.1.4.10        0100.02fd.fa0a.63       Mar 08 2001 08:36 AM    Automatic
10.1.4.65        0100.107b.ed9b.45       Infinite                Manual
10.1.4.66        0100.107b.ed9b.23       Infinite                Manual

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 29243