宽带电缆 : 电缆调制解调器终端系统 (CMTS)

在Cisco CMTS上配置DHCP, ToD,和TFTP服务:一体化配置

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 22 日) | 反馈


目录


简介

本文显示作为动态主机配置协议(DHCP)、ToD和TFTP server在思科的有线调制解调器终端系统(CMTS)的一配置。使用在CMTS的CLI它也解释如何创建了DOCSIS配置文件。此配置叫作“思科的CMTS的一体化配置”。

开始使用前

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

先决条件

读者应该有DOCSIS协议和Cisco IOS line命令的基本的了解在UBR系列路由器。

使用的组件

在本文的硬件使用是从思科uBR7200、ubr7100或者ubr10k CMTS和DOCSIS兼容的有线调制解调器。

说明

DOCSIS兼容的有线调制解调器要求对服务器的三种类型的访问为了顺利地来联机。

  • 第一是DHCP服务器,提供有线调制解调器IP地址、子网掩码和其他IP相关参数。

  • 第二是告诉调制解调器的RFC868兼容每日定时(ToD)服务器什么当前时间是。有线调制解调器需要认识时间为了能适当地添加准确时间戳到其事件日志。

  • 第三是有线调制解调器能下载包含有线调制解调器特定操作参数的DOCSIS配置文件的简单文件传输协议(TFTP)服务器。

大多有线电视运营商使用Cisco网络认证(CNR)作为DHCP、DNS和TFTP服务器。ToD服务器不作为CNR的部分。使用的ToD服务器取决于平台他们的系统。ToD应该是兼容的RFC868。对于UNIX系统,确保文件在Solaris只包括,它是必要的“inetd.conf”该在“/etc”目录的寿命包含以下线路:

# Time service is used for clock synchronization.
#
time��� stream� tcp���� nowait� root��� internal
time��� dgram�� udp���� wait��� root��� internal

对于Windows,使用的最普通的软件是灰色软体leavingcisco.com

下表显示不同的服务器功能被添加了到CMTS的思科IOS�软件版本。

服务器功能 Cisco IOS 软件版本
DHCP 12.0(1)T
ToD 12.0(4)XI�
TFTP 11.0 (所有平台)

本文将解释这些功能中的每一个。包含所有这些功能在CMTS的配置是什么我们称“cmts的一体化配置”。使用此配置您不需要任何另外的服务器测试您的电缆装置提供高速互联网访问。

配置驻留在CMTS的DOCSIS配置文件而不是TFTP server也是可能的。根据版本注释,您需要至少Cisco IOS软件版本12.1(2)ec1使用此功能。

虽然此“一体化配置”为实验室环境、初始测试,小部署和排除故障是非常方便的,不是可扩展支持一个非常大数目的电缆调制解调器。不因此推荐在可操作的电缆装置中使用此配置与电缆调制解调器的大部署。

TAC工程师经常使用此配置能排除变量,当排除故障电缆问题时。

CMTS 上的 Cisco IOS 动态主机配置协议 (DHCP) 服务

运行Cisco IOS软件12.0(1)T或以上版本的Cisco路由器有行动能力作为DHCP服务器。此DHCP服务可能配置提供DHCP租约给电缆调制解调器和用户预定设备(CPE)例如PCs和工作站。

有一最小值设置电缆调制解调器在线路典型地要求为了来的DHCP选项。即:

  • IP地址(DHCP信息包头的yiaddr字段)

  • 子网掩码(DHCP选项1)

  • 从GMT抵消的本地时间以秒钟(DHCP选项2)

  • 默认路由器(DHCP选项3)

  • ToD服务器(DHCP选项4)的IP地址

  • 日志服务器(DHCP选项7)

  • TFTP server (DHCP信息包头的siaddr字段的) IP地址

  • DOCSIS配置文件(DHCP信息包头的文件字段的)名称

  • DHCP租用时光以秒钟(DHCP选项51)

在路由器中这可以配置如下:

!
ip dhcp pool cm-platinum
�� network 10.1.4.0 255.255.255.0
�� bootfile platinum.cm
�� next-server 10.1.4.1�
�� default-router 10.1.4.1�
�� option 7 ip 10.1.4.1�
�� option 4 ip 10.1.4.1�
�� option 2 hex ffff.8f80
�� lease 7 0 10
!

每命令的说明如下:

  • dhcp pool命令定义了含义电缆调制解调器的白金服务)范围的名称(cm-platinum。

  • 网络提供IP地址和子网掩码(DHCP选项1)。

  • bootfile提供在这种情况下是platinum.cm的引导程序文件名。

  • next-server命令指定TFTP服务器IP地址(在这种情况下是在接口c4/0)的主IP地址。

  • 默认路由器是默认网关,在这种情况下是主要接口IP地址c4/0 (option3)。

  • 选项7是日志服务器DHCP选项。

  • 选项4是ToD服务器IP地址(主要接口IP地址c4/0)。

  • 选项2是GMT -8hr的(-8hr时间偏移选项= -28800在十六进制的秒= ffff.8f80)。

  • 租用时间是7天0个小时10分钟。

注意: 要得知更多如何变换抵销时间十进制值到十六进制,请读技术提示如何计算DHCP选项的2 (时间偏移)十六进制值

对于CPE设备以下选项最低为了能顺利地运行。

  • IP地址(DHCP信息包头的yiaddr字段)

  • 子网掩码(DHCP选项1)

  • 默认路由器(DHCP选项3)

  • 一个或更多域名服务器(DHCP选项6)的IP地址

  • 域名(DHCP选项15)

  • DHCP租用时光以秒钟(DHCP选项51)

!
ip dhcp pool pcs-c4�

! -- the scope for the hosts

    network 172.16.29.0 255.255.255.224

! -- the ip address and mask for the hosts

��� next-server 172.16.29.1

! -- tftp server, in this case we put the secondary add.

��� default-router 172.16.29.1
��� dns-server 172.16.30.2

! -- dns server (which is not configured on the cmts)

��� domain-name cisco.com
��� lease 7 0 10
!

当配置DHCP池时,在电缆接口配置里包括cable dhcp-giaddr policy命令是重要的。此命令有处理DHCP服务器分配租期对电缆调制解调器与主网络号相应在电缆接口和租期效果对CPE与附属网络号相应在电缆接口。如果此命令那么未命中所有DHCP租约将来自池与在电缆接口的主网络号相应。并且,因为我们在下面的接口的部分配置里将看到,范围cm-platinum关联与在接口电缆定义的主要地址4/0,并且范围pcs-c4在备用地址的网络。

!
interface Cable4/0
�� ip address 172.16.29.1 255.255.255.224 secondary

! -- CPE network

�� ip address 10.1.4.1 255.255.255.0

! -- Cable Modem Network

�� cable dhcp-giaddr policy
!

注意没有cable helper-addressip helper-address命令在电缆接口下。这是因为DHCP请求不需要转发到外部服务器,当使用时内部IOS DHCP服务器。如果此命令在接口下被添加,并且有配置的一个外部DHCP服务器,电缆调制解调器将注册与外部DHCP的配置。

进一步的 DHCP 服务器功能

可以使用使用Cisco IOS DHCP服务器的其它特性包括:

  • IP DHCP ping :在保证的租期功能前的Ping DHCP服务器不发出已经是在使用中的IP地址的租期。

  • IP DHCP数据库:存储DHCP捆绑在外部数据库中,为了在CMTS重新通电期间维护MAC地址到IP地址的关系。

  • 显示IP DHCP :可以用于监控DHCP服务器的操作的命令组。

  • debug ip dhcp server :可以用于排除故障DHCP服务器的操作的命令组。

所有这些额外的功能和功能在Cisco IOS DHCP服务功能版本注释描述查找在Cisco IOS DHCP服务器文档

Cisco IOS 时间 (ToD) 服务

在有线调制解调器成功地获取一DHCP租用后然后继续对尝试联系ToD服务器。运行Cisco IOS软件版本12.0(4)XI的Cisco CMTS产品或以后能提供RFC868 ToD服务。

常见的误解是电缆调制解调器需要使用的ToD服务,因为联机来的部分是同在Cisco路由器通常配置的网络时间协议(NTP)服务一样。NTP服务和ToD服务是不兼容的。电缆调制解调器不能与Ntp server对话。当电缆调制解调器必须尝试联系时间服务器作为联机时的进程的部分来,调制解调器兼容与DOCSIS 1.0 RFI规格的最新的版本将进行来联机,即使ToD服务器不可能被到达。

根据规格的多数最近版本,如果有线调制解调器无法联系ToD服务器然后它可以继续联机的进程来。然而它应该周期地继续设法联系ToD服务器,直到是成功的。DOCSIS 1.0 RFI规格的更旧的版本要求,如果有线调制解调器不可能联系ToD服务器然后调制解调器不可能来联机。知道是重要的运行老固件的电缆调制解调器可能遵照规格的此早版本。

注意: 某些供应商的电缆调制解调器与Cisco IOS时间服务不兼容。如果这些调制解调器与DOCSIS 1.0 RFI规格的多数最新版本是兼容的那么他们应该继续来联机尽管。此互操作性问题由Cisco Bug ID CSCdt24107解决。

注意: 要配置在思科的CMTS只两global命令的ToD请是需要的:

service udp-small-servers max-servers no-limit
!
cable time-server
!

Cisco IOS 简单文件传输协议 (TFTP) 服务

在有线调制解调器尝试联系ToD服务器后,继续与TFTP server联系为了下载DOCSIS配置文件。如果一个二进制DOCSIS配置文件可以复制到在Cisco CMTS的一个闪存设备那么路由器能作为该文件的一TFTP server。

下载DOCSIS配置文件的步骤到闪存下列:

首先,请确保CMTS能到达DOCSIS配置文件居住的服务器:

7246VXR#ping 172.16.30.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.30.2, timeout is 2 seconds:
!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

其次,请复制文件,它在这种情况下呼叫silver.cm到CMTS的闪存。

7246VXR#copy tftp flash
Address or name of remote host []? 172.16.30.2
Source filename []? silver.cm
Destination filename [silver.cm]?�

Accessing tftp://172.16.30.2/silver.cm...
Loading silver.cm from 172.16.30.2 (via Ethernet2/0): !
[OK - 76/4096 bytes]

76 bytes copied in 0.152 secs

最后,它总是一个好想法检查闪存和验证文件的大小正确。对于此请执行show flash

7246VXR#show flash
-#- ED --type-- --crc--- -seek-- nlen -length- -----date/time------ name
1�� .. unknown� 2D6C7818�� 200CC��� 9������ 74 Feb 28 2001 7:39:09 silver.cm
2�� .. unknown� 1CB785DC�� 20258��� 7������ 62 Feb 20 2001 15:44:11 test.cm
3�� .. image��� 4350A04F� 7A0CC8�� 24� 7866864 Feb 27 2001 09:36:40 ubr7200-ik1s-mz.121-4.EC
4�� .. unknown� 36E5D6D3� 7A0D94��� 7������ 76 Feb 28 2001 07:23:12 gold.cm

8516204 bytes available (7867796 bytes used)

启用在那里CMTS的TFTP服务我们只需要包括以下in命令全局配置模式。

tftp-server slot0:silver.cm alias silver.cm

一旦此命令被输入,下列以后在配置里将显示:

!
tftp-server slot0:silver.cm alias silver.cm
tftp-server server��
!

关于TFTP server的配置的更多信息在路由器的请参阅本文其他文件传输命令

内部 DOCSIS 配置文件生成器

运行Cisco IOS软件版本12.1(2)EC的Cisco CMTS产品或以后(在EC版本系列)可以配置生成和内部地存储DOCSIS配置文件。因为拿走需求访问一个外部DOCSIS配置文件生成工具,这是有用的。使用内部配置工具时,当DOCSIS配置文件创建,文件通过TFTP自动地变为联机。另外在直接地连接的线缆接口的仅电缆调制解调器能下载这些配置文件。

以下配置示例显示两个DOCSIS配置文件的创建。

允许有线调制解调器来联机的第一呼叫disable.cm,但是终止从访问服务提供商的网络的连接的CPE设备。在这种情况下我们看到命令“拒绝访问”。注意下行和上行速度在这种情况下是1Kbps,最大突发大小是1600个字节。

cable config-file disable.cm
�access-denied
�service-class 1 max-upstream 1
�service-class 1 max-downstream 1600
�timestamp
!

有线电视运营商会有此“disable.cm” DOCSIS配置文件的原因是,因为他或她要拒绝对CPE的访问在电缆调制解调器背后,当让有线调制解调器来联机时。这是更有效的方式拒绝使用“请排除”在CNR的选项不会允许有线调制解调器来联机的CPE服务并且将浪费带宽的有线调制解调器将设法多次获得联机。

获得此DOCSIS配置文件的电缆调制解调器将看起来象在show cable modem命令下:

Cable4/0/U0 10�� online(d)� 2287��� 0.50� 6�� 0�� 10.1.4.65������ 0010.7bed.9b45

(||当联机)如下给予在此输出时的更多详细信息请添加链路。联机的状态“(d)”意味着电缆调制解调器只是,但是访问拒绝。

在第二示例中, DOCSIS配置文件名是创建的呼叫的“platinum.cm”。在这种情况下最大上行值是1Mbps,保证的上行是100Kpbs,最大下行是10Mbps,并且允许将连接的30个CPE设备对此。

cable config-file platinum.cm
�service-class 1 max-upstream 1000
�service-class 1 guaranteed-upstream 100
�service-class 1 max-downstream 10000
�service-class 1 max-burst 1600
�cpe max 30
�timestamp
!

注意,当配置在我们不需要语句“TFTP server slot0:platinum.cm别名platinum.cm”的CMTS的DOCSIS配置文件,因为没有在内存时存储的“.cm”文件,它在配置内驻留。在内部DOCSIS配置文件工具的更详细的资料可以在本文Cable modem终端系统命令找到。

示例图

一典型的实验室设置拓扑在图片描述。

/image/gif/paws/28990/all_in_one_config1.gif

配置

所有思科的CMTS平台支持此配置。这包括uBR7200、uBR7246VXR、ubr7100和uBR10000。

在一配置方面支持所有,包括DOCSIS配置文件的配置的Cisco IOS软件版本,是Cisco IOS软件版本12.1(2)EC和随后的EC培训版本。

以下配置在uBR7246VXR使用Cisco IOS软件版本12.1(4)EC和有被执行了NPE300。首先提交基本配置更多高级配置然后将显示。

基本一体化配置

下面的配置汇总我们在本文解释的所有片段。它有两个DHCP范围,一电缆调制解调器的和人一个主机的在电缆调制解调器背后。

一个DOCSIS配置文件创建呼叫platinum.cm。此文件应用对呼叫的DHCP池cm-platinum。呼叫disabled.cm的另一个DOCSIS配置文件当时没有应用对任何东西。

有在本例中,一个电缆调制解调器的和另一个配置的两个DHCP池PC的在电缆调制解调器背后。

注意: 一体化配置命令在粗体

基本“一体化配置” 7246VXR
7246VXR#show run

version 12.1
no service pad
service timestamps debug datetime msec localtime

! -- provides nice timestamps on all log messages

service timestamps log datetime localtime
no service password-encryption
service linenumber
service udp-small-servers max-servers no-limit

! -- supports a large number of modems / hosts attaching quickly

!
hostname 7246VXR
!
logging buffered 1000000 debugging
enable password cable
!
cable qos profile 8
cable qos profile 10
cable qos profile 10 grant-size 1500
cable qos profile 12 guaranteed-upstream 100000
no cable qos permission create
no cable qos permission update
cable qos permission modems
cable time-server

! --� permits cable modems to obtain Time of Day (ToD) from uBR7246VXR

!
cable config-file disable.cm
�access-denied
�service-class 1 max-upstream 1
�service-class 1 max-downstream 1600
�cpe max 1
�timestamp
!
cable config-file platinum.cm
�service-class 1 max-upstream 128
�service-class 1 guaranteed-upstream 10
�service-class 1 max-downstream 10000
�service-class 1 max-burst 1600
�cpe max 10
�timestamp
!
clock timezone PDT -8
clock summer-time PDT recurring
clock calendar-valid
ip subnet-zero
ip cef

! -- Turn on cef switching / routing, anything but process� switching (no ip route-cache)

ip cef accounting per-prefix�
no ip finger
ip tcp synwait-time 5
no ip domain-lookup

! -- Prevents cmts from looking up domain names / attempting�
! -- to connect to machines when mistyping commands

ip host vxr 172.16.26.103
ip domain-name cisco.com
ip name-server 171.68.10.70
ip name-server 171.69.2.132
ip name-server 171.68.200.250
no ip dhcp relay information check
!
!
!��
ip dhcp pool cm-platinum

! -- name of the dhcp pool. This scope is for the cable modems attached�
! -- to interface cable 4/0

�� network 10.1.4.0 255.255.255.0

! -- pool of addresses for scope modems-c4/0

�� bootfile platinum.cm

! -- DOCSIS config file name associated with this pool

�� next-server 10.1.4.1

! -- IP address of TFTP server which sends bootfile

�� default-router 10.1.4.1

! -- default gateway for cable modems, necessary to get DOCSIS files

�� option 7 ip 10.1.4.1

! -- Log Server DHCP option

�� option 4 ip 10.1.4.1

! -- ToD server IP address

�� option 2 hex ffff.8f80

! -- Time offset for ToD, in seconds, HEX, from GMT, -28,000 = PST = ffff.8f80

�� lease 7 0 10

! -- lease 7 days 0 hours 10 minutes

!�
ip dhcp pool pcs-c4

! -- name of the dhcp pool. This scope is for the CPEs� attached�
! -- the cable modems that are connected to interface cable 4/0

�� network 172.16.29.0 255.255.255.224

! -- pool of addresses for scope pcs-c4 (associated with the secondary address)

�� next-server 172.16.29.1�
�� default-router 172.16.29.1
�� dns-server 172.16.30.2�
�� domain-name cisco.com�
�� lease 7 0 10������
!
!
interface Ethernet2/0
�ip address 172.16.30.4 255.255.255.192
�no ip mroute-cache
�half-duplex
!
interface Cable4/0
�ip address 172.16.29.1 255.255.255.224 secondary

! -- used for the scope pcs-c4 so that PC's get an ip address on this network
ip address 10.1.4.1 255.255.255.0

! -- used for the scope modems-c4/0 so that cable modems get an ip address from this network

�no ip route-cache cef
�no keepalive
�cable downstream rate-limit token-bucket shaping
�cable downstream annex B
�cable downstream modulation 64qam
�cable downstream interleave-depth 32
�cable downstream frequency 555000000
�cable upstream 0 frequency 40000000
�cable upstream 0 power-level 0
�no cable upstream 0 shutdown
�cable upstream 1 shutdown
�cable upstream 2 shutdown
�cable upstream 3 shutdown
�cable upstream 4 shutdown
�cable upstream 5 shutdown
�cable dhcp-giaddr policy

! -- Used to� modify the GIADDR field of DHCPDISCOVER and DHCPREQUEST packets with a
! -- Relay IP address before they are forwarded to the DHCP server

!���������
!���������
router eigrp 202
�redistribute connected
�redistribute static
�network 10.0.0.0
�network 172.16.0.0
�no auto-summary
�no eigrp log-neighbor-changes
!���������
router rip
�version 2
�redistribute connected
�redistribute static
�network 10.0.0.0
�network 172.16.0.0
�no auto-summary
!���������
ip default-gateway 172.16.30.1
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.30.1
ip route 172.16.30.0 255.255.255.0 Ethernet2/0
ip http server
ip http authentication local
!���������
snmp-server engineID local 00000009020000E01ED77E40
snmp-server community public RO
snmp-server community private RW
tftp-server server

! -- enable the cmts to act as a tftp server

tftp-server slot0:silver.cm alias silver.cm

! -- get the DOCSIS config file called silver.cm that is pre-downloaded to flash.
! -- this DOCSIS config file is built using DOCSIS CPE Configurator.��

!���������
line con 0
�exec-timeout 0 0
�transport input none
line aux 0
�speed 19200
line vty 0 4
�session-timeout 60�
�login
!
ntp clock-period 17179977
ntp server 172.16.135.51
end

基本配置验证提示

首先我们必须确保, Cisco IOS软件版本支持命令。对于此我们能执行show version。

7246VXR#show version
Cisco Internetwork Operating System Software�
IOS (tm) 7200 Software (UBR7200-IK1S-M), Version 12.1(4)EC, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2000 by cisco Systems, Inc.
Compiled Fri 08-Dec-00 17:35 by ninahung
Image text-base: 0x60008950, data-base: 0x612AA000

ROM: System Bootstrap, Version 12.0(19990210:195103) [12.0XE 105], DEVELOPMENT SOFTWARE
BOOTFLASH: 7200 Software (UBR7200-BOOT-M), Version 12.0(7)T,� RELEASE SOFTWARE (fc2)

7246VXR uptime is 9 minutes
System returned to ROM by reload at 09:47:00 PDT Tue Feb 27 2001
System restarted at 09:48:26 PDT Tue Feb 27 2001
System image file is "slot0:ubr7200-ik1s-mz.121-4.EC"

cisco uBR7246VXR (NPE300) processor (revision C) with 253952K/40960K bytes of memory.
Processor board ID SAB03500058
R7000 CPU at 262Mhz, Implementation 39, Rev 1.0, 256KB L2, 2048KB L3 Cache
6 slot VXR midplane, Version 2.0

Last reset from power-on
Bridging software.
X.25 software, Version 3.0.0.
4 Ethernet/IEEE 802.3 interface(s)
1 FastEthernet/IEEE 802.3 interface(s)
5 Cable Modem network interface(s)
125K bytes of non-volatile configuration memory.

16384K bytes of Flash PCMCIA card at slot 0 (Sector size 128K).
4096K bytes of Flash internal SIMM (Sector size 256K).
Configuration register is 0x2102

我们需要验证DOCSIS配置文件在闪存。

7246VXR#show flash
-#- ED --type-- --crc--- -seek-- nlen -length- -----date/time------ name
1�� .. unknown� 2D6C7818�� 200CC��� 9������ 74 Feb 28 2001 7:39:09 silver.cm
2�� .. unknown� 1CB785DC�� 20258��� 7������ 62 Feb 20 2001 15:44:11 test.cm
3�� .. image��� 4350A04F� 7A0CC8�� 24� 7866864 Feb 27 2001 09:36:40 ubr7200-ik1s-mz.121-4.EC
4�� .. unknown� 36E5D6D3� 7A0D94��� 7������ 76 Feb 28 2001 07:23:12 gold.cm

8516204 bytes available (7867796 bytes used)

注意使用DOCSISCPE配置工具,文件“silver.cm”被创建了。对于在CMTS配置里被创建您不需要语句“TFTP server slot0:platinum.cm别名platinum.cm”的platunum.cm文件,因为没有“Cm”文件,它在配置内驻留。

下一步是验证电缆调制解调器联机。我们能达到此与show cable modem命令。

7246VXR#show cable modem
Interface�� Prim Online���� Timing Rec��� QoS CPE IP address����� MAC address
����������� Sid� State����� Offset Power
Cable4/0/U0 75�� online���� 2290��� 0.00� 5�� 1�� 10.1.4.2������� 0010.7bed.9b23
Cable4/0/U0 76�� online���� 2809��� 0.00� 5�� 0�� 10.1.4.3������� 0002.fdfa.0a63
Cable4/0/U0 77�� online���� 2288��� 0.25� 5�� 1�� 10.1.4.5������� 0010.7bed.9b45
Cable4/0/U0 78�� online���� 2810��� 0.50� 5�� 0�� 10.1.4.4������� 0004.2752.ddd5
Cable4/0/U0 79�� online���� 2813��� 0.25� 5�� 0�� 10.1.4.6������� 0002.1685.b5db
Cable4/0/U0 80�� online���� 2812�� -0.50� 5�� 0�� 10.1.4.7������� 0001.64ff.e47d


注意所有电缆调制解调器联机。那个连接对接口电缆4/0/U0在网络10.1.4.0。我们能从配置看到他们的IP地址从呼叫的DHCP池被采取“cm-platinum”。

并且请注意有MAC地址的0010.7bed.9b23各自电缆调制解调器和0010.7bed.9b45,有CPE后边。那些电缆调制解调器来联机与默认桥接配置。那些PCs配置与DHCP,以便他们能从网络获得他们的IP地址。

7246VXR#show interface cable 4/0 modem 0
SID�� Priv bits� Type����� State���� IP address��� method��� MAC address
75��� 00�������� host����� unknown�� 172.16.29.2�� static��� 00c0.4f97.61c5
75��� 00�������� modem���� up������� 10.1.4.2����� dhcp����� 0010.7bed.9b23
76��� 00�������� modem���� up������� 10.1.4.3����� dhcp����� 0002.fdfa.0a63
77��� 00�������� host����� unknown�� 172.16.29.3�� dhcp����� 00a0.243c.eff5
77��� 00�������� modem���� up������� 10.1.4.5����� dhcp����� 0010.7bed.9b45
78��� 00�������� modem���� up������� 10.1.4.4����� dhcp����� 0004.2752.ddd5
79��� 00�������� modem���� up������� 10.1.4.6����� dhcp����� 0002.1685.b5db
80��� 00�������� modem���� up������� 10.1.4.7����� dhcp����� 0001.64ff.e47d

以下图片显示那些PCs从池获得IP地址呼叫"pcs-c4."

all_in_one_config2.gif

我们能从此PC也看到TCP/IP设置是自动获取IP地址。

all_in_one_config3.gif

高级一体化配置

此部分提供介入DHCP池的层级功能的更加复杂的配置示例。方式DHCP池层级工作是所有DHCP池用是另一个池的网络号的一子集的网络号继承该其他池所有特性。这保存在DHCP服务器配置的重复。然而,如果同一个项目用一个不同的参数完成然后参数将覆盖。此示例将显示有呼叫platinum.cm的bootfile的一个常规池,并且此池的一子集将有呼叫disable.cm的bootfile。

除在基本示例创建的DHCP池之外,我们有两电缆调制解调器的特殊需求。

有线调制解调器0010.7bed.9b45将是拒绝访问。这意味着有线调制解调器将授权IP地址,但是不会来联机。对于此我们将创建以下池:

ip dhcp pool cm-0010.7bed.9b45
�� host 10.1.4.65 255.255.255.0
�� client-identifier 0100.107b.ed9b.45
�� bootfile disable.cm

此配置示例多数显著的特点是与单个有线调制解调器MAC地址相应的特殊DHCP池指定的部分。这是,以便DHCP服务器能发送唯一DHCP选项到这些调制解调器。为了指定特定有线调制解调器使用“client-identifier”参数。“client-identifier”必须设置到条目对应设备的MAC地址跟随的01。01对应于以太网硬件类型DHCP的。

注意: 当更改调制解调器的时配置文件执行以下是必要的,以便有线调制解调器手工获得配置的参数:

  • 收拾IP DHCP绑定表使用clear ip dhcp binding <ip address>命令”。

  • 重置有线调制解调器有问题的使用clear cable modem <mac address > res命令。

有线调制解调器0010.7bed.9b23也有一个特殊需求。这将获得一个不同的服务质量。所以不同的bootfile关联对范围。请参阅下面部分配置:

ip dhcp pool cm-0010.7bed.9b23
�� host 10.1.4.66 255.255.255.0
�� client-identifier 0100.107b.ed9b.23
�� bootfile silver.cm

!

当配置特定电缆调制解调器的时DHCP池它总是良好的做法给予一相关名称。并且,因为一个特定IP地址分配到使用host命令的池,我们需要global命令IP DHCP排除10.1.4.60 10.1.4.70的添加。此命令告诉DHCP不实施属于此范围的地址。

先进的“一体化配置” 7246VXR
7246VXR# show run

version 12.1
no service pad
service timestamps debug datetime msec localtime
service timestamps log datetime localtime
no service password-encryption
service linenumber
service udp-small-servers max-servers no-limit
!
hostname 7246VXR
!
logging buffered 1000000 debugging
!
cable qos profile 8
cable qos profile 10
cable qos profile 10 grant-size 1500
cable qos profile 12 guaranteed-upstream 100000
no cable qos permission create
no cable qos permission update
cable qos permission modems
cable time-server
!
cable config-file disable.cm
�access-denied
�service-class 1 max-upstream 1
�service-class 1 max-downstream 1600
�cpe max 1
�timestamp
!
cable config-file platinum.cm
�service-class 1 max-upstream 128
�service-class 1 guaranteed-upstream 10
�service-class 1 max-downstream 10000
�service-class 1 max-burst 1600
�cpe max 10
�timestamp
!
clock timezone PDT -8
clock summer-time PDT recurring
clock calendar-valid
ip subnet-zero
no ip finger
no ip domain-lookup
ip host vxr 172.16.26.103
ip domain-name cisco.com
ip name-server 171.68.10.70
ip name-server 171.69.2.132
ip name-server 171.68.200.250
ip dhcp excluded-address 10.1.4.60 10.1.4.70
!
ip dhcp pool cm-platinum
�� network 10.1.4.0 255.255.255.0
�� bootfile platinum.cm
�� next-server 10.1.4.1�
�� default-router 10.1.4.1�
�� option 7 ip 10.1.4.1�
�� option 4 ip 10.1.4.1�
�� option 2 hex ffff.8f80
�� lease 7 0 10
!
ip dhcp pool pcs-c4
�� network 172.16.29.0 255.255.255.224
�� next-server 172.16.29.1�
�� default-router 172.16.29.1�
�� dns-server 172.16.30.2�
�� domain-name cisco.com
�� lease 7 0 10
!
ip dhcp pool cm-0010.7bed.9b45
�� host 10.1.4.65 255.255.255.0
�� client-identifier 0100.107b.ed9b.45
�� bootfile disable.cm
!
ip dhcp pool cm-0010.7bed.9b23
�� host 10.1.4.66 255.255.255.0
�� client-identifier 0100.107b.ed9b.23
�� bootfile silver.cm
!
!
interface Ethernet2/0
�ip address 172.16.30.4 255.255.255.192
�no ip mroute-cache
�half-duplex
!
interface Cable4/0
�ip address 172.16.29.1 255.255.255.224 secondary
�ip address 10.1.4.1 255.255.255.0
�no keepalive
�cable downstream rate-limit token-bucket shaping
�cable downstream annex B
�cable downstream modulation 64qam
�cable downstream interleave-depth 32
�cable downstream frequency 555000000
�cable upstream 0 frequency 40000000
�cable upstream 0 power-level 0
�no cable upstream 0 shutdown
�cable upstream 1 shutdown
�cable upstream 2 shutdown
�cable upstream 3 shutdown
�cable upstream 4 shutdown
�cable upstream 5 shutdown
�cable dhcp-giaddr policy
!
router eigrp 202
�redistribute connected
�redistribute static
�network 10.0.0.0
�network 172.16.0.0
�no auto-summary
�no eigrp log-neighbor-changes
!
router rip
�version 2
�redistribute connected
�redistribute static
�network 10.0.0.0
�network 172.16.0.0
�no auto-summary
!
ip default-gateway 172.16.30.1
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.30.1
ip route 172.16.30.0 255.255.255.0 Ethernet2/0
ip http server
ip http authentication local
!
access-list 188 permit tcp any any eq www log
access-list 188 permit ip any any
route-map docsis permit 10
!
snmp-server engineID local 00000009020000E01ED77E40
snmp-server community public RO
snmp-server community private RW
tftp-server slot0:silver.cm alias silver.cm
tftp-server server

line con 0
�exec-timeout 0 0
�transport input none
line aux 0
�speed 19200
line vty 0 4
�session-timeout 60�
�exec-timeout 0 0
�login
!
ntp clock-period 17179973
end

高级配置验证提示

此配置的验证着重电缆调制解调器获得的服务,特别0010.7bed.9b45和0010.7bed.9b23。我们需要肯定他们获得手工配置的地址和服务。

测试的第一件事是0010.7bed.9b45将来联机,但是服务将拒绝。对于此我们请看一看在show cable modem命令

7246VXR#show cable modem
Interface�� Prim Online���� Timing Rec��� QoS CPE IP address����� MAC address
����������� Sid� State����� Offset Power
Cable4/0/U0 7��� online���� 2813��� 0.00� 7�� 0�� 10.1.4.7������� 0002.1685.b5db
Cable4/0/U0 8��� online���� 2809��� 0.25� 7�� 0�� 10.1.4.10������ 0002.fdfa.0a63
Cable4/0/U0 9��� online���� 2288�� -0.25� 5�� 1�� 10.1.4.66������ 0010.7bed.9b23
Cable4/0/U0 10�� online(d)� 2287��� 0.50� 6�� 0�� 10.1.4.65������ 0010.7bed.9b45
Cable4/0/U0 11�� online���� 2809�� -0.50� 7�� 0�� 10.1.4.6������� 0001.64ff.e47d
Cable4/0/U0 12�� online���� 2812�� -0.50� 7�� 0�� 10.1.4.9������� 0004.2752.ddd5

有注意的几个点此处:

  • 有线调制解调器0010.7bed.9b23获得了IP地址10.4.1.66在范围cm-0010.7bed.9b23上指定。有计算机附加对它,并且从池pcs-c4获得其IP地址。

  • 有线调制解调器0010.7bed.9b23有不同的QoS。

  • 有线调制解调器0010.7bed.9b45获得了IP地址10.1.4.65在范围cm-0010.7bed.9b45上指定。有计算机附加对它,然而CPE值是0。原因是服务拒绝。

  • 意味着0010.7bed.9b45的在线状态联机(d)有线调制解调器来联机,但是对有线网络的访问拒绝。请参阅debug cable mac log verbose输出从有线调制解调器的。

21:52:16:� 78736.550 CMAC_LOG_RESET_RANGING_ABORTED��������������
21:52:16:� 78736.554 CMAC_LOG_STATE_CHANGE���������������������� reset_interface_state
21:52:16:� 78736.558 CMAC_LOG_STATE_CHANGE���������������������� reset_hardware_state
21:52:17:� 78737.024 CMAC_LOG_STATE_CHANGE���������������������� wait_for_link_up_state
21:52:17:� 78737.028 CMAC_LOG_DRIVER_INIT_IDB_RESET������������� 0x082B9CA8
21:52:17:� 78737.032 CMAC_LOG_LINK_DOWN��������������������������
21:52:17:� 78737.034 CMAC_LOG_LINK_UP����������������������������
21:52:17:� 78737.040 CMAC_LOG_STATE_CHANGE���������������������� ds_channel_scanning_state
21:52:17: %LINEPROTO-5-UPDOWN: Line protocol on Interface cable-modem0, changed state to down
21:52:18:� 78738.386 CMAC_LOG_UCD_MSG_RCVD���������������������� 1
21:52:19:� 78739.698 CMAC_LOG_DS_64QAM_LOCK_ACQUIRED������������ 747000000
21:52:19:� 78739.702 CMAC_LOG_DS_CHANNEL_SCAN_COMPLETED����������
21:52:19:� 78739.704 CMAC_LOG_STATE_CHANGE���������������������� wait_ucd_state
21:52:20:� 78740.368 CMAC_LOG_UCD_MSG_RCVD���������������������� 1
21:52:22:� 78742.396 CMAC_LOG_UCD_MSG_RCVD���������������������� 1
21:52:22:� 78742.398 CMAC_LOG_ALL_UCDS_FOUND���������������������
21:52:22:� 78742.402 CMAC_LOG_STATE_CHANGE���������������������� wait_map_state
21:52:22:� 78742.406 CMAC_LOG_FOUND_US_CHANNEL������������������ 1
21:52:24:� 78744.412 CMAC_LOG_UCD_MSG_RCVD���������������������� 1
21:52:24:� 78744.416 CMAC_LOG_UCD_NEW_US_FREQUENCY�������������� 39984000
21:52:24:� 78744.420 CMAC_LOG_SLOT_SIZE_CHANGED����������������� 8
21:52:24:� 78744.500 CMAC_LOG_UCD_UPDATED������������������������
21:52:24:� 78744.560 CMAC_LOG_MAP_MSG_RCVD�����������������������
21:52:24:� 78744.564 CMAC_LOG_INITIAL_RANGING_MINISLOTS��������� 41
21:52:24:� 78744.566 CMAC_LOG_STATE_CHANGE���������������������� ranging_1_state
21:52:24:� 78744.570 CMAC_LOG_RANGING_OFFSET_SET_TO������������� 9610
21:52:24:� 78744.574 CMAC_LOG_POWER_LEVEL_IS�������������������� 55.0� dBmV (commanded)
21:52:24:� 78744.578 CMAC_LOG_STARTING_RANGING�������������������
21:52:24:� 78744.580 CMAC_LOG_RANGING_BACKOFF_SET��������������� 0
21:52:24:� 78744.586 CMAC_LOG_RNG_REQ_QUEUED�������������������� 0
21:52:24:� 78744.622 CMAC_LOG_RNG_REQ_TRANSMITTED����������������
21:52:24:� 78744.626 CMAC_LOG_RNG_RSP_MSG_RCVD�������������������
21:52:24:� 78744.628 CMAC_LOG_RNG_RSP_SID_ASSIGNED�������������� 10
21:52:24:� 78744.632 CMAC_LOG_ADJUST_RANGING_OFFSET������������� 2286
21:52:24:� 78744.636 CMAC_LOG_RANGING_OFFSET_SET_TO������������� 11896
21:52:24:� 78744.638 CMAC_LOG_STATE_CHANGE���������������������� ranging_2_state
21:52:24:� 78744.644 CMAC_LOG_RNG_REQ_QUEUED�������������������� 10
21:52:25:� 78745.654 CMAC_LOG_RNG_REQ_TRANSMITTED����������������
21:52:25:� 78745.658 CMAC_LOG_RNG_RSP_MSG_RCVD�������������������
21:52:25:� 78745.660 CMAC_LOG_RANGING_SUCCESS��������������������
21:52:25:� 78745.680 CMAC_LOG_STATE_CHANGE���������������������� dhcp_state
21:52:25:� 78745.820 CMAC_LOG_DHCP_ASSIGNED_IP_ADDRESS���������� 10.1.4.65
21:52:25:� 78745.824 CMAC_LOG_DHCP_TFTP_SERVER_ADDRESS���������� 10.1.4.1
21:52:25:� 78745.826 CMAC_LOG_DHCP_TOD_SERVER_ADDRESS����������� 10.1.4.1
21:52:25:� 78745.830 CMAC_LOG_DHCP_SET_GATEWAY_ADDRESS�����������
21:52:25:� 78745.834 CMAC_LOG_DHCP_TZ_OFFSET�������������������� -28800
21:52:25:� 78745.836 CMAC_LOG_DHCP_CONFIG_FILE_NAME������������� disable.cm
21:52:25:� 78745.840 CMAC_LOG_DHCP_ERROR_ACQUIRING_SEC_SVR_ADDR��
21:52:25:� 78745.846 CMAC_LOG_DHCP_COMPLETE����������������������
21:52:25:� 78745.968 CMAC_LOG_STATE_CHANGE���������������������� establish_tod_state
21:52:25:� 78745.978 CMAC_LOG_TOD_REQUEST_SENT�������������������
21:52:26:� 78746.010 CMAC_LOG_TOD_REPLY_RECEIVED���������������� 3192525217
21:52:26:� 78746.018 CMAC_LOG_TOD_COMPLETE�����������������������
21:52:26:� 78746.020 CMAC_LOG_STATE_CHANGE���������������������� security_association_state
21:52:26:� 78746.024 CMAC_LOG_SECURITY_BYPASSED������������������
21:52:26:� 78746.028 CMAC_LOG_STATE_CHANGE���������������������� configuration_file_state
21:52:26:� 78746.030 CMAC_LOG_LOADING_CONFIG_FILE��������������� disable.cm
21:52:26: %LINEPROTO-5-UPDOWN: Line protocol on Interface cable-modem0, changed state to up
21:52:27:� 78747.064 CMAC_LOG_CONFIG_FILE_PROCESS_COMPLETE�������
21:52:27:� 78747.066 CMAC_LOG_STATE_CHANGE���������������������� registration_state
21:52:27:� 78747.070 CMAC_LOG_REG_REQ_MSG_QUEUED�����������������
21:52:27:� 78747.076 CMAC_LOG_REG_REQ_TRANSMITTED����������������
21:52:27:� 78747.080 CMAC_LOG_REG_RSP_MSG_RCVD�������������������
21:52:27:� 78747.082 CMAC_LOG_COS_ASSIGNED_SID������������������ 1/10
21:52:27:� 78747.088 CMAC_LOG_RNG_REQ_QUEUED�������������������� 10
21:52:27:� 78747.090 CMAC_LOG_NETWORK_ACCESS_DENIED��������������
21:52:27:� 78747.094 CMAC_LOG_REGISTRATION_OK��������������������
21:52:27:� 78747.096 CMAC_LOG_STATE_CHANGE���������������������� establish_privacy_state
21:52:27:� 78747.100 CMAC_LOG_PRIVACY_NOT_CONFIGURED�������������
21:52:27:� 78747.102 CMAC_LOG_STATE_CHANGE���������������������� maintenance_state
21:52:31:� 78751.122 CMAC_LOG_RNG_REQ_TRANSMITTED����������������
21:52:31:� 78751.124 CMAC_LOG_RNG_RSP_MSG_RCVD�������������������
21:52:37:� 78757.164 CMAC_LOG_RNG_REQ_TRANSMITTED����������������
21:52:37:� 78757.168 CMAC_LOG_RNG_RSP_MSG_RCVD�������������������
21:52:43:� 78763.206 CMAC_LOG_RNG_REQ_TRANSMITTED����������������
21:52:43:� 78763.210 CMAC_LOG_RNG_RSP_MSG_RCVD�������������������
21:52:49:� 78769.250 CMAC_LOG_RNG_REQ_TRANSMITTED����������������
21:52:49:� 78769.252 CMAC_LOG_RNG_RSP_MSG_RCVD

此调试输出显示网络访问拒绝。

7246VXR#show cable modem detail
Interface�� SID� MAC address��� Max CPE� Concatenation� Rx SNR
Cable4/0/U0 7��� 0002.1685.b5db 10������ yes����������� 33.52
Cable4/0/U0 8��� 0002.fdfa.0a63 10������ yes����������� 33.24
Cable4/0/U0 9��� 0010.7bed.9b23 1������� no������������ 33.29
Cable4/0/U0 10�� 0010.7bed.9b45 1������� no������������ 33.23
Cable4/0/U0 11�� 0001.64ff.e47d 10������ yes����������� 33.20
Cable4/0/U0 12�� 0004.2752.ddd5 10������ yes����������� 33.44

注意电缆调制解调器的最大数量CPE有特殊范围的是1和其余是10。如果看到范围platinum.cm的配置,安排10个CPE指定,另一方面,范围disable.cm有only1 CPE。预先配置的DOCSIS配置文件silver.cm只也有指定的一个CPE。

7246VXR#show interface cable 4/0 modem 0
SID�� Priv bits� Type����� State���� IP address��� method��� MAC address
7���� 00�������� modem���� up������� 10.1.4.7����� dhcp����� 0002.1685.b5db
8���� 00�������� modem���� up������� 10.1.4.10���� dhcp����� 0002.fdfa.0a63
9���� 00�������� host����� unknown�� 172.16.29.2�� static��� 00c0.4f97.61c5
9���� 00�������� modem���� up������� 10.1.4.66���� dhcp����� 0010.7bed.9b23
10��� 00�������� modem���� up������� 10.1.4.65���� dhcp����� 0010.7bed.9b45
11��� 00�������� modem���� up������� 10.1.4.6����� dhcp����� 0001.64ff.e47d
12��� 00�������� modem���� up������� 10.1.4.9����� dhcp����� 0004.2752.ddd5

要验证电缆调制解调器获得正确级别服务,我们看到show cable qos profile命令的输出。

7246VXR#show cable qos profile
ID� Prio Max������ Guarantee Max������� Max�� TOS� TOS�� Create� B���� IP prec.
�������� upstream� upstream� downstream tx��� mask value by����� priv� rate
�������� bandwidth bandwidth bandwidth� burst������������������� enab� enab
1�� 0��� 0�������� 0�������� 0��������� 0���� 0x0� 0x0�� cmts(r) no��� no������
2�� 0��� 64000���� 0�������� 1000000��� 0���� 0x0� 0x0�� cmts(r) no��� no������
3�� 7��� 31200���� 31200���� 0��������� 0���� 0x0� 0x0�� cmts��� yes�� no������
4�� 7��� 87200���� 87200���� 0��������� 0���� 0x0� 0x0�� cmts��� yes�� no������
5�� 4��� 64000���� 0�������� 512000���� 0���� 0x0� 0x0�� cm����� no��� no������
6�� 0��� 1000����� 0�������� 1600000��� 0���� 0x0� 0x0�� cm����� no��� no������
7�� 0��� 128000��� 10000���� 10000000�� 1600� 0x0� 0x0�� cm����� no��� no������
8�� 0��� 0�������� 0�������� 0��������� 0���� 0x0� 0x0�� mgmt��� no��� no������
10� 0��� 0�������� 0�������� 0��������� 0���� 0x0� 0x0�� mgmt��� no��� no������
12� 0��� 0�������� 100000000 0��������� 0���� 0x0� 0x0�� mgmt��� no��� no

注意qos ID 7配比与在platinum.cm的配置:

cable config-file platinum.cm
�service-class 1 max-upstream 128
�service-class 1 guaranteed-upstream 10
�service-class 1 max-downstream 10000
�service-class 1 max-burst 1600
�cpe max 10
�timestamp

同样发生与disable.cm DOCSIS配置。

7246VXR#show ip dhcp binding
IP address������ Hardware address������� Lease expiration������� Type
10.1.4.6�������� 0100.0164.ffe4.7d������ Mar 08 2001 07:58 AM��� Automatic
10.1.4.7�������� 0100.0216.85b5.db������ Mar 08 2001 07:58 AM��� Automatic
10.1.4.9�������� 0100.0427.52dd.d5������ Mar 08 2001 07:58 AM��� Automatic
10.1.4.10������� 0100.02fd.fa0a.63������ Mar 08 2001 08:36 AM��� Automatic
10.1.4.65������� 0100.107b.ed9b.45������ Infinite��������������� Manual
10.1.4.66������� 0100.107b.ed9b.23������ Infinite��������������� Manual

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 28990