?????? : 思科应用和内容网络系统 (ACNS) 软件

如何使用 WCCP 配置 Cache Engine 以使用反向代理缓存

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2014 年 10 月 1 日) | 反馈



目录


简介

通过使用WEB缓存通信协议(WCCP),本文描述如何配置Reverse-Proxy Caching的Cisco缓存引擎。

硬件和软件版本

此配置使用下面软件和硬件版本开发并且被测试。

  • 在实验室环境的Cisco Cache Engine 560清除配置运行思科高速缓存软件版本2.3和ACNS版本4.0的和ACNS 5.0。

  • 运行Cisco IOS软件版本12.1(2)的Cisco 2600路由器。
使用在实验室环境的设备本文提供的信息创建。设备开始与原始。如果在真实网络工作,请确保您了解命令的潜在影响使用它以前。

网络图


配置

Cache Engine 560 (缓存软件软件版本2.3或ACNS软件版本4.0或5.0)
Current configuration:
!
!
user add admin uid 0 
password 1 "eeSdy9dcy" 
capability admin-access
!
!
!
hostname ce
!
interface ethernet 0
 ip address 10.0.0.2 255.255.255.0
!--- Important: If you configure the Cache Engine
!--- with a private address, it must get translated
!--- to a public address.
 ip broadcast-address 10.0.0.255 exit ! interface ethernet 1 exit ! ip default-gateway 10.0.0.1 ip name-server 171.70.168.183 ip domain-name cisco.com ip route 0.0.0.0 0.0.0.0 10.0.0.1 cron file /local/etc/crontab ! wccp router-list 1 10.0.0.1 wccp reverse-proxy router-list-num 1 wccp version 2 ! authentication login local enable authentication configuration local enable rule no-cache url-regex .*cgi-bin.* rule no-cache url-regex .*aw-cgi.* ! !

Cisco 2600路由器(Cisco IOS软件版本12.1[2])
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 2611-5
!
enable secret 5 $1$9VQ.$BTPbq8xlE2dsKwKPDDmpL/
!
!
ip subnet-zero
ip wccp 99
!
!
interface Ethernet0/0
 description Interface to the Internet 
 ip address 172.17.63.194 255.255.255.192
 no ip redirects
!
interface Serial0/0
 no ip address
 no ip mroute-cache
 shutdown
!
interface Ethernet0/1
 ip address 10.0.0.1 255.255.255.0
!
interface Ethernet1/0
 ip address 10.1.0.1 255.255.255.0
 ip wccp 99 redirect out
!
interface Ethernet1/1
 no ip address
 shutdown
 full-duplex
!
interface Ethernet1/2
 no ip address
 shutdown
!
interface Ethernet1/3
 no ip address
 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.17.63.193
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 login
!
end

debug 和 show 命令

在发出 debug 命令之前,请参阅有关 Debug 命令的重要信息

Cache Engine Debug与Show调试指令:

  • show wccp cache -显示WCCP CE信息
  • show wccp flows -显示WCCP数据包流
  • show wccp routers -显示WCCP路由器列表
  • show wccp services -配置的Show wccp services
  • show wccp slowstart -显示WCCP缓慢的开始
  • show wccp status -显示WCCP运行状态
  • show statistics http savings -显示HTTP节省统计数据
  • 调试WCCP全WCCP打开所有调试
  • debug wccp events - WCCP事件
  • debug wccp packets - WCCP包相关信息
路由器Debug与Show调试指令:
  • show ip wccp 99 detail -此命令显示Cache Engine和WCCP路由器统计数据服务组的。
  • show ip wccp 99 view -服务组查阅信息
  • debug ip wccp events - WCCP事件
  • debug ip wccp packets - WCCP包相关信息

验证

验证反向代理高速缓冲存储用这些命令工作。

发出此命令检查WCCP缓存/内容引擎状态:

router#sh ip wccp 99 detail 
WCCP Cache-Engine information: 
       IP Address:            10.0.0.2 
       Protocol Version:      2.0 
       State:                 Usable                              
	   !--- This cache is active.
       Initial Hash Info:     00000000000000000000000000000000 
                              00000000000000000000000000000000 
       Assigned Hash Info:    FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF 
                              FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF 
       Hash Allotment:        256 (100.00%) 
       Packets Redirected:    93 
       Connect Time:          00:15:27

发出此命令检查在路由器的WCCP透明反向重定向:

router#sh ip wccp 99 
Global WCCP information: 
    Router information: 
        Router Identifier:                   172.17.63.194 
        Protocol Version:                    2.0 
    Service Identifier: 99 
        Number of Cache Engines:             1 
        Number of routers:                   1 
        Total Packets Redirected:            93                   
		!--- The router is redirecting.
        Redirect access-list:                -none- 
        Total Packets Denied Redirect:       0 
        Total Packets Unassigned:            0 
        Group access-list:                   -none- 
        Total Messages Denied to Group:      0 
        Total Authentication failures:       0


发出此命令检查在缓存/内容引擎的HTTP统计信息:

cache#sh statistic http request 
                              Statistics - Requests 
                                                Total             % of Requests 
                            --------------------------------------------------- 
     Total Received Requests:                      23                         - 
              Forced Reloads:                       2                       8.7 
               Client Errors:                       0                       0.0 
               Server Errors:                       0                       0.0 
         URL Blocked (Reset):                       0                       0.0 
                 URL Blocked:                       0                       0.0 
      Sent to Outgoing Proxy:                       0                       0.0 
Failures from Outgoing Proxy:                       0                       0.0 
Excluded from Outgoing Proxy:                       0                       0.0 
             ICP Client Hits:                       0                       0.0 
             ICP Server Hits:                       0                       0.0 
               If-Range Hits:                       0                       0.0 
           HTTP 0.9 Requests:                       0                       0.0 
           HTTP 1.0 Requests:                       0                       0.0 
           HTTP 1.1 Requests:                      23                     100.0 
       HTTP Unknown Requests:                       0                       0.0 
           Non HTTP Requests:                       0                       0.0 
          Non HTTP Responses:                       0                       0.0 
      Chunked HTTP Responses:                       0                       0.0 
        Http Miss Due To DNS:                       0                       0.0 
     Http Deletes Due To DNS:                       0                       0.0 
  Objects cached for min ttl:                       4                      17.4

发出此命令验证请求高速缓冲存储:

cache#sh stat http sav 
                         Statistics - Savings 
                        Requests                          Bytes 
         ----------------------------------------------------------- 
  Total:                      23                          16481 
   Hits:                       6                           2205 
   Miss:                      17                          14276 
Savings:                    25.0 %                         13.4 %

命令汇总

这些Cache Engine命令用于此配置。
  • WCCP版本{1|2}
  • wccp router-list number ip-address
  • WCCP router-list-num编号
这些路由器命令用于此配置。
  • ip WCCP {web-cache|服务编号}
  • ip WCCP {web-cache|服务编号}重定向
  • ip WCCP版本2


相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息



Document ID: 28832