网络应用服务 : Cisco LocalDirector 400 系列

排除内容负载均衡在LocalDirector 4.1.1故障

2016 年 10 月 27 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


Cisco已宣布Cisco LocalDirector终止销售。更多信息,请参见LocalDirector 400系列生命周期终止和销售终止通知以及产品公告


目录


简介

本文提供一配置示例和其它命令排除故障在Cisco LocalDirector 416 (版本4.1.1)的内容负载平衡功能联机。

注意: 与内容负载均衡的几个问题在代码的多数最近版本修改LocalDirector的。严格推荐您使用版本4.2.4或以上。参考Software Download页(仅限注册用户)欲知更多信息。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

此配置使用这些软件和硬件版本开发并测试:

  • 当客户端的LocalDirector 416 (版本4.1.1),运行Windows 2000服务器、Windows NT 4.0服务包4.0和Windows 98

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

网络图

/image/gif/paws/28847/load_balancing.jpg

配置

/index.htm页的一客户端请求去服务器172.18.124.205或172.18.124.207。与/rtp/local-director的获得请求去服务器172.18.124.101。其他请求去172.18.124.206。

LocalDirector 416 (版本4.1.1。)
Current configuration:
 syslog output 20.3
 no syslog console
 enable password 000000000000000000000000000000 encrypted
 hostname 38-ld416
 no shutdown ethernet 0
 no shutdown ethernet 1
 no shutdown ethernet 2
 interface ethernet 0 auto
 interface ethernet 1 auto
 interface ethernet 2 auto
 mtu 0 1500
 mtu 1 1500
 mtu 2 1500
 multiring all
 no secure  0
 no secure  1
 no secure  2
 ping-allow 0
 ping-allow 1
 no ping-allow 2
 ip address 172.18.124.209 255.255.255.0
 route 0.0.0.0 0.0.0.0 172.18.124.1 1
 arp timeout 30
 no rip passive
 rip version 1
 failover ip address 0.0.0.0
 no failover
 failover hellotime 30
 password cisco
 snmp-server enable traps
 snmp-server community public
 no snmp-server contact
 no snmp-server location
 no dns-boomerang enable
 content-rule nsteam depth 1024 "/index*.htm*"
 content-rule jahrule depth 1024 "/rtp/local-director/*"
 virtual 172.18.124.219:80:0:tcp:jahrule is
 virtual 172.18.124.219:80:0:tcp is
 virtual 172.18.124.219:80:0:tcp:nsteam is
 service 172.18.124.219:80:0:tcp clb-close
 real 172.18.124.205:80:0:tcp is
 real 172.18.124.101:80:0:tcp is
 real 172.18.124.206:80:0:tcp is
 real 172.18.124.207:80:0:tcp is
 bind 172.18.124.219:80:0:tcp:jahrule 172.18.124.101:80:0:tcp
 bind 172.18.124.219:80:0:tcp 172.18.124.206:80:0:tcp
 bind 172.18.124.219:80:0:tcp:nsteam 172.18.124.205:80:0:tcp
 bind 172.18.124.219:80:0:tcp:nsteam 172.18.124.207:80:0:tcp
end

show 命令输出示例

show real

验证真实服务器状态。

LocalDirector# show real
  Real Machines:  
                                                       No Answer  TCP Reset   DataIn   Machine

                            Connect  State Thresh   Reassigns  Reassigns   Conns  
 172.18.124.205:80:0:tcp       0      IS      8         0          0         0
 172.18.124.101:80:0:tcp       0      IS      8         0          0         0
 172.18.124.206:80:0:tcp       0      IS      8         0          0         0
 172.18.124.207:80:0:tcp       0      IS      8         0          0         0

show server

验证服务配置。

LocalDirector# show service
  Virtual Machine(s)              Service
 172.18.124.219:80:0:tcp         clb-close

show rule

查看规则。

LocalDirector# show rule
  Name            Depth           Content-String
  nsteam          1024            "/index*.htm*"
  jahrule         1024            "/rtp/local-director/*"

查看特定规则。

LocalDirector# show rule jahrule

  Name            Depth           Content-String
  jahrule         1024            "/rtp/local-director/*"

show bind

验证捆绑。

LocalDirector# show bind

 Virtual Machine(s)                      Real Machines/Urls
 172.18.124.219:80:0:tcp:jahrule(IS)
 172.18.124.101:80:0:tcp (IS)
 172.18.124.219:80:0:tcp (IS)
 172.18.124.206:80:0:tcp (IS)
 172.18.124.219:80:0:tcp:nsteam(IS)
 172.18.124.205:80:0:tcp (IS)
 172.18.124.207:80:0:tcp (IS)

编辑规则

  1. 通过使用no bind命令,解开。

  2. 通过使用to no-inservice命令,禁用虚拟服务器使用规则。

  3. 通过使用no virtual命令,删除虚拟服务器。

  4. 通过键入no rule命令编辑规则。


相关信息


Document ID: 28847