拨号和接入 : 综合业务数字网络 (ISDN),随路信令 (CAS)

对 Cisco 路由器使用一个 ADTRAN 终端适配器

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 22 日) | 反馈


目录


简介

ADTRAN ISDN终端适配器(TA)可以用于提供基本速率接口(BRI)连接给路由器,不用BRI接口。TA (连接对串行端口)终止BRI呼叫并且传达数据给路由器,同步数据数据流。

本文如何略述对工作的ADTRAN ISU™ TA用Cisco路由器。我们建议您在行动之前参考在ADTRAN网站的leavingcisco.com 产品文档。

先决条件

要求

验证BRI电路正确地工作。您可以希望以BRI端口使用在路由器的电路在部署它之前测试电路在此配置方面。并且请验证并且测试对等设备保证正常运行。

对于一些应用程序, ADTRAN ISU必须支持同步多链路PPP (MPPP)。ISUs包括ISU Express (部件号1200.081L5、1200.081L6和1202.081 L6), ISU 2x64 (支持同步MP的1200.051L1和1200.051L2)和第二代ISU 128 (1202.029L2和1202.029L3。)

要使用在Cisco路由器的MPPP, ISU的软件修订一定最新。在下表提交最低软件修订版本列表按产品:

单元 部件号 软件修订
ISU 128 1202.029 E.00
ISU 2x64 1200.051 D.00或G.00
ISU Express L6 1200.081L6 K.28
ISU Express L6 1202.081L6 D.43

注意: 因为需求可能更改,请验证与使用ADTRAN ISUs的固件需求以Cisco路由器leavingcisco.com

使用的组件

本文档中的信息基于以下软件和硬件版本。

  • 有同步串行接口的一个路由器。serial interfaces可以内置或在WIC/Network模块。

  • 没有此配置的思科IOS�软件限制。

本文档中的信息都是基于特定实验室环境中的设备创建的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您是在真实网络上操作,请确保您在使用任何命令前已经了解其潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

拨号方法

有能由TA使用启动拨号的三个方法:

  • V.25或V.25bis拨号

  • 数据终端就绪(DTR)正在拨号

  • 键盘正在拨号

V.25 或 V.25bis 拨号

使用此方法,路由器发送电话号码对TA。此方法允许路由器发出和收到ISDN呼叫。要激活拨号的V.25/V,.25bis,您必须配置dialer in-band命令在路由器接口。例如:

interface Serial0
   ip address 172.25.254.97 255.255.255.252
   encapsulation ppp
   dialer in-band
   dialer idle-timeout 300
   dialer map ip 172.25.254.98 name Remote broadcast 5551212&5551213
   ppp authentication chap
   dialer-group 1

您应该配置V.25bis拨号和MPPP的ISU。

当路由器收到关注数据流时,培养DTR和请求发送,造成TA启动在第一B信道的一个拨号。然而,路由器不请求TA首次第二B信道连接。在这种情况下,必须编程ADTRAN拨号第二B信道或有在同一dialer string内通过的第二个数字。路由器串行接口是点对点接口并且不知道在ADTRAN配置的B信道数量。

请勿配置在路由器的ppp multilink命令,因为TA实际上处理多链路连接,当仅路由器需要进程从TA时的同步流。

注意: 使用多个拨号地图(因为我们在BRI接口会)不为此多链路问题帮助。

DTR 拨号

使用此方法,路由器能只发出呼叫到一个特定的电话号码,它不能收到呼入呼叫。使用此方法,在TA的内存必须存储远程站点的电话号码。当TA看到DTR上升时,拨号在TA存储的号码。这要求dialer dtr命令在serial interfaces下。例如:

示例:

interface Serial0
   ip address 172.25.254.97 255.255.255.252
   encapsulation ppp
   dialer dtr
   dialer idle-timeout 300
   ppp authentication chap

必须为DTR拨号配置ADTRAN,多链路PPP,等等,并且有被编程的目的地电话编号。

两B信道由ADTRAN拨号。

键盘拨号

一些TA有在允许的他们的键盘交互式拨号直接地从TA。使用此方法,在连接将做时候,用户在TA键盘必须输入编号拨。为了便于测试此方法主要用于得验证连接。需要的路由器配置如下所示:

interface Serial0
   ip address 172.25.254.97 255.255.255.252
   encapsulation ppp
   dialer in-band
   dialer idle-timeout 300
   dialer map ip 172.25.254.98 name Remote broadcast
   ppp authentication chap

缚住

连接路由器的串行端口到TA使用V.35 DTE电缆(与DB-60串行端口或聪明的序列在一端)。以下图表显示示例电缆:

adtran_ta1.gif

如果TA只有RS-232端口,则您也需要V.35到RS-232 (DB-25)电缆除显示的电缆之外如上。交替地,您能使用一个DB-60-to-DB-25 RS-232电缆

关于串行电缆的参考的产品目录部分关于布线的更多信息。

使用 V.25bis 的配置示例

此部分显示使用V.25b is的配置示例。

/image/gif/paws/28080/adtran_ta2.gif

ADTRAN ISU 配置

此部分包括在配置ADTRAN ISU的一些提示。然而,请在配置TA前leavingcisco.com 请参见ADTRAN网站,比如功能,功能,并且配置参数可能更改。

  1. 连接ADTRAN TA到PC。此步骤是必要的,以便您能访问TA和在连接它之前配置多种参数至路由器。

    附加RJ-45到DB-9适配器被标记的“终端”到PC的通信(COM)端口。从适配器的RJ-45末端连接一条平滑Rolled RJ-45--RJ-45电缆(零件号码CAB-500RJ =),每个Cisco路由器都应配有该与控制台连接的电缆。您也需要RJ-45对DB-25适配器被标记的“调制解调器” (部件号CAB-25AS-MMOD)连接反转电缆到DB-25端口被标记RS-232在ADTRAN背面。

  2. 回车AT! v (或,如果连接对RS366/Maintenance端口,使用! V)得到主菜单。然后请按Ctrl+C输入配置菜单。

    您应该下面看到菜单类似于那个(这可能根据TA型号变化) :

     Ctl-V STATUS   Ctl-T TEST   Ctl-C CONFIG   Ctl-D DIAL   Ctl-X EXIT
                             ISU 128 Configuration Menu
    
     1) Netw. options = Dial Line           17) RTS Options = 1 ms delay
     2) Switch Protocl = National ISDN1     18) CTS Options = Forced CTS
     3) Call type = Data 64Kbps             19) CD Options = Normal
     4) SPID 1 = 51255511110101             20) DTR Options = Idle when Off
     5) SPID 2 = 51255511120101             21) DSR Options = OFF Idle+Test
     6) LDN 1 = 5551111                     22) Transmit Clock = Normal
     7) LDN 2 = 5551112                     23) Protocol = PPP asyn-sync
     8) Dial options = V.25                 24) Method = Multilink
     9) V.25 = V.25 HDLC FLAGS              25) Quick setup
    10) Auto answer = Enabled
    11) Answer tone = No Answer tone
    12) Connect Timout = 30 sec (def)
    13) Call Screening = Answer any
    14) DTE options = Synchronous
    15) Bit Rate = 128000
    16) Connector Type = RS-232
    ____________________________________________________________________________
    
    Select =                                    Enter SELECT    Esc NO CHANGE
    ____________________________________________________________________________
    
     Ctl-V STATUS   Ctl-T TEST   Ctl-C CONFIG   Ctl-D DIAL   Ctl-X EXIT
  3. 请使用对应数输入多种属性的配置模式。

    应该配置以下属性(在最低) :

    • 交换机协议:Telco指定的交换机类型。

    • 呼叫类型:指定64个k或56k数据(根据电路种类)。

    • SPID1, SPID2, LDN1, LDN2 :如果适用,请分配Telco和LDNs提供的SPID。

    • 拨号选项:V.25.

    • V.25 :V.25 HDLC (如果曾经同步序列)或V.25异步(如果曾经异步序列)。

    • DTE选项:同步(如果曾经同步序列)或异步(如果曾经异步序列)。

    • 比特率:128000 (或112000 56k呼叫的)。

    • 协议:PPP asyn-sync。

    • 方法:多链路。

    我们建议您参考ISU数据表或宣传单页/指南在ADTRAN网站leavingcisco.com 可能的选项的每个参数的。显示的示例如上应该为多数情况工作。

路由器配置和测试

使用以下步骤配置和测试路由器。

  1. 连接V.35或RS-232 DTE电缆到路由器串行端口。参考部分布线关于您应该使用的电缆类型的更多信息。

  2. 请使用show controller serial (指示的x电缆类型路由器连接对)验证在路由器端的电缆是DTE。例如:

    Router#show controller serial 1
    HD unit 1, idb = 0xCF6E8, driver structure at 0xD4A30
    buffer size 1524  HD unit 1, RS-232 DTE cable
    cpb = 0xE3, eda = 0x940, cda = 0x800
    ...
    ...

    您应该也验证在ADTRAN (在以上示例的选项16的连接器类型设置)匹配使用的布线。

  3. 配置路由器如下:

    username peer password 0 cisco
    !
    interface Serial1 
    ip address 192.168.180.2 255.255.255.0 
    encapsulation ppp 
    dialer in-band
     
    !--- Enable V.25bis dialing. 
    
    dialer map ip 192.168.180.22 name peer 5551111&5551112
     
    !--- Dialer map for the peer. 
    !--- Note the multiple numbers separated by "&"
     
    dialer-group 1 
    pulse-time 1 
    ppp authentication chap
    !
    ip classless
    ip route 192.168.180.22 255.255.255.255 Serial1
    dialer-list 1 protocol ip permit

    注意: 为了使启动的TA两个信道,您必须存储在ADTRAN的第二个数字,或者请使用[phonenumber1]&[phonenumber2]在思科拨号映射语句(建议使用)。serial interfaces是一点对点接口,因此有多个拨号地图不影响多链路连接。

    ADTRAN拨号第一个数字,协商并且验证,立即然后拨号第二。注意ppp multilink命令在路由器没有配置,因为TA处理多链路

    注意: 如果在异步模式希望使用serial interfaces,请使用physical-layer async命令在串行接口配置下。然而,一些serial interfaces硬件不支持异步通信。要连接调制解调器到此接口,参见“使用AUX端口上的某个调制解调器配置Dialout”。本文使用Aux端口。然而,配置是非常类似的。

  4. 启动ping到远程路由器。路由器发送dialer string对TA,然后启动ISDN链路。一旦ISDN链路是UP,路由器协商PPP,并且和验证出现。您应该能此时通过流量。

验证

当前没有可用于此配置的验证过程。

故障排除

本部分提供的信息可用于对配置进行故障排除。

故障排除命令

命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

注意: 在发出 debug 命令之前,请参阅有关 Debug 命令的重要信息

  • debug dialer -显示关于在拨号程序有能力接口接收的数据包的调试信息。当按需拨号路由(DDR)在接口时启用,信息关于所有呼叫的原因(呼叫拨号原因)也显示。欲知更多信息,请参阅在调试指令文档的debug dialer信息。

  • debug interface serial -请使用debug serial interface exec命令显示关于串行连接故障的信息。欲知更多信息,请参阅在调试指令文档的debug interface serial信息。

  • debug ppp negotiation - 显示关于PPP流量的信息,并进行交换,同时协商PPP组件,这些组件包括链路控制协议(LCP)、认证以及网络控制协议(NCP)。成功的PPP协商将打开LCP状态,然后首先验证和终于协商NCP。关于读请参考了解debug ppp协商输出的本文的debug ppp协商输出的更多信息

  • debug ppp authentication -显示PPP认证协议消息,包括质询验证协议(CHAP)信息包交换和密码认证协议(PAP)交换。参考以下文档欲知更多信息:排除故障PPP (CHAP或PAP)验证

调试输出

激活debug dialerdebug ppp协商,然后启动ping给对等体。路由器应尝试拨号。一旦ISDN连接被建立PPP协商应该开始。debug输出以下表示成功的呼叫。

Router#show debug
Dial on demand:  Dial on demand events debugging is on
PPP:  
  PPP authentication debugging is on  
  PPP protocol negotiation debugging is on
Router#ping 192.168.180.22
  Type escape sequence to abort.
   Sending 5, 100-byte ICMP Echos to 192.168.180.22, timeout is 2 seconds:
 Serial1: Dialing cause ip (s=192.168.180.2,d=192.168.180.22)

!--- Dialing cause is ping to 192.168.180.22.

   Serial1: Attempting to dial 5551111&5551112
   
!--- Call is dialed out using Serial1 
   !---(which is connected to the ADTRAN).
   !--- Remember that ADTRAN handles the ISDN L1-L3, so ISDN messages
   !--- will not be visible on the router.

   Se1 UNKNOWN(0x00FF): LCP not open, discarding packet.
   Se1 UNKNOWN(0x00FF): LCP not open, discarding packet
   Se1 LCP: I CONFREQ [Closed] id 49 len 15

!--- PPP Negotiation begins.

   Se1 LCP: AuthProto CHAP (0x0305C22305)
   Se1 LCP: MagicNumber 0x65FF6351 (0x050665FF6351)
   Se1 LCP: Lower layer not up, discarding packet
   %LINK-3-UPDOWN: Interface Serial1, changed state to up.
   Se1 PPP: Treating connection as a callout
   Se1 PPP: Phase is ESTABLISHING, Active Open
   Se1 LCP: O CONFREQ [Closed] id 47 len 15
   Se1 LCP: AuthProto CHAP (0x0305C22305)
   Se1 LCP: MagicNumber 0x048333B0 (0x0506048333B0)
   Se1 LCP: I CONFACK [REQsent] id 48 len 15
   Se1 LCP: AuthProto CHAP (0x0305C22305)
   Se1 LCP: MagicNumber 0x048333B0 (0x0506048333B0)
   Se1 LCP: I CONFREQ [ACKrcvd] id 50 len 15
   Se1 LCP: AuthProto CHAP (0x0305C22305)
   Se1 LCP: MagicNumber 0x65FF6351 (0x050665FF6351)
   Se1 LCP: O CONFACK [ACKrcvd] id 50 len 15
   Se1 LCP: AuthProto CHAP (0x0305C22305)
   Se1 LCP: MagicNumber 0x65FF6351 (0x050665FF6351)
   Se1 LCP: State is Open
   Se1 PPP: Phase is AUTHENTICATING, by both
   Se1 CHAP: O CHALLENGE id 11 len 42 from "Router"
   Se1 CH.AP: I CHALLENGE id 11 len 30 from "peer"
   Se1 CHAP: O RESPONSE id 11 len 42 from "Router"
   Se1 CHAP: I SUCCESS id 11 len 4
   Se1 CHAP: I RESPONSE id 11 len 30 from "peer"
   Se1 CHAP: O SUCCESS id 11 len 4 
   
!--- Authentication is successful.

   Se1 PPP: Phase is UP
   Se1 IPCP: O CONFREQ [Closed] id 16 len 10
   Se1 IPCP: Address 192.168.180.2 (0x0306CF12B402)
   Se1 IPCP: I CONFREQ [REQsent] id 1 len 10
   Se1 IPCP: Address 192.168.180.22 (0x0306CF12B416)
   Se1 IPCP: O CONFACK [REQsent] id 1 len 10
   Se1 IPCP: Address 192.168.180.22 (0x0306CF12B416)
   %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1, 
   changed state to up
   Se1 IPCP: TIMEout: Time 0x476F808 State ACKsent
   Se1 IPCP: O CONFREQ [ACKsent] id 17 len 10
   Se1 IPCP: Address 192.168.180.2 (0x0306CF12B402)
   Se1 IPCP: I CONFACK [ACKsent] id 17 len 10
   Se1 IPCP: Address 192.168.180.2 (0x0306CF12B402)
   Se1 IPCP: State is Open
   Se1 IPCP: Install route to 192.168.180.22
   dialer Protocol up for Se1

注意: 关于读debug ppp协商输出的更多信息,请参考了解debug ppp协商输出的本文。

故障排除步骤

此部分包括一些普通的故障排除程序。如果遇到在所有步骤的问题参考ADTRAN技术文档欲知更多信息:

  1. 验证在ADTRAN的前面的显示读如下:

    Adtran ISU 128
    [Switch-type] Ready

    这保证ISDN配置,例如交换类型,服务配置文件标识符(SPID),并且本地目录号(LDN)由Telco正确地配置并且接受。

  2. 首次对使用在ADTRAN的对等体的测试连接键盘。这可帮助保证ISDN电路和ISDN相关的配置在TA正确。

  3. 启动ping给对等体。您应该看到以下在ADTRAN的前面板显示:“呼叫[电话号码”。这表明至少V.25bis正确地工作。如果看不到消息,请尝试交换电缆和均等TA。这可帮助隔离坏电缆和V.35接口在TA。

  4. 激活debug dialer。启动ping。验证您看到以下在debug输出中:

    Serial1: Dialing cause ip (s=192.168.180.2, d=192.168.180.22)
    Serial1: Attempting to dial 5551111&5551112

    如果看不到消息,则问题DDR相关的。验证路由器配置是如上所述。确保路由和触发数据流定义配置。

  5. 激活debug serial interface,启动ping并且验证TA培养Data Set Ready。

    只有当路由器检测一个高DSR时,路由器尝试协商PPP。如果DSR不上升,则我们必须排除故障一较低层例如ISDN、硬件和布线。

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 28080