语音 : H.323

设计和配置基于ISDN的VoIP

2016 年 10 月 27 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 12 月 19 日) | 反馈


目录


简介

在综合服务数字网(ISDN)的VoIP使用IP电话,有时是一个理想组合,特别是在企业网络。要求的功能为VoIP、低延迟排队(LLQ)、基于类的加权公平排队(CBWFQ)和链路分段和交织(LFI)提供必要的服务质量(QoS),为ISDN和组合工作支持。然而,有考虑到的重大的设计注意事项。本文讨论警告,并且限制涉及在使用这些VoIP涉及与ISDN的QoS功能,并且提供一些测试的配置示例。

先决条件

要求

Cisco 建议您了解以下主题:

  • ISDN

  • 点对点协议 (PPP)

  • 多链路PPP (MLPPP)

  • LFI

  • LLQ

  • CBWFQ

  • 压缩的实时协议 (cRTP)

本文在这些主题不提供技术培训,然而相当说明这些技术如何在VoIP网络。请参阅“相关信息”部分关于这些主题的更多信息。

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • Cisco IOS�软件版本12.2

  • 对12.2(10)T的Cisco IOS软件版本12.2(2)T

  • Cisco IOS软件版本12.2(12)T和以后

这些设计选项在本文被提交和用要注意的Cisco IOS软件版本测试:

使用以下设备,测试执行。这些路由器直接地在ISDN间连接。Pagent用于模拟RTP流量和过度预定连接。

  • 有PRI接口的Cisco 7200路由器

  • 有BRI接口的Cisco 2600路由器

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

设计问题

有要求特别注意事项的三个问题,当您设计基于ISDN的VoIP网络时。这些在此表里简要地描述然后被扩展。

问题 说明
可变带宽 作为B信道变化的ISDN链路带宽被添加或丢弃。
LFI造成的数据包重拨 当插入时RTP数据包他们能到达故障中,当传送在多B信道间。
Cisco CallManager呼叫接纳控制(CAC)限制 Cisco CallManager基于位置的CAC当前不拓朴意识的。

可变带宽

ISDN允许B信道将被添加或丢弃以回应对带宽的需求。事实随着时间的推移变化的链路的带宽提出对Cisco IOS CBWFQ和LLQ排队机制的一特殊挑战。直到Cisco IOS软件版本12.2(2)T,被实施的LLQ或CBWFQ可能只分配一定量的带宽的策略映射。默认情况下,分配的带宽能只消耗75%可用的带宽。在ISDN接口, CBWFQ和LLQ假设,仅64 Kbps是可用的,即使接口有可能性提供带宽1.544或2.408 Mbps。所以,仅75% 64 Kbps或者48 Kbps,可以由在所有ISDN接口的一策略映射分配。这限制可以被传送VoIP呼叫的数量。如果分配更多带宽,则错误消息生成,当策略映射应用对ISDN接口时。

考虑此策略映射使用情况为例:

policy-map 命令
policy-map isdn-qos
  class VoIP-RTP
  priority 64
  class VoIP-Sig
  bandwidth 10

当它应用对BRI接口时, policy-map命令拒绝,因为超过75%一B信道(48 Kbps)保留:

service-policy output命令

!--- Note the highlighted error message when the policy 
!--- is applied to the dialer interface
.

router(config)# interface dialer 0
  router(config-if)# service-policy output isdn-qos
  I/f Dialer0 class VoIP-RTP requested bandwidth 64 (kbps) Available only 47 (kbps)

对此问题的解决方案在Cisco IOS软件版本12.2(2)T介绍。自此版本,保留百分比带宽联机而不是绝对量带宽是可能的。为了保留RTP的64 Kbps和发信号的8 Kbps在一个BRI接口用共计128 Kbps和8 Kbps一D-channel的两B信道,服务策略是:

policy-map 命令
policy-map isdn-qos
  class VoIP-RTP
  priority percent 50
  class VoIP-SIG
  bandwidth 8

结果,为RTP,当第一B信道出现时和64 Kbps联机有32 Kbps可用的,当第二个信道出来时。另外,因为超额预订不能发生, Cisco IOS从接口从未取消服务策略由于超额预订。

LFI造成的数据包重拨

当您执行基于ISDN的VoIP时, MLPPP使用LFI。LFI分开大数据包成更加小的片段并且在所有在套件的B信道间平行传送他们。同时语音数据包在片段之间被插入,并且降低他们的延时。插页信息包不是受MLPPP封装支配,他们被封装作为正常PPP数据包。所以,如果他们到达故障中,他们没有MLPPP序号,并且不可能重拨。重拨的可能性实时。多种链路队列的深度在套件的能有所不同,由于在排队延迟的差异造成RTP数据包互相超越。多种B信道能通过ISDN网络也采取不同的路径和结束用不同的传输延迟。

通常,此重拨数据包不是RTP数据包的一问题。在接收的VoIP设备的消抖动缓冲区重新排序根据RTP序号的数据包。然而,如果使用,重拨变为问题cRTP。cRTP算法假设, RTP数据包是被压缩和解压在同样命令。如果他们重新命令,则解压不正确地发生。如果有超过在MLPPP套件的一B信道使用cRTP是不现在安全的。同一限制为MLPPP over ATM或帧中继适用。在这种情况下,如果有超过在套件的一个虚拟电路cRTP不是可能的。

对重拨的问题的一解决方案由多类多链路PPP (MCMP)提供。MCMP给插页信息包一个小报头用序号。在cRTP解压发生前,这允许套件的远端将重拨的插页信息包。MCMP支持在Cisco IOS软件版本12.2(12)T预计。参考的RFC 2686和Cisco Bug ID CSCdv46666 (仅限注册用户)欲知详情。

Cisco CallManager CAC限制

有分支机构网络的企业用户经常用于ISDN数据备份。当IP电话部署时,客户喜欢使用ISDN备份链路语音,以及数据。此配置是可能的,但是有遵守的一些警告。

在分支机构网络的IP电话根据集中式呼叫处理型号典型地,并且使用基于位置的CAC限制呼叫数量在广域网间的。基于位置的CAC当前没有跟踪任何的机制在网络的拓扑更改。Cisco CallManager不知道,如果对分组的主链路断开,并且ISDN备份激活。为此,非常重要的是ISDN备份链路支持VoIP呼叫同一数量象主链路。否则, CAC能过度预定备份链路。

主链路和备份链路的实际带宽不需要是相同的。链路需要能传送VoIP呼叫同一数量。例如,而主链路不,备份链路能使用cRTP。在这种情况下,较少带宽在备份链路要求传送呼叫同一数量象主链路。

设计选项

有多种清楚的设计选项可用对根据Cisco IOS软件版本的网络设计者使用。这些选项是:

在每个选项的讨论跟随包括列出的配置示例此处。

共存在单个B信道的语音和数据有或没有cRTP

在Cisco IOS软件版本12.2,在策略映射的带宽可能只指定作为固定量至默认最大值75%链路带宽。另外, ISDN总是假设提供64 Kbps带宽不考虑使用的B信道数量在BRI或PRI接口。所以, 48 Kbps是默认最大值在ISDN的策略映射可以保留的带宽。

这些限制意味着它只有意义使用一B信道运载的RTP数据包。凭需求,您能选择传送数据和语音在同一B信道。或者,您能使用BRI的第二B信道仅数据。在这两个设计选项,使用cRTP,因为所有RTP数据包移动单个B信道是安全的,并且不能到达故障中。

此设计选项发送所有语音和数据流量在单个B信道下。因为语音和数据争夺同一条链路,您需要LFI、LLQ和CBWFQ。因为没有RTP数据包的机会能变得重拨,您能安全也使用cRTP。

默认情况下,服务策略不能保留超过48 Kbps (75% 64 Kbps) RTP和VoIP信令的。您能分配到VoIP信令类的最小数量是8 Kbps。使用可用的剩余40 Kbps供RTP使用,您能生产显示呼叫最大可以由单个BRI传送的此表。

样本大小(字节) PPS cRTP 数据包长度(字节) 带宽(Kbps) 呼叫每个BRI
20 50 66 26.4 1
20 50 28 11.2 3
30 33 76 20.1 1
30 33 38 10.0 3
40 25 86 17.2 2
40 25 48 9.6 4

此输出显示语音的一在同一B信道的配置示例和数据。

语音的在单个B信道的配置和数据有cRTP的

!--- This section shows only relevant parts of the configuration.


class-map match-all VoIP-RTP
 match ip dscp ef
 
!--- RTP packets.

class-map match-all VoIP-SIG
 match ip dscp af31
 
!--- VoIP signaling packets.


policy-map voice-and-data
 class VoIP-RTP
  priority 40
 
!--- 40 Kbps available for voice.

 class VoIP-SIG
  bandwidth 8
  
!--- 8 Kbps is the minimum value allowed by Cisco IOS.


interface BRI0/0
 encapsulation ppp
 dialer pool-member 1
 ppp authentication chap

interface Dialer1
 encapsulation ppp
 bandwidth 64
 
!--- Increase the bandwidth from 56 to 64 Kbps
. 
 dialer pool 1
 dialer remote-name routerB-dialer1
 dialer-group 1
 dialer string 12345678
 service-policy output voice-and-data
 
!--- The service policy.

 ppp authentication chap
 ppp chap hostname routerA-dialer1
 ppp chap password cisco
 ppp multilink
 ppp multilink fragment-delay 10
 
!--- THe LFI delay equals 10 msec.

 ppp multilink interleave
 
!--- Enable LFI.

 ip rtp header-compression
 
!--- RTP header compression is OK.

语音和数据在Separate B信道有或没有cRTP

此设计利用Cisco IOS软件版本12.2也是可能的。然而,为了使可用的ISDN B信道用得更好,语音和数据被分离。选择的示例适用RTP数据包使用一B信道的基本速率配置和数据和语音信令第二B信道。相似的原理为更多信道可以用于数据的主速率配置应用。

由于RTP数据包与任何数据不竞争,不应该要求LFI和LLQ在语音信道。然而,它是良好的做法无论如何启用它。思科设备发现协议(CDP)和路由更新可以错误地启用,或者服务拒绝(DoS)攻击能充斥语音信道。在数据信道上, LFI没有要求。但是CBWFQ要求保护从一般数据的VoIP信令。在语音信道的路由更新需要被抑制避免在此接口间路由的流量。在其地方,请使用策略基于路由强制在语音信道间的RTP数据包。因为没有RTP数据包的机会能变得重拨,您能安全使用cRTP。

默认情况下服务策略不能保留超过48 Kbps (75% 64 Kbps) RTP和VoIP信令的。然而,尽管没有在语音信道的其他流量增加百分比到90%与此设计是安全的。此增加的最大数量可以用max-reserved-bandwidth命令指定。

基于RTP的57 Kbps,您能生产显示呼叫最大单个BRI能传送的此表。

样本大小(字节) PPS cRTP 数据包长度(字节) 带宽(Kbps) 呼叫每个BRI
20 50 66 26.4 2
20 50 28 11.2 5
30 33 76 20.1 2
30 33 38 10.0 5
40 25 86 17.2 3
40 25 48 9.6 5

此表显示语音的一在分开B信道的配置示例和数据。

语音的在Separate B信道的配置和数据有cRTP的

!--- This section shows only relevant parts of the configuration.



Class-map match-all VoIP-RTP
 match ip dscp ef
class-map match-all VoIP-SIG
 match ip dscp af31 

policy-map voice-only
 class VoIP-RTP
  priority 57

policy-map data-and-signaling
 class VoIP-SIG
  bandwidth 8

interface BRI0/0
 encapsulation ppp
 dialer pool-member 1
 ppp authentication chap

interface Dialer1
 encapsulation ppp
 bandwidth 64
 
!--- Increase the bandwidth from 56 to 64 Kbps.

 dialer pool 1
 dialer remote-name routerB-dialer1
 max-reserved-bandwidth 90
 
!--- Allow 90% of the bandwidth to be reserved.

 dialer-group 1
 dialer string 12345678
 service-policy output voice-only
 
!--- RTP packets only.

 ppp authentication chap
 ppp chap hostname routerA-dialer1
 ppp chap password cisco
 ppp multilink
 ppp multilink fragment-delay 10
 ppp multilink interleave 
 ip rtp header-compression

interface Dialer2
 encapsulation ppp
 dialer pool 1
 dialer remote-name routerB-dialer2
 dialer-group 1
 dialer string 12345678
 service-policy output data-and-signaling
 
!--- Data and VoIP signaling.

 ppp authentication chap
 ppp chap hostname routerA-dialer2
 ppp chap password cisco

router eigrp 1
 passive-interface dialer 1
 
!--- Suppress routing on the voice channel.


interface fastethernet 0/1
 ip policy route-map ip-rtp
 
!--- Policy route RTP packets.


route-map ip-rtp permit 10
 match ip address 100
 set interface dialer 1
 
!--- Route RTP packets out dialer 1.


access-list 100 permit udp any range 16384 32768
  any range 16384 32768 dscp ef

共存在多B信道的语音和数据,不用cRTP

此设计利用自Cisco IOS软件版本12.2(2)T,您能指定在策略映射的带宽作为百分比而不是一个绝对编号的事实。此功能允许您运用服务策略到一个套件用多B信道。结果, RTP数据包可以在多B信道间被传送。折衷方案是多条路径的实施意味着cRTP不是安全使用由于RTP数据包潜在重新安排。

Cisco IOS为您提供两机制控制另外的B信道如何带来以回应需求。第一机制通常指按需拨号路由(DDR)。DDR要求作为一小部分可用的带宽将指定的负载阈值。当通信流超出此阈值数字时,一个另外的信道被添加到套件。阈值计算作为运行平均值,并且有启动另外的B信道的某一延迟,当负载增加时。此延迟不是与数据的一问题。然而,与语音,不是可接受,如果用户做一部电话,并且需要分钟启动所需的带宽支持呼叫的QoS。

您可以降低延时启动另外的信道到大约30秒用load-interval命令在物理ISDN接口。然而,没有需要的QoS, 30秒太长为了呼叫能去。解决方案将有dialer load-threshold命令集对保证在保留的充足的带宽支持与适当的QoS的至少一次另外的VoIP呼叫的值。

因为问题仍然存在,如果两呼叫在30秒间隔内启动,第二和更加稳健的解决方案更喜欢。只要ISDN服务要求,解决方案将提出所有B信道立即和保持他们。您能使用ppp multilink links minimum命令指定此操作。

使用两B信道联机,服务策略能当前保留96 Kbps (75% 128 Kbps) RTP和VoIP信令的。您需要VoIP信令的8 Kbps,因此这留下RTP的88 Kbps。基于使用两B信道,此表显示在BRI可以被传送呼叫的最大。

-- -- --
样本大小(字节) PPS cRTP 数据包长度(字节) 带宽(Kbps) 呼叫每个BRI
20 50 66 26.4 3
20 50 28 11.2
30 33 76 20.1 4
30 33 38 10.0
40 25 86 17.2 5
40 25 48 9.6

此输出显示在多B信道共存,不用cRTP的语音和数据的一配置示例。

语音的共存在多B信道的配置和数据,不用cRTP

!--- This section shows only relevant parts of the configuration.



Class-map match-all VoIP-RTP
 match ip dscp ef
class-map match-all VoIP-SIG
 match ip dscp af31 

policy-map voice-and-data
 class VoIP-RTP
  priority percent 65
  
!--- This is 65% of 64/128K for RTP.

 class VoIP-SIG
  bandwidth percent 10
  
!--- This is 10% of 64/128K for VoIP signaling.


interface BRI0/0
 encapsulation ppp
 dialer pool-member 1
 ppp authentication chap

interface Dialer1
 encapsulation ppp
 dialer pool 1
 dialer remote-name routerB-dialer1
 dialer-group 1
 dialer string 12345678
 service-policy output voice-and-data
 ppp authentication chap
 ppp chap hostname routerA-dialer1
 ppp chap password cisco
 ppp multilink
 ppp multilink fragment-delay 10
 ppp multilink interleave 
 ppp multilink links minimum 2
 
!--- Bring up two B-channels immediately.

 no ip rtp header-compression
 
!--- cRTP is not safe

共存在有cRTP的多B信道的语音和数据

使用MCMP的介绍在Cisco IOS软件版本12.2(12)T的,重拨问题的cRTP解决,并且有语音使用多B信道和仍然执行cRTP是可能的。在语音和数据此的设计原则与那是相同的讨论的共存在多B信道没有cRTP部分,当唯一的差异是您能当前启用cRTP。此表根据使用在两B信道的cRTP添加可以被传送在BRI呼叫的最大。

样本大小(字节) PPS cRTP 数据包长度(字节) 带宽(Kbps) 呼叫每个BRI
20 50 66 26.4 3
20 50 28 11.2 7
30 33 76 20.1 4
30 33 38 10.0 8
40 25 86 17.2 5
40 25 48 9.6 9

对于此方案共存在多B信道的语音和数据的配置,不用cRTP适用。例外是MCMP当前启用,并且cRTP在,当您添加此输出到拨号接口时。

示例PPP多链路多类配置

!--- This command is available with Cisco IOS Software Release 12.2(12)T.
 
interface Dialer1 ppp multilink multiclass
	  
!--- Enable MCMP.

 ip rtp header-compression
    
!--- Support cRTP on the bundle


相关信息


Document ID: 25610