长距离以太网 (LRE) 和数字用户线 (xDSL) : 对称高数据速率 DSL (G.SHDSL)

通过 G.SHDSL 端口进行 CPE 背对背连接的配置

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 22 日) | 反馈


目录


简介

本文为两路由器的配置提供一配置示例背对背通过多速率对称高速的数字用户线(G.SHDSL)端口。它描述终止从另一个远程G.SHDSL CPE设备的一连接的G.SHDSL Cisco�路由器如何可以配置工作as�a中心局DSL设备。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • 运行Cisco IOS�软件版本12.2(8)T1的828客户端前置设备(CPE)

  • 2612路由器运行Cisco IOS软件版本12.2(8)T

  • 2612路由器使用广域网接口卡(WIC)-1SHDSL

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 有关本文档所用命令的详细信息,请使用命令查找工具仅限注册用户)。

网络图

本文档使用以下网络设置:

/image/gif/paws/25900/dsl_cpe_config1.gif

配置

本文档使用以下配置:

注意: 在此配置中828A配置与设备类型“CO”,模拟从CO的信令。当2612与G.SHDSL WIC配置与设备类型“CPE时”。

作为CO)的DSL5-828A(Cisco 828 CPE
DSL5-828A#show run
Building configuration...

Current configuration : 769 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname DSL5-828A
!
!
ip subnet-zero
!
!
!
!
!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 hold-queue 100 out
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 pvc 0/35 
  encapsulation aal5snap
 !
 pvc 8/35 
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
 dsl equipment-type CO
 dsl operating-mode GSHDSL symmetric annex A
 dsl linerate AUTO
!
interface Dialer0
 ip address 1.1.1.1 255.255.255.0
 encapsulation ppp
 dialer pool 1
 dialer-group 1
!
ip classless
ip http server
ip pim bidir-enable
!
!         
dialer-list 1 protocol ip permit
!
line con 0
 stopbits 1
line vty 0 4
!
scheduler max-task-time 5000
end

DSL4-2612A (作为CPE)的Cisco 2612路由器
dsl4-2612a#show run
Building configuration...

Current configuration : 927 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname dsl4-2612a
!
!
ip subnet-zero
!
!
!
!
!
!
!
!
!
!
fax interface-type fax-mail
mta receive maximum-recipients 0
!
!
!
!
interface ATM0/0
 no ip address
 no atm ilmi-keepalive
 pvc 0/35 
  encapsulation aal5snap
 !
 pvc 8/35 
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
 dsl equipment-type CPE
 dsl operating-mode GSHDSL symmetric annex A
 dsl linerate AUTO
!
interface Ethernet0/0
 ip address 172.16.1.2 255.255.255.0
 shutdown
 half-duplex
!         
interface TokenRing0/0
 no ip address
 shutdown
 ring-speed 16
!
interface Dialer0
 ip address 1.1.1.2 255.255.255.0
 encapsulation ppp
 dialer pool 1
 dialer-group 1
!
ip classless
ip http server
ip pim bidir-enable
!
!
dialer-list 1 protocol ip permit
!
call rsvp-sync
!
!
mgcp profile default
!         
dial-peer cor custom
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

命令参考

此部分描述已修改命令。其他命令与此功能一起使用在Cisco IOS软件版本12.2命令参考出版物描述。

已修改命令

  • dsl equipment-type

  • dsl linerate

  • dsl operating-mode (g.shdsl)

dsl equipment-type

发出dsl equipment-type命令在ATM接口模式配置DSL ATM接口功能作为CO设备或CPE。请使用此命令no表示恢复默认设备类型。

  • dsl equipment-type {co|CPE}

  • 没有dsl equipment-type

这些命令的语法说明是:

  • 共同配置DSL ATM接口功能作为CO设备。

  • CPE —配置DSL ATM接口功能作为CPE。

默认设置

DSL ATM接口功能作为CPE。

interface命令模式

G.SHDSL的WIC ATM接口集成到这些Cisco IOS软件版本:

  • 12.2(4)XL —在Cisco 2600系列路由器

  • 12.2(8)T —在Cisco 2600系列和Cisco 3600系列路由器

使用指南

此配置命令适用对一个特定ATM接口。在您发出此命令前,您必须指定ATM接口。在您发出此命令前, ATM接口必须也在关闭状态。此示例显示如何配置DSL ATM接口1/1功能作为CO设备。

Router#configure terminal 
  
Enter configuration commands, one per line. End with CNTL/Z. 
Router(config)#interface atm 1/1 
Router(config-if)#dsl equipment-type co 

Router(config-if)#end 
Router# clear interface atm 0/1 

Router#

相关命令

  • dsl线路速率—指定DSL ATM接口的一线路速率。

  • dsl operating-mode (g.shdsl) —指定DSL ATM接口的操作模式。

dsl linerate

发出dsl linerate命令在ATM接口模式指定DSL ATM接口的一线路速率。请使用此命令no表示恢复默认线路速率。

  • dsl线路速率{Kbps|自动}

  • 没有dsl线路速率

这些命令的语法说明是:

  • Kbps —指定在千位每秒的一线路速率DSL ATM接口的。允许的条目是72, 136, 200, 264, 392, 520, 776, 1032, 1160, 1544, 2056和2312。

  • 自动—配置DSL ATM接口为一最佳的线路速率自动地培训通过协商与远端的DSL Access Multiplier (DSLAM)或WIC。

默认设置

DSL ATM接口与远端的DSLAM或WIC自动地同步其线路速率。

interface命令模式

G.SHDSL的WIC ATM接口集成到这些Cisco IOS软件版本:

  • 12.2(4)XL —在Cisco 2600系列路由器

  • 12.2(8)T —在Cisco 2600系列和Cisco 3600系列路由器

使用指南

此配置命令适用对一个特定ATM接口。在您发出此命令前,您必须指定ATM接口。在您发出此命令前, ATM接口必须也在关闭状态。此示例显示如何配置DSL ATM接口0/1在1040 Kbps的线速率运行:

Router#configure terminal 
  
Enter configuration commands, one per line. End with CNTL/Z. 
Router(config)#interface atm 0/1 
Router(config-if)#dsl linerate 1040 

Router(config-if)#end 
Router#clear interface atm 0/1 

Router# 

相关命令

  • dsl equipment-type —配置DSL ATM接口功能作为CO设备或CPE。

  • dsl operating-mode (g.shdsl) —指定DSL ATM接口的操作模式。请使用此命令noform恢复默认操作模式。

dsl operating-mode (g.shdsl)

发出dsl operating-mode ATM接口命令指定DSL的操作模式ATM接口的。请使用此命令no表示恢复默认操作模式。

  • dsl operating-mode gshdsl对称附录{A|B}

  • 没有dsl operating-mode

这些命令的语法说明是:

  • gshdsl —在多速率高速的模式配置DSL ATM接口操作每ITU G.991.2。

  • 对称—在对称模式配置DSL ATM接口操作每ITU G.991.2。

  • 附录{A|B} —指定地区使用参数。输入北美的欧洲的AB。默认是A。

默认设置

默认操作模式是G.SHDSL对称附件A。

interface命令模式

G.SHDSL的WIC ATM接口在Cisco IOS软件版本12.1(3)X介绍,并且集成到这些Cisco IOS软件版本。

  • 12.2(2)T —在Cisco 1700系列路由器

  • 12.2(4)XL —在Cisco 2600系列路由器

  • 12.2(8)T —在Cisco 2600系列和Cisco 3600系列路由器

使用指南

此配置命令适用对一个特定ATM接口。在您发出此命令前,您必须指定ATM接口。在您输入此命令前, ATM接口必须也在关闭状态。此示例在G.SHDSL模式显示如何配置DSL ATM接口0/0运行。

Router#configure terminal 
  
Enter configuration commands, one per line. End with CNTL/Z. 
Router(config)#interface atm 0/0 
Router(config-if)#dsl operating-mode gshdsl symmetric annex A 

Router(config-if)#end 
Router#clear interface atm 0/1 

Router#

相关命令

  • dsl equipment-type —配置DSL ATM接口功能作为CO设备或CPE。

  • dsl线路速率—指定DSL ATM接口的一线路速率。

验证

您应该看到此输出去在控制台会话间。请发出term mon命令,如果远程登录到路由器,查看控制台信息。

00:51:25: %GSI-6-RESET: Interface ATM0/0, bringing up the line. 
It may take several seconds for the line to be active. 
00:52:09: %ATM-5-UPDOWN: Changing VC 0/35 VC-state to PVC activated. 
00:52:09: %ATM-5-UPDOWN: Changing VC 8/35 VC-state to PVC activated. 
00:52:10: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up 
00:52:10: %DIALER-6-BIND: Interface Vi1 bound to profile Di0 
00:52:11: %LINK-3-UPDOWN: Interface ATM0/0, changed state to up 
00:52:12: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM0/0, changed state to up 
00:52:12: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to up 

本部分所提供的信息可用于确认您的配置是否正常工作。

命令输出解释程序仅限注册用户)(OIT) 支持某些 show 命令。使用 OIT 可查看对 show 命令输出的分析。

  • show running-config —验证当前配置,并且查看所有控制器的状态。

  • show controllers atm slot/port —视图ATM控制器统计信息。

  • show atm vc —验证永久虚拟电路(PVC)状态。

  • show dsl interface atm —查看G.SHDSL调制解调器的状态

  • show interface atm —查看ATM接口的状态。

这是从show atm vc命令的示例输出。确保激活PVC是UP。

dsl4-2612a#show atm vc 
           VCD /                                        Peak  Avg/Min Burst 
Interface  Name         VPI   VCI  Type   Encaps   SC   Kbps   Kbps   Cells  Sts 
0/0        1              0    35  PVC    SNAP     UBR    2304                UP 
0/0        2              8    35  PVC    MUX      UBR    2304                UP

这是从show dsl interface atm命令的示例输出。如果线路发生故障,线路不是活跃的。某些值可能不是准确的。语句出现。您能也验证设备类型和操作模式配置是否为您的应用程序是正确。

dsl4-2612a#show dsl interface atm 0/0 
Globespan G.SHDSL/SDSL Chipset Information 

 Equipment Type:         Customer Premise 
 Operating Mode:         G.SHDSL Annex A 
 Clock Rate Mode:        Auto rate selection Mode 
 Reset Count:            1 
 Actual rate:            2312 Kbps 
 Modem Status:           Data (0x1) 
 Received SNR:           39 dB 
 SNR Threshold:          23 dB 
 Loop Attenuation:      -0.3400 dB 
 Transmit Power:         7.5 dBm 
 Receiver Gain:          4.3900 dB 
 Last Activation Status: No Failure (0x0) 
 CRC Errors:             33372 
 Chipset Version:        1 
 Firmware Version:       R1.5 

dsl4-2612a#show dsl interface atm 0/0 
Globespan G.SHDSL/SDSL Chipset Information 

Line is not active. Some of the values printed may not be accurate. 
 Equipment Type:         Customer Premise 
 Operating Mode:         G.SHDSL Annex A 
 Clock Rate Mode:        Auto rate selection Mode 
 Reset Count:            1 
 Actual rate:            2312 Kbps 
 Modem Status:           Idle (0x0) 
 Received SNR:           38 dB 
 SNR Threshold:          23 dB 
 Loop Attenuation:      -0.3400 dB 
 Transmit Power:         7.5 dBm 
 Receiver Gain:          4.3900 dB 
 Last Activation Status: No Failure (0x0) 
 CRC Errors:             33372 
 Chipset Version:        1 
 Firmware Version:       R1.5

如果无法在ATM电路间ping,请验证ATM接口通过发出show interface命令是UP/UP在两路由器的ATM接口的。发出show interface atm命令查看ATM接口的状态。确保ATM slot、端口和线路通信协议是UP,因为此示例显示。

DSL5-828A#show interfaces atm0 
ATM0 is up, line protocol is up 
  Hardware is PQUICC_SAR (with Globespan G.SHDSL module) 
  MTU 1500 bytes, sub MTU 1500, BW 2312 Kbit, DLY 80 usec, 
     reliability 255/255, txload 1/255, rxload 1/255 
  Encapsulation ATM, loopback not set 
  Encapsulation(s): AAL5, PVC mode 
  10 maximum active VCs, 2 current VCCs 
  VC idle disconnect time: 300 seconds 
  Last input never, output 00:00:08, output hang never 
  Last clearing of "show interface" counters never 
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0 
  Queueing strategy: None 
  5 minute input rate 0 bits/sec, 0 packets/sec 
  5 minute output rate 0 bits/sec, 0 packets/sec 
     261 packets input, 11170 bytes, 0 no buffer 
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles 
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort 
     264 packets output, 11388 bytes, 0 underruns 
     0 output errors, 0 collisions, 2 interface resets 
     0 output buffer failures, 0 output buffers swapped out

排除故障

本部分提供的信息可用于对配置进行故障排除。

故障排除命令

注意: 使用 debug 命令之前,请参阅有关 Debug 命令的重要信息

  • debug atm events —,当他们生成,识别ATM相关事件。

  • debug atm errors —指示哪些接口有麻烦。

这是示例从ATM接口的调试信息,运行在此部分列出的调试和来联机(请记住也许采取30秒或更多电路的能出来)。

01:07:15: ATM0/0 dslsar_1a_reset: PLIM type is 19, Rate is 2304Mbps 
01:07:15: ATM0/0 dslsar_1a_shutdown: state=4 
01:07:15: dslsar disable ATM0/0 

01:07:15: %GSI-6-RESET: Interface ATM0/0, bringing up the line.
It may take several seconds for the line to be active. 
01:07:15: Resetting ATM0/0 
01:07:15:  dslsar_1a_config(ATM0/0) 
01:07:15:  dslsar_1a_enable(ATM0/0) 
01:07:15: ATM0/0: dslsar_init(825AD084,FALSE) 
01:07:15: dslsar disable ATM0/0 

01:07:16: ATM0/0 dslsar_init: DSLSAR TXRX disabled 

01:07:16: ATM0/0 dslsar_1a_enable: restarting VCs: 0 
01:07:16: (ATM0/0)1a_enable,calling atm_activate_pvc, vcd = 1, vc = 0x82A17BE0adb->flags = 0x4800C 
01:07:16: (ATM0/0)1a_enable,calling atm_activate_pvc, vcd = 2, vc = 0x82A1863Cadb->flags = 0x4800C 
dsl4-2612a# 
dsl4-2612a# 
01:07:16: %SYS-5-CONFIG_I: Configured from console by console 
01:07:19: dslsar disable ATM0/0 

01:08:03: ATM0/0 dslsar_MatchSARTxToLineSpeed(): usbw 2304, clkPerCell 6360 prev_clkPerCell 9702 
01:08:03: ATM0/0 dslsar_update_us_bandwidth(): upstream bw =2304 Kbps 
01:08:09:  dslsar_periodic: ENABLING DSLSAR 

01:08:09: dslsar enable ATM0/0 

01:08:09:  dslsar_1a_setup_vc(ATM0/0): vc:1 vpi:0 vci:35 state 2 
01:08:09: ATM0/0 dslsar_vc_setup: vcd 1, vpi 0, vci 35, avgrate 0 
01:08:09: CONFIGURING VC 1 (0/35) IN TX SCHEDULE TABLE SET 0 
01:08:09: Forcing Peakrate and Avgrate to: 2304 
01:08:09: Requested QoS: Peakrate = 2304, Avgrate = 2304, Burstsize =0 
01:08:09: Configuring VC 1:  slot 0 in TST 5 
01:08:09: SUCCESSFUL CONFIGURATION OF  VC 1 (0/35), QOS Type 4 
01:08:09: ATM0/0: vcd = 1, bw = 2304, tbds_per_tsi = 15, max_pkt_len = 4470, 
max_tx_time = 1862ATM0/0 last_address 0x12E14 

01:08:09: %ATM-5-UPDOWN: Changing VC 0/35 VC-state to PVC activated. 
01:08:09:  dslsar_1a_setup_vc(ATM0/0): vc:2 vpi:8 vci:35 state 2 
01:08:09: ATM0/0 dslsar_vc_setup: vcd 2, vpi 8, vci 35, avgrate 0 
01:08:09: CONFIGURING VC 1 (0/35) IN TX SCHEDULE TABLE SET 1 
01:08:09: Forcing Peakrate and Avgrate to: 2304 
01:08:09: Requested QoS: Peakrate = 2304, Avgrate = 2304, Burstsize =0 
01:08:09: Configuring VC 1:  slot 0 in TST 5 
01:08:09: SUCCESSFUL CONFIGURATION OF  VC 1 (0/35), QOS Type 4 
01:08:09: ATM0/0: vcd = 1, bw = 1152, tbds_per_tsi = 15, max_pkt_len = 4470, max_tx_time = 3725 
01:08:09: CONFIGURING VC 2 (8/35) IN TX SCHEDULE TABLE SET 1 
01:08:09: Forcing Peakrate and Avgrate to: 2304 
01:08:09: Requested QoS: Peakrate = 2304, Avgrate = 2304, Burstsize =0 
01:08:09: Configuring VC 2:  slot 1 in TST 5 
01:08:09: SUCCESSFUL CONFIGURATION OF  VC 2 (8/35), QOS Type 4 
01:08:09: ATM0/0: vcd = 2, bw = 1152, tbds_per_tsi = 15, max_pkt_len = 4470, max_tx_time = 3725 

01:08:09: %ATM-5-UPDOWN: Changing VC 8/35 VC-state to PVC activated. 
01:08:09: CONFIGURING VC 1 (0/35) IN TX SCHEDULE TABLE SET 0 
01:08:09: Forcing Peakrate and Avgrate to: 2304 
01:08:09: Requested QoS: Peakrate = 2304, Avgrate = 2304, Burstsize =0 
01:08:09: Configuring VC 1:  slot 0 in TST 5 
01:08:09: SUCCESSFUL CONFIGURATION OF  VC 1 (0/35), QOS Type 4 
01:08:09: ATM0/0: vcd = 1, bw = 1152, tbds_per_tsi = 15, max_pkt_len = 4470, max_tx_time = 3725 
01:08:09: CONFIGURING VC 2 (8/35) IN TX SCHEDULE TABLE SET 0 
01:08:09: Forcing Peakrate and Avgrate to: 2304 
01:08:09: Requested QoS: Peakrate = 2304, Avgrate = 2304, Burstsize =0 
01:08:09: Configuring VC 2:  slot 1 in TST 5 
01:08:09: SUCCESSFUL CONFIGURATION OF  VC 2 (8/35), QOS Type 4 
01:08:09: ATM0/0: vcd = 2, bw = 1152, tbds_per_tsi = 15, max_pkt_len = 4470, max_tx_time = 3725 

01:08:10: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up 
01:08:10: %DIALER-6-BIND: Interface Vi1 bound to profile Di0 
01:08:11: %LINK-3-UPDOWN: Interface ATM0/0, changed state to up 
01:08:11:  dslsar_atm_lineaction(ATM0/0): state=4 
01:08:12: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM0/0, changed state to up 
01:08:13: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to up

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 25900