IP : 开放最短路径优先 (OSPF)

转发地址对类型 5 LSA 路径选择的影响

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

本文档旨在介绍在路由器收到给定外部网络的两个类型 5 链路状态通告 (LSA) 时的开放最短路径优先 (OSPF) 路径选择行为。在本示例中,一个 LSA 已将转发地址设置为零 (0.0.0.0),另一个 LSA 已将转发地址设置为非零。

先决条件

要求

本文档的读者应具备以下方面的知识:

  • 常规 IP 路由

  • OSPF 路由协议概念和术语

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

使用的组件

本文档中的信息基于以下软件和硬件版本。

  • Cisco 2503 路由器

  • Cisco IOS�在所有路由器的软件版本12.2(24a)运行

本文档中的信息都是基于特定实验室环境中的设备创建的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您是在真实网络上操作,请确保您在使用任何命令前已经了解其潜在影响。

类型 5 LSA 转发地址能如何影响路径选择

不是为两个 LSA 设置的转发地址

如下所示的拓扑用于展示在OSPF类型5 LSA的转发地址如何能影响类型5 LSA的路径选择。

/image/gif/paws/25493/type5_lsa_01.gif

在以上图表,所有路由器,除路由器8之外,运行在area 0的OSPF。,为本文、路由器配置3和Router4是最重要的目的,因为他们是生成类型5 LSA的自治系统边界路由器(ASBRs)。如下所示, Router3和Router4有静态路由对网络200.200.200.0 255.255.255.0,重新分配到OSPF。

路由器 3
interface Ethernet0
 ip address 172.16.3.3 255.255.255.0
 ip ospf cost 15
!
interface Serial0
 ip address 172.16.2.3 255.255.255.0
!
router ospf 7
 redistribute static subnets
 network 172.16.2.0 0.0.0.255 area 0
!
ip route 200.200.200.0 255.255.255.0 172.16.3.8

Router4
interface Ethernet0
 ip address 172.16.3.4 255.255.255.0
!
interface Serial0
 ip address 172.16.7.4 255.255.255.0
!
router ospf 7
 redistribute static subnets
 network 172.16.7.0 0.0.0.255 area 0
!
ip route 200.200.200.0 255.255.255.0 172.16.3.8

注意: Router3和Router4在OSPF程序不包括网络172.16.3.0 255.255.255.0;因此,两路由器生成的类型5 LSA有转发地址设置到0.0.0.0

在本例中, Router5可以用于查看外部LSA。要查看外部LSA,请发出show ip ospf database external命令在Router5。此命令输出如下所示。

Router5
router-5# show ip ospf database external

            OSPF Router with ID (172.16.6.5) (Process ID 7)

                Type-5 AS External Link States

  Routing Bit Set on this LSA
  LS age: 1514
  Options: (No TOS-capability, DC)
  LS Type: AS External Link
  Link State ID: 200.200.200.0 (External Network Number )
  Advertising Router: 172.16.3.3
  LS Seq Number: 80000030
  Checksum: 0x93C0
  Length: 36
  Network Mask: /24
        Metric Type: 2 (Larger than any link state path)
        TOS: 0
        Metric: 20
        Forward Address: 0.0.0.0
        External Route Tag: 0

  Routing Bit Set on this LSA
  LS age: 1922
  Options: (No TOS-capability, DC)
  LS Type: AS External Link
  Link State ID: 200.200.200.0 (External Network Number )
  Advertising Router: 172.16.7.4
  LS Seq Number: 80000027
  Checksum: 0x83D4
  Length: 36
  Network Mask: /24
        Metric Type: 2 (Larger than any link state path)
        TOS: 0
        Metric: 20
        Forward Address: 0.0.0.0
        External Route Tag: 0

router-5#

什么您能看到上述是两Router3生成的类型5 LSA的转发地址和Router4设置为0.0.0.0。在这种情况下,在Router5路由表里将安装的LSA取决于比较量度与生成LSA的ASBRs。通过发出show ip ospf border-routers命令在Router5,您能看到Router5有为ASBRs的量度。此命令输出如下所示。

Router5
router-5# show ip ospf border-routers

OSPF Process 7 internal Routing Table

Codes: i - Intra-area route, I - Inter-area route

i 172.16.7.4 [74] via 172.16.6.6, Ethernet0, ASBR, Area 0, SPF 14
i 172.16.3.3 [64] via 172.16.2.3, Serial0, ASBR, Area 0, SPF 14
router-5#

而到达ASBR的量度172.16.7.4是74,如上所述, 64是到达ASBR的Router5量度172.16.3.3;因此, Router5在其路由表里选择ASBR生成的LSA 172.16.3.3安置(如下所示)。

Router5
router-5# 
show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

O E2 200.200.200.0/24 [110/20] via 172.16.2.3, 19:59:25, Serial0
     172.16.0.0/24 is subnetted, 3 subnets
C       172.16.6.0 is directly connected, Ethernet0
O       172.16.7.0 [110/74] via 172.16.6.6, 19:59:25, Ethernet0
C       172.16.2.0 is directly connected, Serial0
router-5#

为一个 LSA 设置并且不用于另一个 LSA 的转发地址

拓扑和一样以上使用本文的此部分。Router4配置也依然是不可更改,但是Router3的配置在OSPF程序的area 0更改包括网络172.16.3.0 255.255.255.0。Router3配置以突出显示的变化下面表示在粗体上。

路由器 3
interface Ethernet0
 ip address 172.16.3.3 255.255.255.0
 ip ospf cost 15
!
interface Serial0
 ip address 172.16.2.3 255.255.255.0
!
router ospf 7
 redistribute static subnets
 network 172.16.2.0 0.0.0.255 area 0
 network 172.16.3.0 0.0.0.255 area 0
!
ip route 200.200.200.0 255.255.255.0 172.16.3.8

上述配置更改的结果是Router3生成的类型5 LSA当前有设置的转发地址对路由器IP地址8,如输出被采取的数据库所显示从下面Router5。

Router5
router-5# show ip ospf database external

            OSPF Router with ID (172.16.6.5) (Process ID 7)

                Type-5 AS External Link States

  Routing Bit Set on this LSA
  LS age: 270
  Options: (No TOS-capability, DC)
  LS Type: AS External Link
  Link State ID: 200.200.200.0 (External Network Number )
  Advertising Router: 172.16.3.3
  LS Seq Number: 80000033
  Checksum: 0x5138
  Length: 36
  Network Mask: /24
        Metric Type: 2 (Larger than any link state path)
        TOS: 0
        Metric: 20
        Forward Address: 172.16.3.8
        External Route Tag: 0

  Routing Bit Set on this LSA
  LS age: 258
  Options: (No TOS-capability, DC)
  LS Type: AS External Link
  Link State ID: 200.200.200.0 (External Network Number )
  Advertising Router: 172.16.7.4
  LS Seq Number: 80000029
  Checksum: 0x7FD6
  Length: 36
  Network Mask: /24
        Metric Type: 2 (Larger than any link state path)
        TOS: 0
        Metric: 20
        Forward Address: 0.0.0.0
        External Route Tag: 0

router-5#

您能看到上述Router3生成的类型5 LSA当前有设置的转发地址对172.16.3.8,而Router4生成的类型5 LSA仍然有0.0.0.0转发地址。

在这种情况下,在Router5路由表里将安装的LSA取决于比较Router5量度与ASBR (生成与0.0.0.0转发地址的LSA对Router5量度到达172.16.3.8转发地址,为LSA设置的路由器4)由ASBR (路由器3)生成。

要看到量度到ASBRs,请发出show ip ospf border命令在Router5。输出如下所示。

Router5
router-5# show ip ospf border-routers

OSPF Process 7 internal Routing Table

Codes: i - Intra-area route, I - Inter-area route

i 172.16.7.4 [74] via 172.16.6.6, Ethernet0, ASBR, Area 0, SPF 15
i 172.16.3.3 [64] via 172.16.2.3, Serial0, ASBR, Area 0, SPF 15
router-5#

在上述输出中,对Router4的量度是74。这与Router5量度比较到达172.16.3.8转发地址,使用show ip route 172.16.3.8命令,能被看到。此命令输出下面。

Router5
router-5# show ip route 172.16.3.8
Routing entry for 172.16.3.0/24
  Known via "ospf 7", distance 110, metric 79, type intra area
  Last update from 172.16.2.3 on Serial0, 00:30:49 ago
  Routing Descriptor Blocks:
  * 172.16.2.3, from 172.16.3.3, 00:30:49 ago, via Serial0
      Route metric is 79, traffic share count is 1

router-5#

因此,到达ASBR路由器的量度4,是74,与量度比较到达172.16.3.8转发地址(生成由路由器3),是79。所以,在路由表里安装的LSA是Router4生成的LSA,如下面show ip route所显示Router5输出。

Router5
router-5# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

O E2 200.200.200.0/24 [110/20] via 172.16.6.6, 00:35:14, Ethernet0
     172.16.0.0/24 is subnetted, 4 subnets
C       172.16.6.0 is directly connected, Ethernet0
O       172.16.7.0 [110/74] via 172.16.6.6, 00:35:14, Ethernet0
C       172.16.2.0 is directly connected, Serial0
O       172.16.3.0 [110/79] via 172.16.2.3, 00:35:14, Serial0
router-5#

当被重新分配的路由的量度从多个ASBRs的是相等的如本文所示时,转发地址更改类型5 LSA路径选择的行为。当路由器接收两个类型5 LSA对同一个目的地在两个LSA时设置的转发地址,路由器做根据量度的一个比较对转发地址。与提供更加小的量度的转发地址的LSA被放置到路由表。

如果被重新分配的路由的量度不同的,路由器偏好有最低权值而不是最低权值的路由对转发地址。


相关信息


Document ID: 25493