语音 : Voice over Frame Relay (VOFR)

在帧中继与 ATM 上设计与部署多链路 PPP

2016 年 10 月 27 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

在ATM的在帧中继的多链路PPP和多链路PPP (MLPoATM和MLPoFR)在Cisco IOSï ¿  ½软件版本12.1(5)T介绍。此功能被瞄准在部署在介质间的VoIP对低速的广域网链路有相互作用的帧中继/ATM的客户(FR/ATM IW)。在此功能之前,没有由在两个ATM的Cisco IOS和有FR/ATM IW的帧中继客户支持被迫执行第3层分段的普通的Layer2分段机制。

先决条件

要求

本文供在介入MLPoATM和帧中继网络VoIP网络的设计和部署涉及的网络人员使用。Cisco 建议您了解以下主题:

  • 帧中继

  • ATM

  • PPP

  • MLP

  • 相互作用的帧中继/ATM

  • 语音服务质量(QoS)配置

本文在这些主题没有打算提供技术培训。参考资料列表包括在本文结束时。思科建议您在读本文之前查看并且了解这些文档:

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • Cisco IOS软件版本12.1(5)T或以上为在FR/ATM IW的MLP

  • Cisco IOS软件版本12.2(2)T或以上为压缩实时传输协议(cRTP)在ATM

  • 低延迟队列的(LLQ)在物理接口的Cisco IOS软件版本12.0(7)T在帧中继和ATM

  • 基于帧中继的LLQ的Cisco IOS软件版本12.1(2)T和ATM每个永久虚拟电路(PVC)

在本文包括的案例研究根据使用这些软件和硬件版本的生产网络:

  • 核心Cisco 3660路由器运行Cisco IOS软件版本12.2(5.8)T。cRTP的需求在ATM指明使用Cisco IOS软件版本12.2T.此已知问题在Cisco IOS软件版本12.2(8)T1被解决:

    Cisco Bug ID CSCdw44216 (仅限注册用户) - cRTP导致高CPU,当基于类别的加权公平队列(CBWFQ) /LLQ链路到达拥塞时。

  • 分组Cisco 2620路由器是在升级从Cisco IOS软件版本12.2(3)过程中到一2.2(6a)。Cisco 2620也作为分组H.323网关。升级由相关问题触发。就广域网和QoS功能关系到, Cisco IOS软件版本12.2(3)不陈列任何重大的问题。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

设计

此部分讨论与多链路PPP的设计和部署涉及的几个设计观念在帧中继和ATM的。

数据链路开销

当您设计ATM和帧中继网络与MLP时,您必须了解数据链接开销。顶上影响每次VoIP呼叫带宽消耗的相当数量。它也帮助确定最佳MLP分段大小。优化分段大小适合整数ATM信元,特别是在巨大数量的带宽在信元填充被浪费的慢速PVC是关键的。在基于帧中继的MLP和ATM PVC的数据链接开销取决于这些要素:

  • FRF.8 IW设备的操作模式(透明或平移)。

  • 流量方向(ATM至帧中继或帧中继对ATM)。

  • PVC段。开销是不同的在PVC的ATM和帧中继分支。

  • 流量类型。数据包有一个MLP报头;VoIP信息包不。

此表显示数据包的数据链接开销。它选派在多种帧中继、ATM、LLC、PPP和MLP报头的字节数FRF.8操作模式、流量方向和PVC段的所有替换的。

FRF.8模式 透明 转换
流量方向 对ATM的帧中继 ATM至帧中继 对ATM的帧中继 ATM至帧中继
帧中继或PVC的ATM段 帧中继 ATM ATM 帧中继 帧中继 ATM ATM 帧中继
                 
帧标志位(0x7e) 1 0 0 1 1 0 0 1
帧中继报头 2 0 0 2 2 0 0 2
LLC DSAP/SSAP1 (0xfefe) 0 0 2 2 0 2 2 0
LLC控制(0x03) 1 1 1 1 1 1 1 1
NLPID2 (PPP的0xcf) 1 1 1 1 1 1 1 1
MLP协议ID (0x003d) 2 2 2 2 2 2 2 2
MLP序号 4 4 4 4 4 4 4 4
PPP协议ID (仅第一个片段) 2 2 2 2 2 2 2 2
有效负载(层3+) 0 0 0 0 0 0 0 0
ATM适配层(AAL) 5 0 8 8 0 0 8 8 0
帧校验序列 (FCS) 2 0 0 2 2 0 0 2
总开销(字节) 15 18 20 17 15 20 20 15

1DSAP/SSAP —目的地服务访问点/源服务访问点。

2NLPID —网络层协议ID。

因为开销是相同的在两个方向,平移PVC是最容易领会。这是因为FRF.8设备翻译在MLPoATM和MLPoFR格式之间。结果,帧格式是在帧中继分支的MLPoFR在两个方向。在ATM段的格式是在两个方向的MLPoATM。

因为开销在两个方向,有所不同透明PVC是轻微更加杂乱的。因为帧中继路由器发送在MLPoFR格式的数据包此复杂性出现。此格式由在ATM侧上的IW设备通过运载。同样地, ATM路由器发送在MLPoATM格式的数据包。此格式由在帧中继端上的IW设备通过运载。所以,结果是在两个方向的不同的帧格式在每个段。

比较起来,使用FRF.12在端到端帧中继PVC的开销是11个字节。所以,在端到端帧中继链路, FRF.12比MLP是链路分段和交织(LFI)的一更有效的选择。在端到端ATM虚拟电路(VC),因为没有基于标准的分段联机, MLP是唯一的选择。然而,端到端ATM VC是中等对高速。所以, LFI没有要求。对此规则的例外是慢速在数字用户线路DSL的ATM VC。

PPP ID是存在仅第一个MLP片段。所以,在第一个片段的开销总是两个字节更多比在随后的片段。

此处表显示VoIP信息包的数据链接开销。它选派在多种帧中继、ATM、LLC和PPP报头的字节数FRF.8操作模式、流量方向和PVC段的所有替换的。数据和VoIP信息包之间的主要区别是VoIP信息包被发送作为PPP数据包和不作为MLP数据包。其他方面与数据方案是相同的。

FRF.8模式 透明 转换 对帧中继的帧中继
流量方向 对ATM的帧中继 ATM至帧中继 对ATM的帧中继 ATM至帧中继  
帧中继或PVC的ATM段 帧中继 ATM ATM 帧中继 帧中继 ATM ATM 帧中继  
                   
帧标志位(0x7e) 1 0 0 1 1 0 0 1 1
帧中继报头 2 0 0 2 2 0 0 2 2
LLC DSAP/SSAP (0xfefe) 0 0 2 2 0 2 2 0 0
LLC控制(0x03) 1 1 1 1 1 1 1 1 1
NLPID (PPP的0xcf) 1 1 1 1 1 1 1 1 1
PPP ID 2 2 2 2 2 2 2 2 0
有效负载(IP+用户数据报协议(UDP) +RTP+Voice) 0 0 0 0 0 0 0 0 0
AAL5 0 8 8 0 0 8 8 0 0
FCS 2 0 0 2 2 0 0 2 2
总开销(字节) 9 12 14 11 9 14 14 9 7

比较起来,一个VoIP信息包的数据链接开销在端到端帧中继PVC在最右端列显示。

VoIP 带宽需求

当您设置VoIP的时带宽,在带宽计算必须包括数据链接开销。此表显示每VoIP多种类似的呼叫带宽需求。它根据PVC的特性。计算在此表里假设cRTP的一个最好情况方案(例如,没有UDP校验和和没有传输错误。)报头一致然后压缩从40个字节到2个字节。

FRF.8模式 透明 转换 对帧中继的帧中继
流量方向 对ATM的帧中继 ATM至帧中继 对ATM的帧中继 ATM至帧中继  
帧中继或PVC的ATM段 帧中继 ATM ATM 帧中继 帧中继 ATM ATM 帧中继  
                   
G.729 - 20毫秒示例-没有cRTP 27.6 42.4 42.4 28.4 27.6 42.4 42.4 27.6 26.8
G.729 - 20毫秒示例- cRTP 12.4 21.2 21.2 13.2 12.4 21.2 21.2 12.4 11.6
G.729 - 30毫秒示例-没有cRTP 20.9 28.0 28.0 21.4 20.9 28.0 28.0 20.9 20.3
G.729 - 30毫秒示例- cRTP 10.8 14.0 14.0 11.4 10.8 14.0 14.0 10.8 10.3
G.711 - 20毫秒示例-没有cRTP 83.6 106.0 106.0 84.4 83.6 106.0 106.0 83.6 82.8
G.711 - 20毫秒示例- cRTP 68.4 84.8 84.8 69.2 68.4 84.8 84.8 68.4 67.6
G.711 - 30毫秒示例-没有cRTP 76.3 97.9 97.9 76.8 76.3 97.9 97.9 76.3 75.8
G.711 - 30毫秒示例- cRTP 66.3 84.0 84.0 66.8 66.3 84.0 84.0 66.3 65.7

由于开销在PVC的不同的段变化,为最坏局面设计是必要的。例如,请考虑与20毫秒(毫秒)采样的在透明PVC间的G.729和cRTP。此方案的带宽需求在帧中继分支是在一个方向的12.4 Kbps和在其他的13.2 Kbps。供应需要完成考虑到每呼叫13.2 Kbps。

比较起来,在端到端帧中继PVC的VoIP带宽需求在上表的最右端列也显示。PPP的另外的开销与本地帧中继封装比较导致在0.5 Kbps和0.8 Kbps之间的额外带宽消耗每呼叫。所以,与FRF.12的帧中继封装在端到端帧中继VC比MLP有更多意义。

注意: 在ATM的cRTP要求Cisco IOS软件版本12.2(2)T或以后。

优化分段大小

原因使用在帧中继/ATM PVC的MLP是允许大数据包将被分段到更加小的大块。路由器通过插入他们然后加快VoIP信息包在数据分段之间。在Cisco IOS,分段大小没有直接地配置。反而,所需的延迟在ppp multilink fragment-delay命令帮助下配置。Cisco IOS然后使用此公式计算适当的分段大小:

fragment size = delay x bandwidth/8

当您执行在ATM间时的MLP,分段大小需要优化,以便适合到整数信元。如果此优化没有完成,要求的带宽能几乎加倍由于填充。例如,如果每个片段是长49个的字节,两个ATM信元要求运载每个片段。所以, 106个字节只用于传送49个字节有效负载。

当执行MLPoATM和MLPoFR时, Cisco IOS自动地优化分段大小使用整数ATM信元。Cisco IOS自动地舍入计算的分段大小到ATM信元下个整数。新的CLI命令没有被添加。Cisco IOS执行在帧中继和MLPoFR/ATM PVC的ATM结尾的此优化。很可能, MLP PVC可以是端到端帧中继。在这种情况下,优化它为ATM没有要求。然而, Cisco IOS优化ATM的此方案,因为没有方式检测远程终端是否是ATM或帧中继。

注意: 由于舍入,发生的延迟高于配置的那可以轻微。此舍入错误是重大在低速的PVC。

您能手工也配置优化。因为分段大小直接地在Cisco IOS不能指定,计算最佳的分段大小和转换它到延迟。当您计算分段大小时,为数据链接开销请调整, MLP代码假设,每条链路是高级数据链路控制(HDLC)并且有2字节的数据链接开销。除HDLC数据链接开销之外, MLP代码在8个字节组成MLP ID的其计算, MLP序号和PPP ID算入如上面第一个表所述。

使用此步骤为了计算在Cisco IOS将配置的延迟:

  1. 计算根据所需的延迟和PVC的带宽的理论上的分段大小:

    fragment = bandwidth * delay / 8
  2. 确保片段是48个字节的多个,因此适合到整数ATM信元。

    计算信元校正的分片大小的公式是:

    fragment_aligned = (int(fragment/48)+1)*48
  3. 为没有由MLP考虑到的数据链接开销调整。

    如被看到前,此开销有所不同基于PVC特性。请考虑PVC的ATM侧,因为这是您优化的侧。此表显示数据链接开销字节数在ATM侧的。

    FRF.8模式 透明 转换
    流量方向 对ATM的帧中继 ATM至帧中继 对ATM的帧中继 ATM至帧中继
    帧中继或PVC的ATM段 ATM ATM ATM ATM
             
    LLC DSAP/SSAP (0xfefe) 0 2 2 2
    LLC控制(0x03) 1 1 1 1
    NLPID (PPP的0xcf) 1 1 1 1
    AAL5 8 8 8 8
             
    非顶上的MLP (字节) 10 12 12 12

    要到达在MLP根据其计算的分段大小,从希望的信元校正的分片大小减去数据链接开销。添加上一步2字节为了补尝MLP总是假设的HDLC封装。

    计算分段大小的公式MLP代码目标是:

    fragment_mlp = fragment_aligned - datalink_overhead + 2
  4. 转换结果到与此公式的对应的延迟里的分段大小:

    delay = fragment_mlp/bandwidth x 8bits/byte
  5. 在大多数情况下,计算的延迟不是整数毫秒。因为Cisco IOS只接收整数值,您必须舍入下来。所以,您在Cisco IOS配置在ppp multilink fragment-delay命令帮助下的延迟值是:

    fragment_delay = int(fragment_mlp/bandwidth x 8bits/byte)
  6. 为了补尝上述舍入错误,请捏造MLP用于的带宽从延迟转换分段。您在Cisco IOS配置在bandwidth命令帮助下的被捏造的带宽是:

    bandwidth = fragment_mlp/fragment_delay * 8

此表显示最普通的PVC速度的最佳值ppp multilink fragment-delay带宽。10毫秒目标延迟假设。为了简化表,计算不区分在透明和平移PVC之间,或者在流量方向之间。在数据链接开销的最大区别只是2个字节。所以,设计的补偿最坏情况的12个字节小。并且在表里显示遇到的归结于事实的“实时”延迟您增加分段大小,以便片段适合到整数信元。

PVC速度 分段大小 ppp多链路片段延迟 带宽 实时迪莱
(Kbps) (信元) (毫秒) (Kbps) (毫秒)
56 2 12 57 13.7
64 2 10 68 12.0
128 4 11 132 12.0
192 6 11 202 12.0
256 7 10 260 10.5
320 9 10 337 10.8
384 11 10 414 11.0
448 12 10 452 10.3
512 14 10 529 10.5
576 16 10 606 10.7
640 17 10 644 10.2
704 19 10 721 10.4
768 21 10 798 10.5

流量整形和策略注意事项

特别注意事项给对流量整形和管制在帧中继/ATM IW环境。在帧中继的问题对ATM方向是不同的对在ATM至帧中继方向的问题。所以,每个主题分开描述。

当去从帧到信元时,在帧中继的主要问题对ATM方向是在带宽消耗的潜在的扩展。例如,在帧中继端的一个49字节帧消耗两个信元或者106个字节,在ATM侧。所以,不可能假设,可持续信元率(SCR)等于承诺信息速率(CIR)。当每个帧中继帧包含1有效载荷字节,最坏的情况发生。这些字节中的每一个消耗在ATM侧的一个全双工53个字节信元。例如此概念,是53倍CIR的此极其和不切实际的方案指明SCR。两更加可实现的示例是:

  • (当MLP和帧中继开销包括)时, G.729 VoIP信息包是长60个的字节或者69个字节。在ATM段上,它消耗两个信元或106个字节。所以,如果运载的所有流量是VoIP,然后一适当的映射是SCR = 106/69 = 1.5 x CIR。

  • Telnet数据包运载的单个击键包含40个TCP/IP报头字节和1字节的数据。在帧中继端,这共计56个字节,包括开销。然而,在ATM侧此数据包展开对两个信元。在这种情况下, SCR = 106/56 = 1.9 x CIR。

ATM论坛标准的附录A, BISDN相互载波接口(B-ICI)规范版本2.0,描述映射两个方法SCR和CIR之间的。当两个提供一个科学方式从CIR时派生SCR,都比他们应用的数据不再准确的。公式要求的其中一个编号是典型的帧大小,是难确定在实际网络的编号。并且,能潜在更改的编号,当新应用在现有ATM/帧中继网络被转出。因为他们的策略策略将是关键里程,最好的建议解决此问题是紧密工作用您的载波。在载波的帮助下,此故障自动保险的方法是可能的:

  • 对ATM方向的帧中继-在对ATM方向的帧中继中,载波需要修正流量仅入站在帧中继入口点。例如,在帧中继交换机连接对帧中继附加的客户端前置设备(CPE)设备,载波根据被收缩的CIR修正流量。此策略策略在图说明此处。一旦流量允许到在进入点的网络进一步管制不应该发生。此策略策略的暗示是在帧中继端接收的数据允许展开和使用任何带宽要求允许信元税、AAL在头顶上和填充符为了在网络的ATM段间运载它。在大多数情况下,要求的ATM带宽比使用的帧中继带宽两次是较少。

    http://www.cisco.com/c/dam/en/us/support/docs/voice/voice-over-frame-relay-vofr/25084-ingress-policing.gif

  • ATM至帧中继方向-在ATM至帧中继方向,对面是有经验的。带宽用量减少,当去从ATM到帧作为信元税, AAL在头顶上,并且时,当填充删除时。然而,因为ATM侧的潜在的发送速度高于那帧中继链路,设置流量整形正确地在ATM路由器为语音完整性是关键。如果shaping是太松散的,则ATM路由器比帧中继链路的物理速度供给数据在速率快速在另一边。结果,数据包开始排队在FRF.8交换机。有时,丢弃的数据包开始。并且,因为ATM/帧中继网络不区分在语音和数据之间, VoIP信息包也丢弃。

    同时,如果整形太限制式,然后吞吐量遭受。由于ATM信元税, AAL开销和填充符由FRF.8设备删除。它不使用在帧中继链路的带宽。所以,您能轻微过度预定PVC的ATM侧。相当数量填充符和AAL开销变化取决于平均的帧帧大小,并且多么积极分段是。由于您不能准确地合格此开销,您是优化的更加境况较好不尝试为它。另一方面,信元税是完全确定的。它是每48有效载荷字节的5个字节。您能为信元税优化通过设置在ATM路由器的shaping目标到53/48 x SCR。必须设置在运营商侧的管制允许此轻微超量预订。

提示和警告

  • MLPoATM /Frame中继用服务策略只当前测试并且支持附加对虚拟模板或拨号程序接口。省略服务策略能造成功能不运作。此的一示例在Cisco Bug ID CSCdu19313 (仅限注册用户)描述。

  • MLPoATM /Frame中继克隆每个PVC的两个虚拟访问接口。这些中的一个代表PPP链路。其他代表MLP套件。show ppp multilink命令用于告诉哪些是哪些。每个套件不支持多条PPPoFR链路。放两个PPPOFR电路到一个套件流量不会是在电路间很好被均衡的负载,因为PPPOFR驱动程序不提供实时序列驱动程序的流量控制信令。在ATM的MLPPP负载均衡或帧中继比在物理接口的同样负载均衡也许显示引人注意地较少效果。

  • 每个PVC关联与四个不同的接口,即物理接口、sub-interface和两个虚拟访问接口。仅MLP虚拟访问接口有启用的理想的排队机制。其他三个接口必须有先入先出(FIFO)排队。

  • 当您实施service-policy命令到虚拟模板时, Cisco IOS显示此正常警告消息:

    cr7200(config)#interface virtual-template 1
    cr7200(config-if)#service-policy output Gromit
    Class Based Weighted Fair Queueing (CBWFQ) not supported on interface Virtual-Access1
    Note CBWFQ supported on MLP bundle interface only.
    

    这些消息是正常。第一条消息建议PPP虚拟访问接口不支持服务策略。第二个消息确认服务策略生效了对MLP套件虚拟访问接口的。此事实在show interfaces虚拟访问show queueshow policy-map interface命令检查排队机制帮助下验证。

  • 因为PVC是类似租用线路, PPP认证没有严格要求。然而,因为show ppp multilink命令然后用于确定路由器的名称在PVC的另一端, PPP认证是方便的。

  • 必须为在帧中继路由器的MLPoFR PVC启用帧中继流量整形。

  • Cisco IOS软件版本12.2最初支持最多每个路由器二十五个虚拟模板。如果每个PVC要求有唯一IP地址,此限制能影响ATM分布式路由器的缩放。受影响的版本的应急方案是使用Ip unnumbered或使用拨号接口而不是虚拟模板。在Cisco IOS软件版本12.2(8)T,支持增加到200个虚拟模板。

  • 一些服务提供商不支持在他们的FRF.8设备的PPP转换。每当此限制合适,供应商必须配置他们的透明模式的PVC。

  • 在Cisco IOS文档的多数示例显示包括帧中继或ATM子接口的配置。此sub-interface不为目的服务。应该附加虚拟模板到物理接口。结果是更多紧凑和管理的配置。如果有很大数量的PVC,这是特别重要。

  • 请使用show ppp multilink命令作为一个极简单方式确定是否有在运营商侧的任何信元/帧丢包。唯一的可接受片段损失是循环冗余冗余校验(CRC)错误造成的一个。

  • 虽然MLPoATM /Frame中继在Cisco IOS软件版本12.1(5)T介绍, Bug在这中和后续版本指明该关心被采取,当您选择Cisco IOS软件版本时。思科推荐使用Cisco IOS 12.2主流的最新的维护版。然而,如果抗损远程站点电话(SRST)要求,其他VoIP功能需求能指明使用一个不同的Cisco IOS软件版本,例如12.2(2)XT。此表列出某些已知问题。当您选择Cisco IOS时,应该评估每个Cisco Bug ID选中的IOS。

Cisco Bug ID 说明
CSCdt09293 (仅限注册用户) 在7200次原因一方式语音呼叫的LFI-快速交换。
CSCdt25586 (仅限注册用户) PPPoA在空闲超时或交换虚拟电路(SVC)没扯下的接口盖。
CSCdt29661 (仅限注册用户) MLP- ATM接口关闭在快速交换期间的失败路由器。
CSCdt53065 (仅限注册用户) 性能改进用ATM LFI功能的atm_lfi代码。
CSCdt59038 (仅限注册用户) MLPoATM :与大数据包失效的Ping在PA-A3。
CSCdu18344 (仅限注册用户) MLPoATM /Frame中继PVC吞吐量比半是较少SCR/CIR。
CSCdu19297 (仅限注册用户) 没有服务策略的MLPoATM PVC生成错误。
CSCdu41056 (仅限注册用户) MLPoATM :驱动程序两次接到呼叫vc_soutput的惯例。
CSCdu44491 (仅限注册用户) VirtualAccess计数器不正确在MLPoFR。
CSCdu51306 (仅限注册用户) 在PPPoX中断的Keepalive。
CSCdu57004 (仅限注册用户) CEF不与MLP一起使用。
CSCdu84437 (仅限注册用户) 在MLP和tx环之间的流量控制实施调整了驱动程序。
CSCdv03443 (仅限注册用户) u76585的进行修正在Cisco IOSï ¿  ½软件版本12.2 -流入MLP数据包是交换的进程。
CSCdv10629 (仅限注册用户) MLPoATM :语音数据包没有排队在LLQ。
CSCdv20977 (仅限注册用户) 流入MLP数据包获得进程交换。
CSCdw44216 (仅限注册用户) 当CBWFQ/LLQ链路到达拥塞时, cRTP导致高CPU。
CSCdy70337 (仅限注册用户) 当与QoS服务策略的一个MLP套件是在使用中的。
CSCdx71203 (仅限注册用户) MLP套件也许偶尔地有一些条非激活链路。

案例研究

简介

此部分描述其中一个MLPoATM /Frame中继功能的第一个用户部署。客户由假名XYZ Ltd.是指在2001年, Global Name Registry, LTD XYZ用IP电话解决方案替换他们的PBX。作为此项目一部分,一个新的IP网络被构件。并且相互作用的帧中继/ATM为广域网选择。提供WAN服务的载波使用Newbridge交换机提供ATM和帧中继服务。

网络概述

Global Name Registry, LTD XYZ网络是连接与两个核心站点的二十六个分组的星型网网络。其中每一个核心站点由E3 ATM附加的Cisco 3660路由器服务。十八二十六个分组中型。他们有双重帧中继PVC连接回到3660s在两个核心站点通过ATM/帧中继IW。剩余的八个分组非常小。他们连接回到最接近的中型分组通过单个帧中继PVC。所有分支路由器是Cisco 2620。端到端ATM PVC在两个中心站点联络两3660路由器。此图说明拓扑。

http://www.cisco.com/c/dam/en/us/support/docs/voice/voice-over-frame-relay-vofr/25084-network.gif

此表显示帧中继访问存取速度和CIR。CIR变化从32 Kbps到256 Kbps。并且在表里显示每个PVC运载的同时VoIP呼叫最大。

站点 远程站点 访问(Kbps) CIR (Kbps) 呼叫数目
Branch1 核心1 320 192 6
Branch2 分组22 128 64 2.0
Branch3 核心1 576 256 8.0
Branch 4 分组16 64 32 2.0
分组5 核心1 128 64 2.0
分组6 Branch3 64 32 2.0
分组7 核心1 512 256 8.0
分组8 核心1 512 256 8.0
分组9 分组13 128 256 2.0
分组10 核心1 256 128 4.0
分组11 核心2 128 96 2.0
分组12 核心1 128 64 2.0
分组13 核心1 768 256 12.0
分组14 核心1 192 96 4.0
分组15 核心1 192 96 4.0
分组16 核心1 448 192 8.0
分组17 分组13 128 64 2.0
分组18 核心1 128 96 2.0
分组19 分组16 128 64 2.0
分组20 核心1 64 32 2.0
核心2 核心1 34000 256 12.0
分组21 分组13 128 64 2.0
分组22 核心1 384 192 6.0
分组23 核心1 512 256 8.0
分组24 核心1 192 96 2.0
分组25 核心1 128 96 4.0
分组26 Branch1 64 32 2.0

帧中继流量整形由分支路由器执行。突发传输在CIR之外允许。Cisco IOS流量整形设置整形到接入速率,与mincir相等与CIR。如果后向显式拥塞通知(BECN)从载波接收,路由器然后节流回到mincir。此方法Cisco推荐,当执行基于帧中继的VoIP时。当路由器响应对拥塞通知的时候,语音已经是麻烦。然而,载波在这种情况下相信其网络充分地设置从未丢弃所有帧或信元,并且,不应该看到BECN。

ATM流量整形设置整形以帧接入速率在远程终端,加上信元税。例如,如果接入速率是512 Kbps,然后SCR设置对512x53/48 = 565 Kbps。此整形速率用于最大化吞吐量。因为信元税剥离在IW点,这是安全。在运营商侧的管制慷慨地配置,以便轻微超量预订允许。

cRTP在广域网间使用。热点,就CPU而言是Cisco 3660分布式路由器在核心站点1。通过添加在上表的编号,确定理论上最大数量横断此路由器VoIP呼叫的最大数字是102呼叫。从此图表的性能编号表明Cisco 3660 CPU负载是快速交换式)的100 cRTP会话的(是大约50百分比。

http://www.cisco.com/c/dam/en/us/support/docs/voice/voice-over-frame-relay-vofr/25084-3660-performance.gif

虚拟模板与IP被编号的广域网链路一起使用。是可能的一个虚拟模板每个PVC要求,因为在每Cisco 3660终止PVC的总数少于二十五是。

配置

本文档使用以下配置:

核心ATM路由器

!--- Note: This section shows the parts of a core Cisco 3660 router 
!--- configuration that is relevant to MLPoATM.

        
class-map match-all Voice_Stream
  match access-group 100
class-map match-all Voice_Control
  match access-group 101

policy-map toortr01
  class Voice_Stream
    priority 175
  class Voice_Control
   bandwidth 18
   random-detect

interface loopback0
 ip address 10.16.0.105 255.255.255.252

interface ATM2/0
 description To Carrier E3 ATM Service
 no ip address

interface ATM2/0.15 point-to-point
 pvc toortr01 0/58 
  vbr-nrt 406 406
  tx-ring-limit 8
  protocol ppp Virtual-Template15

interface Virtual-Template15
 bandwidth 320
 ip unnumbered loopback0
 ip tcp header-compression iphc-format
 service-policy output toortr01
 ppp multilink
 ppp multilink fragment-delay 14
 ppp multilink interleave
 ip rtp header-compression iphc-format


!--- Note:  Do not configure 
!--- IP addresses directly on any configuration source, 
!--- such as a virtual template, whenever the possibility 
!--- exists that this information  is cloned to multiple 
!--- active interfaces. The exception to this rule is the 
!--- rare case where the intent is to define multiple parallel 
!--- IP routes and have IP do load balancing between them. 
!--- If an IP address is present on the configuration source, 
!--- this IP address  is copied to all the cloned interfaces.
!---  IP  installs a route to each of these interfaces.
 

分组帧中继路由器

!--- Note: This section shows the parts of a branch Cisco 2600 router 
!--- configurations that is relevant to MLPoFR.


class-map match-all Voice_Stream
  match access-group 100
class-map match-all Voice_Control
  match access-group 101

policy-map dhartr21
  class Voice_Stream
    priority 240
  class Voice_Control
   bandwidth 18
   random-detect

interface loopback0
 ip address 10.16.0.106 255.255.255.252

interface Serial0/0
 description To Carrier Frame Relay Service
 encapsulation frame-relay IETF
 frame-relay traffic-shaping

interface Serial0/0.1 point-to-point
 frame-relay interface-dlci 38 ppp Virtual-Template1
  class dhartr21

interface Virtual-Template1
 bandwidth 320
 ip unnumbered loopback0
 max-reserved-bandwidth 85
 service-policy output dhartr21
 ppp multilink
 ppp multilink fragment-delay 10
 ppp multilink interleave

map-class frame-relay dhartr21
 frame-relay adaptive-shaping becn
 frame-relay cir 320000
 frame-relay bc 3200
 frame-relay mincir 320000


相关信息


Document ID: 25084