语音 : H.323

Cisco IOS电话业务(ITS)配置和排除故障

2016 年 10 月 27 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 11 月 12 日) | 反馈


目录


简介

Cisco IOS电话业务(ITS),以前叫作IP Keyswitch,是IP电话呼叫处理解决方案集成到Cisco IOSï¿Â适合语音、视频和集成数据的½软件(AVVID)思科体系结构。基本概念是为与语音网关直接连接的少量IP电话提供最小的PBX/密钥交换机功能。分支机构没有WAN,也没有通过卫星链路的WAN连接时,可以部署Cisco ITS。

Cisco ITS制造了这样的环境:用户想要在这种站点添加电话服务,不需要Cisco CallManager具有所有电话功能。本文描述ITS功能的示例部署在示例网络的。

注意: Cisco ITS不相同,功能也不相同,抗损远程站点电话(SRST)功能可以与Cisco CallManager结合使用。

先决条件

要求

尝试此配置之前,请确保满足下列前提条件:

  • Cisco IOS电话服务版本2.01的熟悉。

  • TCP/IP基本基本的了解,例如IP寻址、DHCP、网络时间协议(NTP)、TFTP和HTTP

  • Cisco IOS软件基本基本的了解,例如命令行界面(CLI)配置

  • VoIP基本基本的了解,例如配置dial-peer、语音端口和服务质量(QoS)

使用的组件

本文档中的信息基于下列软件和硬件版本:

  • Cisco IOS软件版本12.2(8)T或以上,与至少IP Plus (在1700系列的IP/VOX加号)特性组。本文在Cisco IOS软件方面假设Cisco ITS 2.0支持。

  • 带有IOS软件版本12.2(11)T和IP PLUS功能集的Cisco 3660网关可用于配置示例,虽然大多数IAD 2400、1700、2600、3600和3700系列路由器目前可用。请检查Cisco IOS软件版本笔记对于当前版本和软件支持信息。

  • Cisco ITS 2.0.3软件套件用于此示例。您能下载从软件下载的此套件:Cisco CallManager Express/ITS和SRST (仅限注册用户)。

  • 要支持Cisco ITS,建议您为每个平台配置最大内存,特别是需要配置最多电话数量及不同名称(DN)时。

  • 在本例中, Catalyst 3500系列XL交换机使用作为分支机构交换机。配置语音的独立的VLAN和数据为质量和安全原因。

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

网络图

本文档使用下图所示的网络设置。

/image/gif/paws/25100/config_troubleshoot_its1.gif

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

背景信息

下面的表通过独立的VLAN指定关于语音的信息和数据传输。它也指定网络和接口地址和端口。

目的 VLAN 网络 接口 接口地址
数据 50 10.1.50.0/24 Fa0/0.50 10.1.50.1/24
语音 150 10.1.150.0/24 Fa0/0.150 10.1.150.1/24

Cisco ITS路由器是与IP Plus特性组的一3660运行的Cisco IOS软件版本12.2(11)T。在.tar或.zip格式应该下载Cisco ITS文件从软件下载:Cisco CallManager Express/ITS和SRST (仅限注册用户)。

一旦解压缩,必须转接每个文件到路由器闪存通过TFTP。每次单个文件复制,请勿清除闪存。以下是Cisco ITS 2.0.3中的文件列表(并不需要所有这些文件)。

文件名 说明
P003G302.bin 电话负载与Cisco ITS一起使用Cisco 7910 IP电话。电话负荷包括一个单独的版本说明,解释了以前版本的一些修正问题。(必需)
P004G302.bin 电话负载与Cisco ITS一起使用Cisco 7960 IP电话。电话负荷包括一个单独的版本说明,解释了以前版本的一些修正问题。(必需)
admin_user.html 配置系统的管理员网页
ephone_admin.html 电话管理网页。
normal_user.html 管理转发和其它特性的电话的用户(非管理员)网页。
telephony_service.html 每个用户访问的顶层网页,将配置电话或配置管理员系统。(可选)
logohome.gif
en_dest_busy.au 分机忙线的一个示例音频提示。使用由its_Cisco.2.0.0.tcl脚本。
en_dest_unreachable.au 一不可得到的分机的一个示例音频提示。使用由its_Cisco.2.0.0.tcl脚本。
en_disconnect.au 一断开或未注册的分机的一个示例音频提示。使用由its_Cisco.2.0.0.tcl脚本。
en_enter_dest.au 用户的一个示例音频提示能输入目的地。使用由its_Cisco.2.0.0.tcl脚本。
en_reenter_dest.au 用户的一个示例音频提示能重新输入目的地。使用由its_Cisco.2.0.0.tcl脚本。
en_welcome.au 用户问候语的一个示例音频提示。使用由its_Cisco.2.0.0.tcl脚本。
its_Cisco.2.0.0.tcl 可以将呼叫路由到分机的示例自动话务员的TCL脚本。使用示例au文件问候用户,提示输入编号,将呼叫路由到所需目的地。
music-on-hold.au 用于Music on Hold的示例音频文件。

以下文件也是Cisco ITS-2.0.3.zip文件的组成部分,但不需要放置在IT路由器的闪存中。

文件名 说明
CiscoIOSTSP.zip 此电话应用编程接口(TAPI)被服务提供商(TSP)开发用于Cisco ITS,用作TAPI(Windows 2000操作系统的组成部分)和IT之间的某个接口。TSP允许基于TAPI的应用程序例如电话拨号程序和ACT!提供呼叫控制的软件给IP电话在Cisco ITS。在Cisco ITS的TAPI实施是不完全TAPI 堆栈,但是一个“TAPI Lite”实施。它支持以下功能:
  • 在单个线路的多个地址。
  • 发出呼叫使用从应用程序的通讯簿正在拨号。
  • 回答或拒绝从应用程序的呼叫。
  • 保持通过使用屏幕弹出的呼叫。
  • 对应用程序的进行的呼叫方id联机。
  • 在同一条线路的不同的地址上发出呼叫保持和呼叫之间的交换。
TSP提供启用IP电话的一对一的遥控的一个接口。虽然多个TSP可以在同一台计算机上运行,但只有一个IP电话可以与每个TSP相连。由于此TSP不支持媒介服务提供商(MSP),因此不支持诸如Cisco SoftPhone的应用程序。

注意: 装备Cisco CallManager的TSP不支持与其。

配置

在Catalyst 3500XL的VLAN配置

Cisco ITS运行在LAN时,IP电话和Cisco CallManager则通过Catalyst交换机连接到语音网关。用传送语音数据的VLANS正确地配置这些设备非常重要。此部分提供在语音网关3660路由器上Catalyst 3500XL配置和相应LAN连接的概述。

  1. 应该用一台没有配置的交换机设置语音和数据VLAN(如下示例显示):

    Cat3500BranchSwitch# vlan database
    Cat3500BranchSwitch(vlan)# vlan 50 name corporate-data-vlan
    VLAN 50 added:
    Name: corporate-data-vlan
    Cat3500BranchSwitch(vlan)# vlan 150 name corporate-voice-vlan
    VLAN 150 added:
    Name: corporate-voice-vlan
    Cat3500BranchSwitch(vlan)#
    Cat3500BranchSwitch(vlan)# exit
    APPLY completed.
    Exiting....
    Cat3500BranchSwitch#
  2. 以下示例是在Catalyst 3500XL和3660路由器之间接口配置的示例:

    interface FastEthernet0/1
     description Port to 3660 (supports Dot1q)
     duplex full
     speed 100
     switchport trunk native 50
     switchport trunk encapsulation dot1q
     switchport trunk allowed vlan 1,50,150,1002-1005
     switchport mode trunk
    !
    
  3. 以下示例是将用于电话连接端口:

    interface FastEthernet0/2
     description DOT1Q port to IP Phone
     switchport trunk encapsulation dot1q
     switchport trunk native vlan 50
     switchport mode trunk
     switchport voice vlan 150
     spanning-tree portfast
    !
    

欲知详情,参考Catalyst 2900系列XL和Catalyst 3500系列XL交换机

在Cisco ITS路由器的VLAN配置

遵从下面步骤配置在Cisco ITS路由器的VLAN。

  1. 第一步是在3660接口上配置QoS参数和VLAN(如下所示)。

    ! 
    class-map match-all L3-to-L2_VoIP-Cntrl
     match ip dscp af31 
    class-map match-all L3-to-L2_VoIP-RTP
     match ip dscp ef 
    !
    !
    policy-map output-L3-to-L2
     class L3-to-L2_VoIP-RTP
      set cos 5
     class L3-to-L2_VoIP-Cntrl
      set COs 3
    !
    
  2. 现在请运用这些策略对接口并且创建VLAN。

    interface FastEthernet0/0
     description Catalyst 3500 Branch Office Switch
     no ip address
     no ip mroute-cache
     load-interval 30
     speed 100
     full-duplex
    !
    interface FastEthernet0/0.50
     encapsulation dot1Q 50
     ip address 10.1.50.1 255.255.255.0
     service-policy output output-L3-to-L2
    !
    interface FastEthernet0/0.150
     description native subnet 10.1.150.0 voice
     encapsulation dot1Q 150
     ip address 10.1.150.1 255.255.255.0
     service-policy output output-L3-to-L2
    !
    

欲知详情,参考Catalyst 2900系列XL和Catalyst 3500系列XL交换机

在Cisco ITS路由器的DHCP服务器配置

以下步骤是必要配置在3660路由器的一个DHCP服务器。只要您有一个外部DHCP服务器,而且您的IP地址没有静态配置,您就需要此步骤。以下示例显示了IP电话和其他VLAN上的其他设备的DHCP范围。

ip dhcp excluded-address 10.1.50.1 10.1.50.10
ip dhcp excluded-address 10.1.150.1 10.1.150.10
!
ip dhcp pool ip-phones
 network 10.1.150.0 255.255.255.0  

!--- This defines the range of IP addresses to be assigned.

 default-router 10.1.150.1
 option 150 ip 10.1.150.1   

!--- This must be the IP address of the ITS router.  

!
ip dhcp pool Data-clients
 network 10.1.50.0 255.255.255.128
 default-router 10.1.50.1 
 domain-name cisco.com
 dns-server 10.1.50.100 
 netbios-name-server 10.1.50.100 
!

注意: 如果想要只为特定设备启用DHCP,您可以使用host命令(而不是network命令,如上所述)创建DHCP范围。您还必须为您希望提供IP地址的IP电话配置客户端标识符和硬件地址。对于客户端标识,您必须指定电话的01+MAC地址,而硬件地址必须包含作为参数的电话的MAC地址。

欲知详情,参考Cisco IOS DHCP服务器

在Cisco ITS路由器的时间配置

由于IP电话接收Cisco ITS路由器发出的日期/时间设置,因此重要的是确保时钟正确设置在路由器上。若可能我们极力推荐您配置NTP。指定时间区域,并且,如果需要,夏令时,并且配置Ntp server。示例如下所示。

its-router(config)# clock time EST -5
its-router(config)# clock summer-time EST recurring 
its-router(config)# ntp server 172.18.106.15

关于NTP的更多信息,参考执行的基本的系统管理

在3660的Cisco ITS配置

基本配置

应该输入以下配置配置在3660的Cisco ITS :

telephony-service
 load 7910 P004G302       

!--- This is the load file minus the .bin extension. 
!--- Only the 7910, 7940/7960, and 7935 IP Phones are supported.


 load 7960-7940 P003G302  

!--- This is the load file minus the .bin extension.

 ip source-address 10.1.150.1 port 2000  

!--- This is the ip address of the Cisco ITS router on the voice subnet.

 max-ephones 48  

!--- This is the total number of phones that will be allowed to register.
!--- The maximum varies by platform and sometimes by software level.


 max-dn 192      

!--- This is the maximum number of directory numbers that can be configured 
!--- on this gateway (maximum varies by platform and sometimes by software level).

 voicemail 52222 

!--- This is the number that will be dialed when the "Messages" 
!--- button is pressed on the phone (optional).

!

大多剩余的命令可选。唯一的命令是“负荷”语句(并非所有语句需要用于所有电话),其中包括ip source-address、max-ephones和max-dn命令。

注意: Cisco ITS路由器的设计是适用于比Cisco CallManager 3.1更早版本的负荷文件;例如,负荷文件从SEPDEFAULT.cnf文件而不是从XML文件获得它们的配置。确保此命令在配置里:

tftp-server 
  flash:XMLDefault.cnf.xml

其他telephony-service选项在以下示例显示:

Its-router(config-telephony)# telephony-service
its-router(config-telephony)# ? 
  Cisco IOS Telephony Service configuration commands:
  admin-password      define password for admin user
  admin-username      define username for admin user
  date-format         Set date format for IP Phone display 
  default             Set a command to its defaults
  dialplan-pattern    Define E.164 telephone number prefix
  directory           Define directory naming order
  dn-webedit          enable Edit DN through Web
  exit                Exit from telephony-service configuration mode
  ip                  Define IP address and port for Telephony-Service/Fallback
  keepalive           Define keepalive timeout period to unregister IP phones
  load                Select the IP phone firmware load file
  max-conferences     Define max number of 3 party G.711 conferences
  max-dn              Maximum directory numbers supported 
  max-ephones         Define max number of IP phones
  moh                 Define music-on-hold filename
  mwi                 Define IP address and port for MWI Server
  no                  Negate a command or set its defaults
  reset               reset ethernet phone
  time-format         Set time format for IP Phone display 
  time-webedit        enable Edit Time through Web
  timeouts            Define timeout value for IP phone
  transfer-pattern    Define valid call transfer destinations
  url                 Define Ephone URL's
  voicemail           Set the voicemail access number called when the MESSAGES IP
                      phone button is pressed

its-router(config-telephony)#

警告 警告: 电话服务的许多更改(例如更改日期或时间格式),要求重置电话。一些选项,例如更改最大ephones或max-dn设置,要求一全双工路由器重启。要重置所有电话,请输入以下:

its-router(config-telephony)# telephony-service
its-router(config-telephony)# reset all

其中一些选项在以下部分讨论;其他可以通过是指Cisco IOS电话服务版本2.01找到。

在ITS路由器的TFTP配置

遵从下面步骤配置在ITS路由器的TFTP。

  1. 确保所有文件适当地传输到路由器的闪存。至少,必须装载负载文件P003G302.bin和P004G302.bin。一旦装载,闪存应该类似于以下示例:

    Its-router# show flash
    System flash directory:
    File Length    Name/status
    1    16084816  c3660-is-mz.122-11.T 
    2    229542    admin_user.html 
    3    42484     en_dest_busy.au 
    4    26376     en_dest_unreachable.au 
    5    14352     en_disconnect.au 
    6    19512     en_enter_dest.au 
    7    17167     en_reenter_dest.au 
    8    17486     en_welcome.au 
    9    4152      ephone_admin.html 
    10   5968      its_Cisco.2.0.0.0.tcl 
    11   29092     logohome.gif 
    12   496521    music-on-hold.au 
    13   35138     normal_user.html 
    14   268008    P003G302.bin 
    15   258360    P004G302.bin 
    16   522       telephony_service.html 
    17   54        SEPDEFAULT.cnf     
    
    !--- This file will not show up until telephony-service is configured.
    
    18   249       XMLDefault.cnf.xml 
    
    !--- This file will not show up until telephony-service is configured.
    
    [17551227 bytes used, 49033349 available, 66584576 total]
    65536K bytes of processor board System flash (Read/Write)
    
    its-router#
    
  2. 在配置中,您必须允许IP电话由TFTP从Cisco ITS路由器下载负载文件。注意这些文件名区分大小写。

    tftp-server flash:P003G302.bin
    tftp-server flash:P004G302.bin
    tftp-server flash:SEPDEFAULT.cnf
    tftp-server flash:XMLDefault.cnf.xml
    
  3. 一旦telephony-service和IP源地址commandsare发出, SEPdefault.cnf和XMLDefault.cnf.xml文件自动地创建

  4. XMLDefault.cnf.xml文件包含ATA适配器应该注册的路由器的某个以太网端口的IP地址。这些文件是特别针对于此路由器的,不可能由多个路由器共享。

在ITS路由器的IP电话配置

遵从下面步骤配置在ITS路由器的IP电话。

  1. 这时,如果IP电话接通并收到DHCP地址,它们则可以向Cisco ITS路由器登记。他们不会把任何线路配置。发出show ephone命令,查看命令输出,您可以验证电话是否注册,应该类似于:

    its-router# show ephone
    ephone-1 Mac:0006.D74B.0F46 TCP socket:[1] activeLine:0 REGISTERED
    mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0
    IP:10.1.150.10 50568 Telecaster 7960 keepalive 889 max_line 6
    
    
    ephone-2 Mac:0006.D74B.1361 TCP socket:[2] activeLine:0 REGISTERED
    mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0
    IP:10.1.150.11 52397 Telecaster 7960 keepalive 872 max_line 6
    
    
    ephone-3 Mac:0006.D74B.107C TCP socket:[3] activeLine:0 REGISTERED
    mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0
    IP:10.1.150.12 51116 Telecaster 7960 keepalive 871 max_line 6
    
    
    ephone-4 Mac:0008.E31B.7A8A TCP socket:[5] activeLine:0 REGISTERED
    mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0
    IP:10.1.150.13 50321 Telecaster 7960 keepalive 867 max_line 6
    
    its-router#
  2. 您能当前配置这些电话通过CLI或通过Web管理。(参考本文的Cisco ITS Router部分的配置的Web管理。)一些特别配置信息为Cisco 7910 IP电话是可用的在7910 IP电话部分的Cisco ITS配置里

    !
    ephone-dn 1
     number 1000
     name George P Burdell
     call-forward noan 52222 timeout 10
     no huntstop
    !
    ! 
    ephone-dn 2
     number 1000
     name George P Burdell
     preference 1
     call-forward busy 52222
     call-forward noan 52222 timeout 10
    !
    !
    ephone-dn 10
     number 1111
     name Helpdesk
     no huntstop
    !
    !
    ephone-dn 11
     number 1111
     name Helpdesk
     preference 1
    !
    !
    ephone-dn 12
     number 1111
     name Helpdesk
     preference 2
    !
    !
    ephone-dn 13
     number 1111
     name Helpdesk
     preference 3
    !
    
  3. 每ephone-dn代表一条线路。如果需要您能分配线路到多个电话。在本例中,用户配置了谁在双线路上有扩展名1000。帮助台线路是四条线路的一个搜索组,也被添加了。现在请配置ephone,分配线路到实际电话设备。

    !
    ephone 1
     username "gpburdell" password letmein
     mac-address 0006.D74B.0F46
     button 1:10 2:11 3:12 4:13 5:1 6:2
    !
    !
    !
    ephone 2
     Mac-address 0006.D74B.1361
     button 1:15 2:10 3:11 4:12 5:13
     speed-dial 1 1000
    !
    
  4. 按钮标记参考回到ephone-dn标记。show ephone命令输出应该类似于下面输出。

    its-router# show ephone
    ephone-1 Mac:0006.D74B.0F46 TCP socket:[3] activeLine:0 REGISTERED
    mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0
    IP:10.1.150.14 52311 Telecaster 7960 keepalive 6 max_line 6
    button 1: dn 10 number 1111 IDLE 
    button 2: dn 11 number 1111 IDLE 
    button 3: dn 12 number 1111 IDLE 
    button 4: dn 13 number 1111 IDLE 
    button 5: dn 1 number 1000 IDLE 
    button 6: dn 2 number 1000 IDLE 
    Username: gpburdell Password: letmein 
    
    
    ephone-2 Mac:0006.D74B.1361 TCP socket:[2] activeLine:0 REGISTERED
    mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0
    IP:10.1.150.11 50512 Telecaster 7960 keepalive 7 max_line 6
    button 1: dn 15 number 1001 IDLE 
    button 2: dn 10 number 1111 IDLE 
    button 3: dn 11 number 1111 IDLE 
    button 4: dn 12 number 1111 IDLE 
    button 5: dn 13 number 1111 IDLE 
    speed dial 1:1000
    
    its-router#
    Ephone 1 Ephone 2
    第 1 行 1111 第 1 行 1001
    第 2 行 1111 第 2 行 1111
    第 3 行 1111 第 3 行 1111
    第 4 行 1111 第 4 行 1111
    第 5 行 1000 第 5 行 1111
    第 6 行 1000 第 6 行 George P Burdell

  5. 呼叫进入1111时会发出铃声,直到有人摘听(没有配置呼叫转发)。如果ephone dn 10 (line 1 on ephone 1或line 2 on ephone 2)正在使用中,到1111的下一个呼叫将自动传到ephone dn 10,因为没有配置huntstop,因此首选较高值(默认首选为0)。如果首选是相同的,则两条线路将敲响。

  6. 如果呼叫发送到1000但没人摘听,它将滚到语音邮件(在此呼叫转发设置中,扩展名为5222)。如果ephone-dn 1是在使用中的,下一个呼叫被路由到ephone-dn 2。这是由于正常拨号对等体 路由,并且没有配置huntstop。在这种情况下,无需具有转发繁忙设置,除非您需要呼叫繁忙时转发到不同的DN (如果1000繁忙,将转发到1001)。在ephone dn 2上,您必须配置呼叫繁忙时转发和无应答,因为没有其他扩展名1000配有更高的首选路由(即使有,您可以暗中配置好huntstop,这样呼叫就会到此结束)。

关于正常拨号对等体路由的更多信息,参考的语音技术支持

Ephone 1也有“gpburdell的一个用户名和密码”。这将允许用户访问并登录到同一个telephony_service.html网页,更改他的转发(繁忙、无应答、全部)和快速拨号,并执行本地目录搜索。

Ephone 2有在线路6.的快速拨号。如果该按钮按, 1001将拨号1000。speed-dial命令本身不指定按钮位置。它认为,在这种情况下,第一自由行将快速拨号到1000号。事实偶然是线路6没有直接地配置。如果配置了另一个快速拨号(例如“快速拨号2 1004”),不会生成错误信息,也不会显示。

如下所示的ephone-dn的一些其他配置命令。

its-router(config-ephone-dn)# ?
Ephone DN configuration commands:
  application   The selected application
  call-forward  Define E.164 telephone number for call forwarding
  caller-id     Configure port caller id parameters
  cor           Class of Restriction on dial-peer for this dn
  default       Set a command to its defaults
  description   dn desc, for DN Qualified Display Name
  exit          Exit from ephone-dn configuration mode
  hold-alert    Set Call On-Hold timeout alert parameters
  huntstop      Stop hunting on Dial-Peers
  intercom      Define intercom/auto-call extension number
  loopback-dn   Define dn-tag to create loopback dn pair with this ephone-dn
  mwi           set message waiting indicator options (mwi)
  name          Define dn user name
  no            Negate a command or set its defaults
  number        Define E.164 telephone number 
  paging        set audio paging mode
  preference    Preference for the attached dial-peer for the primary dn number
  translate     Translation rule

its-router(config-ephone-dn)#

下面显示ephone的其他配置命令。

Its-router(config-ephone-dn)# ephone 1
its-router(config-ephone)# ?
Ethernet phone configuration commands:
  button        define button to dn map
  default       Set a command to its defaults
  exit          Exit from ephone configuration mode
  Mac-address   define ethernet phone MAC address
  no            Negate a command or set its defaults
  paging-dn     set audio paging dn group for phone
  reset         reset ethernet phone
  speed-dial    Define ip-phone speed-dial number
  username      define username to access ethernet phone from Web
  vm-device-id  define voice-mail id string

its-router(config-ephone)#

警告 警告: ephone或ephone dn的任何更改以后,必须重置电话更改应用。使用reset命令,可以在ephone之下或在telephony-service配置菜单之下执行该全局操作,如前面所述。

7910个IP电话的Cisco ITS配置

不同于7960个IP电话, 7910只有一线路按键。对在此电话的支持呼叫等待和转移,两条线路要求。所以,对此电话来说,您可以用相同的DN配置双线路 (如下):

ephone-dn  20
 number 1020
 no huntstop
!
!
ephone-dn 21
 number 1020
 preference 1
!
...
ephone 10
 button 1:20 2:21
!

即使这些是双线路外观,它也不可能同时保持两条线路。当主线路接通时,按line按钮,选择第二线路,可以拨打第二次呼叫(或应答)。一旦接通第二次呼叫,按hold按钮将在保持状态下发出第二次呼叫并且重新连接主线路。按保留按键再将再按乒乓键在主要和备用线路之间。按线路按键再将断开当前连接的当事人。

配置Cisco ITS路由器的Web管理

通过Web适当管理Cisco ITS服务器,同时允许终端用户通过Web管理他们的电话,闪存中必须有以下文件:

  • admin_user.html

  • ephone_admin.html

  • logohome.gif

  • normal_user.html

  • telephony_service.html

要通过Web允许网页的管理,必须输入以下全局配置命令:

ip http server
  ip http path flash

必须输入其他命令在telephony-service配置部分下。

telephony-service
 admin-username administrator 

 !--- This sets up the administrator account used to access the web page.

 admin-password cisco  

 !--- This sets up the password for the admin account.

 dn-webedit    

 !--- (optional) This permits the editing of DNs through the web interface.

 time-webedit  

 !--- (optional) This permits editing of the system time through the web interface.

!

要通过Web访问Cisco ITS路由器,请将您的浏览器连接以下URL:

http://ITSrouter_ipaddr/telephony_service.html

URL是相同的为大家。其他.html文件认为telephony-service.html网页呼叫的内部文件。呼叫其他文件可能直接地导致Javascript错误。要使用网页的用户首先必须在ephone上配置(如下所示)。

ephone 1
 username "gpburdell" password letmein

用户(在本示例中,用户为“gpburdell”)可以登录并更改他们的转发信息,执行目录搜索,甚至配置他们自己的快速拨号设置。有在线帮助联机。

管理员可执行电话或DN添加,删除和更改,以及一些系统更改。注意,如果您通过Web和命令行进行配置,则可能出现问题,因为网页不会定期轮询Cisco IOS软件配置,也不会使用浏览器上的Refresh按钮更新此信息。实际上,当设法刷新该方式时,您将退出GUI网页,看见失败的配置更改和不允许错误信息机箱的配置更改。在主菜单的仅更新按钮从Cisco ITS路由器获取最新的更改。

从网页中,书写系统配置按钮导致更改被立即写给NVRAM。然而对于普通用户,只要vty、控制台和辅助线路上没有激活的会话,每隔10分钟便写入更改。

注意: 执行更新时,请确保至少有4条自由vty线路可用于Cisco ITS,即使某1条自由vty线路对于正常配置更改就已经足够。

呼叫历史记录信息也供给管理员。首先必须通过配置启用它如下:

call-history-mib retain-timer 500
call-history-mib max-size 500

至多, 500个条目和500分钟呼叫历史记录在MIB表里保留。

登录以后,从GUI选择View System Configuration,然后选择View Call History Information,您便可以查看呼叫记录。

配置在Cisco ITS路由器的PSTN连接

假设,IT路由器配有语音接口卡,您现在便可以配置那些卡,以便呼叫可以发出/发到IP电话。这比在路由器的其他语音连接不较大不同。您可以把带有被分配到每个ephone dn的编号的电话当作路由器上的局外交换站编号(FXS)端口。

配置其他 ITS 功能

保持功能配置

外部呼叫方的一个其它功能是暂挂中Music on Hold (MoH) /Tone (ToH)。ToH总是默认情况下并且不可能禁用。MoH可以提供给暂挂中发出的公共交换电话网(PSTN)或G.711网内呼叫。相同IT路由器上的从IP电话到IP电话的呼叫,接听时永远只能听到ToH嘟嘟声。对于MoH,在确保以后音频文件在闪存存在,请配置如下:

telephony-service
 moh music-on-hold.au

MoH播放的au或wav文件需要采用G.711 u-law或a-law格式。为了区分呼叫等待和ToH,呼叫等待声音听起来象哔哔声,间隔为10秒钟。如果有呼叫等待多条线路,只有一音被发送每10秒。然而,每隔8秒就会听到ToH,ToH共包括三次哔哔声(单个语音重复三次)。ToH比呼叫等待音获得更高的优先权。如果两个语音应当在完全相同的时间播放,用户首先会听到ToH,然后在8秒钟以内听到另一个ToH,最后在二秒多钟内听到呼叫等待声音。

一旦呼叫设置为挂断,则有几个选项(如下所示),可以向仍然处于挂断状态的用户发送可以听见的通知。

Its-router(config-ephone-dn)# hold-alert 15 ?
  idle        alert on-hold originator only if idle
  originator  alert on-hold originator always
  shared      alert all phones that share the line

在配置间隔可以配置1秒环警报(每隔15秒到300秒),此警报总是发送到呼叫发出方,或者只有在呼叫发出方空闲时才发送。另一个选项是配置告警,发送到所有电话,这些电话共享同一条线路。默认设置是为没有警报,无论长呼叫暂挂。

会议配置

只要所有方都是G.711用户,并且会议资源可用,就支持三方通话的会议。会议资源配置如下:

telephony-service
 max-conferences 10

如果开会时有一方按住暂挂,其他两方会听到MoH或ToH。然而,它们也能彼此对话,伴有背景音乐或声音。

转移配置

能力转移呼入呼叫经常要求更多的配置。默认情况下,Cisco ITS的注册IP电话能传输到注册到同一个IT路由器的其它IP电话。其他转移,到PSTN或VoIP目的地,拒绝。要启用这些传输的类型,必须在telephony-service之下配置传输模式(如下):

Telephony-service
 transfer-pattern 9.......

现在假设有pots拨号对端将呼叫路由到PSTN ,IP电话便可以将呼叫转移到任何7位数号码,方法是首先拨打9。没有辅助拨号音的选项与其。

警告 警告: 传输IT路由器上外汇管理局(FXO)端口的入呼叫和其他FXO端口的出呼叫时,需要特别谨慎,因为这可能导致两个端口继续使用,即使双方都挂断电话。参考了解FXO断开问题。如果您的提供商不能支持断开监督表和FXO,请勿允许传输回PSTN。

要传输/转发另一个VoIP目的地(例如另一个IT路由器)发来的呼叫,则需要回环。在本文的范围之外,这是高级主题。

内部通信配置

内部通信功能允许在两IP电话之间的一个按键通话的功能。共享线路上不支持该功能,意味着配置用于对讲机操作的ephone dn必须只与一部IP电话连接。

!
ephone-dn 30
number A1234
name "Intercom"
intercom A4321 label "Office A"
!
!
ephone-dn 31
number A4321
name "Intercom"
intercom A1234 label "Office B"
!
...
!
ephone 3
Mac-address 0006.D74B.107C
button 1:16 6:30
!
!
!
ephone 4
Mac-address 0008.E31B.7A8A
button 1:17 6:31
!

现在,当按ephone 4的第6行时,呼叫将会发送到ephone 3的第6行(例如,自动呼叫A1234)。如果目的地电话默认为挂机,则摘机,进入免提模式,并将扬声器设置为静音。在intercom命令的其它选项是驳船在no-auto-answer。驳船选项允许流入对讲呼叫,迫使现有呼叫进入暂挂状态。电话立即然后应答对讲机呼叫。no-auto-answer选项导致对讲机呼叫只是响铃,而不是被自动接听。

使用所有对讲机呼叫,配有对讲机语句的标签将显示在显示行的右侧,非常类似于快速拨号。没有标签选项,名称(如果配置在ephone dn)将显示在显示行的左侧,而对讲机机编号则显示在右侧。

注意: Cisco建议不使用Cisco 7910的对讲机机功能,因为电话没有麦克风,并且扬声器可能不出声,因此必须提起话筒进行答复。

传呼配置

传呼功能运行很象前面描述的对讲机功能,除了它使用no press-to-answer选项,只提供单向语音流。仅空闲电话由传呼到达;电话在使用中不会接收页。寻呼支持音频分配使用单播、组播(最多10台设备)、或两者(以便音频能够到达不可能通过组播到达的电话)推荐组播传呼。每传呼分机要求一个唯一IP组播地址。

例如,请说三传呼组创建:“冷静人民”, “Uncool人”,和“所有人”,是前两组的总和。组播是音频发送方法,因此您会配置以下:

!
ephone-dn 40
 number 4001
 name "Cool People"
 paging ip 239.0.1.20 port 2000
!
!
ephone-dn 41
 number 4002
 name "Uncool People"
 paging ip 239.0.1.21 port 2000
! 
!
ephone-dn 42
 number 4000
 name "All People"
 paging ip 239.0.1.22 port 2000
 paging group 40,41
!

注意: IP电话不支持组播在224.x.x.x地址。

现在配置并分配每ephone到寻呼DN,如下所示(在每个ephone上省略了其他配置)。切记每个IP电话只能属于一寻呼组。并且,不能分配为传呼配置的ephone-dn到电话按钮。

!
ephone 1
 paging-dn 40
!
ephone 2
 paging-dn 40
!
ephone 3
 paging-dn 41
!
ephone 4
 paging-dn 41
!
ephone 5
 paging-dn 42
!

使用此配置,您可以把寻呼编号4001 (“冷酷的人”)分配到ephones 1和2,把寻呼编号4002 (“不冷酷的人”)分配到到ephones 3和4,把寻呼编号4000 (“所有人”)分配到ephones 1到5。

例如,到4001的任何呼叫连接到ephones 1和2 (如果它们不繁忙)。

注意: 支持传呼最多远离ITS路由器的一路由器跳。

验证

本部分所提供的信息可用于确认您的配置是否正常工作。

命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

如下所示的show telephony-service命令(特别是所有)将为您提供配置快照。

its-router# show telephony-service ?
  admin        Show telephony-service admin username and password
  all          Show telephony-service details
  dial-peer    Show telephony-service dialpeers 
  ephone       Show ephone configuration
  ephone-dn    Show ephone-dn configuration
  voice-port   Show telephony-service voice ports
  |            Output modifiers
<cr>

如下所示的显示ephone命令提供您IP电话的当前状态。多数时间,请显示ephone单独是必要的非常。

Its-router# show ephone ?
  7910              7910 phone status
  7940              7940 phone status
  7960              7960 phone status
  H.H.H             mac address
  dn                Dn with tag assigned
  offhook           Offhook phone status
  registered        Registered ephone status
  remote            non-local phones (with no arp entry)
  ringing           Ringing phone status
  summary           Summary of all ephone
  tapiclients       Ephone status of tapi client
  telephone-number  Telephone number assigned
  unregistered      Unregistered ephone status
  |                 Output modifiers
  <cr>

show ephone-dn命令输出将查找非常相似的show voice port命令输出。对于最常见的问题,此命令不象某些其它工具一样有用。

Its-router# show ephone-dn ? 
  <1-960>   dn tag
  loopback  Show ephone-dn in loopback mode
  summary   Summary of all ephone-dn
  |         Output modifiers
  <cr>

故障排除

本部分提供的信息可用于对配置进行故障排除。

故障排除命令

命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

注意: 在发出 debug 命令之前,请参阅有关 Debug 命令的重要信息

Cisco ITS有另外的故障检修命令和调试,能更加容易地收集一些信息。

有可能是有用的,当排除故障问题时的一些调试。debug ephone命令鉴于此是唯一的Cisco特定ITS的命令。

Its-router# debug ephone ?
  alarm       Enable ephone alarm message debugging
  detail      Enable ephone detail debugging
  error       Enable ephone error debugging
  keepalive   Enable ephone keepalive debugging
  loopback    Enable ephone loopback debugging
  moh         Enable ephone music-on-hold debugging
  mwi         Enable ephone mwi debugging
  pak         Enable ephone packet debugging
  raw         Enable ephone raw protocol debugging
  register    Enable ephone registration debugging
  state       Enable ephone state debugging
  statistics  Enable ephone statistics debugging

大多数情况下,排除两个电话之间的某个问题时,需要发出debug ephone error和debug ephone state命令,除非问题特殊涉及注册、消息等待指示符(MWI)或MoH。如果有很多电话,那么一个好想法是只限制输出到相关的MAC地址。例如:

its-router# debug ephone state Mac-address 0009.433C.E5EC
EPHONE state debugging is enabled for phone 0009.433C.E5EC

呼叫远程VoIP 目的地等问题可能需要其他调试命令(对于Cisco路由器上的VoIP更常见),例如debug voip ccapi inout和debug vtsp all命令。对排除PSTN信令故障和其它特定执行的项目的详细信息不包括在本文中。有关更多信息,请参阅下列文档:

这是一呼叫的一示例debug ephone state命令输出从1004到1002。show ephone命令输出的相关部分如下所示。

ephone-3 Mac:0006.D74B.107C TCP socket:[5] activeLine:0 REGISTERED
mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:1
IP:10.1.150.12 51718 Telecaster 7960 keepalive 92 max_line 6
button 1: dn 16 number 1002 IDLE 


ephone-4 Mac:0008.E31B.7A8A TCP socket:[2] activeLine:0 REGISTERED
mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:1
IP:10.1.150.13 50396 Telecaster 7960 keepalive 96 max_line 6
button 1: dn 17 number 1004 IDLE

现在您能检查调试。可以看到OFFHOOK消息,发出呼叫(您不会看到此追踪中捕获的单个数字),并回复。OpenReceive信道信息传送到每个电话并且最新已确认;StartMedia消息告诉每个电话什么IP地址和端口发送音频到。最后,挂机消息被看到。

Its-router# debug ephone state
EPHONE state debugging is enabled
its-router#
Sep 26 18:39:40.837: ephone-4[2]:OFFHOOK
Sep 26 18:39:40.837: ephone-4[2]:SIEZE on activeline 0
Sep 26 18:39:40.837: ephone-4[2]:SetCallState line 1 DN 17 ref 52 TsOffHook
Sep 26 18:39:40.837: DN 17 Voice_Mode
Sep 26 18:39:40.837: dn_tone_control DN=17 tonetype=0:DtSilence onoff=0 pid=113
Sep 26 18:39:40.841: dn_tone_control DN=17 tonetype=33:DtInsideDialTone onoff=1 pid=113
Sep 26 18:39:40.841: dn_tone_control DN=17 tonetype=0:DtSilence onoff=0 pid=113
Sep 26 18:39:40.841: dn_tone_control DN=17 tonetype=33:DtInsideDialTone onoff=1 pid=113
Sep 26 18:39:42.349: dn_tone_control DN=17 tonetype=0:DtSilence onoff=0 pid=113
Sep 26 18:39:42.853: dn_tone_control DN=17 tonetype=0:DtSilence onoff=0 pid=113
Sep 26 18:39:43.105: dn_tone_control DN=17 tonetype=0:DtSilence onoff=0 pid=113
Sep 26 18:39:43.609: ephone-4[2]:Skinny-to-Skinny call DN 17 to DN 16 instance 1
Sep 26 18:39:43.609: ephone-4[2]:SetCallState line 1 DN 17 ref 52 TsRingOut
Sep 26 18:39:43.609: ephone-4[2]:Call Info DN 17 line 1 ref 52 called 1002 calling 1004 
origcalled calltype 2
Sep 26 18:39:43.609: ephone-4[2]: John Doe calling 
Sep 26 18:39:43.609: ephone-4[2]: Jane Doe
Sep 26 18:39:43.609: dn_tone_control DN=17 tonetype=0:DtSilence onoff=0 pid=113
Sep 26 18:39:43.609: ephone-3[5]:SetCallState line 1 DN 16 ref 53 TsRingIn
Sep 26 18:39:43.613: ephone-3[5]:Call Info DN 16 line 1 ref 53 called 1002 calling 1004 
origcalled calltype 1
Sep 26 18:39:43.613: ephone-3[5]: John Doe calling 
Sep 26 18:39:43.613: ephone-3[5]: Jane Doe
Sep 26 18:39:43.613: ephone-3[5]:Ringer Inside Ring On
Sep 26 18:39:43.613: dn_tone_control DN=17 tonetype=36:DtAlertingTone onoff=1 pid=113
Sep 26 18:39:51.926: ephone-3[5]:OFFHOOK
Sep 26 18:39:51.926: ephone-3[5]:Ringer Off
Sep 26 18:39:51.926: ephone-3[5]:ANSWER call
Sep 26 18:39:51.926: ephone-3[5]:Answer Incoming call from ephone-(4) DN 17
Sep 26 18:39:51.926: ephone-3[5]:SetCallState line 1 DN 16 ref 53 TsConnected
Sep 26 18:39:51.926: ephone-4[2]:SetCallState line 1 DN 17 ref 52 TsConnected
Sep 26 18:39:51.926: ephone-4[2]:OpenReceive DN 17 codec 4:G711Ulaw64k duration 20 ms bytes 160
Sep 26 18:39:51.926: ephone-3[5]:OpenReceive DN 16 codec 4:G711Ulaw64k duration 20 ms bytes 160
Sep 26 18:39:51.926: dn_tone_control DN=16 tonetype=0:DtSilence onoff=0 pid=113
Sep 26 18:39:51.930: DN 17 End Voice_Mode
Sep 26 18:39:51.930: DN 17 Voice_Mode
Sep 26 18:39:51.930: DN 16 Voice_Mode
Sep 26 18:39:51.930: dn_tone_control DN=17 tonetype=0:DtSilence onoff=0 pid=113
Sep 26 18:39:52.182: ephone-4[2]:OpenReceiveChannelAck:IP 10.1.150.13, port=23094, 
dn_index=17, dn=17
Sep 26 18:39:52.182: ephone-3[5]:StartMedia 10.1.150.13 port=23094
Sep 26 18:39:52.182: DN 17 codec 4:G711Ulaw64k duration 20 ms bytes 160
Sep 26 18:39:52.182: ephone-3[5]:OpenReceiveChannelAck:IP 10.1.150.12, port=22778, 
dn_index=16, dn=16
Sep 26 18:39:52.182: ephone-4[2]:StartMedia 10.1.150.12 port=22778
Sep 26 18:39:52.182: DN 17 codec 4:G711Ulaw64k duration 20 ms bytes 160
Sep 26 18:40:01.254: ephone-3[5]:ONHOOK
Sep 26 18:40:01.254: ephone-4[2]:CloseReceive
Sep 26 18:40:01.254: ephone-4[2]:StopMedia
Sep 26 18:40:01.254: ephone-3[5]:call clean up this DN 16 was called by other DN 17
Sep 26 18:40:01.254: this ephone-3 other ephone-(4) other DN state CONNECTED
Sep 26 18:40:01.254: ephone-3[5]:CloseReceive
Sep 26 18:40:01.254: ephone-3[5]:StopMedia
Sep 26 18:40:01.254: DN 16 End Voice_Mode
Sep 26 18:40:01.254: ephone-3[5]:SetCallState line 1 DN 16 ref 53 TsOnHook
Sep 26 18:40:01.254: ephone-3[5]:SpeakerPhoneOnHook
Sep 26 18:40:01.254: DN 17 End Voice_Mode
Sep 26 18:40:01.254: ephone-4[2]:SetCallState line 1 DN 17 ref 52 TsOnHook
Sep 26 18:40:01.254: ephone-4[2]:SpeakerPhoneOnHook
Sep 26 18:40:01.258: ephone-3[5]:SpeakerPhoneOnHook
Sep 26 18:40:01.354: DN 16 Voice_Mode
Sep 26 18:40:01.354: DN 16 End Voice_Mode
Sep 26 18:40:01.354: dn_tone_control DN=16 tonetype=0:DtSilence onoff=0 pid=113
Sep 26 18:40:01.366: SkinnyReportDnState DN 17 ONHOOK
Sep 26 18:40:01.366: dn_tone_control DN=17 tonetype=0:DtSilence onoff=0 pid=113

相关信息


Document ID: 25100