Video : Cisco uBR7100 系列通用宽带路由器

配置在桥接模式的UBR7100

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 22 日) | 反馈


目录


简介

本文详述ubr7100和Cisco Network Registrar的配置桥接网络的。不同于uBR7200, ubr7100可以使用作为网桥。桥接配置包括禁用的IP路由,放置所有接口在一个网桥组中和配置电缆接口。在此配置中,路由功能在uBR7100's网关/路由器完成。因为路由功能在ubr7100没有完成配置被简化。桥接配置在网络放置Cisco网络认证(CNR)服务器和CMTS和电缆调制解调器一样。在网关配置以IP辅助工具地址路由在电缆调制解调器和CNR之间情况下的广播CNR能在网关/路由器后驻留。

开始使用前

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

先决条件

读者应该有DOCSIS协议和Cisco IOS� line命令的基本的了解在UBR系列路由器。

使用的组件

使用以下,此配置开发并且测试了:

  • 运行Cisco IOS版本12.10EC1的Cisco uBR7100系列通用宽带路由器

  • 运行V 5.5的Cisco网络认证(CNR)

本文档中的信息都是基于特定实验室环境中的设备创建的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您是在真实网络上操作,请确保您在使用任何命令前已经了解其潜在影响。

背景理论

DOCSIS基础

从客户预期DOCSIS是“即插即用”,含义有线调制解调器从网络自动地配置。当第一次接通电缆将扫描DOCSIS载波的下行。检测的调制解调器将锁定到第一DOCSIS载波。上行信道描述符(UCD),有线调制解调器读从下行载波,告诉调制解调器如何传送。UCD有转发错误(FEC)参数、上行频率、调制类型和符号码率。一旦有线调制解调器和CMTS对适当的传输级别达成协议调制解调器将开始动态主机配置协议(DHCP)进程。CNR服务器应该听到调制解调器发现。调制解调器和CNR服务器将交换导致调制解调器有IP连通性对网络的其余的一系列的消息。一旦调制解调器有IP连通性能请求每日定时(ToD)和下载其有线调制解调器配置文件。一旦调制解调器配置将发送注册请求对CMTS。如果保密性基准(BPI) �没有启用,调制解调器将注册与CMTS。如果BPI启用,调制解调器在充分注册前将交换有CMTS的加密密钥。

桥接模式概念

在接口的网桥模式全部在CMTS的在一个网桥组中配置。所有接口关联与网桥组认为广播域的部分。这意味着每个设备关联与这些接口之一将听到从所有设备的广播在网桥组中。因为我们在同一网络,能放置CNR服务器、CMTS和电缆调制解调器这是方便的。当有线调制解调器广播DHCP时请发现在CMTS的电缆接口将转发它对其他接口在网桥组中。因为CNR服务器在同一个网桥组中将听到DHCP发现和回应DHCP提供。随后,调制解调器通过简单文件传输协议(TFTP)将获得ToD (从一个外部服务器在网桥组内或配置的CMTS是ToD服务器)和其配置文件,并且注册与CMTS。

配置

注意: 要查找本文档所用命令的其他信息,请使用命令查找工具仅限注册用户)。

网络图

http://www.cisco.com/c/dam/en/us/support/docs/video/ubr7100-series-universal-broadband-routers/24544-ubr7100-bridging-24544-1.gif

图 1

配置

本文档使用如下所示的配置。

配置分成两部分:CNR服务器配置和CMTS配置。CNR是使用的分配IP地址通过DHCP并且提供调制解调器他们需要访问网络的关键要素的网络连通性信息。在CMTS配置部分, ubr7100配置注册电缆调制解调器和向前电缆调制解调器数据流到LAN的其余。

CNR配置

配置CNR请包括配置策略和范围电缆调制解调器和主机的。策略是的DHCP选项列表与范围有关联。范围是将分配到网络的IP地址范围。

创建电缆调制解调器的一项策略

  1. 启动CNR程序和登录。在DHCP服务器的�Click。

    ubr7100_bridging_24544_2.gif

    图 2

  2. 点击在服务器管理器bar.�的SHOW PROPERTIES按钮

  3. 点击Policies选项。在本例中的策略被命名bb-ubr7114-1a.�

  4. 选择新创建一项新的策略。

  5. 下面请编辑选项添加以下DHCP选项:

    1. dhcp-lease-time –这是租用时间以秒钟。在本例中,租用时间是(是秒钟数量在7天的期限的)的604800。注意在本例中我们选择使那些租期永久性通过检查租期是永久性box.�

    2. 路由器–这是IP网关地址。对于此示例IP地址是14.66.1.1。

    3. tftp-server –这是TFTP server的地址。对于此示例地址是14.66.1.1,是相同的象CNR服务器的IP地址。注意的默认目录在Windows平台的服务的文件是程序文件\网络寄存器\数据\ TFTP。

    4. LOG服务器–寻址记录DHCP服务器消息。在本例中它是14.66.1.1 (CNR服务器)。

    5. 时间服务器–外部时间时间服务器可以是使用。在我们的示例中CMTS作为时间服务器14.66.1.1。

    6. 偏移量–这是从GMT的抵销时间以秒钟。在本例中时间偏移是18000。

    7. packet-file-name –此选项选派将使用的cm文件的名称。在我们的示例中使用gold.cm。

    ubr7100_bridging_24544_3.gif

    图 3

创建电缆调制解调器的一个范围

  1. 点击DHCP server.�

  2. 点击Add按钮服务器管理器柱状图。

    http://www.cisco.com/c/dam/en/us/support/docs/video/ubr7100-series-universal-broadband-routers/24544-ubr7100-bridging-24544-4.gif

    图 4

  3. 在冒出的添加范围方框中请分配名称到范围。

  4. 从被拉下的策略请选择为此范围创建的策略。

  5. 进入您的在网络空白的网络。对于此示例网络号是14.66.1.0。

  6. 输入您的网络的子网掩码在子网掩码空白。对于此示例子网掩码是255.255.255.0。

  7. 输入第一并且持续在起始地址的IP地址并且结束地址框。在本例中第一个地址是14.66.1.245,并且为时是14.66.1.254。

ubr7100_bridging_24544_5.gif

图 5

CMTS 配置

在升频器来用装备构件的UBR7100系列路由器。外部升频器可以通过运行从外部升频器的DS0端口输出的IF使用。在本例中使用内部升频器。

注意: 关于配置集成上行变频器的更多信息,参考设置在配置Cisco电缆接口的集成上行变频器ubr7100文档的。

因为此配置在实验室环境被执行了, RF设置相当简单。RF和设置的评定是超出本文的范围之外,并且读者是指的连接和配置电缆头端文档适当的RF设置和测量的和符合DOCSIS规范(SP-RFI-IO5-991105或以上版本)。

Cisco IOS配置

  1. 配置在CMTS的一主机名。

  2. 配置在CMTS的一特权密码。

  3. 配置在VTY线路的一个密码。

  4. 通过执行no ip routing命令禁用IP路由。

  5. 配置在快速以太网接口0/0的一个IP地址。

  6. 配置在快速以太网接口的桥接用bridge-group命令

  7. 禁用在快速以太网0/0的生成树用bridge-group spanning-disabled命令

  8. 在接口电缆1/0上请配置升频器:

    1. 请勿通过执行电缆下行rf-shutdown启动上转换器。

    2. 设置下行频率用cable downstream frequency命令。记住频率在赫兹。您必须使用标准NTSC CATV频道频率。

    3. 设置下行信道电源用cable downstream rf-power命令

    4. 通过执行未关闭激活线卡。

    5. 通过执行no cable upstream 0 shutdown激活上行。

    6. 设置上行频率用cable upstream frequency命令

    7. 使用cable upstream channel-width命令,设置上行信道宽度。

  9. 配置在接口电缆1/0的桥接。

  10. 禁用在Cable1/0的生成树。

设备名(Cisco 1600路由器)
version 12.1
       no service pad
       service timestamps debug datetime msec localtime
       service timestamps log datetime
       no service password-encryption
       enable password cisco
       service udp-small-servers max-servers no-limit
       service tcp-small-servers max-servers no-limit
       !
       hostname ubr7100
       !
       cable time-server
       !
       clock timezone PST -9
       clock calendar-valid
       ip subnet-zero
       no ip routing 
!--Disable IP routing, enabled by default 

       no ip domain-lookup
       !
       interface FastEthernet0/0
       ip address 14.66.1.2 255.255.255.0
       no ip route-cache
       no ip mroute-cache
       no keepalive
       duplex half
       speed auto
       no cdp enable
       bridge-group 1
       bridge-group 1 spanning-disabled
       !
       interface FastEthernet0/1
       ip address 14.66.1.2 255.255.255.0
       no ip route-cache
       no ip mroute-cache
       shutdown 
!-- Not connected
 
       duplex auto
       speed 10
       no cdp enable
       bridge-group 1
       bridge-group 1 spanning-disabled
       !
       interface Cable1/0
       ip address 14.66.1.2 255.255.255.0
       no ip route-cache
       no ip mroute-cache
       load-interval 30
       no keepalive
       cable downstream annex B
       cable downstream modulation 256qam 
!-- for a non-lab environment 64 QAM is suggested

       cable downstream interleave-depth 32
       cable downstream frequency 525000000 
!-- This is a required line for the uBR7100

       no cable downstream rf-shutdown 
!-- This line turns on the internal upconverter.

       cable downstream rf-power 55 
!-- This line specifies the CMTS's transmit level.

       cable upstream 0 frequency 17808000 
!-- This line configures the frequency specified in the UCD

       cable upstream 0 power-level 0
       cable upstream 0 channel-width 3200000
       no cable upstream 0 shutdown 
!-- This line turns the upstream receiver on.

       bridge-group 1 
!-- This line configure bridging on the cable interface.

       bridge-group 1 subscriber-loop-control
       bridge-group 1 spanning-disabled
       !
       ip default-gateway 14.66.1.1
       ip classless
       no ip http server
       !
       no cdp run
       alias exec scm show cable modem
       !
       line con 0
       exec-timeout 0 0
       privilege level 15
       length 0
       line aux 0
       line vty 0 4
       password cisco
       no login
       !
       end

验证

注意: 命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

show cable modem将显示与CMTS联系的所有调制解调器和信息与在注册过程的调制解调器状态相关。此命令输出是快照。在理论上,如果此命令被执行系列您能看到调制解调器从init(r1)进步到在线状态。在下面的示例中BPI打开。

ubr7100#show cable modem
 Interface Prim Online Timing Rec QoS CPE IP address MACaddress
 Sid State Offset Power 
 Cable1/0/U0 1 online(pt) 1551 0.00 5 0  14.66.1.245 0050.7366.1e69
 Cable1/0/U0 2 online(pt) 1920 -0.75 5 0 14.66.1.252 0006.2854.72db
 Cable1/0/U0 3 online(pt) 1549 0.25 5 0  14.66.1.250 0050.7366.1e6d
 Cable1/0/U0 4 online(pt) 1548 -0.25 5 0 14.66.1.251 0050.7366.1e41

在CNR的租期验证

要确认IP地址被递交到有线调制解调器,请去范围的Lease选项。确认实施IP地址。此部分显示IP块和其租赁信息。输出是快照。要更新信息,按下了刷新列表按钮。

ubr7100_bridging_24544_6.gif

图 6

如果调制解调器附加对您的CMTS不注册,请参考针对UBR电缆调制解调器不在线问题的故障排除

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 24544