IP : Integrated Intermediate System-to-Intermediate System (IS-IS)

使用超载比特与IS-IS

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

本文如何并且何时引入set-overload-bit中间系统对中间系统(IS-IS)配置命令,和以使用它wait-for-bgp抑制关键字。在本文中,期限中间系统(是)和路由器是可互换的。

先决条件

要求

本文读者应该有基础知识:

  • 边界网关协议(BGP)和IS-IS路由协议。

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • Cisco IOSï ¿  ½软件版本12.1(9)

  • Cisco2500和3600系列路由器

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

传统使用超载位

当路由器用尽系统资源(内存或CPU),不能存储链路状态数据库或运行Shortest Path First (SPF)。在这种情况下,路由器应该通过设置其链路状态包的(LSP)一个特定的位警告在其区域内的其他路由器。当其他路由器检测此位设置,他们不会使用此路由器中转流量,但是他们将使用它数据包直接地被注定对被超载的路由器的连接的网络和IP前缀。

在IS-IS中,路由器在发送完全序列号PDU (CSNP)数据包以前立即充斥其自己的LSP。超载位从而用于建议网络的其余不通过最近重新加载的路由器路由中转流量。

对于每LSP, ISO/IEC 10589:1992leavingcisco.com 定义了呼叫的一个特殊位LSP数据库超载位。草稿提及超载状态(在第7.3.19部分) :由于网络配置错误或者某些瞬间情况, “很可能,可能有可用内存不足的资源存储已接收林克状态PDU。当这发生, IS需要采取某些步骤保证,如果其LSP数据库变得不一致与这些IS不依靠通过被超载的转发路径的其他ISs',是”。

当在此情况的IS is,它设置生成的非pseudonode LSP片段的0此位。

并且,在草稿,部分7.2.8.1做一注意其他IS不应该使用被超载的是作为转接路由器,但是可能到达直接地附加的终端系统(埃斯)。在直接此时间连接的接口,以及IP前缀期间,可及的。Cisco IOS不使用超载位此功能,虽然能力永久设置过载位介绍到与Cisco Bug ID CSCdj18100的IOS。在Cisco实施,当超载位集设置时,直接地连接的interfaces/IP前缀可及的。

展开的使用超载位

IS-IS超载位技术展开与Cisco Bug ID CSCdp01872 (仅限注册用户)。您能配置路由器在重新加载以后通告其LSP用特定量的时刻的超载位。当计时器超时时,清除超载位,并且LSP再泛洪的。

这新建的功能对运行边界网关协议(BGP)和Is-is避免两三个“黑洞”方案的网络服务提供商(ISP)是有用。设置一定量的时刻的超载位,在重新加载保证之后路由器不收到中转流量,当路由协议仍然聚合时。

设置此位的技术某一时期使用以下命令后,在重新加载实现。此命令采取5到86400秒范围超载位的时刻保持集合在重新加载以后。

router isis
set-overload-bit [on-startup [<timeout> | wait-for-bgp] ]

例如:

Router(config-router)#set-overload-bit on-startup 3500 wait-for-bgp

!--- Set the overload bit for 5 minutes (default is 10 minutes).

当BGP聚合,此功能也使成为可能配置路由器自动地禁用超载位。欲知关于等待BGP的详情,请参阅RFC3277 Intermediate System to Intermediate System (IS-IS)瞬变黑洞避免leavingcisco.com

根据BGP规格,只要发送更新, BGP路由器不需要发送Keepalive。因此,只有在所有更新被发送了后, Keepalive将被发送。当Keepalive从所有BGP邻居时,接收BGP考虑聚合。

如果BGP Keepalive没有从所有BGP邻居接收和wait-for-bgp配置, IS-IS在10分钟之后将禁用超载位。

set-overload-bit配置时, ISP在路由器的自己的LSP可能要抑制从通告的某些IP前缀。例如,允许1级到2级IP前缀传播可能不是理想的,将做路由器IP数据流的一个转接点。

Cisco Bug ID CSCdr98046 (仅限注册用户)给对发生了什么的更多控制,当超载位用于其展开的产能时。此增强允许IS-IS 1级-再分布从1级到2级或2级的IP路由到1级继续通告在其LSP的这些被重新分配的路由的2级(L1L2)路由器,当超载位设置。

使用抑制关键字,既使当set-overload-bit配置,您能配置L1L2路由器再分布和通告从1级的IP路由到2级或反之亦然。命令语法如下:

[no] set-overload-bit [on-startup [<n> | wait-for-bgp]] | [suppress [interlevel | external]]

如果超载位设置,抑制级别之间关键字通知路由器不通告从另一个IS-IS级别了解的IP前缀。如果超载位设置,抑制外部关键字通知路由器不通告从其他协议了解的IP前缀。默认不是抑制和维护Cisco Bug ID CSCdp01872 (仅限注册用户)行为。

抑制选项只生效,当您自己的超载位设置时,并且没有,当接收或配置时(例如,您可能有set-overload-bit启动时,并且位没有设置)。

router isis
set-overload-bit on-startup 40 suppress interlevel

上述情况,超载位实际上没有设置,直到路由器重新加载,和,因此您应该继续漏在级别之间的IP前缀。当您重新加载和实际上设置位时,您应该抑制级别之间广告。

配置示例

以下网络图用于展示set-overload-bit命令wait-for-bgp抑制选项。

/image/gif/paws/24509/TOPO.gif

这是包含在Router2的配置wait-for-bgp选项。

路由器 2 配置
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255

!--- Creates loopback interface and assigns
!--- IP address to interface Loopback0.

!
interface Ethernet0/0
ip address 135.8.1.1 255.255.255.0
ip router isis 
!

!--- Assigns IP address to interface Ethernet0/0 
!--- and enables IS-IS for IP on the interface.

!
!
interface Ethernet1/0
ip address 135.8.2.1 255.255.255.0
ip router isis 
!

!--- Assigns IP address to interface Ethernet1/0 
!--- and enables IS-IS for IP on the interface.

!
!
router isis
passive-interface Loopback0
net 12.0020.0200.2002.00
set-overload-bit on-startup wait-for-bgp
!

!--- Enables the IS-IS process on the router.
!--- Makes loopback interface passive 
!--- (does not send IS-IS packets on interface).
!--- Assigns area and system ID to router.
!--- Sets the overload bit on startup to wait for BGP
!--- using the default timeout of 10 minutes.

路由器新近地重新加载,并且,在eBGP聚合前您能看到超载位在IS-IS 1级数据库的Router2's LSP设置。

IS-IS Level-1 Link State Database:
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
r2.00-00              0x00000017   0x2372        284               0/0/1

下面,我们在BGP在Router2:聚合debug isis update中的输出看到

*Mar 1 00:00:51.015 UTC: BGP(0): Revise route installing 1.1.1.1/32 
-> 135.8.1.1 to main IP table

Router2当前重建其1级LSP,因为BGP聚合,并且清除超载位。所以您看到“在下面debug isis update中输出更改的”重要字段。

*Mar 1 00:00:51.087 UTC: ISIS-Upd: Building L1 LSP
*Mar 1 00:00:51.087 UTC: ISIS-Upd: Important fields changed
*Mar 1 00:00:51.087 UTC: ISIS-Upd: Full SPF required

现在我们能看到Router2完成其有邻居的BGP更新会话:

*Mar 1 00:00:52.127 UTC: BGP: 135.8.1.1 initial update completed

当我们再时查看Router2's 1级LSP,我们看到Router2清除了超载位(因为BGP聚合),并且LSP Seq Num字段由1增加(因为一新的LSP创建) :

IS-IS Level-1 Link State Database:
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
r2.00-00              0x00000018   0xAD87        287               0/0/0

这是Router2配置用L1L2路由泄漏配置的和被清除的超载位。

路由器 2 配置
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255

!--- Creates loopback interface and assigns
!--- IP address to interface Loopback0.

!
interface Ethernet0/0
ip address 135.8.1.1 255.255.255.0
ip router isis 

!--- Assigns IP address to interface Ethernet0/0 
!--- and enables IS-IS for IP on the interface.

!
!
!
interface Ethernet1/0
ip address 135.8.2.1 255.255.255.0
ip router isis 
!

!--- Assigns IP address to interface Ethernet1/0 
!--- and enables IS-IS for IP on the interface.

!
!
router isis 
redistribute static ip metric 11 level-1
redistribute isis ip level-2 into level-1 distribute-list 100
passive-interface Loopback0
net 12.0020.0200.2002.00
!

!--- Enables the IS-IS process on the router.
!--- Configured L2 to L1 route leaking
!--- Makes loopback interface passive
!--- (does not send IS-IS packets on interface).
!--- Assigns area and system ID to router.

!
ip route 200.200.200.200 255.255.255.255 loopback0 

!--- Static route to 200.200.200.200 via loopback0.

access-list 100 permit ip any any

!--- Access list 100 is used to control which route
!--- gets leaked from Level 2 to Level 1.

注意Router2's 1级数据库显示超载位是清楚的在Router2's L1 LSP。

IS-IS Level-1 LSP r2.00-00        
LSPID       LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL        
r2.00-00 * 0x0000005D   0xC252        180           0/0/0        
Area Address: 12        
NLPID: 0xCC         
Hostname: r2
IP Address: 2.2.2.2
Metric: 10 IP 135.8.2.0 255.255.255.0
Metric: 10 IP 135.8.1.0 255.255.255.0
Metric:  0 IP 2.2.2.2 255.255.255.255
Metric: 10 IS r2.02
Metric: 10 IS r3.01
Metric: 11 IP-External 200.200.200.200 255.255.255.255
Metric:138 IP-Interarea 1.1.1.1 255.255.255.255

当我们查看IP路由时Router3学习,我们能看到它了解从L2L1路由泄漏的路由器1's环回地址1.1.1.1。也注意Router3也接收再分布的静态路由200.200.200.0/32。

r3#show ip route isis
200.200.200.0/32 is subnetted, 1 subnets
i L1 200.200.200.200 [115/21] via 135.8.2.2, Ethernet0/0
1.0.0.0/32 is subnetted, 1 subnets
i ia 1.1.1.1 [115/148] via 135.8.2.2, Ethernet0/0
2.0.0.0/32 is subnetted, 1 subnets
i L1 2.2.2.2 [115/10] via 135.8.2.2, Ethernet0/0
135.8.0.0/24 is subnetted, 2 subnets
i L1 135.8.1.0 [115/20] via 135.8.2.2, Ethernet0/0

现在与抑制选项的Router2请配置set-overload-bit。我们抑制两内部和外部路由。命令语法如下:

[no] set-overload-bit [on-startup [<n> | wait-for-bgp]] | [suppress [interlevel | external]]

抑制级别之间防止路由器从级别了解的广播前缀2.抑制外部防止再分配。

r2(config-router)#set-overload-bit suppress interlevel external

调查Router2 1级数据库我们能看到超载位在Router2's 1级LSP当前设置。200.200.200.200/32和1.1.1.1/32被抑制了。他们没有被注入1级数据库。

IS-IS Level-1 LSP r2.00-00
LSPID       LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
r2.00-00 * 0x0000005F   0x23C6       266            0/0/1
Area Address: 12
NLPID: 0xCC 
Hostname: r2
IP Address: 2.2.2.2
Metric: 10 IP 135.8.2.0 255.255.255.0
Metric: 10 IP 135.8.1.0 255.255.255.0
Metric: 0 IP 2.2.2.2 255.255.255.255
Metric: 10 IS r2.02
Metric: 10 IS r3.01

当我们启用在Router2时的debug isis update-packets,我们看到“在输出中更改的”重要字段,当1级和2级LSP被构件时。这表明有设置的超载位的LSP内容更改,换句话说,我们接收LSP。一新的LSP要求将运行的全双工SPF。

*Mar 1 03:16:08.987 UTC: ISIS-Upd: Building L1 LSP
*Mar 1 03:16:08.987 UTC: ISIS-Upd: Important fields changed
*Mar 1 03:16:08.987 UTC: ISIS-Upd: Full SPF required
*Mar 1 03:16:08.987 UTC: ISIS-Upd: Building L2 LSP
*Mar 1 03:16:08.987 UTC: ISIS-Upd: Important fields changed
*Mar 1 03:16:08.987 UTC: ISIS-Upd: Full SPF required
*Mar 1 03:16:09.035 UTC: ISIS-Upd: Sending L1 LSP 0020.0200.2002.00-00, seq 61, ht 299 on Ethernet0/0
*Mar 1 03:16:09.095 UTC: ISIS-Upd: Sending L2 LSP 0020.0200.2002.00-00, seq 65, ht 299 on Ethernet1/0

路由器3's更新的路由表不再包括IP网络200.200.200.200和1.1.1.1。

r3#show ip route isis
2.0.0.0/32 is subnetted, 1 subnets
i L1 2.2.2.2 [115/10] via 135.8.2.2, Ethernet0/0
135.8.0.0/24 is subnetted, 2 subnets
i L1 135.8.1.0 [115/20] via 135.8.2.2, Ethernet0/0

DDTS 信息

  • Cisco Bug ID CSCdj18100 (仅限注册用户) -介绍能力手工设置超载位。

  • Cisco Bug ID CSCdp01872 (仅限注册用户) -介绍能力设置启动的超载位。等待,直到BGP发了信号收敛或设置计时器清除超载位。

  • Cisco Bug ID CSCdr98046 (仅限注册用户) -再分布从1级到2级或2级的IP路由到1级的IS-IS L1L2路由器可能继续通告在其LSP的这些被重新分配的路由,当超载位设置时。


相关信息


Document ID: 24509