IP : 边界网关协议(BGP)

在 Cat6000 MSFC 中配置单路由器模式冗余和 BGP

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 22 日) | 反馈


目录


简介

本文为单路由器模式冗余提供一配置示例和边界网关协议(BGP)在Catalyst 6000多层交换机特性卡(MSFC)。

好网络设计实践是提供Layer2,以及第3层,冗余。网络用两台Catalyst 6000交换机,中的每一用两个Supervisor引擎和两MSFC能提供希望的冗余。两个Supervisor引擎(一个是活跃的,并且一个暂挂)提供Layer2冗余和两MSFC在每个机箱提供第3层冗余。另外,两个Catalyst 6000机箱可以是多址对两不同的ISP使用BGP,在ISP的失败情形下,提供另外的冗余。

有一定数量的方式配置在Catalyst 6000的冗余:

  • 双MSFC冗余(高可用性)

  • 单路由器模式(SRM)冗余

  • 手工模式冗余

本文为在Catalyst 6000的SRM冗余提供一运行CatOS系统软件的配置示例以双重Supervisor和MSFC。在一个多宿主BGP网络中用两个Catalyst 6000机箱, SRM冗余提供在上面三个可能的选项中的简单配置。

开始使用前

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

先决条件

本文读者应该熟悉配置BGP以及Supervisor和MSFC冗余配置Catalyst 6000系列交换机的。关于这些主题的更多信息,请参阅在本文相关信息部分的链路。

使用的组件

Catalyst 6000/Catalyst 6500冗余的参考的硬件需求关于冗余的硬件需求的更多信息在Catalyst 6000系列交换机。参考了解在混合模式Catalyst 6000交换机的内部MSFC冗余关于在Supervisor和MSFC要求的最低软件版本的更多信息SRM的。

此配置使用下面软件和硬件版本开发并且被测试。

  • Catalyst 1在下图所示中是有两1000BaseX Supervisor WS-X6K-SUP1A-2GE和两MSFC WS-F6K-MSFC2的一台Catalyst 6509。

  • Catalyst 2在下图所示中是有两1000BaseX Supervisor WS-X6K-SUP1A-2GE和两MSFC WS-F6K-MSFC的一台Catalyst 6506。

  • 两台Catalyst交换机运行cat6000-supk8.8-1-2.bin OS软件。

  • 在Catalyst 1的MSFC2运行c6msfc2-psv-mz.121-13.E10,并且在Catalyst 2的MSFC运行c6msfc-psv-mz.121-13.E10软件。

  • 在AS10和AS20的设备在图表中是运行Cisco IOS 软件版本12.3(3)的思科2500系列路由器。

本文档中的信息都是基于特定实验室环境中的设备创建的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您是在真实网络上操作,请确保您在使用任何命令前已经了解其潜在影响。

参考产品资料关于Catalyst 6000/6500系列交换机的更多信息。

背景理论

在SRM冗余,只有指定路由器(MSFC)在指定时候是可视对网络。非指定的路由器启动完全并且参与配置同步,自动地启用,当输入SRM时。不同于MSFC高性能的方法,非指定的路由器的配置正确地是相同的象指定路由器,但是其接口在"line down"状态被保留并且不是可视对网络。进程,例如路由协议,在非指定的路由器和指定路由器创建,但是所有非指定的路由器接口在"line down"状态;他们不发送也不接收从网络的更新。

当指定路由器出故障时,非指定的路由器更改其状态变为指定路由器和其接口状态变换“连接”。当现有Supervisor引擎交换处理器条目用于转发第3层流量时,它构件其路由表。在新指定路由器构件其路由表后,在交换处理器的条目更新。

由于仅一个MSFC到时是可视对网络,您不需要设立并列在两MSFC之间的多个BGP。(其他冗余方法要求在两MSFC在一个Catalyst系列机箱和两MSFC之间的同位体在另一个Catalyst系列机箱。)在指定的MSFC的失败情形下,非指定的MSFC设立BGP并列。所以,总是看起来作为单个BGP对等体对网络并且简化网络设计,但是给同样水平冗余,万一MSFC有一失败。

运行CatOS系统软件的Catalyst 6000系列交换机仅支持SRM冗余功能。对于配置在操作Cisco IOS系统软件的Catalyst 6000交换机的冗余,参考配置EHSA Supervisor引擎冗余配置RPR和RPR+ Supervisor引擎冗余

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 要查找本文档所用命令的其他信息,请使用命令查找工具仅限注册用户)。您能也参考Catalyst 6500系列命令参考Catalyst 6500系列cisco ios命令参考资料关于这些命令的更多信息。

基本步骤配置是:

  1. 配置在Catalyst 1及Catalyst 2交换机的SRM冗余。关于逐步指导,请参阅Single Router Mode Redundancy部分在配置冗余

  2. 配置在指定路由器(MSFC)的BGP并列和策略两台Catalyst 1及Catalyst 2交换机的。关于如何配置在双址和多址情况的BGP的更多信息,参考共享与在单宿主和多宿主环境的BGP的负载的配置示例

网络图

本文档使用下图所示的网络设置。

/image/gif/paws/23704/bgp_cat_6500_msfc_01.gif

点击以上图显示它在独立浏览器窗口,为了请使用作为后的参考在本文。

在此网络中,自治系统AS4分别为多址对AS10和AS20通过VLAN10 (Vlan10)和VLAN 20 (Vlan20)。在AS4内,网络有两台Catalyst 6000交换机(CAT 1和CAT 2),中的每一个用两个Supervisor和两MSFC。使用SRM配置,两个交换机配置提供Layer2和第3层冗余。CAT 1执行与(iBGP)的外部BGP除IBGP同位体外用CAT 1,并列用CAT 2. CAT 2的AS10和内部BGP执行有AS20的eBGP对等体,因而提供冗余,万一对一个ISP的连接发生故障。

配置

本文档使用如下所示的配置。

CAT 1
CAT1> (enable) show running-config

!--- Output suppressed.

begin
!
# ***** NON-DEFAULT CONFIGURATION *****
!
!
#version 8.1(2)
!
#system
set system name CAT1
set system highavailability enable

!--- Enables high availability on Catalyst switch.

!
#vtp
set vtp domain cisco

!--- Output suppressed.

set vlan 1,10,20
!

!--- Output suppressed.

#set boot command
set boot config-register 0x2102
set boot system flash bootflash: cat6000-supk8.8-1-2.bin
!
# default port status is enable!!#module 1 : 2-port 1000BaseX Supervisor
!
#module 2 : 2-port 1000BaseX Supervisor
!
#module 3 : 48-port 10/100BaseTX Ethernet
set vlan 10 3/2

!--- Port 3/2 is connected to AS10 on VLAN 10.

!
#module 4 empty!
#module 5 : 8-port 1000BaseX Ethernet
set trunk 5/2 on isl 1-1005,1025-4094

!--- Port 5/2 is connected to CAT 2 as Trunk.

!

!--- Output suppressed.

!
#module 15 : 1-port Multilayer Switch Feature Card

!--- MSFC #1 on Port 1, Mod 15.

!
#module 16 : 1-port Multilayer Switch Feature Card

!--- MSFC #2 on Port 2, Mod 16.

CAT 2
CAT2 (enable) show running-config

!--- Output suppressed.

begin
!
# ***** NON-DEFAULT CONFIGURATION *****
!
!
#version 8.1(2)
!
#system
set system name CAT2
set system highavailability enable

!--- Enables high availability on Catalyst switch.
 
!
#vtp
set vtp domain cisco

!--- Output suppressed.

set vlan 1,10,20
!

!--- Output suppressed.

!
#set boot command
set boot config-register 0x2102
set boot system flash bootflash: cat6000-supk8.8-1-2.bin
!
!
# default port status is enable!!#module 1 : 2-port 1000BaseX Supervisor
!
#module 2 : 2-port 1000BaseX Supervisor
!
#module 3 : 48-port 10/100BaseTX Ethernet
set vlan 20 3/3

!--- Port 3/3 is connected to AS20 on VLAN 20.
 
! 
#module 4 : 8-port 1000BaseX Ethernet
set trunk 4/2 on isl 1-1005,1025-4094

!--- Port 4/2 is connected to CAT 1 as Trunk.
 
!

!--- Output suppressed.

!
#module 15 : 1-port Multilayer Switch Feature Card

!--- MSFC 1 on Port 1, Mod 15.

!
#module 16 : 1-port Multilayer Switch Feature Card

!--- MSFC #2 on Port 2, Mod 16.

在CAT1的MSFC配置
CAT1> (enable)
CAT1> (enable) session 15
Trying Router-15...
Connected to Router-15.
Escape character is '^]'.

MSFC-CAT1> enable
MSFC-CAT1# show running-config
Building configuration...

Current configuration : 868 bytes
!
version 12.1
!

!--- Output suppressed.

!
hostname MSFC-CAT1
!
boot system bootflash: c6msfc2-psv-mz.121-13.E10
boot bootldr bootflash:c6msfc2-boot-mz.121-13.E10
!
ip subnet-zero
!
!
!
redundancy 

!--- This command enables redundancy.

 high-availability 

!--- This command enables high availability.

 single-router-mode 

!--- This command enables SRM.

!
interface Vlan10
 ip address 192.168.1.1 255.255.255.0

!--- Interface Vlan10 is acting as the routed interface for Vlan 10 on CAT1
 

!--- and is used for eBGP peering with AS10.

!
interface Vlan20
 ip address 192.168.2.3 255.255.255.0

!--- Interface Vlan20 is acting as the routed interface for Vlan 20 on CAT1


!--- and is used for iBGP peering with CAT2 via the trunk.

!
router bgp 4
 no synchronization
 bgp log-neighbor-changes
 network 192.168.0.0 mask 255.255.0.0
 neighbor 192.168.1.2 remote-as 10

!--- This command establishes eBGP peering with AS10.

 neighbor 192.168.2.1 remote-as 4

!--- This command establishes iBGP peering with interface VLAN 20 on CAT2.

 neighbor 192.168.2.1 next-hop-self

!--- This command assigns a next-hop value to 192.168.2.3
 

!--- for updates sent to 192.168.2.1 (the iBGP peer).

!
ip classless
ip route 192.168.0.0 255.255.0.0 Null0

!--- Output suppressed.

在CAT2的MSFC配置
CAT2 (enable)
CAT2 (enable) session 15
Trying Router-15...
Connected to Router-15.
Escape character is '^]'. 
MSFC-CAT2> enable
MSFC-CAT2# show running-config
Building configuration...

Current configuration : 890 bytes
!
version 12.1
!

!--- Output suppressed.

!
hostname MSFC-CAT2
!
boot system flash bootflash: c6msfc-psv-mz.121-13.E10
boot bootldr bootflash:c6msfc-boot-mz.121-13.E10
!
ip subnet-zero
!
! 
redundancy 

!--- This command enables redundancy.

 high-availability 

!--- This command enables high availability.

 single-router-mode 

!--- This command enables SRM.

!
interface Vlan10
 ip address 192.168.1.3 255.255.255.0

!--- Interface Vlan10 is acting as the routed interface for Vlan 10 on CAT2

!
interface Vlan20
 ip address 192.168.2.1 255.255.255.0

!--- Interface Vlan20 is acting as the routed interface for Vlan 20 on CAT2


!--- and is used for iBGP peering with CAT1 as well as eBGP peering with AS20.

!
router bgp 4
 no synchronization
 bgp log-neighbor-changes
 network 192.168.0.0 mask 255.255.0.0
 neighbor 192.168.2.2 remote-as 20

!--- This command establishes eBGP peering with AS20.
 
 neighbor 192.168.2.3 remote-as 4

!--- This command establishes iBGP peering with interface Vlan20 on CAT1.

 neighbor 192.168.2.3 next-hop-self

!--- This command assigns a next-hop value to 192.168.2.1
 

!--- for updates sent to 192.168.2.3 (the iBGP peer).
 
!
ip classless
ip route 192.168.0.0 255.255.0.0 Null0

!--- Output suppressed.

验证

本部分所提供的信息可用于确认您的配置是否正常工作。

命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

  1. 识别并且验证在CAT1的MSFC模块是在活动状态,并且在备用状态。请使用show module命令验证状态。下面选中项目的输出识别Mod 15在活动状态(状态=好),并且Mod 16在备用状态。

    CAT1> (enable) show module
    Mod Slot Ports Module-Type               Model               Sub Status
    --- ---- ----- ------------------------- ------------------- --- --------
    1   1    2     1000BaseX Supervisor      WS-X6K-SUP1A-2GE    yes ok
    15  1    1     Multilayer Switch Feature WS-F6K-MSFC2        no  ok
    2   2    2     1000BaseX Supervisor      WS-X6K-SUP1A-2GE    yes standby
    16  2    1     Multilayer Switch Feature WS-F6K-MSFC2        no  standby
    3   3    48    10/100BaseTX Ethernet     WS-X6248-RJ-45      no  ok
    5   5    8     1000BaseX Ethernet        WS-X6408A-GBIC      no  ok
    
    !--- Output suppressed.
    
    
  2. 连接对激活MSFC并且验证冗余状态。在我们的情况中,激活MSFC在Mod 15。要连接到Mod 15,请使用二者之一session or switch console命令

    CAT1> (enable) session 15
    Trying Router-15...
    Connected to Router-15.
    Escape character is '^]'.
    MSFC-CAT1>
    
    

    一旦连接,请使用show redundancy命令验证冗余状态。

    MSFC-CAT1> enable
    MSFC-CAT1# show redundancy
    Designated Router: 1 Non-designated Router: 2
    Redundancy Status: designated 
    Config Sync AdminStatus : enabled
    Config Sync RuntimeStatus: enabled
    Single Router Mode AdminStatus : enabled
    Single Router Mode RuntimeStatus: enabled
    Single Router Mode transition timer : 120 seconds

    这确认在Mod 15的MSFC在活动状态,并且其冗余状态被选定。SRM状态启用。当SRM启用时,同步运行和启动配置在活动和暂挂MSFC之间在交换机的设置同步功能自动地启用。

  3. 连接对待机MSFC并且验证冗余状态。在Mod 16的MSFC在备用状态。要连接到它,我们使用session命令,我们然后使用show redundancy命令验证状态。

    CAT1> (enable) session 16
    Trying Router-16...
    Connected to Router-16.
    Escape character is '^]'.
    
    MSFC-CAT1>
    MSFC-CAT1> enable
    MSFC-CAT1# show redundancy
    Designated Router: 1 Non-designated Router: 2
    
    Redundancy Status: non-designated
    Config Sync AdminStatus : enabled
    Config Sync RuntimeStatus: enabled
    Single Router Mode AdminStatus : enabled
    Single Router Mode RuntimeStatus: enabled
    Single Router Mode transition timer : 120 seconds

    上述输出确认Mod 16在非指定的状态,并且SRM状态启用。在备用状态,所有MSFC接口在故障状态。请使用show ip interface brief命令确认此如下所示。

    MSFC-CAT1# show ip interface brief
    Interface                  IP-Address      OK? Method Status   Protocol
    Vlan10                     192.168.1.1     YES NVRAM  down     down
    Vlan20                     192.168.2.3     YES NVRAM  down     down

    注意: 步骤4到步骤6是相同的象Step1对步骤3,但是在CAT2和使用验证适当作用SRM。

  4. 首先请检查在Mod 15的MSFC在活动状态(状态=好),并且在Mod 16的MSFC在备用状态。

    CAT2> (enable) show module
    Mod Slot Ports Module-Type               Model               Sub Status
    --- ---- ----- ------------------------- ------------------- --- --------
    1   1    2     1000BaseX Supervisor      WS-X6K-SUP1A-2GE    yes ok
    15  1    1     Multilayer Switch Feature WS-F6K-MSFC         no  ok
    2   2    2     1000BaseX Supervisor      WS-X6K-SUP1A-2GE    yes standby
    16  2    1     Multilayer Switch Feature WS-F6K-MSFC         no  standby
    3   3    48    10/100BaseTX Ethernet     WS-X6248-RJ-45      no  ok
    4   4    8     1000BaseX Ethernet        WS-X6408-GBIC       no  ok
    
    !--- Output suppressed.
    
    
  5. 连接对激活MSFC并且验证冗余状态。

    CAT2 (enable) session 15
    Trying Router-15...
    Connected to Router-15.
    Escape character is '^]'.
    
    MSFC-CAT2> enable
    MSFC-CAT2# show redundancy
    Designated Router: 1 Non-designated Router: 2
    
    Redundancy Status: designated
    Config Sync AdminStatus : enabled
    Config Sync RuntimeStatus: enabled
    Single Router Mode AdminStatus : enabled
    Single Router Mode RuntimeStatus: enabled
    Single Router Mode transition timer : 120 seconds

    上述输出确认冗余启用,并且此MSFC (Mod 15)是在所指定的状态。

  6. 连接对待机MSFC并且验证冗余状态。

    CAT2 (enable) session 16
    Trying Router-16...
    Connected to Router-16.
    Escape character is '^]'.
    
    MSFC-CAT2> enable
    MSFC-CAT2# show redundancy
    Designated Router: 1 Non-designated Router: 2
    
    Redundancy Status: non-designated
    Config Sync AdminStatus : enabled
    Config Sync RuntimeStatus: enabled
    Single Router Mode AdminStatus : enabled
    Single Router Mode RuntimeStatus: enabled
    Single Router Mode transition timer : 120 seconds

    上述输出确认MSFC的冗余状态在Mod 16的如非指定的。

故障排除

即然您验证高性能的SRM配置,您需要验证在MSFC的BGP状态在CAT1和CAT2。

  1. 请使用show ip bgp summary命令在CAT1的激活MSFC验证邻居建立。下面的输出确认成功的eBGP和IBGP同位体与AS10和CAT2各自MSFC。

    MSFC-CAT1# show ip bgp summary 
    BGP router identifier 192.168.2.3, local AS number 4 
    BGP table version is 4, main routing table version 4 
    3 network entries and 4 paths using 435 bytes of memory 
    4 BGP path attribute entries using 240 bytes of memory 
    2 BGP AS-PATH entries using 48 bytes of memory 
    0 BGP route-map cache entries using 0 bytes of memory 
    0 BGP filter-list cache entries using 0 bytes of memory 
    BGP activity 3/14 prefixes, 4/0 paths, scan interval 15 secs
      
    Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
    192.168.1.2     4    10      90      92        4    0    0 01:26:02        1
    192.168.2.1     4     4      91      91        4    0    0 01:25:38        2
    
  2. 验证在激活MSFC的BGP状态在CAT2。下面的输出确认成功的eBGP和IBGP同位体与各自AS20和CAT1。

    MSFC-CAT2# show ip bgp summary  
    BGP router identifier 192.168.2.1, local AS number 4 
    BGP table version is 4, main routing table version 4 
    3 network entries and 4 paths using 435 bytes of memory 
    4 BGP path attribute entries using 240 bytes of memory 
    2 BGP AS-PATH entries using 48 bytes of memory 
    0 BGP route-map cache entries using 0 bytes of memory 
    0 BGP filter-list cache entries using 0 bytes of memory 
    BGP activity 3/0 prefixes, 4/0 paths, scan interval 15 secs 
     
    Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
    192.168.2.2     4    20     110     112        4    0    0 01:46:43        1
    192.168.2.3     4     4     101     101        4    0    0 01:35:09        2
    
  3. 在指定的MSFC的事件(在CAT1的Mod 15)体验失败,待机MSFC (在CAT1的Mod 16)接收激活MSFC角色。请注意与指定的MSFC和故障切换的失败对非指定的MSFC,数据包交换继续与旧有指定的MSFC编程的Supervisor引擎交换处理器条目一起使用。新指定MSFC最终重编程序有其自己的条目的Supervisor引擎交换处理器,并且旧有条目超时。交换处理器条目是多层交换抄近路一旦有PFC的Supervisor 1A模块或者存储在一个Supervisor2模块的Cisco express forwarding (CEF)表有PFC2的。

    指定的MSFC的失败通过重置在CAT1的Mod模拟15如下所示。

    CAT1> (enable) reset 15
    This command will reset module 15.
    Unsaved configuration on module 15 will be lost
    Do you want to continue (y/n) [n]? y
    2002 May 16 11:52:54 %SYS-5-MOD_RESET:Module 15 reset from Console//
    Resetting module 15...

    Ping数据流从AS10生成到在AS20的一个目的地在CAT1的故障切换期间从指定到非指定的MSFC。注意有最小包丢失在此故障切换期间,并且信息包转发继续与Mod编程的旧有MLS快捷方式一起使用15 MSFC,直到Mod 16 MSFC重编程序有其自己的MLS交换项的交换处理器。

    AS10-Router# ping
    Protocol [ip]:
    Target IP address: 172.16.1.1
    Repeat count [5]: 1000
    Datagram size [100]:
    Timeout in seconds [2]:
    Extended commands [n]:
    Sweep range of sizes [n]:
    Type escape sequence to abort.
    Sending 1000, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
    !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    !!!!!!!!!!!!!!!!!!!!!!!!!!.!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    !!!!!!!!!!!!!!!!!!!!!
    Success rate is 99 percent (999/1000), round-trip min/avg/max = 1/3/116 ms

    与Catalyst 6000的MSFC其他冗余选项比较, SRM冗余提供通过使用同一个地址在活动和暂挂MSFC,从而减少路由协议同位体和进行的配置的保存IP地址优点更加简单,当提供同样故障切换功能如此示例所显示时。

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 23704