异步传输模式 (ATM) : IP to ATM 业务类别

在桥接 ATM PVC 上应用 QoS 服务策略与 CBWFQ/LLQ

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 22 日) | 反馈


目录


简介

本文为理想的排队机制选项提供一配置示例,例如基于类别的加权公平队列(CBWFQ)和低延迟队列(LLQ),在配置的ATM接口接受RFC 1483 桥接格式协议数据单元(PDU)。

Cisco IOS�软件支持三个用于网外路由的协议(对一不同的IP网络号)在RFC 1483桥接的应用程序。这些协议是,路由-网桥封装(RBE)和桥接形式永久虚电路(PVC)。所有这些协议允许ATM PVC接收桥接格式PDU。本文是指PVC配置与一个桥接协议例如桥接的PVC。

服务策略配置与模块化服务质量(QoS)命令行界面(CLI) (MQC)应用QoS机制对接口、子接口或者VC。在桥接的PVC,运用异样的排队机制的服务策略仅支持与RBE。运行IRB不支持在配置的ATM VC的服务策略。在这样VC,如果定义了在IP访问控制列表的类映射(ACL)配比,对此类的数据包匹配不发生,并且所有信息包分类对默认组。

先决条件

要求

本文读者应该有这些主题知识: :

注意: IRB配置不支持每个vc CBWFQ或LLQ。在您设法实现CBWFQ或LLQ前,必须移植配置到RBE或PPPoE在ATM配置。

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • 有NM-1A-OC3 ATM接口的Cisco 2620路由器

  • Cisco IOS 软件版本 12.2(27)

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

背景信息

QoS服务策略管理队列深度,标记该流量,并且识别在逐个VC的不重要的流量。特别地,此策略得到这些目标:

  • 使用NBAR为了分类非业务关键的流量,例如Napster。

  • 使用基于类的策略功能标记优先值一致,超出和违犯流量。

  • 应用基于类的WRED为了管理队列深度。

    注意: 服务策略输出随机-检测-组命令是互相排斥在PVC级别。您不能运用WRED组到您通过服务策略的应用程序启用CBWFQ的VC。然而,如果配置random-detect命令在一类在策略映射里面,您能运用两个功能。

  • 应用基于分类的营销以set命令为了由流量类型标记这些IP优先级值。

优先级值 流量类型
1 非业务关键的,例如Napster
4 默认,用于正常流量
5 保留为将来实时数据流,例如VoIP。
6 和 7 保留为网络控制流量

潜在拥塞点是喂养连接DSL的用户的ATM VC。IP流到达在快速以太网接口在至100 Mbps并且流出ATM VC。这些为与T1接口(1.544 Mbps)的默认峰值信元速率的未指明的比特率(UBR) ATM业务类型配置。因此,在快速以太网接口到达的QoS服务策略标记该流量。WRED然后用于引人注目的价值为了创建根据IP优先级的服务类和通过唯一丢弃级别提供差分服务每类。

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 要查找本文档所用命令的其他信息,请使用命令查找工具仅限注册用户)。

网络图

本文档使用以下网络设置:

/image/gif/paws/22820/bridging_cbwfq1.gif

注意: UBR服务类别的ATM VC根据定义不提供任何最小带宽。因此,您不能应用CBWFQ或LLQ和保证带宽到UBR VC。除UBR之外,例如vbr-nrt或ABR,为了执行如此,您必须更改ATM业务类型到某事。欲了解更详细的信息在此,参考了解ATM虚拟电路的UBR服务类别

配置

本文档使用以下配置:

Cisco 2600 路由器
class-map match-any HTTP-HACKS 

!--- Use the class-map command in global configuration mode
!--- in order to match packets to a specified class.


   match protocol http url "*.ida*"  
   
!--- In order to configure NBAR to match HTTP traffic 
!--- by URL, HOST, or Multi-purpose Internet Mail Extension (MIME)-type, use the
!--- match protocol http command in class-map configuration mode.

   match protocol http url "*cmd.exe*"  
   match protocol http url "*root.exe*"  
   match protocol http url "*Admin.dll*"  
   match protocol http url "*readme.eml*"  
class-map match-any JUNK  
   match protocol napster 
   match protocol fasttrack
class-map match-all IP-PREC-4  match ip precedence 4class-map match-all DEFAULT  
match any
! 
policy-map DSL-OUT-C

!--- Use this command
!--- in order to create or modify a policy map that can be attached to one or more 
!--- interfaces to specify a service policy.

  class IP-PREC-4
   police 32000 250000 5000000 conform-action set-prec-transmit 4 exceed-action
 set-prec-transmit 3 violate-action set-prec-transmit 2
  
!--- Use this command to mark a packet with different quality of service (QoS) 
!--- values based on conformance to the service-level agreement.

! 
policy-map LAN-IN  
  class HTTP-HACKS  
     police 8000 1000 1000 conform-action drop exceed-action
       drop  
  class JUNK  
   set ip precedence 1  
  class DEFAULT  
   set ip precedence 4  
! 
policy-map DSL-OUT  
   class class-default
    
!-- Used to make class-default a single FIFO queue 
!-- inside the WFQ system. 
 
    bandwidth percent 1 
    
    random-detect  
    random-detect exponential-weighting-constant 7  
    random-detect precedence 0   20    40    10  
    random-detect precedence 1   22    40    10 
    random-detect precedence 2   24    40    10 
    random-detect precedence 3   26    40    10 
    random-detect precedence 4   28    40    10  
    random-detect precedence 5   31    40    10  
    random-detect precedence 6   33    40    10  
    random-detect precedence 7   35    40    10  
    random-detect precedence rsvp   37    40    10 
    service-policy DSL-OUT-C
    
!--- In order to use a service policy as a QoS policy within a policy map
!--- (called a hierarchical service policy), use the service-policy command
!--- in policy-map class configuration mode.

! 
interface Loopback1  
  ip address 172.16.1.1 255.255.255.0  
!  
interface FastEthernet0/0  
  ip address 10.1.1.1 255.255.255.192  
  service-policy input LAN-IN  
  
!--- Use this command in order to attach a policy map to an input interface
!--- or virtual circuit (VC), or an output interface or VC, to be used as 
!--- the service policy for that interface or VC.

!  
interface ATM1/0  
  no ip address  
  no atm ilmi-keepalive 
!  
interface ATM1/0.4 point-to-point  
  ip unnumbered Loopback1  
  no ip redirects  
  no ip unreachables  
  no ip mroute-cache  
  atm route-bridged ip  
  pvc 1/35  
   service-policy output DSL-OUT  
  ! 
!  
interface ATM1/0.5 point-to-point  
  ip unnumbered Loopback1  
  no ip redirects  
  no ip unreachables  
 no ip mroute-cache  
  atm route-bridged ip 
 
!--- Use in order to configure an interface to use ATM RBE.

  pvc 1/36
   service-policy output DSL-OUT 
!
ip route 172.16.1.2 255.255.255.255 ATM1/0.4
ip route 172.16.1.3 255.255.255.255 ATM1/0.5
end

验证

本部分所提供的信息可用于确认您的配置是否正常工作。

命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

  • show queueing interface atm —显示特定VC的排队统计信息在接口的。当IP流排队对第3层队列时,活动“会话的”非零值在拥塞期时显示。

    2600# show queueing interface atm1/0.4
            Interface ATM1/0.4 VC 1/35
            Queueing strategy: weighted fair
            Total output drops per VC: 0
            Output queue: 0/512/64/0 (size/max total/threshold/drops)
               Conversations  0/1/64 (active/max active/max total)
               Reserved Conversations 1/1 (allocated/max allocated)
               Available Bandwidth 0 kilobits/sec
  • show policy-map interface atm —,当您监控您的服务策略时,请使用此命令检查这些统计信息:

    • 增加匹配类的数据包的值。如果这不工作,请保证CEF启用,并且数据包跟随CEF交换开关路径。发出show interface stats命令为了查看数据包是否经过CEF交换的。

    • 比较" packets "值对" pkts matched "值。" pkts matched "值增加在仅拥塞的时期。欲知更多信息,在show policy-map interface输出中参考了解信息包计数器

    • 更正随机的丢包编号。监控" mean queue depth "字段的值并且确定此字段是否达到在最低门限值上的一个值。当平均队列深度在级时,一特定的IP优先级的最低门限值上上升WRED开始掉数据包。

2600# show policy-map interface atm1/0.4
ATM1/0.4: VC 1/35 -
 Service-policy output: DSL-OUT
 Class-map: class-default (match-any)
     29121 packets, 41550530 bytes
     5 minute offered rate 0 bps, drop rate 0 bps
     Match: any
     Queueing
       Output Queue: Conversation 73
       Bandwidth 1 (%)
       (pkts matched/bytes matched) 59/8894
       (depth/total drops/no-buffer drops) 0/0/0
        exponential weight: 7
        mean queue depth: 0

 class    Transmitted      Random drop   Tail drop    Minimum   Maximum   Mark
          pkts/bytes       pkts/bytes    pkts/bytes   thresh    thresh    prob
 0        15791/22456790       0/0           0/0          20        40    1/10
 1           0/0               0/0           0/0          22        40    1/10
 2         8555/13041140       0/0           0/0          24        40    1/10
 3         3417/5207580        0/0           0/0          26        40    1/10
 4         1358/845020         0/0           0/0          28        40    1/10
 5           0/0               0/0           0/0          31        40    1/10
 6           0/0               0/0           0/0          33        40    1/10
 7           0/0               0/0           0/0          35        40    1/10
 rsvp        0/0               0/0           0/0          37        40    1/10
     Service-policy : DSL-OUT-C
 Class-map: IP-PREC-4 (match-all)
   13330 packets, 19093740 bytes
   5 minute offered rate 0 bps, drop rate 0 bps
   Match: ip precedence 4
   police:
     32000 bps, 250000 limit, 5000000 extended limit
     conformed 1358 packets, 845020 bytes; action: set-prec-transmit 4
     exceeded 3417 packets, 5207580 bytes; action: set-prec-transmit 3
     violated 8555 packets, 13041140 bytes; action: set-prec-transmit 2
     conformed 0 bps, exceed 0 bps, violate 0 bps
 Class-map: class-default (match-any)
   15791 packets, 22456790 bytes
   5 minute offered rate 0 bps, drop rate 0 bps
   Match: any 

故障排除

目前没有针对此配置的故障排除信息。

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 22820