拨号和接入 : 综合业务数字网络 (ISDN),随路信令 (CAS)

进行环回呼叫以测试 BRI 电路

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

本文提供说明关于怎样进行环回为了测试基本速率接口(BRI)电路。

先决条件

要求

本文档的读者应掌握以下这些主题的相关知识:

在您尝试此步骤前,请从Telco得到以下信息:

  • 将配置的交换类型。

  • 服务配置文件标识符(SPID)和本地目录号(LDN)。SPID和LDN在美利坚合众国要求。

  • 两B信道是否在搜索组中。如果他们在寻找组中我们只需要拨号一个号码到达任一B信道。

  • 在BRI线路的呼叫是否需要被做在56k或64k

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • Cisco IOS软件版本12.0(3)T和以后。这是因为isdn call命令在Cisco IOS软件版本12.0(3)T介绍。

本文档中的信息都是基于特定实验室环境中的设备创建的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您是在真实网络上操作,请确保您在使用任何命令前已经了解其潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

背景信息

在环回呼叫,路由器拨号其自己的基本速率接口(BRI) ISDN编号。呼叫进入TELCO网云,电信公司将呼叫切换到第二条BRI信道。此呼叫被路由器看作第二条信道上的入呼叫。因此,路由器既发送又接收 ISDN 呼叫。

环回呼叫测试的是路由器发起和终止 ISDN 呼叫的能力。成功的回环呼叫给予您明确的提示对TELCO网云的ISDN电路是工作。

有您可执行测试BRI电路环回呼叫的两种类型:

  • ISDN层3环回呼叫? ? ?哪些您能使用isdn call interface命令。此环回呼叫可帮助您验证ISDN层1, 2和3是否是工作在路由器和本地ISDN交换机之间。此测验使用D-channel,并且不在B信道间的测验数据。这不介入对路由器的配置的更改。执行此测验第一。如果它成功,请尝试数据回环呼叫测验。

  • 数据回环呼叫? ? ?哪些测验B信道是否能实际上传递数据。这介入在路由器的一个配置更改。

这些步骤只允许您测试对本地交换机的BRI电路是否是工作。它不测试与按需拨号路由(DDR)或问题涉及的端到端ISDN连通性。关于排除故障的更多信息BRI参考以下文档:

执行ISDN层3环回呼叫

此部分提供一成功的ISDN层3环回呼叫的示例。没有DDR需求的isdn call命令enable (event)流出的ISDN呼叫例如关注数据流和路由。此命令只用于测试ISDN电路至第3层,并且不可能使用通过流量或作为适当DDR配置的一替换法。此命令验证ISDN电路,特别是第3层,是否是工作。

图1显示呼叫流和某些debug isdn q931消息:

图1 -呼叫流和一些debug isdn q931消息

/image/gif/paws/22802/bri_loopback_call1.gif

maui-soho-04#isdn call interface bri 0 5551111

!--- The router dials 5551111 (the ISDN number of the router's own BRI).
!--- If the BRI circuit has two different phone numbers for each B-channel,
!--- use the number that belongs to the second B-channel.
!--- You can use this command to make calls at 56k, with the speed 56 option
.
maui-soho-04#
*Mar  1 17:55:08.344: ISDN BR0: TX ->  SETUP pd = 8  callref = 0x09

!--- Q931 Setup message is Transmitted (TX) to the telco switch.

*Mar  1 17:55:08.360:         Bearer Capability i = 0x8890
*Mar  1 17:55:08.360:         Channel ID i = 0x83
*Mar  1 17:55:08.364:         Keypad Facility i = '5551111'
*Mar  1 17:55:08.484: ISDN BR0: RX <-  CALL_PROC pd = 8  callref = 0x89

!--- Call Proceeding message is Received (RX) from the telco switch.
!--- The switch now processes the call.

*Mar  1 17:55:08.488:         Channel ID i = 0x89
*Mar  1 17:55:08.516: ISDN BR0: RX <-  SETUP pd = 8  callref = 0x12

!--- A Setup message is Received (RX) from the switch. This message is for the 
!--- incoming call. Remember that the router sent a Setup message (for the
!--- outgoing call) and now receives a SETUP message for the same call.

*Mar  1 17:55:08.516:         Bearer Capability i = 0x8890
*Mar  1 17:55:08.520:         Channel ID i = 0x8A
*Mar  1 17:55:08.520:         Signal i = 0x40 - Alerting on - pattern 0 
*Mar  1 17:55:08.532:         Called Party Number i = 0xC1, '5551111'
*Mar  1 17:55:08.532:         Locking Shift to Codeset 5
*Mar  1 17:55:08.532:         Codeset 5 IE 0x2A  i = 0x808001038001118001, '<'
*Mar  1 17:55:08.564: ISDN BR0: Event: Received a DATA call from  on B2 at 64 Kb/s
*Mar  1 17:55:08.620: %DIALER-6-BIND: Interface BRI0:2 bound to profile Dialer1
*Mar  1 17:55:08.652: ISDN BR0: TX ->  CALL_PROC pd = 8  callref = 0x92

! --- Transmit (TX) a Call Proceeding message for the incoming call.

*Mar  1 17:55:08.652:         Channel ID i = 0x8A
*Mar  1 17:55:08.700: %LINK-3-UPDOWN: Interface BRI0:2, changed state to up
*Mar  1 17:55:08.988: ISDN BR0: TX ->  CONNECT pd = 8  callref = 0x92

! --- Transmit (TX) a Connect message for the incoming call.

*Mar  1 17:55:08.988:         Channel ID i = 0x8A
*Mar  1 17:55:09.040: ISDN BR0: RX <-  CONNECT_ACK pd = 8  callref = 0x12

! --- Receive (RX) a Connect Acknowledgment for the incoming call.

*Mar  1 17:55:09.040:         Channel ID i = 0x8A
*Mar  1 17:55:09.040:         Signal i = 0x4F - Alerting off 
*Mar  1 17:55:09.064: ISDN BR0: RX <-  CONNECT pd = 8  callref = 0x89

! --- Receive (RX) a Connect message for the outgoing call.

*Mar  1 17:55:09.076: ISDN BR0: TX ->  CONNECT_ACK pd = 8  callref = 0x09
*Mar  1 17:55:09.080: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up
*Mar  1 17:55:09.104: %DIALER-6-BIND: Interface BRI0:1 bound to profile BRI0
*Mar  1 17:55:09.112: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 5551111 

! ---  Call is now connected. Loopback call is successful.

注意

  • 在环回呼叫期间,路由器执行作为呼叫的Router和呼叫路由器不同的B信道的。重要的是您记录这些“双重角色”,当您解释debug isdn q931输出时。例如,路由器太传送设置信息(TX- >设置)和接收一(RX < -设置)。当收到的SETUP消息关联与呼入呼叫时,必须关联已发送设置与呼出呼叫。

  • 在上述示例中,第一B信道的号码拨号。然而, telco认为第一B信道忙碌(因为做呼叫),并且交换呼叫到第二B信道,并且连接顺利地完成。然而,在电信公司交换机的一个不正确的配置能导致环回呼叫的失败。这能发生,当交换机尝试分配呼叫在忙碌进行呼叫)的第一个信道(。请求telco添加两B信道在寻找组中。然而,为此测验,我们能指定在isdn call interface命令的第二个B信道编号在此问题附近的目的工作。

  • 另一方面执行环回呼叫路由器。

  • 如果环回呼叫成功,并且对远程终端的呼叫继续发生故障,您能设法数据回环呼叫测试B信道数据完整性正如下一部分所描述。

关于如何排除故障所有问题的信息,参考这些文档:

执行数据回环呼叫

数据回环呼叫是有用的测试B信道是否能适当地传送数据。在许多情况下, debug ppp协商可以不断地发生故障。此测验可以用于检查在B信道的数据完整性。

注意: 此测验,不同于前次试验,介入对路由器的一个配置更改。

在数据回环呼叫,我们配置在路由器的两拨号接口。拨号接口在BRI线路配置用必要的编址、验证和DDR命令顺利地拨出,收到呼入呼叫,绑定对另一拨号接口和成功连接。

创建拨号配置文件拨号在同一路由器的另一拨号配置文件。

配置路由器

要配置环回呼叫的路由器,请完成这些步骤:

  1. copy running-config startup-config命令帮助下保存运行的配置。当您如此时,您能重新启动和恢复running-configuration到预告测验版本,在测验完成后。

  2. 配置物理接口。

    注意: 此部分假设,您知道必要的相关信息例如,交换类型和SPID。

    interface BRI0
     no ip address
     
    !--- Do not configure an IP address on the physical interface.
     !--- The IP address will be configured on the dialer. 
    
     encapsulation ppp
     !--- physical interface uses PPP encapsulation
     dialer pool-member 1
     
    !--- Assign BRI0 as member of dialer pool 1.
     !--- Dialer pool 1 is specified in interface Dialer 1, and 
     !--- interface Dialer 2.
    
     isdn switch-type basic-ni
     isdn spid1 71355511110101 5551111
     isdn spid2 71355511120101 5551112
     
    !--- switch-type and SPID configuration.
     !--- Contact the telco for this information. 
    
     ppp authentication chap callin   
     
    !--- The physical interface uses CHAP authentication.
     !--- Authentication is required on the physical interface to bind the 
     !--- incoming call to the right dialer profile.
    
    
  3. 配置第一拨号接口:

    interface Dialer1
     ip address 1.1.1.1 255.255.255.0
     
    !--- Assign an IP address to the dialer interface.
     !--- In this example, the IP addresses for both dialers
     !---  are in the same subnet.
    
     encapsulation ppp
     
    !--- The dialer interface uses PPP (same as the physical BRI interface).
    
     dialer pool 1
    
     !--- his defines Dialer pool 1. BRI 0 is a member of this pool.
    
     dialer remote-name dialer2
     
    !--- This name must match the name used by the other dialer interface to
     !--- authenticate itself. Dialer string 7135551112.
     !--- Phone number for the other B-channel.
     !--- If your connection only needs one number for both B-channels
     !--- (that is, they are in a hunt-group), use that number here.
    
     dialer-group 1
     
    !--- Apply interesting traffic definition from dialer-list 1.
    
     ppp authentication chap callin
    
     !--- Use one-way CHAP authentication. This is sufficient for this test.
    
     ppp chap hostname dialer1
    
     !--- CHAP hostname to be sent out for authentication.
    
     ppp chap password dialer1
    
     !--- CHAP Password to be sent out for authentication.
    
    
  4. 配置第二拨号接口:

    interface Dialer2
     ip address 1.1.1.2 255.255.255.0
    
     !--- Assign an IP address to the dialer interface.
     !--- In this example, IP address for both dialers are in the same subnet.
    
     encapsulation ppp
     dialer pool 1
    
     !--- This defines Dialer pool 1.
     !--- BRI 0 is a member of this pool.
    
     dialer remote-name dialer1
    
     !--- This name must match the name used by the other dialer interface 
     !--- (dialer1) to authenticate itself. Dialer string 7135551111.
     !--- Phone number for the other B-channel.
     !--- If your connection only has one number for both B-channels 
     !--- (that is, they are in a hunt-group), use that number here.
    
     dialer-group 1
    
     !--- Apply interesting traffic definition from dialer-list 1.
    
     ppp authentication chap callin
     ppp chap hostname dialer2
    
     !--- CHAP hostname to be sent out for authentication.
    
     ppp chap password dialer2
    
     !--- CHAP Password to be sent out for authentication.
    
    
  5. 配置用户名和密码验证的:

    username dialer1 password 0 dialer1
    username dialer2 password 0 dialer2
    

    用户名和密码是相同的象那些您在ppp chap hostnameppp chap password命令帮助下配置在每拨号接口下。

  6. 为了清晰配置静态路由:

    ip route 1.1.1.1 255.255.255.255 Dialer1
    
    !--- Note that the route for 1.1.1.1 points to dialer1.
    
    ip route 1.1.1.2 255.255.255.255 Dialer2
    
    !--- Note that the route for 1.1.1.2 points to dialer2.
    !--- The routes are used to determine which dialer interface is 
    !--- used for dialout.
    
    

    提示: 如果配置interface dialer 1的IP地址(步骤3)和interface dialer 2 (在独立子网的步骤4),静态路由不是必要的。

  7. 配置触发数据流定义。

    dialer-list 1 protocol ip permit

    注意: dialer-list编号必须是相同的象在拨号组配置的那个在拨号接口下。在此示例中,请配置 dialer-list 1

  8. 当测验完成时,请重新加载路由器(请勿保存配置)返回到在测验之前使用的原始配置。

发起数据回环呼叫

我们当前将发起数据回环呼叫,并且寻找PPP协商成功的完成。成功的PPP协商表明B信道能适当地传递数据。

图2 -发起数据回环呼叫

bri_loopback_call2.gif

激活这些调试:

注意: 当环回呼叫进展中时,路由器执行作为呼叫的Router和呼叫路由器不同的B信道的。重要的是您记录这些“双重角色”,当您解释debug isdn q931debug ppp协商命令的输出时。例如,路由器太传送设置信息(TX- >设置)和接收一(RX < -设置)。而收到的SETUP消息关联与呼入呼叫,必须关联已发送设置与呼出呼叫。

这是背对背ISDN呼叫的调试:

router#show debug
Dial on demand:
  Dial on demand events debugging is on
PPP:
  PPP protocol negotiation debugging is on
ISDN:
  ISDN Q931 packets debugging is on
  ISDN Q931 packets debug DSLs. (On/Off/No DSL:1/0/-)
  DSL  0 --> 1
  1 -

router#ping 1.1.1.1

!--- Because of the static route entry shown in step 6 above,
!--- the call is made out from dialer 1.


Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:

03:40:41: BR0 DDR: rotor dialout [priority]
03:40:41: BR0 DDR: Dialing cause ip (s=1.1.1.1, d=1.1.1.1)
03:40:41: BR0 DDR: Attempting to dial 7135551112
03:40:41: ISDN BR0: TX ->  SETUP pd = 8  callref = 0x08

!--- Outgoing SETUP message.

03:40:41:         Bearer Capability i = 0x8890
03:40:41:         Channel ID i = 0x83
03:40:41:         Keypad Facility i = '7135551112'
03:40:41: ISDN BR0: RX <-  CALL_PROC pd = 8  callref = 0x88
03:40:41:         Channel ID i = 0x89
03:40:41: ISDN BR0: RX <-  SETUP pd = 8  callref = 0x2A

!--- Incoming SETUP message on the other B-channel.

03:40:41:         Bearer Capability i = 0x8890
03:40:41:         Channel ID i = 0x8A
03:40:41:         Signal i = 0x40 - Alerting on - pattern 0
03:40:41:         Called Party Number i = 0xC1, '5551112', Plan:ISDN,
  Type:Subscriber(local)
03:40:41:         Locking Shift to Codeset 5
03:40:41:         Codeset 5 IE 0x2A  i = 0x808001038001118001, '<'
03:40:42: ISDN BR0: Event: Received a DATA call from  on B2 at 64 Kb/s

!--- Note that the call comes in on the second B-channel (BRI0:2).
!--- Hence the outgoing call must have been on BRI0:1.

03:40:42: ISDN BR0: Event: Accepting the call id 0xB
03:40:42: %LINK-3-UPDOWN: Interface BRI0:2, changed state to up.
03:40:42: BR0:2 PPP: Treating connection as a callin
03:40:42: BR0:2 PPP: Phase is ESTABLISHING, Passive Open [0 sess, 0 load]
03:40:42: BR0:2 LCP: State is Listen

!--- PPP LCP negotiations begin. 

03:40:42: ISDN BR0: TX ->  CALL_PROC pd = 8  callref = 0xAA
03:40:42:         Channel ID i = 0x8A
03:40:42: ISDN BR0: TX ->  CONNECT pd = 8  callref = 0xAA
03:40:42:         Channel ID i = 0x8A
03:40:42: ISDN BR0: RX <-  CONNECT_ACK pd = 8  callref = 0x2A
03:40:42:         Channel ID i = 0x8A
03:40:42:         Signal i = 0x4F - Alerting off
03:40:42: ISDN BR0: RX <-  CONNECT pd = 8  callref = 0x88
03:40:42: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up
03:40:42: BR0:1: interface must be fifo queue, force fifo
03:40:42: %DIALER-6-BIND: Interface BR0:1 bound to profile Di1
03:40:42: BR0:1 PPP: Treating connection as a callout
03:40:42: BR0:1 PPP: Phase is ESTABLISHING, Active Open [0 sess, 0 load]
03:40:42: BR0:1 PPP: No remote authentication for call-out

!--- One-way authentication (configured with PPP authentication CHAP callin).

03:40:42: BR0:1 LCP: O CONFREQ [Closed] id 11 len 10
03:40:42: BR0:1 LCP:    MagicNumber 0x513D7870 (0x0506513D7870)
03:40:42: ISDN BR0: TX ->  CONNECT_ACK pd = 8  callref = 0x08
03:40:42: BR0:2 LCP: I CONFREQ [Listen] id 11 Len 10
03:40:42: BR0:2 LCP:    MagicNumber 0x513D7870 (0x0506513D7870)
03:40:42: BR0:2 LCP: O CONFREQ [Listen] id 11 Len 15
03:40:42: BR0:2 LCP:    AuthProto CHAP (0x0305C22305)
03:40:42: BR0:2 LCP:    MagicNumber 0x513D7A45 (0x0506513D7A45)
03:40:42: BR0:2 LCP: O CONFACK [Listen] id 11 Len 10
03:40:42: BR0:2 LCP:    MagicNumber 0x513D7870 (0x0506513D7870)
03:40:42: BR0:1 LCP: I CONFREQ [REQsent] id 11 Len 15
03:40:42: BR0:1 LCP:    AuthProto CHAP (0x0305C22305)
03:40:42: BR0:1 LCP:    MagicNumber 0x513D7A45 (0x0506513D7A45)
03:40:42: BR0:1 LCP: O CONFACK [REQsent] id 11 Len 15
03:40:42: BR0:1 LCP:    AuthProto CHAP (0x0305C22305)
03:40:42: BR0:1 LCP:    MagicNumber 0x513D7A45 (0x0506513D7A45)
03:40:42: BR0:1 LCP: I CONFACK [ACKsent] id 11 Len 10
03:40:42: BR0:1 LCP:    MagicNumber 0x513D7870 (0x0506513D7870)
03:40:42: BR0:1 LCP: State is Open
03:40:42: BR0:1 PPP: Phase is AUTHENTICATING, by the peer [0 sess, 1 load]
03:40:43: BR0:2 LCP: I CONFACK [ACKsent] id 11 Len 15
03:40:43: BR0:2 LCP:    AuthProto CHAP (0x0305C22305)
03:40:43: BR0:2 LCP:    MagicNumber 0x513D7A45 (0x0506513D7A45)
03:40:43: BR0:2 LCP: State is Open
03:40:43: BR0:2 PPP: Phase is AUTHENTICATING, by this end [0 sess, 1 load]

!--- Authentication begins.

03:40:43: BR0:2 CHAP: O CHALLENGE id 7 Len 26 from "router"
03:40:43: BR0:1 CHAP: I CHALLENGE id 7 Len 26 from "router"
03:40:43: BR0:1 CHAP: Using alternate hostname dialer1

!--- Use the alternate hostname specified with PPP CHAP hostname 
!--- under int Dialer 1.

03:40:43: BR0:1 CHAP: Username router not found
03:40:43: BR0:1 CHAP: Using default password
03:40:43: BR0:1 CHAP: O RESPONSE id 7 Len 28 from "dialer1"

!--- Outgoing CHAP response sent on B-channel 1. 

03:40:43: BR0:2 CHAP: I RESPONSE id 7 Len 28 from "dialer1"

!--- Incoming CHAP response seen on B-channel 2.

03:40:43: BR0:2 CHAP: O SUCCESS id 7 Len 4

!--- Authentication is successful

03:40:43: BR0:2: interface must be fifo queue, force FIFO
03:40:43: %DIALER-6-BIND: Interface BR0:2 bound to profile Di2

!--- Call (from Dialer 1) is bound to int Dialer 2. 
!--- This is because the dialer remote-name dialer1 command is 
!--- configured under int dialer 2. Binding fails when the dialer remote-name 
!--- command is omitted, or is incorrect, .

03:40:43: BR0:2 PPP: Phase is UP [0 sess, 0 load]

!--- IPCP negotiation begins.

03:40:43: BR0:2 IPCP: O CONFREQ [Not negotiated] id 1 Len 10
03:40:43: BR0:2 IPCP:    Address 1.1.1.2 (0x030601010102)
03:40:43: BR0:2 CDPCP: O CONFREQ [Closed] id 1 Len 4
03:40:43: BR0:1 CHAP: I SUCCESS id 7 Len 4
03:40:43: BR0:1 PPP: Phase is UP [0 sess, 1 load]
03:40:43: BR0:1 IPCP: O CONFREQ [Not negotiated] id 1 Len 10
03:40:43: BR0:1 IPCP:    Address 1.1.1.1 (0x030601010101)
03:40:43: BR0:1 CDPCP: O CONFREQ [Closed] id 1 Len 4
03:40:43: BR0:1 IPCP: I CONFREQ [REQsent] id 1 Len 10
03:40:43: BR0:1 IPCP:    Address 1.1.1.2 (0x030601010102)
03:40:43: BR0:1 IPCP: O CONFACK [REQsent] id 1 Len 10
03:40:43: BR0:1 IPCP:    Address 1.1.1.2 (0x030601010102)
03:40:43: BR0:1 CDPCP: I CONFREQ [REQsent] id 1 Len 4
03:40:43: BR0:1 CDPCP: O CONFACK [REQsent] id 1 Len 4
03:40:43: BR0:2 IPCP: I CONFREQ [REQsent] id 1 Len 10
03:40:43: BR0:2 IPCP:    Address 1.1.1.1 (0x030601010101)
03:40:43: BR0:2 IPCP: O CONFACK [REQsent] id 1 Len 10
03:40:43: BR0:2 IPCP:    Address 1.1.1.1 (0x030601010101)
03:40:43: BR0:2 CDPCP: I CONFREQ [REQsent] id 1 Len 4
03:40:43: BR0:2 CDPCP: O CONFACK [REQsent] id 1 Len 4
03:40:43: BR0:2 IPCP: I CONFACK [ACKsent] id 1 Len 10
03:40:43: BR0:2 IPCP:    Address 1.1.1.2 (0x030601010102)
03:40:43: BR0:2 IPCP: State is Open

!--- IPCP on B-channel 2 is Open.

03:40:43: BR0:1 IPCP: I CONFACK [ACKsent] id 1 Len 10
03:40:43: BR0:1 IPCP:    Address 1.1.1.1 (0x030601010101)
03:40:43: BR0:1 IPCP: State is Open

!--- IPCP on B-channel 1 is Open.

03:40:43: BR0:2 DDR: dialer protocol up
03:40:43: BR0:1 DDR: dialer protocol up
03:40:43: Di2 IPCP: Install route to 1.1.1.1
03:40:43: Di1 IPCP: Install route to 1.1.1.2
03:40:44: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:2, 
changed state to up
03:40:44: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, 
changed state to up

!--- Both B-channels are up.

...
Success rate is 0 percent (0/5)
router#

注意: ping可以发生故障由于与路由涉及的问题。您能期待此。成功的PPP协商是真正测试B信道是否能适当地传递在链路的数据。如果呼叫发生故障,欲知关于如何排除故障线路的详情,请与电话公司联系。


相关信息


Document ID: 22802