广域网 : 帧中继

分布式流量整形配置示例

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

本文讨论分布式流量整形并且统一是可用的今天的许多信息。

流量整形(TS)提供一机制控制在特定接口的通信流。“分配了” TS是功能特定到高端平台例如Cisco 7500或12000系列互联网路由器。这些平台有能力卸载从主处理器(路由交换机处理器的流量整形- RSP或千兆路由处理器- GRP)到单个接口处理器(通用接口处理器- VIP或线卡- LC)。在Distributed Cisco Express Forwarding (DCEF)是交换首选的模式的网络中,在VIP的DTS或线卡是流量整形的合理的选择。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档不限于特定的软件和硬件版本。

为什么与DTS的形状流量?

如果读本文,则,很可能,您已经有想法您为什么要整形流量。分布式难题应该是俏丽的清楚,太-您分配主处理器的责任到各自的卡处理器。关于shaping,许多客户尝试避免超出根据与供应商的协议的电路的承诺速率。这防止在网云的丢包,并且,结果,减少重新传输(与TCP/IP),当供应商丢弃数据包时。您需要整形流量的常见情况下面表示。在本例中,如果分支机构只有一个128K电路,没有需要对于中心站点转发流量以T1速率:

dts-config-01.gif

有许多另外的原因为使用DTS。好处包括各种各样的相关服务质量(QoS)功能和驱动一样高效地使用带宽尽可能在各种各样的流量类型间。DTS配置流量整形在级接口级、的子接口或者ATM或帧中继永久虚拟电路的(PVC)逻辑接口接口级别。

Shaping在以下标准达到网络目标,并且能锁上:

  • 在物理或逻辑接口的所有流量

  • 通过简单和扩展IP访问控制分类的流量列出(ACL) (IP地址、TCP/UDP端口, IP优先级)

  • Qos类别分类的流量(由承诺访问速率的一内部信息包标签已应用上行- CAR或者Qos策略传播- QPPB)

DTS支持每个VIP 200个形状队列,支持至OC-3速率,当平均信息包大小是250个字节或更加极大时和,当使用VIP2-50或请改善与8M静态RAM (SRAM)时。不同于正常数据流shaping (GTS), DTS不要求该加权公平排队(WFQ)启用。反而, DTS使用公平排队或分布式先入先出(FIFO)整形过的队列。

平台特定

此表描述如何根据平台配置TS -主要说明功能为高端平台是重大的:

  12000系列 7500系列 7200, 3600, 2600和其他非VIP平台
支持的整形机制 DTS DTS GTS或帧中继TS
配置命令 shape命令在策略映射 shape命令在策略映射 流量速率帧中继的流量整在主接口和与FRTS -映射组配置命令指定整形参数
要求Distributed Cisco Express Forwarding (DCEF) 默认是CEF 是(请用show cef linecard命令验证)

7500系列DTS笔记

在Cisco 7500系列,能力配置帧中继流量整形(FRTS)使用frame-relay traffic-shaping命令当前阻塞,因为在RSP的FRTS执行在一个非分布式的模式。使用dCEF和FRTS, CEF “平底船”邻接造成所有信息包是快速交换式由RSP,为最大转发性能是不理想的。

自Cisco IOS�软件版本12.1(5)T, QoS策略在VIP的分布式模式必须运行;路由/交换处理器(RSP) -不再支持基于QoS。所以,您必须使用模块化QoS命令行界面(MQC)的shape命令和其他命令实现接口的DTS在Cisco 7500系列的VIP。

当Cisco IOS软件版本12.1(2)T介绍低延迟队列的(LLQ)时支持除Cisco 7500系列之外,在平台,分布式LLQ (dLLQ)在VIP的12.1(5)T介绍。分布式版本提高此功能性能。您能配置同一个服务服务策略每数据链路连接标识符(DLCI)。您不需要使用映射类别,并且能实施service-policy命令直接地到子接口或DLCI。然而,思科建议您配置dLLQ在映射类别里面。

当应用分布式FRF.12 (分段)时对帧中继接口,您必须定义映射类别和运用服务策略在映射类别下。FRF.12在Cisco IOS软件版本12.0(4)T介绍和对Cisco 805, 1600个, 1700个, 2500个, 4500个和4700个路由器平台被扩展和从Cisco IOS软件版本12 1(2)T。关于其他详细信息,在另外的平台的参考的FRF.12支持

12000系列互联网路由器DTS笔记

在12000系列,快速交换和进程交换不是选项。如果目的地前缀在入站线路卡的(LC)表里不可能被解决到一个转发条目,数据包丢弃。匹配收集邻接的仅数据包被踢对千兆路由处理器(GRP)。另外,在12000, LC CPU不会踢数据包对功能的GRP,并且LC发送互联网控制消息协议(ICMP)不可达的(只要no ip unreachables命令没有配置)。在12000,唯一的流量被踢对GRP是从路由器发出的数据包被注定对在路由器的一个接口或数据包。欲知更多信息,参考什么服务质量(QoS)以为特色为12000系列互联网路由器是可用的?

配置

请使用前两个步骤配置在基于VIP的帧中继接口的DTS (7500系列) :

  1. 请使用此命令为了启用dCEF :

    router(config)#ip cef distributed
    
  2. 保证帧中继接口为分布式交换启用:

    router(config-if)#interface serial 2/0/0
    router(config-if)#ip route-cache distributed
    router#show ip interface serial 2/0/0
    Serial8/0/0 is up, line protocol is up
      Internet address is 64.0.0.2/24
      Broadcast address is 255.255.255.255
      ICMP redirects are always sent
      ICMP unreachables are always sent
      ICMP mask replies are never sent
      IP fast switching is enabled
      IP fast switching on the same interface is disabled
      IP Flow switching is disabled
      IP CEF switching is enabled
      IP Distributed switching is enabled
      IP Fast switching turbo vector
      IP CEF switching with tag imposition turbo vector
      IP multicast fast switching is enabled
      IP multicast distributed fast switching is disabled
      IP route-cache flags are Fast, Distributed, CEF
      Router Discovery is disabled
      IP output packet accounting is disabled
  3. 创建数据流类别。(必需)

  4. 配置DTS数据流策略。(必需)

  5. 附加数据流策略并且启用DTS。(必需)

  6. 监控并且维护DTS。(可选)

注意: 使用命令查找工具仅限注册用户)可了解有关本文档所使用命令的详细信息。

创建数据流类别

对启用所有功能的第一步使用模块化QoS CLI将创建数据流类别。

Router(config)#class MAP [match-any|全部匹配] class-name —指定名称,并且任一或所有标准是否将构成匹配。

关于模块化QoS CLI和方法的信息创建的数据流类别,参考模块化服务质量命令行接口概述

配置DTS数据流策略

您必须配置数据流策略为了启用DTS。您能配置许多类的数据流策略和在路由器定义至最多256。

配置数据流策略,使用policy-map命令开始处在全局配置模式指定数据流策略名称,然后使用形状配置命令为了配置数据流类别分类名和流量整形。

  1. Router(config)#policy MAP策略名—指定将创建的数据流策略的名称。

  2. 路由器(设置pmap) #class class-name —指定在数据流策略包括的一预定义的数据流类别的名称。类在此进程上一步定义。

  3. 路由器(config-pmap-c) #shape {平均值|高峰} cir [bc] [be] —指定平均值或峰值速率流量整形。

流量被处理对数据流策略默认组,如果不满足策略在数据流策略定义任何其他类的匹配标准。

附加数据流策略并且启用DTS

请使用此in命令接口(或映射类别)配置模式为了附加数据流策略到接口、子接口或者映射类别和为了启用在接口的DTS :

  • 路由器(config-if) #service策略输出了策略名— Enable (event) DTS并且附加指定的数据流策略对接口或映射类别。

注意: 和FRF.12严格推荐dLLQ的应用程序有服务策略应用对帧中继映射种类。

参考与分布式QOS的帧中继流量整形在Cisco 7500系列关于分段的更多信息。

监控并且维护DTS

请使用这些in命令EXEC模式为了监控和维护DTS功能:

  • Router- show interface [interface-name]形状—显示流量整形的详细信息状况。

  • Router- show policy策略名—显示撰写指定的数据流策略的所有类的配置。

  • Router- show policy策略名class-name —显示指定的数据流策略的指定类的配置。

关于QoS监控命令的更多信息,在show policy-map interface输出中参考了解信息包计数器

示例配置

在主接口的DTS

在本例中,在接口pos1/0/0出去的流量被整形以速率10Mbits/sec。

router(config)#class-map class-interface-all

router(config-cmap)#match any

router(config-cmap)#exit

router(config)#policy-map DTS-interface-all-action
router(config-pmap)#class class-interface-all

router(config-pmap-c)#shape average 10000000 
router(config-pmap-c)#exit

router(config)#interface pos1/0/0

router(config-if)#service-policy output DTS-interface-all-action

在主接口的基于类的DTS

在本例中,两类创建,并且匹配标准根据访问列表编号定义。在接口fd4/0/0出去并且匹配在访问列表10的标准的流量被整形对16Mbps。匹配在访问列表20的标准的流量被整形对8 Mbps。

router(config)#access-list 10 permit 171.69.0.0

router(config)#access-list 20 permit 192.168.0.0

router(config)#class-map class1

router(config-cmap)#match access-group 10

router(config-cmap)#exit

router(config)#class-map class2

router(config-cmap)#match access-group 20

router(config-cmap)#exit

router(config)#policy-map DTS-interface-class-action
router(config-pmap)#class class1

router(config-pmap-c)#shape average 16000000

router(config-pmap-c)#exit

router(config-pmap)#class class2

router(config-pmap-c)#shape average 8000000

router(config-pmap-c)#exit

router(config-pmap)#interface fd4/0/0

router(config-if)#service-policy output DTS-interface-class-action

注意: IP地址在此配置方面是仅示例。

对于更多的配置示例,参考配置分布式流量整形

验证

当前没有可用于此配置的验证过程。

故障排除

配置的一个VIP接口与帧中继封装也许失败与总线错误,如果运用服务策略,当接口通过流量时。此问题被解决以多种版本Cisco IOS软件(Cisco Bug ID CSCdt88568)。关于此的更多信息ddts和其他Bug,参考


相关信息


Document ID: 22600