宽带电缆 : 有线电缆数据服务接口规范 (DOCSIS)

使用在DOCSIS和CMTS的max-cpe命令

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

本文解释在有线电缆数据服务接口规范(DOCSIS)配置文件和MAX-CPE参数之间的关系指定的new cable modem max-cpe n命令。DOCSIS配置文件在运行Cisco IOSï ¿  ½软件版本12.1(2)EC1或以上的UBR7200系列路由器装载到有线调制解调器,并且可以被编码。

开始使用前

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

先决条件

Cisco 建议您了解以下主题:

  • 本文档中的信息根据Cisco硬件uBR7246 (NPE150)处理器(版本B)和Cisco IOS软件(UBR7200-IST-M),版本12.1(2)EC1。

  • 本文是指在仅桥接模式的电缆调制解调器。

使用的组件

本文档不限于特定的软件和硬件版本。

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

背景信息

有从有线客户的需求有线调制解调器终端系统(CMTS)的能允许更多CPE连接到有线调制解调器,竟管在电缆调制解调器配置文件的值限制主机数量。允许更多CPE的更改连接到有线调制解调器介绍与CSCdp52029 (仅限注册用户)在Cisco IOS软件Release12.0(9.5)SC,并且Cisco IOS软件版本12.1(1.0.3)ec1 IOS培训。

此需求创建的归结于无法的有线调制解调器保留分配的计数CPE在与CMTS计数的同步。当有线调制解调器初始化,当能与CMTS同步MAX-CPE是之时,当发送MAX-CPE计数对在注册请求流的CMTS。

如果有线调制解调器重新加载,没有对通知它的CMTS的流使CPE的分配的计数降低到零。有线调制解调器,然而,从零再将开始。如果在有线调制解调器请求的新的CPE来后联机,有线调制解调器将允许它对,因为其MAX-CPE计数当前零。与非零的MAX-CPE计数的CMTS,然而,将发生故障请求,并且下列信息出现在CMTS :

 
%UBR7200-5-MAXHOST: New host with IP address x.x.x.x 
 and MAC yyyy.yyyy.yyyy on SID 3 (CM zzzz.zzzz.zzzz) is ignored.

这由事实增强,如果未指定,在DOCSIS配置文件的默认MAX-CPE条目设置到一个。

此的示例是,当有线调制解调器通知CMTS时有MAX-CPE计数一个在其注册请求。有线客户希望重新通电的功能有线调制解调器允许他们的将删除的安装程序的笔记本电脑和在有线调制解调器的最终用户的PC放置的上一步。这将发生故障,因为。在重新加载有线调制解调器将有MAX-CPE计数调整到零,然而后, CMTS将记住安装程序的笔记本电脑条目,并且等于MAX-CPE计数一个。

有应急方案联机通过发出clear cable host x.x.x.x命令,其中x.x.x.x等于在CMTS将清除的主机的IP或MAC地址。此应急方案,然而,是不得人心的对有线客户。

实施

一个新的配置命令被添加了到CMTS。要指定允许的主机最大每个调制解调器(覆盖在有线调制解调器配置文件的MAX-CPE值),请发出cable modem max-cpe n命令在电缆接口配置模式。n等于1到255。

CMTS启用至主机n编号有线调制解调器的。当对无限个或者n的集大于在有线调制解调器的配置文件的时MAX-CPE值,此命令改写配置文件值。DHCP服务器控制IP地址数量分配到主机在单个有线调制解调器背后。

如果有线调制解调器的配置文件大于n指定一定数量的主机,配置文件设置将获得优先权。它是至控制激活主机数量的有线调制解调器。

通过发出cable modem max-cpe unlimited命令, CMTS不会强制执行在CPE数量的一限制连接对单个有线调制解调器。使用此设置,它是至控制CPE的最大的有线调制解调器和至DHCP服务器控制IP地址数量分配到CPE在单个有线调制解调器背后。

警告 警告: 使用cable modem max-cpe unlimited命令,若被采用没有小心,可能通过启用拒绝服务攻击打开系统的一个安全漏洞。特别地,在所有可用的IP地址由此单个用户后,保留它可能使用户获取很大数量的IP地址,从而中断整个网络。推荐因此,如果cable modem max-cpe unlimited命令启用, IP地址数量分配到CPE在单个有线调制解调器背后是严格由DHCP服务器控制的。

通过发出no cable modem max-cpe命令,默认设置启用。在配置文件提供的MAX-CPE值将由CMTS用于对单个有线调制解调器限制连接的CPE数量。

cable modem max-cpe n发出时,若可能show cable modem detail命令显示MAX-CPE值如有线调制解调器的DOCSIS配置文件所配置的一样,和,配置的值。

参考下面示例日志输出。CMTS为MAX-CPE对无限个的等于到四和MAX-CPE等于配置。

test-cmts#show cable modem detail 
Interface ...... SID MAC address .... Max CPE Concatenation Rx SNR
Cable4/0/U0 1 .... 0001.9659.47bb 1 ............. yes ................ 37.37
Cable4/0/U0 2 .... 0001.9659.47ab 1 ............. yes ................ 33.70
Cable4/0/U0 3 .... 0001.9659.47bf .1 ............. yes ................ 30.67
Cable4/0/U0 4 .... 0001.9659.3ef7 .1 ............. yes ................ 28.84
Cable4/0/U0 5 .... 0001.9659.47eb 1 ............. yes ................ 30.89

test-cmts#conf t
Enter configuration commands, one per line. End with CNTL/Z.
test-cmts(config)#cable modem max-cpe ?
<1-255> Number
unlimited Max CPE not enforced

test-cmts(config)#cable modem max-cpe 4
test-cmts(config)#end
test-cmts#
00:05:11: %SYS-5-CONFIG_I: Configured from console by console


test-cmts#show cable modem detail
Interface ...... SID MAC address .... Max CPE Concatenation Rx SNR
Cable4/0/U0 1 .... 0001.9659.47bb 1 (4) .........yes ................37.00
Cable4/0/U0 2 .... 0001.9659.47ab 1 (4) ........ yes ................33.54
Cable4/0/U0 3 .... 0001.9659.47bf .1 (4) ........ yes ................30.70
Cable4/0/U0 4 .... 0001.9659.3ef7 .1 (4) ........ yes ................ 29.00
Cable4/0/U0 5 .... 0001.9659.47eb 1 (4) ........ yes ................ 30.92

test-cmts#conf t
Enter configuration commands, one per line. End with CNTL/Z.
test-cmts(config)#cable modem max
test-cmts(config)#cable modem max-cpe ?
<1-255> Number
unlimited Max CPE not enforced

test-cmts(config)#cable modem max-cpe unli
test-cmts(config)#cable modem max-cpe unlimited 
test-cmts(config)#^Z 
test-cmts#
00:06:06: %SYS-5-CONFIG_I: Configured from console by console


test-cmts#show cable modem detail
Interface ...... SID MAC address .... Max CPE Concatenation Rx SNR
Cable4/0/U0 1 .... 0001.9659.47bb 1 (ul) .........yes ............... 36.64
Cable4/0/U0 2 .... 0001.9659.47ab 1 (ul) ........ yes ............... 33.26
Cable4/0/U0 3 .... 0001.9659.47bf. 1 (ul) ....... .yes ............... 30.73
Cable4/0/U0 4 .... 0001.9659.3ef7 .1 (ul) ...... . yes ............... 29.15
Cable4/0/U0 5 .... 0001.9659.47eb 1 (ul) ...... . yes ............... 30.95

test-cmts#wr t
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname test-cmts
!
boot system flash ubr7200-ist-mz.121-2.EC1
no logging buffered
!
cable modem max-cpe 4
ip subnet-zero 
!
interface FastEthernet0/0
ip address 10.200.68.4 255.255.255.0
half-duplex
!
interface Cable4/0
ip address 10.200.69.49 255.255.255.240 secondary
ip address 10.200.69.33 255.255.255.240
ip accounting precedence input
ip accounting precedence output
no keepalive
cable max-hosts 10
cable downstream annex B
cable downstream modulation 64qam
cable downstream interleave-depth 32
cable upstream 0 frequency 20000000
cable upstream 0 power-level 0
cable upstream 0 rate-limit
no cable upstream 0 shutdown
cable upstream 1 shutdown
cable upstream 2 shutdown
cable upstream 3 shutdown
cable upstream 4 shutdown
cable upstream 5 frequency 20000000
cable upstream 5 power-level 0
cable upstream 5 rate-limit
cable upstream 5 shutdown
cable dhcp-giaddr policycable
helper-addrress 10.200.68.11
! 
router rip
network 10.0.0.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.200.68.1
ip route 10.200.32.0 255.255.224.0 10.200.68.2
no ip http server
!
line con 0
exec-timeout 0 0
password ww
login
transport input none
line aux 0
line vty 0 4
password ww
login
!
end

test-cmts#

注意: 虽然CMTS,允许主机的指定的编号到电缆调制解调器,电缆调制解调器将限制允许在DOCSIS配置文件允许的CPE仅数量。


相关信息


Document ID: 22177