????????? : 思科内容交换模块

在内容交换模块上配置透明缓存

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 23 日) | 反馈


目录


简介

本文描述如何配置Content交换机模块(CSM)透明缓存的,与思科内容引擎作为缓存。透明缓存坐在用户和服务器之间。CSM介绍在用户和缓存之间。CSM是智能由于其第五层能力动态地分析内容和确定是否可缓存的。这些指南应用:

  • 如果可缓存的, CSM负载平衡请求对根据已配置的预报器的缓冲存储器服务。

  • 如果不可缓存的, CSM发送它直接地到源服务器。这避免发生的性能影响,当不可缓存的对象去到缓存,只有安排其请求重定向由缓存对源服务器。

有几均衡方式联机,取决于您如何要分配在缓存的数据(例如,全部的URL, URL字串,等等)。

CSM可以配置与文件扩展列表发送到缓存。此列表呼叫扩展合格者列表(EQL)。一旦配置slb策略CACHE-POLICY透明的vserver下,只有与在地图可缓存URL列表列出的文件扩展的请求发送缓存。如果文件扩展在地图可缓存URL列表没有列出,则请求将点击SlB策略非缓存策略

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • Catalyst 6000 Supervisor管理引擎1的Cisco IOS�软件版本12.1(8)EX有MSFC1的(c6sup11-dsv-mz.121-8a.EX)

  • Catalyst 6000 CSM软件版本2.1(2) (c6slb-apc.2-1-2.bin)

  • Cisco内容引擎565运行的思科应用和内容网络系统(ACNS)软件版本5.1.3

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

配置

在此部分,您可以看到本文所描述功能的配置相关的信息。

网络图

本文档使用以下网络设置:

在CSM的透明缓存

config_transp_caching_19680.gif

配置

本文档使用以下配置:

CSM
Building configuration...
Current configuration : 4500 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname cat
!
boot buffersize 126968
enable password cisco
!
redundancy
 main-cpu
  auto-sync standard
ip subnet-zero
!
ip name-server 10.107.241.185
!

!--- CSM located in slot 3. Module is running as active
!--- cache and client side on the same CSM VLAN 100.

module ContentSwitchingModule 3
 vlan 100 client
  ip address 10.107.249.251 255.255.255.248
  gateway 10.107.249.249
!

!--- End user located in CSM VLAN 200.

 vlan 200 server
  ip address 10.107.249.251 255.255.255.248
!

!--- Probe setup to check the availability of the Content
!--- Engine default probe values. Interval is 300 seconds.

 probe CACHEPROBE tcp
!

!--- Serverfarm CACHE.
!--- Note: Issue the no nat server command.
!--- CSM needs to do a Layer 2 rewrite.
!--- Balancing predictor is hash URL.

 serverfarm CACHE
  no nat server
  no nat client
  predictor hash url
  real 10.107.249.254
   inservice
  real 10.107.249.252
   inservice
  probe CACHEPROBE
!

!--- Serverfarm OUTBOUND.
!--- Note: Use the serverfarm OUTBOUND to bypass the cache.
!--- Requests that do not match the map CACHEABLE url list
!--- will use serverfarm OUTBOUND. The NAT server has no
!--- effect, as no reals are configured.
!--- Balancing predictor forward.

 serverfarm OUTBOUND
  nat server
  no nat client
  predictor forward
!

!--- Map CACHEABLE URL.

 map CACHEABLE url

!--- Extension Qualifier List (EQL).

  match protocol http url *.pdf
  match protocol http url *.fdf
  match protocol http url *.au
  match protocol http url *.bmp
  match protocol http url *.z
  match protocol http url *.gif
  match protocol http url *.html
  match protocol http url *.js
  match protocol http url *.mocha
  match protocol http url *.jpeg
  match protocol http url *.jpg
  match protocol http url *.jpe
  match protocol http url *.jfif
  match protocol http url *.pjpeg
  match protocol http url *.pjp
  match protocol http url *.mp2
  match protocol http url *.mpa
  match protocol http url *.abs
  match protocol http url *.mpeg
  match protocol http url *.mpg
  match protocol http url *.mpe
  match protocol http url *.mpv
  match protocol http url *.vbs
  match protocol http url *.m1v
  match protocol http url *.pcx
  match protocol http url *.txt
  match protocol http url *.text
  match protocol http url *.mov
  match protocol http url *.tiff
  match protocol http url *.tar
  match protocol http url *.avi
  match protocol http url *.wav
  match protocol http url *.gz
  match protocol http url *.zip
!
 map NONCACHABLE url
  match protocol http url *
!
 policy CACHE-POLICY
  url-map CACHEABLE
  serverfarm CACHE
!
 policy NONCACHE-POLICY
  url-map NONCACHABLE
  serverfarm OUTBOUND
!

!--- Vserver TRANSPARENT.
!--- Note: Virtual IP is all zeros.
!--- Use of persistence rebalance for HTTP 1.1.
!--- Parse-lengh set to 2000 bytes.
!--- Two policies added to vserver TRANSPARENT.

 vserver TRANSPARENT
  virtual 0.0.0.0 0.0.0.0 tcp www
  serverfarm CACHE
  persistent rebalance
  parse-length 2000
  slb-policy CACHE-POLICY
  slb-policy NONCACHE-POLICY
  inservice
!

!--- Fault Tolerance group 1.
!--- Used to configure redundancy between modules 3 and 4.

 ft group 1 vlan 250
  priority 20
!

!--- CSM located in slot 4. Module is running as standby
!--- cache and client side on the same CSM VLAN 100.

module ContentSwitchingModule 4
 vlan 100 client
  ip address 10.107.249.253 255.255.255.248
  gateway 10.107.249.249
!

!--- End user located in CSM VLAN 200.
!--- Note: Module 3 and 4 VLAN IP addresses are different.

 vlan 200 server 
  ip address 10.107.249.253 255.255.255.248
!

!--- Probe setup to check availability of Content Engine.
!--- Default probe values. Interval 300 seconds.

!
 probe CACHEPROBE tcp
!

!--- Serverfarm CACHE.
!--- Note: Issue the no nat server command. CSM needs to
!--- do a Layer 2 rewrite.
!--- Balancing predictor is hash URL.

 serverfarm CACHE
  no nat server
  no nat client
  predictor hash url
  real 10.107.249.254
   inservice
  real 10.107.249.252
   inservice
  probe CACHEPROBE
!

!--- Serverfarm OUTBOUND
!--- Note: Use the serverfarm OUTBOUND to bypass the cache.
!--- Requests that do not match the CACHEABLE URL list will
!--- use serverfarm OUTBOUND. The NAT server has no effect,
!--- as no reals are configured.
!--- Balancing predictor forward.

 serverfarm OUTBOUND
  nat server
  no nat client
  predictor forward
!

!--- Map CACHEABLE URL.

 map CACHEABLE url

!--- Extension Qualifier List (EQL).

  match protocol http url *.pdf
  match protocol http url *.fdf
  match protocol http url *.au
  match protocol http url *.bmp
  match protocol http url *.z
  match protocol http url *.gif
  match protocol http url *.html
  match protocol http url *.js
  match protocol http url *.mocha
  match protocol http url *.jpeg
  match protocol http url *.jpg
  match protocol http url *.jpe
  match protocol http url *.jfif
  match protocol http url *.pjpeg
  match protocol http url *.pjp
  match protocol http url *.mp2
  match protocol http url *.mpa
  match protocol http url *.abs
  match protocol http url *.mpeg
  match protocol http url *.mpg
  match protocol http url *.mpe
  match protocol http url *.mpv
  match protocol http url *.vbs
  match protocol http url *.m1v
  match protocol http url *.pcx
  match protocol http url *.txt
  match protocol http url *.text
  match protocol http url *.mov
  match protocol http url *.tiff
  match protocol http url *.tar
  match protocol http url *.avi
  match protocol http url *.wav
  match protocol http url *.gz
  match protocol http url *.zip
!
 map NONCACHABLE url
  match protocol http url *
!
 policy CACHE-POLICY
  url-map CACHEABLE
  serverfarm CACHE
!
 policy NONCACHE-POLICY
  url-map NONCACHABLE
  serverfarm OUTBOUND
!

!--- Vserver TRANSPARENT.
!--- Note: Virtual IP is all zeros.
!--- Use of persistence rebalance for HTTP 1.1.
!--- Parse-lengh set to 2000 bytes.
!--- Two policies added to vserver TRANSPARENT.

 vserver TRANSPARENT
  virtual 0.0.0.0 0.0.0.0 tcp www
  serverfarm CACHE
  persistent rebalance
  parse-length 2000
  slb-policy CACHE-POLICY
  slb-policy NONCACHE-POLICY
  inservice
!

!--- Fault Tolerance group 1.
!--- Used to configure redundancy between modules 3 and 4.

 ft group 1 vlan 250
!
interface GigabitEthernet1/1
 no ip address
 shutdown
!
interface GigabitEthernet1/2
 no ip address
 shutdown
!

!--- CSM client side VLAN. Uplink to the Internet.

interface FastEthernet2/1
 no ip address
 switchport
 switchport access vlan 100
!
interface FastEthernet2/2
 no ip address
 shutdown
!

!--- Cache Engine connected to FE2/3 and FE2/4.
!--- CSM client side VLAN.

interface FastEthernet2/3
 no ip address
 duplex full
 speed 100
 switchport
 switchport access vlan 100
!
interface FastEthernet2/4
 no ip address
 duplex full
 speed 100
 switchport
 switchport access vlan 100
!

!--- CSM Server side VLAN. Connection to end users.

interface FastEthernet2/5
 no ip address
 switchport
 switchport access vlan 200
!

!--- MSFC VLAN 100. Content Engine and client uses this
!--- address as the default gateway.

interface Vlan100
 ip address 10.107.249.250 255.255.255.248
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.107.249.249
no ip http server
!
line con 0
line vty 0 4
password cisco
login
!
end

内容引擎
device mode content-engine
!
hostname ce1
!
http proxy incoming 80

!--- Accept proxy requests on port 80.

!
http l4-switch enable


!--- Instructs the Content Engine to accept traffic that is
!--- directed to any destination IP.

!
ip domain-name cisco.com
!
!
interface Fastethernet 0/0
 ip address 10.107.249.254 255.255.255.248
 exit
!
interface Fastethernet 0/1
 exit
!
ip default-gateway 10.107.249.250
!
primary-interface Fastethernet 0/0
!
!
no auto-register enable
!
ip name-server 10.107.241.185
!
!
username admin password 1 bVmDmMMmZAPjY
username admin privilege 15
!
authentication login local enable primary
authentication configuration local enable primary
!
! End of ACNS configuration

验证

此部分提供您能使用的,用以确认您的配置正常工作的信息。

命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

注意: 在发出 debug 命令之前,请参阅有关 debug 命令的重要信息

CSM Debug与Show调试指令

  • show module

  • show arp —提供服务器负载均衡(SLB)地址解析服务(ARP)缓存列表。

  • show conns —提供SLB连接信息。

  • show dfp —提供SLB动态反馈协议(DFP)管理器信息。

  • show ft —提供SLB容错(FT)信息。

    cat# show module csm 3 ft
    
    FT group 1, vlan 250
    This box is active
    priority 20, heartbeat 1, failover 3, preemption is off
    
    cat# show module csm 4 ft
    
    FT group 1, vlan 250
    This box is in standby state
    priority 10, heartbeat 1, failover 3, preemption is off
  • show map —提供SLB映射信息。

  • show memory —提供SLB内存信息。

  • show natpools —提供SLB客户端NAT池信息。

  • show policy —提供SLB策略信息。

  • show probe —提供SLB探测器信息。

  • show reals —提供SLB真实服务器信息。

  • show serverfarms —提供SLB服务器区域信息。

  • show static —提供SLB静态服务器NAT信息。

  • show stats —提供SLB统计信息。

  • show status —提供SLB状态信息。

  • show sticky —提供SLB粘性数据库。

  • show tech-support —提供SLB技术调试信息。

  • show VLAN —提供SLB VLAN信息。

  • show vservers —提供SLB虚拟服务器信息。

    show module csm 3 vservers name transparent detail
    
    TRANSPARENT, state = OPERATIONAL, v_index = 10
      virtual = 0.0.0.0/0:80, TCP, service = NONE, advertise = FALSE
      idle = 3600, replicate csrp = none, vlan = ALL
      max parse len = 2000, persist rebalance = TRUE
      conns = 0, total conns = 47
      Default policy:
        server farm = CACHE
        sticky: timer = 0, subnet = 0.0.0.0, group id = 0
      Policy           Tot Conn     Client pkts  Server pkts
      ------------------------------------------------------
      CACHE-POLICY     44           249          203
      NONCACHE-POLICY  37           111          37
      (default)        0            0            0
  • 模块csm ?—配置透明缓存的CSM。并且指定您配置CSM的位置。

    cat(config)# module csm ?
    
    <1-6>  slot where the CSM module resides
  • vserver proxy —配置虚拟服务器。

    cat(config-module-csm)# vserver proxy
    
    cat(config-slb-vserver)# ?
    
  • vserver advertise —通告虚拟IP地址。

  • vserver client —设置客户端IP地址。

  • vserver default —设置命令为其默认。

  • vserver exit —退出服务器负载均衡从属方式。

  • vserver idle —设置空闲计时器。

  • vserver inservice — Enable (event)为此虚拟服务器服务。

  • no vserver —否定一命令或设置其默认。

  • vserver parse-length —设置最大第七层解析长度。

  • vserver persistent — Enable (event)或功能失效连接持续时间。

  • vserver replicate —设置vserver容错复制。

  • vserver serverfarm —设置真实服务器组群。

  • vserver slb-policy —设置服务器负载均衡策略。

  • vserver sticky —设置粘性计时器。

  • vserver url-hash —集加前缀/散列的后缀匹配。

  • vserver virtual —配置虚拟服务器。

  • serverfarm cache —配置服务器站。

    cat(config-module-csm)# serverfarm cache
    
    cat(config-slb-sfarm)# ?
    
  • serverfarm bindid — DFP的捆绑ID。

  • serverfarm default —设置命令为其默认。

  • serverfarm exit —退出SLB服务器站从属方式。

  • serverfarm failaction —操作承担真正的服务器故障。

  • serverfarm nat —设置SLB的地址转换。

  • 没有serverfarm —否定一命令或设置其默认。

  • serverfarm predictor —设置负载均衡预测算法。

  • serverfarm probe —配置为使用探测器。

  • serverfarm real —配置真实服务器。

  • serverfarm redirect-vserver —配置SLB重定向虚拟服务器。

内容引擎显示命令

  • show statistics http savings —保存从内容引擎的统计信息。

    ce1# show statistics http savings
    
                           Statistics - Savings
                         Requests           Bytes
    -----------------------------------------------
    Total:               635                2764599
    Hits:                113                254517
    Miss:                505                2483555
    Savings:            17.8 %              9.2 %

    正如你看到的有113命中数。

故障排除

当前没有故障排除此配置的特定可用资料。

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 19680