语音 : Digital CCS

透明 CCS 的配置与故障排除

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

本文描述如何配置和排除故障透明公共渠道信令(T-CCS)。

先决条件

要求

本文档的读者应掌握以下这些主题的相关知识:

  • 如何配置Cisco IOSï¿Â语音功能的½软件。

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • Cisco IOS软件版本12.2.7a。

  • Cisco 3640路由器。

本文档中的信息都是基于特定实验室环境中的设备创建的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您是在真实网络上操作,请确保您在使用任何命令前已经了解其潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

背景信息

T-CCS允许2个PBX与数字接口的连接,该接口使用一个专有或不支持的CCS协议,无需解释呼叫处理的CCS信令。

使用T-CCS, PBX语音信道可以被固定(做永久性)和被压缩在站点之间。随附于的信令信道或信道可以在PBX之间的IP/FR/ATM骨干网间被建立隧道(传送透明地)。因此,从PBX的呼叫没有由根据按呼叫连接基本类型的思科路由,然而跟随一条预先配置的小路对目的地。

有应用功能三种可配置方式:

  • 帧转发T-CCS

  • 清除信道T-CCS

  • 交叉连接T-CCS

交叉连接T-CCS只是可能的在思科3810和没有讨论在本文。

T-CCS 兼容矩阵

此表显示在多种平台可以配置的T-CCS功能。

嗓音1 思科3810 思科26xx/36xx/72xx
VoIP2 clear-channel :
  • 任一种CCS发信号。
  • 任何数量的信令信道。
clear-channel :
  • 任一种CCS发信号。
  • 任何数量的信令信道。
VoFR3 clear-channel :
  • 任一种CCS发信号。
  • 任何数量的信令信道。
帧转发:
  • 使用HDLD帧的signaling.4
  • Only1信令信道:E1。
  • E1 = TS16。
  • T1= TS 24。
TDM5交叉连接:
  • 任一种CCS发信号。
  • 任何数量的信令信道。
clear-channel :
  • 任一种CCS发信号。
  • 任何数量的信令信道。
帧转发:
  • 使用HDLD帧的信令。
  • 信令信道=可配置的信道组每个控制器。
VoATM6 clear-channel :
  • 任一种CCS发信号。
  • 任何数量的信令信道。
帧转发:
  • 使用HDLD帧的信令。
  • Only1信令信道。
clear-channel :
  • 任一种CCS发信号。
  • 任何数量的信令信道。
帧转发:
  • 使用HDLD帧的信令。
  • 信令信道=可配置的信道组每个控制器。

1. 在X的嗓音=语音

2. VoIP =基于IP的语音

3. VoFR =帧中继语音

4. HDLC =高级数据链路控制(HDLC)

5. TDM =时分复用

6. VoATM = Voice over ATM

帧转发 T-CCS

帧转发T-CCS可能只用于支持信令信道或信道使用HDLD帧的PBX专有协议,并且希望的嗓音技术是VoFR或VoATM。在此解决方案, HDLC信令帧通过为在控制器的信令配置的信道组被封装并且转发和因而对待serial interfaces。HDLC构建帧解释并且了解,虽然信令消息不是。空闲帧被抑制,并且仅真正的数据在信令信道间被传播。

实现帧转发T-CCS

警告:CSCdt55871限制

当配置在E1时的帧转发TCCS有在可用的语音信道数量的一当前限制。限制发生由于冲突之间ds0-group和通道组号码范围,和在CSCdt55871 (仅限注册用户)解释。

尝试配置以前是+1输入通道组的ds0组导致失败,如下所示。

!
 controller t1 2/1 
 channel-group 0 timeslot 24 speed 64 
 ds0-group 1 timeslots 1 type ext-sig

上述配置导致错误消息,当ds0组定义时,声称已经使用信道0,如显示此处:

%Channel 0 already used by other group

应急方案是想念相冲突的组,并且继续在范围的下一组编号。这减少可配置组数量按一个。

注意这些点在实现帧转发T-CCS前:

  • 帧转发T-CCS,当将传输的CCS协议使用帧时的一种HDLC类型必须只配置。

  • mode ccs-frame-forwarding命令定义了Frame-Forwarding CCS。

  • DSO组ext信号命令确定哪些语音端口将创建和用于中继与外部源信令。

  • 连接干线命令设立永久性语音信道。

  • channel-group命令定义了帧转发时隙或时隙。

  • 帧转发T-CCS不为VoIP支持。

  • 在E1的TS16为随路信令(CAS)总是保留。如果配置CAS的另一个时隙(正如在上述示例),您然后有一少量语音的时隙。

帧转发 VoFR T-CCS 配置示例

在此部分和测试报告的配置在运行Cisco IOS软件版本12.2.7a的Cisco 3640路由器执行。显示的示例此处代表情况,当信令在正常时隙时(插槽16)没有应用。使用得另一个时隙这里(显示功能的通用性的slot 6) (不可适用在Cisco 3810路由器)。

/image/gif/paws/19087/trans_channel_signal1.gif

语音端配置步骤

要配置语音端,请完成这些步骤:

  1. 在T1或E1控制器上:

    1. 添加mode ccs frame-forwarding命令

    2. 定义每信令信道的信道组(仅Cisco 26xx及36xx系列;Cisco 3810路由器自动地创建D-channel)。

    3. 使用类型ext-sig,定义每条语音信道的ds0groups。

      GTP1
      controller E1 3/0
       mode ccs frame-forwarding
       channel-group 0 timeslots 6
       ds0-group 2 timeslots 2 type ext-sig
       ds0-group 3 timeslots 3 type ext-sig
      .
       ds0-group 30 timeslots 30 type ext-sig

      GTP2
      controller E1 3/0
       mode ccs frame-forwarding
       channel-group 0 timeslots 6
       ds0-group 2 timeslots 2 type ext-sig
       ds0-group 3 timeslots 3 type ext-sig
      .
       ds0-group 30 timeslots 30 type ext-sig

  2. 在D-channel接口(此serial interfaces得到创建,在channel-group命令配置以上)后:

    1. 添加ccs encap frf11命令

    2. 通过使用ccs connect Serial x/y DLCI CID命令,指向D-channel在FR广域网接口的信道ID。

      注意: 如果超过一信令信道要求,必须用于单独的信道ID每D-channel。从信道ID 254开始,并且向后工作。

      GTP1
      interface Serial3/0:0
       no ip address
       ccs encap frf11
       ccs connect Serial0/0 105 254

      GTP2
      interface Serial3/0:0
       no ip address
       ccs encap frf11
       ccs connect Serial0/0 105 254

  3. 在语音端口上:

    添加连接中继xxx到每个语音端口。编号必须匹配终止的语音端口(POTS拨号对端)的目的地模式在另一侧。仅连接的一端应该指定“应答模式”。

    GTP1
    !
    voice-port 3/0:2
     timeouts wait-release 3
     connection trunk 6002
    !
    voice-port 3/0:3
     timeouts wait-release 3
     connection trunk 6003
    !
    ... [channels 4-30 the same] ...
    !
    voice-port 3/0:30
     timeouts wait-release 3
     connection trunk 6030
    !

    GTP2
    voice-port 3/0:2
     timeouts wait-release 3
     connection trunk 8002 answer-mode
    !
    voice-port 3/0:3
     timeouts wait-release 3
     connection trunk 8003 answer-mode
    !
    ... [channels 4-30 the same] ...
    !
    voice-port 3/0:30
     timeouts wait-release 3
     connection trunk 8030 answer-mode

  4. 在POTS拨号对端:

    1. 添加一个VoFR拨号对等体匹配的连接中继呼叫号码,并且指向它帧中继数据链路连接标识符(DLCI)。

    2. 添加一POTS拨号对端到匹配从另一侧的连接中继xxx语句拨号的编号的每个语音端口。

      GTP1
      !
      dial-peer voice 8002 pots
       destination-pattern 8002
       port 3/0:2
      !
      dial-peer voice 8003 pots
       destination-pattern 8003
       port 3/0:3
      ! 
      ... [channels 4-30 the same] ...
      
      dial-peer voice 6000 vofr
       destination-pattern 6...
       session target Serial0/0 105
      !

      GTP2
      !
      dial-peer voice 6002 pots
       destination-pattern 6002
       port 3/0:2
      !
      dial-peer voice 6003 pots
       destination-pattern 6003
       port 3/0:3
      
      ... [channels 4-30 the same] ... 
      !
       dial-peer voice 8000 vofr
       destination-pattern 8...
       session target Serial1/0 105
      !

WAN 端配置步骤

要配置广域网端,请完成这些步骤:

  1. 定义一帧中继serial interfaces和一个点对点子接口与正常VoFR。

  2. 放置在根据用于语音的信道和编码数量的语音带宽

  3. 允许在承诺信息速率(CIR)的额外的带宽共享此DLCI的信令信道和其他数据。

    GTP1
    interface Serial0/0
     no ip address
     encapsulation frame-relay
     frame-relay traffic-shaping
    !
    interface Serial0/0.1 point-to-point
     ip address 10.10.105.2 255.255.255.0
     frame-relay class voice-class
     frame-relay interface-dlci 105   
      vofr cisco
    !
    map-class frame-relay voice-class
     no frame-relay adaptive-shaping
     frame-relay cir 512000
     frame-relay bc 5120
     frame-relay be 0
     frame-relay fair-queue
     frame-relay voice bandwidth 512000
     frame-relay fragment 640
    !

    GTP2
    !
    interface Serial1/0
     no ip address
     encapsulation frame-relay
     clock rate 768000
     frame-relay traffic-shaping
     frame-relay intf-type dce
    !
    interface Serial1/0.1 point-to-point
     ip address 10.10.105.1 255.255.255.0
     frame-relay class voice-class
     frame-relay interface-dlci 105   
      vofr cisco
    !
    !
    map-class frame-relay voice-class
     no frame-relay adaptive-shaping
     frame-relay cir 512000
     frame-relay BC 5120
     frame-relay be 0
     frame-relay fair-queue
     frame-relay voice bandwidth 512000
     frame-relay fragment 640
    !

带宽

在骨干网设置的带宽必须允许所有配置了语音和信令信道。由于这些配置使用连接中继,所有发生的语音和信令信道一直是UP。Voice Activation Detection (VAD)在激活语音信道提供储蓄(虽然不在信令),但是VAD不变得激活,直到语音信道设立。因此每条语音信道需要的起始带宽应该考虑到编码使用,加上报头开销。对于VoFR,应该占语音信道的仅带宽在语音带宽LLQ命令。应该占语音的带宽和信令信道在WAN接口。

排除故障并且验证帧转发T-CCS

以下步骤帮助验证帧转发T-CSS操作如应该。

  1. E1控制器必须是UP为了语音端口能去摘机和建立中继。

  2. 证实呼叫是否到位,并且正确数字信号处理器(DSP)是否在时隙分配。

  3. 如果呼叫不能连接,请检查永久虚拟电路(PVC)状态配置或连接和拨号对端设置。

  4. 如果show voice port命令显示“空闲”和“在挂”任何时隙的,请检查相关时隙是否有分配的正确DSP版本和用show voice dsp命令正确地工作。

  5. debug TCCS signaling命令调试在logging buffered模式(这非常强化中央处理)。

    gtp2#show controllers e1 3/0
    E1 3/0 is up. 
      Applique type is Channelized E1 - balanced
      No alarms detected.
      alarm-trigger is not set
      Version info Firmware: 20011015, FPGA: 15
      Framing is CRC4, Line Code is HDB3, Clock Source is Line.
      Data in current interval (276 seconds elapsed):
         0 Line Code Violations, 0 Path Code Violations
         0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
         0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
    
    gtp2#show voice dsp
     
    DSP  DSP            DSPWARE CURR  BOOT         VOICE       PAK     TX/RX
    TYPE NUM CH CODEC   VERSION STATE STATE RST AI PORT   TS ABORT  PACK COUNT
    ==== === == ======= ======= ===== ===== === == ====== == ===== ============
    C549 000 01 g729ar8  3.4.49 busy  idle       0 3/0:18 18     0 119229/70248
    C549 000 00 g729ar8  3.4.49 busy  idle    0  0 3/0:2  02     0  41913/45414
    C549 001 01 g729ar8  3.4.49 busy  idle       0 3/0:19 19     0 119963/70535
    C549 001 00 g729ar8  3.4.49 busy  idle    0  0 3/0:3  03     0  42865/47341
    C549 002 01 g729ar8  3.4.49 busy  idle       0 3/0:20 20     0  77746/69876
    
    
    !--- This shows DSPs are being used.
    
    
    
    gtp2#show voice call summary
    
    PORT         CODEC    VAD VTSP STATE            VPM STATE
    =========   ======== === ============        ==============
    3/0:2.2       g729ar8  y  S_CONNECT             S_TRUNKED                
    3/0:3.3       g729ar8  y  S_CONNECT             S_TRUNKED                
    3/0:4.4       g729ar8  y  S_CONNECT             S_TRUNKED                
    3/0:5.5       g729ar8  y  S_CONNECT             S_TRUNKED                
    3/0:6.31      g729ar8  y  S_CONNECT             S_TRUNKED
    
    
    !--- This shows call connected.
    
    
    gtp2#show frame-relay pvc
    
    PVC Statistics for interface Serial1/0 (Frame Relay DCE)
    
                  Active     Inactive      Deleted       Static
      Local          1            0            0            0
      Switched       0            0            0            0
      Unused         0            0            0            0
    
    DLCI = 105, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, 
    INTERFACE = Serial1/0.1
    
      input pkts 1201908       output pkts 2177352      in bytes 37341051  
      out bytes 71856239       dropped pkts 0           in FECN pkts 0         
      in BECN pkts 0           out FECN pkts 0          out BECN pkts 0         
      in DE pkts 0             out DE pkts 0         
      out bcast pkts 167       out bcast bytes 48597     
      PVC create time 08:37:30, last time PVC status changed 02:47:05
      Service type VoFR-cisco
    
    
    !--- This shows Frame Relay is active.
    
    
    
    gtp2#show frame-relay fragment 
    interface   dlci  frag-type   frag-size  in-frag  out-frag   dropped-frag
    Serial1/0.1 105   VoFR-cisco  640        172      169        0    
    
    
    debug tccs signaling
    
    Log Buffer (8096 bytes):
    
    08:55:47:  282 tccs packets received from the port.
    08:55:47:  282 tccs packets received from the nework.
    08:55:47: RX from Serial3/0:0:
    08:55:47: tccs_db->vcd = 105, tccs_db->cid = 254
    08:55:47: pak->datagramsize=20
    BE C0 C0 00 FF 03 C0 21 09 48 00 0C 01 49 F3 69 00 0C 42 00 
    08:55:47:  282 tccs packets received from the port.
    08:55:47:  283 tccs packets received from the nework.
    08:55:47: RX from Serial1/0: dlci=105, cid=254, payld-type =0,
                    payld-length=188, cid_type=424
    08:55:47: datagramsize=20
    BE C0 C0 00 FF 03 C0 21 0A 48 00 0C 03 EA DF 0D 00 0C 42 00 
    08:55:50:  282 tccs packets received from the port.
    08:55:50:  284 tccs packets received from the nework.
    08:55:50: RX from Serial1/0: dlci=105, cid=254, payld-type =0,
                    payld-length=188, cid_type=424
    08:55:50: datagramsize=20
    BE C0 C0 00 FF 03 C0 21 09 48 00 0C 03 EA DF 0D 00 62 05 00 
    08:55:50:  283 tccs packets received from the port.
    08:55:50:  284 tccs packets received from the nework.
              08:55:50: RX from Serial3/0:0:
    08:55:50: tccs_db->vcd = 105, tccs_db->cid = 254
    08:55:50: pak->datagramsize=20
    BE C0 C0 00 FF 03 C0 21 0A 48 00 0C 01 49 F3 69 00 62 05 00 
    gtp2# wr t
    
    
    !--- This shows packet forwarding and receiving.
    
    

清除信道编解码 T-CCS

清除信道T-CCS用于支持信令信道是ABCD位基于的或HDLC的PBX专有协议,或者语音传输技术是VoIP的地方。在此解决方案,信令信道和语音信道配置作为ds0groups,并且所有对待语音呼叫。

使用您的选择,语音编码实时语音呼叫永久是连接的中继线连接。使用clear-channel编码器,信令信道也是永久连接的中继,类似于在示例和数据包大小的G.711,但是自动地排除回波取消和VAD。没有智能在软件里知道哪些信道是语音信道,并且哪些是信令信道。您必须配置您知道运载信令流量匹配拨号对端分配clear-channel编码器的时隙,而语音信道必须匹配编码语音的拨号对端(G.729和其他)。

实现清除信道编解码T-CCS

在您实现清除信道T-CCS前,请注意这些点:

  • 清除信道T-CCS用于任一种数字E1或T1信令的是(包括基于HDLC的构建帧)。

  • 可以支持任何数量的信令信道。

  • 清除信道T-CCS可以用于VoIP、VoFR或者VoATM环境

  • clear-channel编码器使用信令信道或信道在清除信道T-CCS。

  • 必须占VoIP信令和语音带宽在IP RTP优先级或低延迟排队(LLQ)。

  • VoIPovFR/VoFR —信令和语音能在同样或分离DLCI。

  • VoFR —发信号带宽计数作为VoFR “语音带宽一部分”。

  • 使用清除信道T-CCS,发信号采取专用带宽64K (不包括数据包开销)。

  • DSO-group命令配置语音和信令信道。

  • Cisco IOS软件不知道信令信道是在使用中的。

  • 三十一个DSP为PBX要求使用在时隙16的信令用30个语音端口,因此在E1 2MFT的两中继将用尽数量在NMV2的DSP (62要求)。

当使用clear-channel编码器传输数据流时,重要的是网络时钟同步。这是因为DSP算法丢弃数据包,当缓冲区超出发生时,并且使用其自动填装算法,当缓冲区underrun发生时(细致为语音流量,但是没有益于数据流)。这两个情况可能造成D-channel发生故障和重新启动。

清除信道 VoIP T-CCS 配置示例

清除信道VoIP T-CCS配置和测试在运行Cisco IOS软件版本12.2.7a的Cisco 3640路由器执行。在显示的示例中此处,信令在正常时隙(16)没有应用。使用得另一个时隙这里(显示功能的通用性的时隙6)。

/image/gif/paws/19087/trans_channel_signal2.gif

  1. 在T1或E1控制器上:

    定义每语音信道和信令信道的ds0groups。

    GTP1
    controller E1 3/0
     ds0-group 0 timeslots 6 type ext-sig
     ds0-group 1 timeslots 1 type ext-sig
     ds0-group 2 timeslots 2 type ext-sig
     ds0-group 3 timeslots 3 type ext-sig
     ds0-group 4 timeslots 4 type ext-sig
     ds0-group 5 timeslots 5 type ext-sig
     ds0-group 6 timeslots 31 type ext-sig
     ds0-group 7 timeslots 7 type ext-sig
     ....
     ds0-group 30 timeslots 30 type ext-sig

    GTP2
    controller E1 3/0
     ds0-group 0 timeslots 6 type ext-sig
    
     ds0-group 1 timeslots 1 type ext-sig
     ds0-group 2 timeslots 2 type ext-sig
     ds0-group 3 timeslots 3 type ext-sig
     ds0-group 4 timeslots 4 type ext-sig
     ds0-group 5 timeslots 5 type ext-sig
     ds0-group 6 timeslots 31 type ext-sig
     ds0-group 7 timeslots 7 type ext-sig
     ....
     ds0-group 30 timeslots 30 type ext-sig

  2. 在语音端口上:

    1. 添加一connection trunk xxx命令到每语音端口配置。编号必须匹配终止的语音端口(POTS拨号对端)的目的地模式在另一侧。

    2. 添加一connection trunk xxx命令到每信令语音端口配置—编号必须匹配终止的语音端口(POTS拨号对端)的目的地模式在另一侧。

    3. 仅连接的一端应该指定应答模式

      GTP1
      voice-port 3/0:0
       timeouts wait-release 3
       connection trunk 3001
      !
      voice-port 3/0:1
       timeouts wait-release 3
       connection trunk 6001
      ! 
      ... [channels 2-30 the same] ...
      !
      voice-port 3/0:30
       timeouts wait-release 3
       connection trunk 6030

      GTP2
      !
       voice-port 3/0:0
       timeouts wait-release 3
       connection trunk 5001 answer-mode
      !
       voice-port 3/0:1
       timeouts wait-release 3
       connection trunk 8001 answer-mode
      !
      ... [channels 2-30 the same] ...
      
      voice-port 3/0:30
       timeouts wait-release 3
       connection trunk 8030 answer-mode

  3. 在拨号对端:

    1. 添加匹配语音信道的连接中继呼叫号码的一个VoIP拨号对等体。指向它远端的IP地址;指定在此拨号对端的希望的(或默认)语音编码。

    2. 添加匹配信令信道的连接中继呼叫号码的一个VoIP拨号对等体。指向它远端的IP地址;指定在此拨号对端的clear-channel编码器。

    3. 添加匹配从另一侧的连接中继语句拨号的编号的POTS拨号对端到每个语音端口。

      GTP1
      dial-peer voice 8001 pots
       destination-pattern 8001
       port 3/0:1
      !
      
      
      !--- Pots dial peers 8001 --- 8030 are 
      !--- configured similarly with exclusive POTS,
      !--- destination patterns and ports. These are 
      !--- associated with the voice channels.
      
      
      dial-peer voice 8030 pots
       destination-pattern 8030
       port 3/0:30
      !
      dial-peer voice 5001 pots
       destination-pattern 5001
       port 3/0:0
      
      
      !--- This is the POTS dial peer associated with 
      !--- the port connected to the local PBX 
      !--- signaling channel.
      
      
      ! 
      dial-peer voice 6000 voip
       destination-pattern 6...
       session target ipv4:10.10.105.1
      !
      dial-peer voice 3001 voip
       answer-address 5001
       destination-pattern 3001
       session target ipv4:10.10.105.1
       codec clear-channel
      
      
      !--- This is the VoIP dial peer associated 
      !--- with the destination pattern that 
      !--- connects to the remote PBX signaling 
      !--- channel port.
      
      

      GTP2
      !
      dial-peer voice 6001 pots
       destination-pattern 6001
       port 3/0:1
      !
      
      
      !--- POTS dial peers 6001 --- 6030 are 
      !--- configured similarly with exclusive POTS,
      !--- destination patterns, and ports. 
      !--- These are associated with the 
      !--- voice channels.
      
      
      dial-peer voice 6030 pots
       destination-pattern 6030
       port 3/0:30
      ! 
      dial-peer voice 3001 pots
       destination-pattern 3001
       port 3/0:0
      
      
      !--- This is the POTS dial peer associated 
      !--- with the port connected to the local PBX 
      !--- signaling channel.
      
      
      !
      dial-peer voice 8000 voip
       destination-pattern 8...
       session target ipv4:10.10.105.2
      !
      dial-peer voice 5001 voip
       answer-address 3001
       destination-pattern 5001
       session target ipv4:10.10.105.2
       codec clear-channel
      
      
      !--- This is the VoIP dial peer associated with 
      !--- the destination pattern that connects 
      !--- to the remote PBX signaling channel port.
      
      

WAN 端配置步骤

要配置广域网端,请完成这些步骤:

放置在根据以下的一个IP RTP Priority命令或LLQ带宽:

  • 语音信道数量和用于语音信号的编码。

  • 80K乘的信令信道数量(对待您将对待G.711)。

GTP1
interface Multilink1
 bandwidth 512
 ip address 10.10.105.2 255.255.255.0
 ip tcp header-compression iphc-format
 no cdp enable
 ppp multilink
 ppp multilink fragment-delay 20
 ppp multilink interleave
 multilink-group 1
 ip rtp header-compression iphc-format
 ip rtp priority 16384 16383 384
!
interface Serial0/0
 no ip address
 encapsulation ppp
 no fair-queue
 ppp multilink
 multilink-group 1

GTP2
interface Multilink1
 bandwidth 512
 ip address 10.10.105.1 255.255.255.0
 ip tcp header-compression iphc-format
 no cdp enable
 ppp multilink
 ppp multilink fragment-delay 20
 ppp multilink interleave
 multilink-group 1
 ip rtp header-compression iphc-format
 ip rtp priority 16384 16383 384
!!
interface Serial1/0
 no ip address
 encapsulation ppp
 no fair-queue
 clock rate 512000
 ppp multilink
 multilink-group 1

排除故障并且验证清除信道T-CCS

这些步骤帮助验证clear-channel T-CSS操作如应该:

  1. E1控制器必须是UP为了语音端口能去摘机和建立中继。

  2. 保证检查呼叫到位,并且正确DSP在时隙分配。

  3. 如果呼叫不能连接,请检查IP配置和连接和拨号对端设置。

  4. 如果IP在接口或链路故障以后恢复,控制器必须有在其接口发出的shut/no shut命令,或者必须重新加载路由器带来中继连接备份。

  5. 如果show voice port命令显示空闲任何时隙的,请检查相关时隙有分配的正确DSP版本,并且用show voice dsp命令正确地工作,如下所示。

gtp#show voice dsp

DSP  DSP            DSPWARE CURR  BOOT         VOICE      PAK       TX/RX
TYPE NUM CH CODEC   VERSION STATE STATE RST AI PORT   TS ABORT    PACK COUNT
==== === == ======= ======= ===== ===== === == ====== == =====   ============
C549 000 02 g729r8   3.4.49 busy  idle       0 3/0:25    25      0     264/2771
C549 000 01 g729r8   3.4.49 busy  idle       0 3/0:12    12      0     264/2825
C549 000 00 clear-ch 3.4.49 busy  idle    0  0 3/0:0     06      0 158036/16069


!--- The above identifies that the clear codec is used for timeslot 6.
!--- Ensure that clear codec is applied correctly against the correct timeslot.
                                                                     


gtp1#show voice port sum

PORT   CH SIG-TYPE   ADMIN OPER STATUS   STATUS   EC
====== == ========== ===== ==== ======== ======== ==
3/0:0  6     ext     up    up   trunked  trunked  y
3/0:1  1     ext     up    up   trunked  trunked  y
3/0:2  2     ext     up    up   trunked  trunked  y
3/0:3  3     ext     up    up   trunked  trunked  y


!--- This shows that the voice port used for signaling is off-hook and trunked.
 


gtp1#show voice call sum
PORT         CODEC    VAD VTSP STATE            VPM STATE
============ ======== === ============        =============
3/0:0.6       clear-ch y  S_CONNECT             S_TRUNKED
3/0:1.1       g729r8   y  S_CONNECT             S_TRUNKED
3/0:2.2       g729r8   y  S_CONNECT             S_TRUNKED
3/0:3.3       g729r8   y  S_CONNECT             S_TRUNKED
3/0:4.4       g729r8   y  S_CONNECT             S_TRUNKED
3/0:5.5       g729r8   y  S_CONNECT             S_TRUNKED
3/0:6.31      g729r8   y  S_CONNECT             S_TRUNKED
3/0:7.7       g729r8   y  S_CONNECT             S_TRUNKED


!--- This shows a signaling call in progress.

启用发信号在AS5350和AS5400的RTP

默认情况下为了防止RTP数据包造成的错误有效载荷类型“123"在Cisco AS5350及AS5400系列平台, RTP信号处理禁用。在一些情况下,数据包此类型能的AS5350和AS5400系列平台导致一个无效内存地址错误,潜在失败设备。

使用语音快速路径语音RTP信令enable (event)隐藏的配置命令,在这些型号上,您能启用RTP信号处理。然而,在您启用RTP信号处理前,请准备平台处理RTP数据包有效载荷类型“123"通过启用T-CCS。

在您准备平台后,您能使用这些命令为了启用或禁用RTP信号处理。

  • 为了启用RTP信号处理,请使用此命令:

    Router(config)#voice-fastpath voice-rtp-signalling enable
    
  • 为了禁用RTP信号处理,请使用此命令:

    Router(config)#no voice-fastpath voice-rtp-signalling enable
    

没有 PBX 如何测试 T-CCS (帧转发和清除通道)

在某些情况下验证T-CCS的配置与PBX的可能是不切实际的。此部分描述用路由器介入PBX替换法的方法,测试发信号可以传输。由于用于PPP的帧结构类似于基于消息的信令使用的那(例如CCS),您能使用配置的路由器PPP测试信令信道工作。这可以是有用的在T-CCS部署失败的情况,并且进一步证明是需要的信令信道工作。(在帧转发T-CCS有显示帧的发射和接收的调试有用的资料。在清除信道T-CCS,实时调试信息不是可用的。)

配置路由器的E1控制器选择信令信道的。此示例使用时隙6,到搭卖与上述测验。配置在产生的serial interfaces的PPP代表信令流量。

trans_channel_signal3.gif

路由器 1
controller E1 0
 clock source internal
 channel-group 0 timeslots 6
!
interface Serial0:0
 ip address 1.1.1.2 255.255.255.0
 encapsulation ppp

路由器 2
controller E1 0
 clock source internal
 channel-group 0 timeslots 6
!
interface Serial0:0
 ip address 1.1.1.1 255.255.255.0
 encapsulation ppp

典型输出用debug ppp数据包
1d00h: Se0:0 LCP: Received id 1, sent id 1, line up
1d00h: Se0:0 PPP: I pkt type 0xC021, datagramsize 16
1d00h: Se0:0 LCP: I ECHOREQ [Open] id 2 len 12 magic 0x0676C553
1d00h: Se0:0 LCP: O ECHOREP [Open] id 2 len 12 magic 0x0917B6ED
1d00h: Se0:0 PPP: I pkt type 0x0207, datagramsize 305
1d00h: Se0:0 LCP: O ECHOREQ [Open] id 2 len 12 magic 0x0917B6ED
1d00h: Se0:0 PPP: I pkt type 0xC021, datagramsize 16
1d00h: Se0:0 LCP: I ECHOREP [Open] id 2 len 12 magic 0x0676C553
1d00h: Se0:0 LCP: Received id 2, sent id 2, line up


相关信息


Document ID: 19087