语音和统一通信 : Cisco ATA 180 系列模拟电话适配器

与 Cisco IOS 网守连接的 ATA 186 的配置与故障排除

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 23 日) | 反馈


目录


简介

Cisco 模拟电话适配器 (ATA) 186 是一台手机对以太网的适配器,它将普通的模拟电话连接到基于 IP 的电话网络。ATA 186有可以只支持传统模拟按键式电话的两个语音端口。不同于普通外部交换站(FXS)端口,这些不可能建立接口与内部交换机(PBX),因为ATA 186不能派出这些端口的位。使用此配置,您能以在其中每一的不同的E.164地址使用两个语音端口。

先决条件

要求

本文假设读者熟悉Cisco ATA 186基本配置文件的内容。

使用H.323特性组,此配置要求ATA 186在版本2.0或以上。

保证有在ATA 186、网关和网守设备之间的IP连通性。并且,请保证ATA 186通过进一步配置的Web服务器方法是可取得。

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • 有版本2.12的ATA 186

  • Cisco 3640用Cisco IOS 软件版本12.1作为网关

  • 与Cisco IOS软件版本12.2的Cisco2600作为网守

本文档中的信息都是基于特定实验室环境中的设备创建的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您是在真实网络上操作,请确保您在使用任何命令前已经了解其潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

网络图

本文档使用以下网络设置:

/image/gif/paws/19084/ata_gatekeeper_1.gif

注册带网守的 ATA 186

遵从这些说明注册ATA 186用网守。

  1. 在Web浏览器地址或Location字段,请键入URL http:// ip_address_of_ata/dev访问ATA 186配置屏幕, ip_address_of_ata是ATA 186的IP地址您注册。

    在本例中, URL是http://172.16.104.117/dev。Cisco ATA 186配置窗口出现。

    注意: 加下划线的字段是此方案的相关配置参数。

    /image/gif/paws/19084/ata_gatekeeper_2.gif

    IP编址可以静态或动态地执行(如在Cisco ATA 186基本配置文件中所述)。在上一屏幕,使用静态IP地址。

  2. 在Cisco ATA 186配置窗口,请配置这些字段:

    • UID0和UID1 —配置E.164地址语音端口0和1。

      两个语音端口不能有同一个E.164地址,因为ATA 186不能寻找,如果其中一个端口忙碌。如果两个语音端口分配同一个E.164地址,呼叫永远将被发送到第一个语音端口。如果此端口忙碌,占线信号发送给呼叫方。

    • RxCodec和TxCodec —配置编码ID。

      • G.723.1 —编码ID 0。

      • G.711a —编码ID 1。

      • G.711u —编码ID 2。

      • G.729a —编码ID 3。

      在如下所示的配置中, G.729r8编码使用在ATA 186在网关。

    • LBRCodec —配置作为0或3,根据选定的编码。

      • LBRC是0 — G.723.1编码对两个FXS端口在任何时间是可用的。每条线路能维持两G.723.1呼叫在非会议状态。所以,四G.723.1呼叫在Cisco ATA 186可以被维持。示例是呼叫等待。

      • LBRC是3 — G.729a按照先到先服务是可用的到两个FXS端口之一。如果Cisco IOS网关配置与默认G.729编码,只有可以使用一个ATA 186端口。使用G.711编码,要防止第二次呼叫失败,请配置在网关的语音编译码类协商第二次呼叫。详细信息,参考编码概要的Codec Negotiation部分:复杂性、硬件支持、MOS和协商文档。

    • GkOrProxy —配置网守的IP地址。

      一旦这执行,从ATA 186语音端口拨号的任何发送到网守。

  3. 点击应用按钮然后重新加载页。

    ATA 186用10秒重新配置自己。

这些示例是Cisco IOS网守和网关的相关配置:

2610网守
interface Ethernet0/0
 ip addreinterface Ethernet0/0
 ip address 172.16.13.12 255.255.255.224
 half-duplex
 h323 interface
 h323 h323-id pro
 h323 gatekeeper ipaddr 172.16.13.12
 h323 t120 bypass
!
dial-peer cor custom
!
!
!
gatekeeper
 zone local gk2 cisco.com 172.16.13.12
no shutdown
!

3640网关
interface Ethernet0/0
 ip address 172.16.13.40 255.255.255.224
 half-duplex
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.13.33
ip http server
!
!
!
voice-port 3/0/0
!
voice-port 3/0/1
!
dial-peer cor custom
!
!
!
dial-peer voice 1 pots
 destination-pattern 34
 port 3/0/0
!
dial-peer voice 2 pots
 destination-pattern 45
 port 3/0/1
!
dial-peer voice 100 pots
 destination-pattern 1234
 port 3/0/0
!
dial-peer voice 3000 voip
 destination-pattern 300.
 session target ras

!--- Dial-peer to send the calls to ATA.

!

增加安全性

自ATA软件版本2.12,在此部分的选项是可用的添加安全。

利用 H.323 ID 在网守鉴别终端

遵从这些步骤配置ATA 186向H.323 ID登记:

  1. 设置AutMethod字段到0 (默认是1)。

    将为此字段配置的十六进制值是0x0。

  2. 设置UseLoginID字段到1。

  3. 配置LoginID0和LoginID1,与H.323 ID ATA 186的。

    ATA 186注册作为两不同H.323终端,一个每个端口的。

这是网守的一个示例工作配置,当使用ATA以H.323 ID认证方法时:

/image/gif/paws/19084/ata_gatekeeper_3.gif

2610网守
aaa authentication login default local
aaa authentication login cisco none
aaa authentication login h323 local
aaa session-id common
enable password ww
!
username atagw1

!--- Same as the LoginID0 and LoginID1 fields.

username atagw2
username 3640

!--- Same as the H.323 ID configured on the gateway.

!
gatekeeper
 zone local gk2 cisco.com 172.16.13.12
security any

!--- Register after the H.323 ID or E.164 address is authenticated.

no shutdown
!

验证终端在有E.164地址的网守

遵从这些步骤配置ATA 186向E.164地址登记:

  1. 设置AutMethod字段到0 (默认是1)。

    将为此字段配置的十六进制值是0x0。

  2. 设置UseLoginID字段到0

    ATA使用UID0和UID1字段由网守得到验证。

这是关守和网关的一个示例工作配置,当使用ATA以E.164 ID认证方法时:

2610网守
aaa authentication login default local
aaa authentication login cisco none
aaa authentication login h323 local
aaa session-id common
enable password ww
!
username 3001

!--- Same as the UID0.

username 3000

!--- Same as the UID1.

!
gatekeeper
 zone local gk2 cisco.com 172.16.13.12
security any

!--- Register after the H.323 ID or E.164 address is authenticated.

no shutdown
!

验证终端在带H.323 ID的网守和密码

遵从这些步骤配置ATA 186向H.323 ID和密码登记:

  1. 设置AutMethod字段到1 (默认是1)。

    将为此字段配置的十六进制值是0x1。此字段设置表明ATA当前寻找密码。

  2. 设置UseLoginID字段到1。

  3. 配置LoginID0和LoginID1,与H.323 ID ATA 186的。

    ATA 186注册作为两不同H.323终端,一个每个端口的。

  4. 配置PWD0和PWD1用密码每个端口的。

    注意: ATA使用密码生成标记。此标记发送到验证的网守。

  5. 配置NTPIP用网络时间协议(NTP)服务器IP地址。

    网守和ATA必须有时钟同步对同样Ntp server。

注意: 时间戳使用令牌的生成。欲知更多信息,参考网关到网守(H.235)和网守到网守(IZCT)安全故障排除指南

这是关守和网关的一个示例工作配置,当使用ATA以H.323 ID和密码验证方法时:

2610网守
aaa authentication login default local
aaa authentication login cisco none
aaa authentication login h323 local
aaa session-id common
enable password ww
!
username atagw1 password cisco

!--- Same as the LoginID0 and PWD0 fields.

username atagw2 password cisco

!--- Same as the LoginID1 and PWD1 fields.

!
gatekeeper
 zone local gk2 cisco.com 172.16.13.12
security token required-for registration

!--- Register after the H.323 ID or E.164 address and token is authenticated.

no shutdown
!

注意: 关于网守安全的更多信息,参考网关到网守(H.235)和网守到网守(IZCT)安全故障排除指南

验证终端在网守用E.164地址和密码

遵从这些步骤配置ATA 186向E.164 ID和密码登记:

  1. 设置AutMethod字段到1 (默认是1)。

    将为此字段配置的十六进制值是0x0。此字段设置表明ATA当前将寻找密码。

  2. 设置UseLoginID字段到0

  3. 配置UID0和UID1与E.164 ID ATA 186的。

    ATA 186注册作为两不同H.323终端,一个每个端口的。

  4. 配置PWD0和PWD1用密码每个端口的。

    注意: ATA使用密码生成标记。此标记发送到验证的网守。

  5. 配置NTPIP用NTP服务器IP地址。

    网守和ATA必须有时钟同步对同样Ntp server。

注意: 时间戳使用令牌的生成。欲知更多信息,参考网关到网守(H.235)和网守到网守(IZCT)安全故障排除指南

这是关守和网关的一个示例工作配置,当使用ATA以E.164 ID和密码验证方法时:

2610网守
aaa authentication login default local
aaa authentication login cisco none
aaa authentication login h323 local
aaa session-id common
enable password ww
!
username 3001 password cisco

!--- Same as the UID0 and PWD0 fields.

username 3000 password cisco


!--- Same as the UID1 and PWD1 fields.

!
gatekeeper
 zone local gk2 cisco.com 172.16.13.12
security token required-for registration

!--- Register after the H.323 ID or E.164 address and token is authenticated.

no shutdown
!

注意: 关于网守安全的更多信息,参考网关到网守(H.235)和网守到网守(IZCT)安全故障排除指南

使用分隔符,验证终端在带H.323 ID的网守和密码

遵从这些步骤配置ATA 186向H.323 ID和密码登记:

  1. 设置AutMethod字段到1 (默认是1)。

    为此字段配置的十六进制值是0x1。此字段设置表明ATA当前寻找密码。

  2. 设置UseLoginID字段到1。

  3. 配置LoginID0和LoginID1与H.323 ID,跟随由分隔符和密码ATA 186的。

    例如, LoginID0是atagw1=cisco

    ATA 186注册作为两不同H.323终端,一个每个端口的。

    注意: ATA使用密码生成标记。此标记发送到验证的网守。

  4. 配置NTPIP用NTP服务器IP地址。

    网守和ATA必须有时钟同步对同样Ntp server。

注意: 时间戳使用令牌的生成。欲知更多信息,参考网关到网守(H.235)和网守到网守(IZCT)安全故障排除指南

这是关守和网关的一个示例工作配置,当使用ATA以H.323 ID和密码验证方法使用分隔符时:

2610网守
aaa authentication login default local
aaa authentication login cisco none
aaa authentication login h323 local
aaa session-id common
enable password ww
!
username atagw1 password cisco

!--- Same as the LoginID0 and PWD0 fields.

username atagw2 password cisco

!--- Same as the LoginID1 and PWD1 fields.

!
gatekeeper
 zone local gk2 cisco.com 172.16.13.12
security h323-id
security password separator =

!--- Register after the H.323 ID or E.164 address and token is authenticated.

no shutdown
!

注意: 关于网守安全的更多信息,参考网关到网守(H.235)和网守到网守(IZCT)安全故障排除指南

验证

在此部分的示例显示关守终点注册。

要验证配置,请发出show gatekeeper endpoint命令

                            GATEKEEPER ENDPOINT
REGISTRATION

CallSignalAddr  Port  RASSignalAddr  Port  Zone Name  Type     Flags
--------------  ----  -------------  ----  ---------  ----     -----
172.16.13.40    1720  172.16.13.40   50923    gk2     VOIP-GW  E164-ID: 1234
                                                               H323-ID: 3640
172.16.13.43    1720  172.16.13.43   58400    gk2     VOIP-GW  H323-ID: 3660-2
172.16.104.117  1720  172.69.85.90   1719     gk2     TERM     E164-ID: 3000
172.16.104.117  1721  172.69.85.90   1739     gk2     TERM     E164-ID: 3001
Total number of active registrations=3

注意: ATA 186注册作为H.323终端(TERM)和不作为H.323网关。这故意地执行,以便打算的仅呼叫供给ATA 186被发送对它。

注意: 您不能有任何地址在ATA网关字段。您不能配置ATA 186与网守以及网关一起使用。

故障排除

本部分提供的信息可用于对配置进行故障排除。

如果没有用网守,顺利地注册ATA 186不提供拨号音。如果ATA 186不用网守注册,请验证这些项目:

  • IP连通性存在ATA 186和网守之间。

  • ATA 186 UID0和UID1领域正确地配置。

    • 如果UID字段设置到0, ATA 186不尝试用网守注册。

    • 至少, UID0字段必须是非零值, ATA 186的能开始注册过程。

    • 如果两个ATA 186端口(UID0和UID1)有非零E.164地址, ATA 186尝试用两个端口注册。ATA 186不提供拨号音,即使其中一个端口无法注册。

  • 网守正确地配置。

    • 如果网守配置与本地区域前缀,必须包括ATA 186的E.164地址。

    • 如果安全在网守配置,必须相应地配置ATA 186。

另外,请验证UseSIP字段设置到0。这是必要配置在H.323模式的ATA 186。如果UseSIP字段设置到1, ATA 186不发送注册请求到网守。

排除故障网守

当安全配置时,请发出debug aaa authentication命令

如果安全没有配置,请发出debug ras命令

注意: ATA 186为分开两个语音端口注册。如此调试所显示, ATA 186,因此,两次得到验证一样不同的H.323终端, :

4w4d: AAA/AUTHEN/CONT (3800768902): continue_login (user='atagw1')
4w4d: AAA/AUTHEN (3800768902): status = GETPASS
4w4d: AAA/AUTHEN/CONT (3800768902): Method=LOCAL
4w4d: AAA/AUTHEN (3800768902): status = PASS
4w4d: AAA: parse name=<no string> idb type=-1    tty=-1
4w4d: AAA/MEMORY: create_user (0x83149EFC) user='atagw2'ruser='NULL' port='NULL'
      rem_addr='NULL' authen_type=ASCII service=LOGIN priv=0 initial_task_id='0'
4w4d: AAA/AUTHEN/START (294225678): port='' list='h323' action=LOGIN service=LOGIN
4w4d: AAA/AUTHEN/START (294225678): found list h323
4w4d: AAA/AUTHEN/START (294225678): Method=LOCAL
4w4d: AAA/AUTHEN (294225678): status = GETPASS
4w4d: AAA/H323: Password:
4w4d: AAA/AUTHEN/CONT (294225678): continue_login (user='atagw2')
4w4d: AAA/AUTHEN (294225678): status = GETPASS
4w4d: AAA/AUTHEN/CONT (294225678): Method=LOCAL
4w4d: AAA/AUTHEN (294225678): status = PASS
4w4d: AAA: parse name=<no string> idb type=-1    tty=-1
4w4d: AAA/MEMORY: create_user (0x831910C0) user='3660'  ruser='NULL' port='NULL'
      rem_addr='NULL' authen_type=ASCII service=LOGIN priv=0 initial_task_id='0

对于更多故障排除示例,参考故障排除关守注册问题

排除故障ATA 186

当您用第三方关守和网关时工作,在ATA 186的故障排除工具是非常有用。要启用ATA 186故障排除工具,请遵从这些步骤:

  1. 在ATA Nprintf字段,请配置在相同子网作为ATA 186 PC的IP地址。

  2. 在地址后指定的端口必须是9001

  3. 在PC的DOS提示符,请发出preserv.exe程序

您能下载从CiscoSoftware中心(registeredcustomers的preserv.exe程序)。

preserv.exe程序在最新的ATA 186软件版本压缩文件包括。

调试由 ATA 186 发出的呼叫示例

D:\Documents and Settings\sshafiqu\My Documents\voice\ata>prserv.exe
GK<-1: KPA-RRQ:300 sec
GK->1: RCF:TTL 300

!--- ATA was reset after the gatekeeper configuration was added.

WStop:0
Wed Feb 06 19:06:54 2002 Hello from 171.69.85.90(0)
Build 1109a: v2.12 ata186
Successfully Registered with the Gatekeeper
GK zone<gk2>172.16.13.12: 3000
GK zone:gk2
0x13e138 delayed RRQ: 48 ticks: 300
GK zone<gk2>172.16.13.12: 3001
GK zone:gk2
0x141e58 delayed RRQ: 56 ticks: 300
BMK : gk2
GK<-1: KPA-RRQ:300 sec
BMK : gk2
GK<-0: KPA-RRQ:300 sec
GK->1: RCF:TTL 300
GK->0: RCF:TTL 300
SCC->(0 0) <cmd 0>
3000 active @0xab45555a (GK @0xac100d0c)

!--- Call made from voice port 0.

[0]DTMF 1
[0]DTMF 2
[0]DTMF 3
[0]DTMF 4
[0]DTMF #
Calling 1234
SCC->(0 0) <cmd 16>
CLIP\
\SCC->(0 0) <cmd 2>
\<0 0> dial<1234>
GK<-0: ARQ: 0
GK->0: ACF:0:direct call
IRR in 240 sec
CallRasCallBack: 1 33e15eb 33e206b 33e39b0
Connect to <0xac100d28 1720>>..
>>>>>>>> TX CALLER ID : 0x1          0x80 6
Q931<-0:Setup:CRV 25006
Q931->0:Proceeding
Connect H245...
H245 TCP conn ac100d28 11006
CESE/MSDSE start:<0 0 0 0>
capSize = 3
H245->0:Cese
RemoteInputCap <15 5>
RemoteInputCap <15 4>
RemoteInputCap <15 1>
RemoteInputCap <4 11>
MODE FRAME : 11 2
RemoteAudioCap <4 10>
Capability set accepted
H245->0:MSD: <rn tt> = <0x269c 60>
H245->0:CeseAck
H245->0:MsdAck
h323.c 1837: cstate : 3
->H245<0> OLC
H245<-0:LcseOpen
set TX audio to G729/G729A 2 fpp
SetG723Mode: 2 0
H245->0:LcseOpen
H245->0:OLC mode 10
remote OpenLogicalReq G711/G729(10) : 2 fpp
OpenRtpRxPort(0,0x0,4000):14
RTP Rx Init: 0, 0
RTP->0:<0xab45555a 4000>
H245->0:LcseOpenAck
RTP<-0:<0xac100d28 17304>
[0]Enable encoder 18
RTP TX[0]:SSRC_ID = 4af964c0
RTP Tx Init: 0, 0
[0]DPKT 1st: 861812319 861812079, pt 18
Enable LEC adapt [0]=1
H323Dispatcher : 3 3
[0]Received pi=8 in q931
Q931->0:Progress
Q931->0:Connect
SCC:ev=12[0:0] 3 0
Q931->0:ReleaseComplete: reason 16, tone = 13
H245<-0:EndSessionCmd 1
0: Close RTPRX
write TCP err : 13 -33
[0:0]Rel LBRC Res
Q931<-*:ReleaseComplete

!--- ATA side hangs up the call.

write TCP err : 12 -33
GK<-0: DRQ:0

!--- Disconnect request sent by ATA.

SCC:ev=13[0:0] 4 0
[0:0]SCC: Disconnected
GK->0: DCF

!--- Disconnect confirm received.

SCC->(0 0) <cmd 1>
[0]MPT mode 0

无拨号音ATA调试示例

两个语音端口需要一个唯一E.164地址,否则ATA接收从网守的拒绝。在此时间,您将看到ATA 186是异口同声注册的端口作为H.323终端,但是将有无拨号音。

K<-0: GRQ
BMK : gk2
GK->0: GCF:GK@0xac100d0c-1719
BMK : gk2
Secured RRQ
GK<-0: RRQ
GK->0:RRJ: reason 4

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 19084