宽带电缆 : 电缆调制解调器

如何配置位于非 Cisco 电缆调制解调器之后的 Cisco 路由器

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2016 年 4 月 21 日) | 反馈


目录


简介

在非思科有线调制解调器的某些环境(CM)使用和CM中只有能力在桥接上,一个Cisco路由器,例如Cisco 806,可以连接到CM通过以太网接口。路由由在CM后的路由器然后执行。下一步连接客户端PC或客户端前置设备(CPE)到路由器。以后在路由器进行此连接,网络地址转换(NAT)配置。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • 运行Cisco IOSï ¿  ½版本12.2(2)XI的806系列路由器

  • 作为网桥的CM路由器

  • PC作为CPE的运行Windows 2000

  • uBR7246VXR有线调制解调器终端系统(CMTS)

注意: 仅Cisco 806路由器配置在本文显示。关于配置CMTS的更多信息,参考有线技术配置示例和技术说明

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

配置

本部分提供有关如何配置本文档所述功能的信息。

网络图

本文档使用以下网络设置:

http://www.cisco.com/c/dam/en/us/support/docs/broadband-cable/cable-modems/19268-router-behind-cm-19268.gif

配置

本文使用806路由器配置:

806路由器配置
Building configuration...
Current configuration : 1673 bytes
!
version 12.2
no parser cache
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Router
!
logging rate-limit console 10 except errors
enable secret 5 $1$1m1W$uRyUMZQpUAp31C9OM2HQR.
!
username Router password 7 08325C5C00170247425D5506382E2523
username Cisco privilege 15 password 7
134146563C5D020B6F2B793C060703061E2A16706F7E62470C3416
ip subnet-zero
ip name-server 24.29.99.81
ip name-server 24.29.99.82
ip dhcp excluded-address 10.10.10.1 


!--- Issue the ip dhcp excluded-address command to exclude IP 
!--- addresses from being assigned by the DHCP server. This excludes 
!--- E0 IP address.

ip dhcp excluded-address 10.10.10.2
ip dhcp excluded-address 10.10.10.10
ip dhcp excluded-address 10.10.10.3
ip dhcp excluded-address 10.10.10.4
ip dhcp excluded-address 10.10.10.5
ip dhcp excluded-address 10.10.10.6
ip dhcp excluded-address 10.10.10.7
ip dhcp excluded-address 10.10.10.8
ip dhcp excluded-address 10.10.10.9
!
ip dhcp pool CLIENT 

!--- Configures a DHCP address pool.

import all
network 10.10.10.0 255.255.255.0
default-router 10.10.10.1
dns-server 24.29.99.82
!
no ip dhcp-client network-discovery
lcp max-session-starts 0
!
!
!
interface Ethernet0 

!--- This interface connects to the internal network, including CPE.

ip address 10.10.10.1 255.255.255.0
ip nat inside 

!--- IP NAT configuration.

no ip route-cache
no cdp enable
!
interface Ethernet1 

!--- This interface connects to the same Ethernet segment as the CM.
 
ip address dhcp 

!--- This command allows the router to obtain IP address dynamically.

ip nat outside 

!--- IP NAT configuration.

no ip route-cache
no cdp enable
!
ip nat inside source list 102 interface Ethernet1 overload 

!--- IP NAT configuration.

ip classless
ip route 0.0.0.0 0.0.0.0 66.108.112.1

!--- IP address 66.108.112.1 is the next hop IP address, also called 
!--- the default gateway. Your Internet service provider (ISP) can tell you what IP address to 
!--- configure as the next hop address.

ip http server
!
access-list 102 permit ip 10.10.10.0 0.0.0.255 any
line con 0
exec-timeout 120 0
stopbits 1
line vty 0 4
exec-timeout 30 0
login local
length 0
!
scheduler max-task-time 5000
end
Router#

                     

                      
                     

                     

验证

要验证路由器动态地获取在其以太网E1的一个IP地址,请使用show ip interface brief命令

Router#show ip interface brief

Interface                  IP-Address      OK? Method Status Protocol
Ethernet0                  10.10.10.1      YES NVRAM  up    up
Ethernet1                  66.108.115.5    YES DHCP   up    up

保证您的路由表有正确条目。例如,在此显示,默认路由是对66.108.112.1。当路由器收到在以太网接口时的IP地址这通过DHCP过程安装。

Router#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is 66.108.112.1 to network 0.0.0.0
66.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       66.0.0.0/8 is directly connected, Ethernet1
C       66.108.112.0/21 is directly connected, Ethernet1
10.0.0.0/24 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, Ethernet0
S*   0.0.0.0/0 [1/0] via 66.108.112.1

故障排除

当路由器在CM后时连接,也许发生的第一问题在路由器的以太网接口不动态地获取IP地址。多数ISP只允许一个主机或PC在CM后。某ISP分配IP地址到根据主机名的PC。所以,如果有在CM后的一个路由器,然后主机名对于使用hostname命令配置的路由器应该是ISP给的同一个主机名。

如果路由器不动态地获取IP地址,检查的第一件事是,如果interface configuration命令IP地址dhcp存在。此命令在以太网接口下连接对CM。命令在IOS软件版本12.1(2)T介绍。

如果ip address dhcp命令存在,但是在CM后的路由器仍然不获取IP地址,请连接在CM后的PC检测,如果接收IP地址。这验证DHCP服务是工作正常。ISP只典型地允许在CM后的一台主机,因此连接在CM计数后的PC,第一台主机。此条目在ISP数据库依然是24个小时。结果,如果连接在CM后的路由器, ISP认为路由器是第二台主机并且拒绝它。如果这发生,请通过完成在您的Windows 2000 PC:的这些步骤释放您的PC的IP地址

  1. 从开始菜单请选择运行

  2. 键入cmd然后按Return回车。

  3. 在提示符,请键入ipconfig /release

  4. 在发布PC的IP地址以后,请重新启动您的CM并且再试一次。

如果这不工作,您需要呼叫您的ISP和请求他们清除在他们的CMTS的第一主机条目。

另一个方法将配置路由器的以太网接口。使用mac-address ieee-address命令,这连接对与PC的MAC地址的CM。

通过使用在连接对CM作为PC的以太网接口的同一MAC地址, ISP只学习大约一台主机和一个IP地址。PC不被拒绝一次已连接在路由器后。NAT在路由器必须配置接受IP地址转换。

故障排除命令

命令输出解释程序仅限注册用户)(OIT) 支持某些 show 命令。使用 OIT 可查看对 show 命令输出的分析。

注意: 使用 debug 命令之前,请参阅有关 Debug 命令的重要信息

  • debug dhcp detail —请使用debug dhcp detail命令显示DHCP调试信息。这用于排除故障Cisco路由器为什么失败获取以太网接口的一个IP地址。

  • debug ip dhcp server [events] [linkage] [packet] —请使用debug ip dhcp server命令显示DHCP服务器调试。这帮助确定PC,连接到路由器,为什么失败获取IP地址。


相关信息


Document ID: 19268