服务质量 (QoS) : QoS 策略

在帧中继 PVC 上配置数据包标记

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 22 日) | 反馈


目录


简介

此本文探讨了支持的命令配置在帧中继接口的数据包标记。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档不限于特定的软件或硬件版本。

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

基于等级的信息包标记

基于等级的信息包标记使用集合命令和模块化服务质量(QoS)命令行界面(CLI)的其他命令更改一个字段的值信息包报头的。

当前思科IOSï ¿  ½软件版本允许您执行这些操作:

  • 设置IP优先级位或IP差分服务代码点在IP服务类型(Tos)字节。

  • 设置Layer2业务类别(CoS)值。

  • 连结一个本地Qos类别值与数据包。

  • 更改设置在一数据包的ATM报头的信元丢失优先权(CLP)位从0的到1。

支持两项输入和输出策略。当您配置基于分类的营销时,请注释这些限制:

  • 输出策略要求帧中继流量整形(FRTS)。

  • 支持仅Cisco快速转发交换的数据包。

  • 包含set atm-clp命令的策略映射可以附加作为仅输出策略。

这是示例DSCP值如何设置:

配置示例-基于分类的营销
class-map user1
  match access-group 101
!
class-map user2
  match access-group 102
!
policy-map dscp
  class user1
    set ip dscp AF11
  class user2
    set ip dscp AF12
!
map-class frame set-dscp
  service-policy input dscp
!
int s0/0/0:0
 no ip address
 encapsulation frame-relay
 frame-relay traffic-shaping
!
int s0/0/0:0.125
 frame-relay interface-dlci 125
  class set-dscp

设置可丢弃位

模块化QoS CLI支持两命令更改丢弃资格(DE)位的值帧中继帧的。那些命令是set fr-de与基于等级的整形和set-frde-transmit与基于类的策略。

注意: set-frde-transmit命令不适用于通过在MPLS (原子)的任何传输传输的帧中继流量。

帧中继支持一两层的信息包优先级划分方案使用DE位。最初,仅网络设备,例如帧中继交换机,设置DE位指示帧的相对重要性。在最近的Cisco IOS软件版本中,路由器能当前设置DE位。

下个图表说明帧中继帧的格式。DE位是控制帧中继拥塞通知机制三个位的之一。

/image/gif/paws/18662/config_fr_pvc.gif

发出这些命令监控基于分类的营销:

  • show frame-relay PVC —显示所有永久虚拟电路(PVC)组件的统计信息。这包括这些统计信息:

    • FRTS和服务策略信息

    • 分段

    • 数据包数量里里外外

    • 帧数量有后向显式拥塞通知(BECN)、前向显式拥塞通知(FECN)和DE bits集的

配置示例-匹配在DE位
class-map match-fr-de
  match fr-de

!--- Define a class-map named “match-fr-de” to match packets with the FR DE bit set.

!
policy-map set-de
  class match-fr-de
   set ip precedence 1

!--- All packets that match the class have IP precedence set to 1.

!
map-class frame-relay pvc150
   service-policy input set-DE

!--- Apply the policy map to the map class.

!
interface Serial0.1 point-to-point
   frame-relay class pvc150
   frame-relay interface-dlci 150

!--- Associate a map class to the Frame Relay data-link connection identifier (DLCI).

Router# show policy-map interface s0.1

Serial0.1

 Service-policy input: set-prec

   Class-map: match-fr-de (match-all)
     358 packets, 103820 bytes
     30 second offered rate 18000 bps, drop rate 0 BPS  Match: fr-de
     QoS Set
       ip precedence  1
         Packets marked 359

   Class-map: class-default (match-any)
     643 packets, 186470 bytes
     30 second offered rate 32000 BPS, drop rate 0 BPS
     Match: any  (1201)

Cisco IOS软件版本12.2(2)T设置与set-frde-transmit选项的DE位的介绍的支持作为police命令一部分。欲知更多信息, (参考流量监管。)设置DE位可以也是有用的,当使用用速率限制机制,类似基于类的策略。这样QoS策略目标将传送有帧中继和DE位的不达标的信息包,在拥塞状况期间,因此下行交换机能潜在降低所有不达标的数据流。

注意: 虽然基于类的策略支持数据包标记,推荐您使用此功能,只有当需要标记数据包避免运行他们通过策略的令牌桶机制。

下配置示例使用police命令对800 Kbps限制总流量。一致的所有流量传送与IP优先级7和所有不达标的数据流有DE位。

配置示例-设置DE位
policy-map set-DE
  class class-default
   police 800000 1000 1000 conform-action
   set-prec-transmit 7 exceed-action set-frde-transmit
   violate-action set-frde-transmit
!
map-class frame-relay pvc100
  frame-relay traffic-rate 1000000
  frame-relay mincir 1000000
  service-policy input set-DE
!
interface S0/0
 no ip address
 encapsulation frame-relay
 frame-relay traffic-shaping
!
interface Serial0/0.1 point-to-point
  ip address 10.1.1.1 255.255.255.252
  no ip directed-broadcast
  frame-relay class pvc100
  frame-relay interface-dlci 100

router# show policy-map set-DE

 Policy Map set-DE
    Class class-default
      police 800000 1000 1000 conform-action
      set-prec-transmit 7 exceed-action
      set-frde-transmit violate-action
      set-frde-transmit

router# show frame-relay PVC 100

PVC Statistics for interface Serial0 (Frame Relay DTE)

DLCI = 100, DLCI USAGE = LOCAL, PVC STATUS = STATIC, INTERFACE = Serial0/0.1

input pkts 0       output pkts 13000    in bytes 0
out bytes 3770000  dropped pkts 0       in FECN pkts 0
in BECN pkts 0     out FECN pkts 0      out BECN pkts 0
in DE pkts 0       out DE pkts 4447
out bcast pkts 0   out bcast bytes 0
PVC create time 00:51:50, last time PVC status changed 00:51:50

service policy set-DE

  Service-policy output: set-DE (1069)

   Class-map: class-default (match-any) (1071/2)
     11519 packets, 3340510 bytes
     30 second offered rate 1140000 BPS, drop rate 0bps
      Match: ip precedence 1  (1075)
      police:
        800000 BPS, 1000 limit, 1000 extended limit
        conformed 4448 packets, 1289920 bytes; action:
        set-prec-transmit 7
        exceeded 11 packets, 3190 bytes; action:
        set-frde-transmit
        violated 8475 packets, 2457750 bytes; action:
        set-frde-transmit
        conformed 394000 BPS, exceed 1000 BPS violate
        749000 BPS
   Output queue size 20/max total 600/drops 1451

当您测试您的配置时,请注释此信息:

  • 基于分类的营销要求Cisco快速转发。如果已经没有启用,发出ip cef命令在全局配置模式,启用Cisco快速转发。

  • 最初,基于分类的营销仅应用到Cisco快速转发交换的数据包。因此,您不会看到增加匹配信息包计数器,如果使用ping生成在同一路由器的流量,因为这样数据包被过程交换。

  • 路由器生成的信息包基于分类的营销的支持在Cisco IOS软件版本12.2(6.8)T介绍。

选择在哪里应用服务策略

在Cisco 7200系列,必须在映射类别内应用Cisco 2600/3600系列和其他非路由/交换处理器(RSP)平台,服务策略;它不可能应用直接地到帧中继PVC。输出策略要求FRTS,您用frame-relay traffic-shaping命令启用。此命令配置PVC队列。因此,应该通常配置服务策略在DLCI配置模式或在PVC。

在当前Cisco IOS软件版本中,帧中继接口支持策略映射的应用程序(用service-policy命令)对接口、子接口和VC。此表列出策略的支持的组合:

输入策略 输出策略
支持在一个逻辑接口。支持在必须是对等体的多个逻辑接口,例如多条PVC。

注意: 主接口和子接口不是对等体接口,并且不可以同时支持服务策略。

同时支持在一两个逻辑接口。有效组合:
  • PVC和主接口
  • 子接口和主接口
无效的组合:
  • PVC和子接口
  • PVC、子接口和主接口

最初,一个服务策略的配置用set命令直接地在主接口没有标记子接口数据流。这说明此问题症状:

Interface Serial5/1:1
no ip address
 encapsulation frame-relay
 no keepalive
 service-policy output set

!--- Avoid the placement of a service policy on a main interface.

 no fair-queue
 frame-relay class data-map
 frame-relay traffic-shaping
!
interface Serial5/1:1.1 point-to-point
 ip address 23.0.0.2 255.0.0.0
 frame-relay interface-dlci 300

giulia# show policy-map interface

 Serial5/1:1

  Service-policy output: set

    Class-map: prec-0 (match-all)
      100 packets, 10400 bytes

!--- Packets are classified correctly.

      5 minute offered rate 0 BPS, drop rate 0 BPS
      Match: ip precedence 0
      QoS Set
        ip precedence 1
          Packets marked 0

!--- No packets are marked.


    Class-map: class-default (match-any)
      0 packets, 0 bytes
      5 minute offered rate 0 BPS, drop rate 0 BPS
      Match: any

作为应急方案,请运用服务策略对子接口。

传统语法 - DE 列表

在不支持新的思科模块化QoS CLI语法的Cisco IOS软件版本中,您能使用思科legacy DE marking语法设置DE位。传统语法使用DE识别数据包特性有资袼丢弃的lists,并且受影响的您能也指定DE组识别DLCI。

Router(config)# frame-relay de-list list-number 
              {protocol protocol | interface typenumber} characteristic


!--- Issue this command on one line.

您能创建DE根据多种特性协议或根据接口和的lists例如数据包、特定传输控制协议(TPC)或用户数据报协议(UDP)端口,访问列表编号或者数据包大小的分段。欲知详情参考frame-relay de-list命令Cisco IOS Wide-area networking命令reference

要定义指定受影响的DE列表和DLCI的DE group,请发出frame-relay de-group组号DLCI in命令接口配置模式。


相关信息


Document ID: 18662