服务质量 (QoS) : QoS 策略

在帧中继 PVC 上配置 CBWFQ

2016 年 10 月 27 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 22 日) | 反馈


目录


简介

本文为配置基于类别的加权公平队列(CBWFQ)提供配置示例在帧中继接口。CBWFQ用bandwidth命令启用,如一策略映射所配置的一样用模块化服务质量命令行界面(服务质量命令行接口)的命令。

开始使用前

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

先决条件

本文档没有任何特定的前提条件。

使用的组件

CBWFQ自以下思科IOSï ¿  ½软件版本支持根据平台:

  • Cisco 7500系列与多功能接口处理器(VIP) (分布式CBWFQ) - 12.1(5)T

  • Cisco 7200系列, 2600/3600系列和其他non-7500系列平台- 12.1(2)T

本文档中的信息都是基于特定实验室环境中的设备创建的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您是在真实网络上操作,请确保您在使用任何命令前已经了解其潜在影响。

整形与排队

排队通常使用在shaping中,减少输出速率和因而导致拥塞。以以下整形机制和命令使用CBWFQ根据您的平台。

  Cisco 7500 系列 Cisco7200, 3600, 2600和其他非VIP平台
支持的整形机制 分布式流量整形 帧中继流量整形(帧中继TS)
配置命令 shape命令在策略映射 在主接口的帧中继的流量整映射组配置发出命令指定整形参数
要求Distributed Cisco Express Forwarding (DCEF) 是(请用show cef linecard命令验证)

Cisco7200, 3600, 2600系列

Cisco IOS 12.1(2)T引入CBWFQ的支持在7200, 2600/3600和其他非路由交换处理器平台。欲知更多信息, (参考低延迟队列(LLQ)在帧中继。)在这些平台上,在帧中继接口的CBWFQ总是在帧中继TS中。请使用frame-relay traffic-shaping命令启用帧中继TS。您不能以通用流量整形(GTS)和shape命令使用CBWFQ在这些平台。下面提供配置示例。

CBWFQ配置示例在Cisco7200的, 3600, 2600系列
 policy-map mypolicy 
  class voice 
   priority 16 
  class priority-data 
   bandwidth 16 

!--- Create a policy-map and apply the bandwidth 
!--- command to a class. 

! 
 int s0/0 
  encapsulation frame-relay IETF 
  load-interval 30 
  frame-relay traffic-shaping 

!--- Enable Frame Relay TS. 

! 
 interface Serial0/0.1 point-to-point 
  frame-relay interface-dlci 100 
    class frclass 

!--- Apply the map-class to the Frame Relay PVC. 

! 
 map-class frame-relay frclass 
  service-policy output mypolicy 
  frame-relay cir 64000 
  frame-relay bc 640 

!--- Apply the service policy inside the map-class.

注意: 如果启用一个服务策略直接地在主接口和不在映射种类命令内,您不能也应用帧中继TS直接地到接口。请注意排队机制然后适用于单个大接口队列而不是对每虚电路(VC)队列

在Cisco 7200系列,从Cisco IOS软件版本12.0(26)S和以后,再配置在frame-relay map-class命令的一个输出服务策略是不可能的。反而应该应用Cisco 7500配置按照以下部分说明。应该配置一分层的策略映射与在父策略的在子策略的shaping和队列。应该然后附加父策略到主或子接口。如果设法配置在map-class frame-relay命令的服务策略输出,以下错误消息将出现:

c7200(config)#map-class frame-relay
	 stef
c7200(config-map-class)#frame-relay cir
	 64000
c7200(config-map-class)#service-policy output
	 aan
Frame relay output service policy is not
	 supported

Cisco 7500 系列

自Cisco IOS 12.1(5)T, QoS策略在VIP的分布式模式必须运行;因为不再支持基于RSP的QoS。因此,您必须使用模块化QoS CLI的shape命令和其他命令实现帧中继接口的DTS在Cisco 7500系列的VIP。DTS结合GTS和帧中继TS。配置示例在配置提供分布式流量整形以下。

DTS配置示例与分级策略的
ip cef distributed 
 !  
 class-map 1  
   match < >  

!--- Define match-on criteria.

 class-map 2  
   match < >

!--- Define match-on criteria.

 !  
 policy-map CBWFQ  
   class 1  
     bandwidth < >  
     !-- Define value in kbps or percent.  
   class 2  
     priority < > 
 
!--- Define value in kbps or percent.

 !  
 Policy-map SHAPE  
    class class-default  
     shape average    
     service-policy CBWFQ  
 !  
 int s0/0/0  
   encapsulation frame-relay  
   ip route-cache distributed  
 !  
 int s0/0/0.1 point-to-point  
   ip address a.b.c.d  
   frame-relay interface-dlci xxx  
    class cisco  
 !  
 map-class frame-relay cisco  
   service-policy output SHAPE

选择在哪里应用服务策略

当配置CBWFQ时,您使用模块化QoS CLI的命令创建与多个数据流种类和一个或更多QoS功能的一个数据流策略图。在Cisco IOS软件中当前版本,帧中继接口支持应用一策略映射用service-policy命令对接口、子接口和VC。当前支持策略的仅正确组合。下表特别地描述您能运用与流量整形的地方QoS策略。

  Cisco 7500 系列 Cisco7200, 2600/3600系列和其他平台
主要 接口 配置在主接口的一个服务策略 支持,只有当帧中继TS没有启用和排队机制适用于单个接口管道。
子接口 配置在子接口的一servicepolicy。 配置在帧中继映射种类内的一个服务策略并且启用每个vc队列用frame-relay traffic-shaping命令。您能运用映射类别到子接口。
VC级别   配置在帧中继映射种类内的一个服务策略并且启用每个vc队列用frame-relay traffic-shaping命令。您能运用映射类别到VC。

已知问题

当配置在帧中继接口时的CBWFQ,请注释以下警告:

  • 在路由器重新加载后,服务策略的信息包匹配计数器可能不增加,当策略应用对主接口时。保证解决此问题加权公平排队(WFQ)分类标志从主接口复制到子接口。

  • LLQ和帧中继TS在物理接口接口级别不同時支持配置。路由器从运行的配置取消服务策略在路由器重启以后。当帧中继TS在接口时,启用必须附加服务策略到映射类别。尝试配置此组合导致错误消息CBWFQ :不支持在此接口

  • 当与CBWFQ的一个服务策略应用直接地对帧中继主接口(例如,非每VC的排队),策略可能删除根据路由器重启,如果带宽说明在子接口和主接口配置。路由器可能汇报日志消息类似于以下:

    CBWFQ: Not enough available bandwidth for all classes Available 44 (kbps) 
        Needed 1 00 (kbps)
        CBWFQ: Removing service policy on Serial1/0

    更改CBWFQ行为解决此问题忽略通知,当在子接口的带宽更改时,因为CBWFQ可以一个仅帧中继映射种类的外部配置在主接口接口级别。作为应急方案,请从子接口删除bandwidth命令。如果使用在子接口的带宽影响路由度量,请使用一替代方法类似开销,正如在开放最短路径优先(OSPF)或延迟,正如在增强的内部网关路由选择协议(EIGRP)。

配置注释

  • 带宽优先级命令计算带宽总量在实体时的联机,以下指南被调用,当实体是一个整形的帧中继永久虚拟电路时(PVC) :

    • 如果未配置最低可接受的承诺信息速率 (minCIR),则将 CIR 除以 2。

    • 如果配置了 minCIR,则在计算中使用此 minCIR。

    • 上述速率的全部带宽可以分配给带宽类和优先级类。因此,帧中继PVC不支持max-reserved-bandwidth命令,虽然您应该保重保证带宽配置的相当数量是足够大也适应Layer2 (L2)开销。欲知更多信息,参考什么字节通过IP到ATM CO排队计数?

  • 避免设置CIR或mincir以接入速率。否则,可以发现输出队列加强和导致大延迟的您的CBWFQ类。原因是形状速率不考虑到标志和循环冗余冗余校验(CRC)领域的开销字节,因此shaping以线路速率实际上过度预定和导致接口拥塞。确实没有原因整形以接入速率。您总是应该流量形状在接入速率的95百分比或,通常,聚集整形的速率应该总是95百分比在接入速率之下。

  • 当FRF.12配置时,输出队列大小增加适应当前被分段的同一字节数。换句话说,您从信息包队列去片段队列。

  • WFQ每个VC在Cisco IOS软件版本12.0(7)T包括。

  • 与GTS的CBWFQ在Cisco IOS软件版本12.1(2)T包括。


相关信息


Document ID: 18661