广域网 : 帧中继

配置使用FRTS的基于类的加权公平排队

2016 年 10 月 27 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

本文为基于类别的加权公平队列(CBWFQ)提供一配置示例以帧中继流量整形(FRTS)。

CBWFQ扩大标准的加权公平排队(WFQ)功能为用户定义的数据流类别提供支持。FRTS使用在帧中继网络的队列限制能导致拥塞的电涌。数据缓冲然后发送到在调控的总数的网络保证在被承诺的流量信封内的流量适应特定的连接的。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

CBWFQ自以下Cisco IOS�软件版本支持根据平台:

  • Cisco 7500系列与多功能接口处理器(VIP) (分布式CBWFQ) - Cisco IOS软件版本12.1(5)T

  • Cisco 7200系列, 2600/3600系列和其他non-7500系列平台- Cisco IOS软件版本12.1(2)T

然而用于此配置文件的两路由器运行Cisco IOS软件版本12.2(2)。

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

为什么以FRTS使用CBWFQ ?

如果有保护特定的数据,使用特定类, CBWFQ提供一个方式进一步指定此数据。使用CBWFQ,为类指定的重要性变为匹配类标准的重要性每数据包。此权重来自于您分配到类的带宽。WFQ然后应用对这些类,而不是应用对流,并且类能包括几个流。

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 要查找本文档所用命令的其他信息,请使用命令查找工具仅限注册用户)。

表下面的提供对您在配置方面也许发现的条目的快速参考指南:

字段 说明
FR接口 输出接口。
子接口 逻辑接口。
DLCI 数据链路连接标识符。指定一个永久虚拟电路(PVC)或交换虚拟电路(SVC)在帧中继网络的值。
类XXX 应用map-class frame-relay XXX。
map-class frame-relay XXX FRTS参数。
服务策略ZZZ CBWFQ.
策略映射ZZZ 指定策略。
类YYY 给出类。
带宽,管制,优先级 此的特定流。
class class-default 语法和拼写事态,当创建您的默认组时。
class-map match-all YYY 设立数据包核对的匹配标准。
match access-group 101 附加类映射对访问列表。
access-list 101 permit ip any any 正常访问列表。

注意: Cisco 7500系列常见问题解答自Cisco IOS软件版本12.1(5)T,服务质量(QoS)策略在多用途接口处理器的分布式模式必须运行,因为路由/交换处理器(RSP) -不再支持基于QoS。所以,请使用shape命令和其他命令模块化QoS命令行界面(CLI)实现帧中继接口的分布式流量整形在Cisco 7500系列的VIP。DTS结合通用流量整形(GTS)和FRTS。

必须步骤

配置与FRTS的CBWFQ包括以下三个必须步骤:

  1. 定义类映射(类映射)。

    设立数据包被检查确定的匹配标准是否属于类。

  2. 配置策略映射(策略映射)和定义类(类)。

    指定策略映射的名称。关联带宽保证、管制和优先级的规格对每数据流类别。此进程需要带宽的配置,等等,应用到属于到其中一的数据包以前定义类映射。对于此进程,请配置指定每数据流类别的策略的策略映射。

  3. 附加服务策略对FRTS映射类别(服务策略)。

    附加建议的策略识别与特定服务策略对映射类别(和因而map-class frame-relay应用)的DLCI或者子接口。

网络图

本文档使用下图所示的网络设置。

/image/gif/paws/17920/traffic_shaping.gif

以上的网络图使用以下值:

  • HUB -物理速率= 192 Kbps,承诺速率= 32 Kbps

  • 远程-物理速率= 64 Kbps,承诺速率= 32 Kbps

配置

本文档使用如下所示的配置。

有配置的CBWFQ的集线器
<snip> 
!
class-map match-all YYY
  match access-group 101
!
!
policy-map ZZZ
  class YYY
   bandwidth percent 50
<snip>
interface Serial0/0 
  no ip address 
  encapsulation frame-relay 
  no fair-queue 
  frame-relay traffic-shaping 

 interface Serial0/0.1 point-to-point 
  ip address 10.1.1.1 255.255.255.0 
  frame-relay interface-dlci 16  
  frame-relay class XXX 
 ! 
 map-class frame-relay XXX 
  frame-relay cir 64000  
  frame-relay mincir 32000 
  frame-relay adaptive-shaping becn 
  frame-relay bc 8000
  service-policy output ZZZ
<snip>
!
access-list 101 permit ip host 10.0.0.1 host 11.0.0.1

远程
interface Serial0/0 
no ip address 
encapsulation frame-relay 
no fair-queue 
frame-relay traffic-shaping 
! 
interface Serial0/0.1 point-to-point 
ip address 10.1.1.2 255.255.255.0 
frame-relay interface-dlci 16  
frame-relay class XXX 
! 
map-class frame-relay XXX 
frame-relay cir 64000 
frame-relay mincir 32000 
frame-relay adaptive-shaping becn 
frame-relay bc 8000 
!

验证

本部分所提供的信息可用于确认您的配置是否正常工作。

命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

  • show frame-relay PVC -显示关于PVC的统计信息帧中继接口的。

  • show policy-map -显示包括指定的服务策略映射的所有类的配置或所有现有策略的所有类映射。

  • show policy-map [interface] -显示为在指定的接口的所有服务策略配置的所有类的配置或显示服务策略的类在接口的特定PVC的。

下列是输出示例: show frame-relay pvc命令

Hubrouter#show frame-relay pvc [interface interface ][dlci]
PVC Statistics for interface Serial0/0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          0            1            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 16, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0.1

  input pkts 0             output pkts 0            in bytes 0
  out bytes 0              dropped pkts 0           in pkts dropped 0
  out pkts dropped 0       out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 0         out bcast bytes 0
  pvc create time 00:01:12, last time pvc status changed 00:01:12
Hubrouter#

您能以此命令使用以下语法:

  • 接口- (可选)指示PVC信息显示的一个特定接口。

  • 接口- (包含您希望显示PVC信息的DLCI的可选)接口号。

  • DLCI - (在接口使用的可选) A特定DLCI号码。当DLCI也指定时,指定的PVC的统计信息显示。

下列是输出示例: show policy-map命令

Hubrouter#show policy-map 
   Policy Map ZZZ 
    Class YYY 
      Weighted Fair Queueing 
            Bandwidth 50 (%) Max Threshold 64 (packets) 
    Class WWW 
      Weighted Fair Queueing 
            Bandwidth 25 (%) Max Threshold 64 (packets)

下列是show policy-map [interface]的输出示例:。

 Hubrouter#show policy-map interface s0/0.1 
  Serial 0/0.1: DLCI 16 
  Service-policy output: ZZZ (1057) 
    Class-map: YYY (match-all) (1059/2) 
      0 packets, 0 bytes 
      30 second offered rate 0 bps, drop rate 0 bps 
      Match: access-group 101 (1063) 
      Weighted Fair Queueing 
        Output Queue: Conversation 73 
        Bandwidth 50 (%) Max Threshold 64 (packets) 
        (pkts matched/bytes matched) 0/0 
        (depth/total drops/no-buffer drops) 0/0/0 
    Class-map: WWW (match-all) (1067/3) 
      0 packets, 0 bytes 
      30 second offered rate 0 bps, drop rate 0 bps 
      Match: access-group 102 (1071) 
      Weighted Fair Queueing 
        Output Queue: Conversation 74 
        Bandwidth 25 (%) Max Threshold 64 (packets) 
        (pkts matched/bytes matched) 0/0 
        (depth/total drops/no-buffer drops) 0/0/0 
    Class-map: class-default (match-any) (1075/0) 
         2 packets, 706 bytes 
         30 second offered rate 0 bps, drop rate 0 bps    
         Match: any  (1079)

您在相似的配置方面可以也发现的其他期限如下解释:

  • CIR -承诺信息速率。帧中继网络同意转接信息通常情况下的速率,被平均在时间最低增量。

  • FIFO队列-先进先出排队。FIFO介入缓冲和转发数据包按到达的顺序。FIFO不实现优先级或流量等级的概念。只有一个队列,并且所有信息包均等地被对待。数据包被派出一个接口按他们到达的顺序。

故障排除

目前没有针对此配置的故障排除信息。


相关信息


Document ID: 17920