局域网交换 : 交换机间链路 (ISL)

在 Cisco 路由器上配置 ISL 干线

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 11 月 11 日) | 反馈


目录


简介

本文讨论Inter-Switch Link (ISL)协议(ISL)中继的配置在外部Cisco路由器的类似7500/7000, 3600, 4500或者2500系列。本文不讨论ISL中继线的配置在Layer2的(L2)/Layer 3 (L3)交换机类似思科Catalyst 6500或4500。

关于配置ISL和802.1q中继的信息在运行Catalyst OS的Catalyst L2和L3交换机之间(CatOS)或思科IOSï ¿  ½软件,参考这些之一:

先决条件

要求

本文档的读者应掌握以下这些主题的相关知识:

  • 在Catalyst交换机的ISL支持

    ISL支持为Catalyst交换机是根据依赖的。当您联络外部路由器到Catalyst 6500/6000时, 5500/5000或4500/4000交换机,使用这些命令之一确定封装支持每个模块:

    • CatOS — show port capabilities

    • Cisco IOS软件— show interfaces功能

  • 在Cisco路由器的ISL支持

    在Cisco IOS软件版本11.2及以上版本,仅a加上特性组是必要的。正特性组是IP Plus或桌面加上。所有快速以太网或千兆以太网接口在路由器支持ISL VLAN建立中继。

    在Cisco IOS软件版本11.3和前,仅IP和互联网分组交换与IEEE 802.3 (Novell以太)封装有支持在ISL。Cisco IOS软件版本11.3已添加另外的封装和协议。

使用的组件

本文档不限于特定的软件和硬件版本。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

背景信息

VLAN是逻辑广播域。为了允许数据横断在两VLAN之间或者广播域,您必须使用第3层设备路由在VLAN之间。七层开放式系统互联(OSI)型号定义了此规则。这些设备中的任一个能完成此路由:

  • 一个外部路由器,例如2500, 4000或者7000

  • 一个内部路由器,例如多层交换机特性卡(MSFC)

  • 一个外部设备用路由软件,类似运行已路由或装门的UNIX主机

原始方法将连接路由器的一个不同的物理端口对每单个VLAN。当VLAN数量增加,此方法变得非常昂贵。但是有一个更加好的方法。网络管理员能决定使用VLAN中继分配多个VLAN到单个路由接口。有100 MB的路由器或仅更加快速的以太网端口能执行VLAN中继。

VLAN中继在识别VLAN数据包属于的数据包允许100 MB快速以太网或1000 MB千兆以太网接口放置标记。当ISL中继线的另一端收到此标记信息包时, ISL中继线在正确VLAN安置数据包。ISL标记是在快速以太网帧附近被添加的30字节报头。所以, ISL是点对点技术和只运作在支持在100 MB快速以太网或1000 MB千兆以太网接口的ISL的两Cisco交换机或路由器之间。

此图提供ISL中继线的一视觉说明:

/image/gif/paws/17051/24a.gif

配置

完成这些步骤:

  1. 连接路由器到交换机用有使用的支持ISL的端口适当电缆。

    请使用直通类别5或光缆。

  2. 确保您创建在Catalyst交换机侧的VLAN,并且您配置交换机端口是ISL中继端口。

    注意: 切记Cisco路由器不能协商动态中继协议(DTP)或Dynamic Interswitch Link Protocol (DISL)帧。所以,您必须配置中继模式是在转换面的nonegotiate。参考的toï ¿  ½配置ISL和802.1q中继在CatOS交换机和外部路由器(InterVLAN路由)或本文之间相关信息部分的本文。

  3. 开始定义在路由器的VLAN。

    确保您了解配置的什么L2和L3信息为每个VLAN。这包括IP地址、IPX网络编号和其他信息。

version 11.3
no service password-encryption
!
hostname lt-4500-static
!
enable secret 5 $1$XqiP$3ADCgrFMC21pwyVQIkith.
!
no ip domain-lookup
appletalk routing
ipx routing 0000.0c0b.f2f5
!
!
interface FastEthernet0              

!--- Only Layer 1 is configured here.

 no ip address
 full-duplex             
!
interface FastEthernet0.1            

!--- All L2 and L3 are on subinterfaces.

 encapsulation isl 1                 

!--- This defines ISL encapsulation and the VLAN number.

 ip address 10.6.1.220 255.255.255.0
 no ip redirects           
 appletalk cable-range 100-100 100.149
 appletalk zone cisco
 ipx network ABC encapsulation SAP
!
interface FastEthernet0.2
 encapsulation isl 2
 ip address 10.7.1.220 255.255.255.0
 no ip redirects
 appletalk cable-range 200-200 200.135
 appletalk zone cisco1
 ipx network DEADBEEF encapsulation ARPA
!
interface FastEthernet0.3
 encapsulation isl 3
 ip address 10.8.1.220 255.255.255.0
 no ip redirects
 appletalk cable-range 300-300 300.69
 appletalk zone cisco2
 ipx network 1234 encapsulation SNAP
!
ip classless
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

在您配置其他L2或L3信息前,您需要配置encapsulation isl vlan-命令。子接口不必须匹配VLAN ID号。然而,匹配做管理并且排除故障更加容易VLAN的问题。

您必须使用子接口避免水平分割规则的侵害。水平分割规则由路由器禁止一个路由的广告通过接口路由器使用到达目的地。此方法是非常类似的使用点对点子接口用帧中继在WAN环境。

调试并且排除故障

一旦验证您的配置、Cisco IOS软件和硬件平台正确,您需要验证事正确地运作。请使用in命令此部分对检验操作并且排除故障问题。

注意: 命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

注意: 在发出 debug 命令之前,请参阅有关 Debug 命令的重要信息

  • show VLAN —此命令告诉您什么L2或L3信息为每个VLAN配置。

    lt-4500-static# show vlan
    Virtual LAN ID:  1 (Inter Switch Link Encapsulation)
    vLAN Trunk Interface:   FastEthernet0.1       
       Protocols Configured:   Address:              Received:        Transmitted:
               IP              10.6.1.220                   0                   0
           IPX (SAP)        ABC.0000.0c0b.f2f5              0                   8
             AppleTalk           100.149                    0                  22
    Virtual LAN ID:  2 (Inter Switch Link Encapsulation)
    vLAN Trunk Interface:   FastEthernet0.2       
       Protocols Configured:   Address:              Received:        Transmitted:
               IP              10.7.1.220                   0                   0
        IPX (ARPA)     DEADBEEF.0000.0c0b.f2f5              0                   8
             AppleTalk           200.135                    0                  22
    Virtual LAN ID:  3 (Inter Switch Link Encapsulation)
    vLAN Trunk Interface:   FastEthernet0.3       
       Protocols Configured:   Address:              Received:        Transmitted:
               IP              10.8.1.220                   0                   0
           IPX (SNAP)      1234.0000.0c0b.f2f5              0                   9
             AppleTalk           300.69                     0                  23
    
  • show interface —此命令告诉您接口和子接口的状态,以及子接口的VLAN颜色。VLAN颜色是相同的象VLAN号。

    lt-4500-static# show interface
    FastEthernet0 is up, line protocol is up 
      Hardware is DEC21140, address is 0000.0c0b.f2f5 (bia 0000.0c0b.f2f5)
      MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec, rely 255/255, load 1/255
      Encapsulation ARPA, loopback not set, keepalive set (10 sec)
      Full-duplex, 100Mb/s, 100BaseTX/FX
      ARP type: ARPA, ARP Timeout 04:00:00
      Last input 00:00:00, output 00:00:03, output hang never
      Last clearing of "show interface" counters 00:04:25
      Queueing strategy: fifo
      Output queue 0/40, 0 drops; input queue 0/75, 0 drops
      5 minute input rate 0 bits/sec, 1 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
         415 packets input, 25392 bytes, 0 no buffer
         Received 415 broadcasts, 0 runts, 0 giants, 0 throttles
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
         0 watchdog, 0 multicast
         0 input packets with dribble condition detected
         137 packets output, 12378 bytes, 0 underruns
         0 output errors, 0 collisions, 0 interface resets
         0 babbles, 0 late collision, 0 deferred
         0 lost carrier, 0 no carrier
         0 output buffer failures, 0 output buffers swapped out
    FastEthernet0.1 is up, line protocol is up 
      Hardware is DEC21140, address is 0000.0c0b.f2f5 (bia 0000.0c0b.f2f5)
      Internet address is 10.6.1.220/24
      MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec, rely 255/255, load 1/255
      Encapsulation ISL Virtual LAN, Color 1.
      ARP type: ARPA, ARP Timeout 04:00:00
    FastEthernet0.2 is up, line protocol is up 
      Hardware is DEC21140, address is 0000.0c0b.f2f5 (bia 0000.0c0b.f2f5)
      Internet address is 10.7.1.220/24
      MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec, rely 255/255, load 1/255
      Encapsulation ISL Virtual LAN, Color 2.
      ARP type: ARPA, ARP Timeout 04:00:00
    FastEthernet0.3 is up, line protocol is up 
      Hardware is DEC21140, address is 0000.0c0b.f2f5 (bia 0000.0c0b.f2f5)
      Internet address is 10.8.1.220/24
      MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec, rely 255/255, load 1/255
      Encapsulation ISL Virtual LAN, Color 3.
      ARP type: ARPA, ARP Timeout 04:00:00
    
  • 显示{ip|ipx|AppleTalk}路由—此命令告诉您正确ISL子接口是学习或发送路由信息。

    lt-4500-static# show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
           U - per-user static route, o - ODR
    Gateway of last resort is not set
          10.0.0.0/24 is subnetted, 3 subnets
    C       10.8.1.0 is directly connected, FastEthernet0.3
    C       10.7.1.0 is directly connected, FastEthernet0.2
    C       10.6.1.0 is directly connected, FastEthernet0.1
    
    lt-4500-static# show appletalk route
    Codes: R - RTMP derived, E - EIGRP derived, C - connected, A - AURP
           S - static  P - proxy 
    3 routes in internet
    The first zone listed for each entry is its default (primary) zone.
    C Net 100-100 directly connected, Fa0.1, zone cisco
    C Net 200-200 directly connected, Fa0.2, zone cisco1
    C Net 300-300 directly connected, Fa0.3, zone cisco2
    
    lt-4500-static# show ipx route
    Codes: C - Connected primary network,    c - Connected secondary network
           S - Static, F - Floating static, L - Local (internal), W - IPXWAN
           R - RIP, E - EIGRP, N - NLSP, X - External, A - Aggregate
           s - seconds, u - uses, U - Per-user static
    3 Total IPX routes. Up to 1 parallel paths and 16 hops allowed.
    No default route known.
    C        ABC (ISL vLAN),      Fa0.1
    C       1234 (ISL vLAN),      Fa0.3
    C   DEADBEEF (ISL vLAN),      Fa0.2
    
  • debug VLAN packet —此命令告诉您,如果有数据包的误配置在ISL中继线的或,如果错误的ISL子接口是发送或接收数据包。

    警告 警告: 总是,当您使用其中任一debug命令时,小心。调试指令能导致在路由器的严重性能问题。对禁用调试,请发出undebug all命令

    lt-4500-static# debug vlan packet
    Virtual LAN packet information debugging is on
    lt-4500-static#
    vLAN: Received ISL encapsulated UNKNOWN packet bearing colour ID 2
          on interface FastEthernet0.2 which is not configured to
          route or bridge this packet type.
    vLAN: Received ISL encapsulated UNKNOWN packet bearing colour ID 1
          on interface FastEthernet0.1 which is not configured to
          route or bridge this packet type.
    vLAN: Received ISL encapsulated UNKNOWN packet bearing colour ID 3
          on interface FastEthernet0.3 which is not configured to
          route or bridge this packet type.
    vLAN: ISL packet received bearing colour ID 4 on FastEthernet0
          which has no subinterface configured to route or bridge ID 4.
    vLAN: ISL packet received bearing colour ID 5 on FastEthernet0
          which has no subinterface configured to route or bridge ID 5.
    vLAN: Received ISL encapsulated UNKNOWN packet bearing colour ID 1
          on interface FastEthernet0.1 which is not configured to
          route or bridge this packet type.
    vLAN: Received ISL encapsulated UNKNOWN packet bearing colour ID 2
          on interface FastEthernet0.2 which is not configured to
          route or bridge this packet type.

相关信息


Document ID: 17051