网络应用服务 : Cisco LocalDirector 400 系列

在 LocalDirector 中配置标准与状态 故障切换

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


Cisco已宣布Cisco LocalDirector终止销售。更多信息,请参见LocalDirector 400系列生命周期终止和销售终止通知以及产品公告


目录


简介

在此技术说明的信息在故障切换配置里适用于Cisco LocalDirector的所有硬件和软件版本。

故障切换的两种类型在LocalDirector可以实现:标准故障切换和状态故障切换。在标准的(非状态的)故障切换,所有现有连接信息丢失在故障切换;然而,状态故障切换维护会话信息,以及粘性会话信息。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文在故障切换配置里适用于Cisco LocalDirector的所有硬件和软件版本。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

故障切换命令

  • failover ip address ip_address —设置故障切换IP地址。IP地址参数指示备用装置用于的IP地址用活动装置通信。以ping命令检查备用装置的状况使用此IP地址。此地址必须在网络和系统IP地址一样。例如,如果系统IP地址是192.168.1.1,设置故障切换IP地址为192.168.1.2。

  • 故障切换[active] —启用对可选故障切换功能的访问。可选活动参数做LocalDirector活动装置。

  • replicate interface interface_number —启用状态故障切换,并且指定发送的复制数据一个接口。interface_number参数指示激活的localdirector单元发送连接复制数据到备用装置的编号。默认是接口0。

  • failover alias ip address ip_address —分配故障切换别名IP地址。备用装置用于IP地址与活动装置联络。

  • 故障切换重置—取出单元在故障状态外面。

  • show failover —显示LocalDirector故障切换状态、电缆状态、主要和备用主机状态和接口说明。

  • 关闭以太网|FDDI interface_number —禁用接口。

欲知更多信息,参考localdirector命令参考资料

配置

注意: 使用命令查找工具仅限注册用户)可获取有关本部分所使用命令的详细信息。

在标准故障切换的LocalDirector

这是LocalDirector基本配置在标准故障切换的:

在标准故障切换的LocalDirector
: Saved 
: LocalDirector 420 Version 4.1.2 
syslog output 20.3 
no syslog console 
enable password 000000000000000000000000000000 encrypted 
hostname localdirector 
no shutdown ethernet 0 
no shutdown ethernet 1 
shutdown ethernet 2 
shutdown ethernet 3 
interface ethernet 0 100full 
interface ethernet 1 100full 
interface ethernet 2 auto 
interface ethernet 3 auto 
mtu 0 1500 
mtu 1 1500 
mtu 2 1500 
mtu 3 1500 
multiring all 
no secure  0 
no secure  1 
no secure  2 
no secure  3 
ping-allow 0 
ping-allow 1 
no ping-allow 2 
no ping-allow 3 
ip address 10.1.1.1 255.0.0.0 
arp timeout 30 
no rip passive 
rip version 1 
failover ip address 10.1.1.2 
failover 
failover hellotime 30 
password cisco 
snmp-server enable traps 
snmp-server community public 
no snmp-server contact 
no snmp-server location 
no dns-boomerang enable 
virtual 10.1.1.5:0:0:tcp is 
real 10.1.1.4:0:0:tcp is 
real 10.1.1.3:0:0:tcp is 
bind 10.1.1.5:0:0:tcp 10.1.1.3:0:0:tcp 
bind 10.1.1.5:0:0:tcp 10.1.1.4:0:0:tcp 
: end 
[OK] 
localdirector(config)#

在状态故障切换的LocalDirector

下面LocalDirector配置示例在状态故障切换的。状态故障切换单元共享活动连接的连接信息并且是可配置根据一个每虚拟基本类型。每次传输控制协议(TCP)连接的状态更改,数据发送对暂挂LocalDirector通过Localdirector-statefull协议。这允许将被反映的所有TCP会话的当前状态对暂挂LocalDirector。

Localdirector-statefull协议使用用户数据报协议(UDP)数据包发送对暂挂LocalDirector的状态变换在以太网接口。请使用一个分开的以太网接口传送状态故障切换信息。使用状态故障切换,没有服务的中断给客户端。对关键的应用程序是理想的并且允许高可用性。

注意: 此示例使用以太网接口2,有在转接状态信息的两LocalDirector之间的一交叉电缆。此示例也使用这些复制命令:

replicate interface 2 
replicate 10.1.1.5:0:0:tcp

这些命令告诉LocalDirector复制连接状态从激活到在Ethernet2间的备用装置并且复制从虚拟10.1.1.5的所有状态信息到备用装置。

在状态故障切换的LocalDirector
: Saved 
: LocalDirector 420 Version 4.1.2 
syslog output 20.3 
no syslog console 
enable password 000000000000000000000000000000 encrypted 
hostname localdirector 
no shutdown ethernet 0 
no shutdown ethernet 1 
no shutdown ethernet 2 
shutdown ethernet 3 
interface ethernet 0 100full 
interface ethernet 1 100full 
interface ethernet 2 100full 
interface ethernet 3 auto 
mtu 0 1500 
mtu 1 1500 
mtu 2 1500 
mtu 3 1500 
multiring all 
no secure  0 
no secure  1 
no secure  2 
no secure  3 
ping-allow 0 
ping-allow 1 
no ping-allow 2 
no ping-allow 3 
ip address 10.1.1.1 255.0.0.0 
arp timeout 30 
no rip passive 
rip version 1 
failover ip address 10.1.1.2 
failover 
failover hellotime 30 
password cisco 
snmp-server enable traps 
snmp-server community public 
no snmp-server contact 
no snmp-server location 
no dns-boomerang enable 
virtual 10.1.1.5:0:0:tcp is 
real 10.1.1.4:0:0:tcp is 
real 10.1.1.3:0:0:tcp is 
replicate interface 2 
replicate 10.1.1.5:0:0:tcp 
bind 10.1.1.5:0:0:tcp 10.1.1.3:0:0:tcp 
bind 10.1.1.5:0:0:tcp 10.1.1.4:0:0:tcp

注意: 所有接口最初在等待模式,含义网络监控未开始。在网络接口进入正常模式后,网络监控开始。当LocalDirector-HELLO消息开始发送每五秒,这发生。

如果一个30秒间隔通过没有接收的LocalDirector-HELLO消息,单元进入测试模式确定哪个单元失败。如果串行电缆被拔,单元将维护他们的当前角色。如果单元不通过测验,将变得失败,并且另一个单元将变得激活。在时候?状态?TCP连接更改,数据发送对暂挂LocalDirector通过Localdirector-statefull协议。所有TCP会话的状态被反映对暂挂LocalDirector。如果虚拟更改支持状态故障切换那么仅新连接的状态信息发送对暂挂LocalDirector。LocalDirector全状态协议不复制存在TCP会话的状态。

验证故障切换状态

如此示例所显示, show failover命令可以用于显示单元和他们的接口的当前故障切换状态, :

Failover Off 
Cable status: My side not connected 
        This host: Secondary - Active 
                Active time: 1 weeks, 3 days, 1 hours, 2 minutes, 5 seconds 
                Interface 5 (10.86.16.225): Normal (Waiting) 
                Interface 4 (10.86.16.225): Normal (Waiting) 
                Interface 3 (10.86.16.225): Normal (Administratively down) 
                Interface 2 (10.86.16.225): Normal (Administratively down) 
                Interface 1 (10.86.16.225): Normal (Waiting) 
                Interface 0 (10.86.16.225): Normal (Waiting) 
        Other host: Secondary - Standby 
                Interface 5 (0.0.0.0): Normal (Waiting) 
                Interface 4 (0.0.0.0): Normal (Waiting) 
                Interface 3 (0.0.0.0): Normal (Administratively down) 
                Interface 2 (0.0.0.0): Normal (Administratively down) 
                Interface 1 (0.0.0.0): Normal (Waiting) 
                Interface 0 (0.0.0.0): Normal (Waiting)

这显示Hello数据包反复通过在两个单元之间,并且两在LDs的接口被关闭了。


相关信息


Document ID: 15060