宽带电缆 : 电缆调制解调器

CPE不稳定连接

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 22 日) | 反馈


目录


简介

本文讨论某些多数常见原因客户端前置设备(CPE) —例如一PC运行Windows 2000或一个相似的操作系统在有线调制解调器背后—为什么无法获取IP地址或无法连接到互联网。本文使用一流程图方法通过一系列的步骤导致您排除故障网络从CPE侧或从数据转发器端。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档不限于特定的软件和硬件版本。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

CPE 如何获得 IP 地址?

在有线调制解调器来联机后,使用动态主机配置协议(DHCP)进程, CPE在有线调制解调器背后设法获取IP地址。客户端典型地发送与设置的DHCP选项的Bootstrap协议(BOOTP)请求对DHCP DISCOVER、0.0.0.0源IP地址和目的IP地址255.255.255.255。此数据包然后中继对DHCP服务器由有线调制解调器终端系统(CMTS)。中继的数据包有在电缆接口配置的备用IP地址的源IP地址,并且有DHCP服务器的目的IP地址,如指定由cable helper-address ip address命令(请参阅下面的配置示例)。

DHCP服务器回应与一定数量的选项的DHCP提供,包括“客户端服务器分配的IP地址”。这中继回到CPE由CMTS。CPE也许然后发送指定的IP地址的DHCP请求。答复是从CPE的DHCP ACK从服务器和使用分配的IP地址。要观察此交换,请发出debug ip dhcp server packets命令收到输出类似于如下所示的那。

CPE mac address: 0010.a4e6.d04d 
CPE assigned IP address: 192.168.50.3 
DHCP Server IP address: 172.17.110.137 
5d20h: DHCPD: setting giaddr to 192.168.50.1. 
5d20h: DHCPD: BOOTREQUEST from 0100.10a4.e6d0.4d forwarded to 172.17.110.137.

!--- DHCP DISCOVER.

5d20h: DHCPD: forwarding BOOTREPLY to client 0010.a4e6.d04d.

!--- DHCP OFFER.
 
5d20h: DHCPD: creating ARP entry (192.168.50.3, 0010.a4e6.d04d). 
5d20h: DHCPD: unicasting BOOTREPLY to client 0010.a4e6.d04d (192.168.50.3). 
5d20h: DHCPD: setting giaddr to 192.168.50.1. 

5d20h: DHCPD: BOOTREQUEST from 0100.10a4.e6d0.4d forwarded to 172.17.110.137.

!--- DHCP REQUEST.

5d20h: DHCPD: forwarding BOOTREPLY to client 0010.a4e6.d04d.

!--- DHCP ACK.
 
5d20h: DHCPD: creating ARP entry (192.168.50.3, 0010.a4e6.d04d). 
5d20h: DHCPD: unicasting BOOTREPLY to client 0010.a4e6.d04d (192.168.50.3). 

警告 警告: debug ip dhcp server packets命令在忙碌CMTS能导致性能严重下降,如果实行。所以,其使用在实验室环境只推荐。

上述进程也许不如期望的一样运作由于一定数量的要素,一些下面是列出的。

  • 不正确地配置的PC

  • 不正确地配置的DHCP服务器

  • 电缆调制解调器问题

  • 有线电缆数据服务接口规范(DOCSIS)配置文件参数

在下一部分的流程图突出显示影响CPE的能力的某些多数重要因素获取IP地址。它为排除故障失败的尝试也提供步骤由CPE获取IP地址。

故障排除流程图

您能点击其中任一个绿色方框去对应的部分。

cpe_no_connect_sm_1.gif

检查 CMTS 上的状态

您必须首先确定CPE是否获取IP地址(请参阅本文的Check CPE Configuration部分)。如果IP地址未分配到CPE,请确认有线调制解调器联机。如果有线调制解调器没有联机,来的onlinecome CPE不能获取IP地址。

要检查在CMTS的状态,请发出show cable modem命令从CMTS。从此命令的输出示例:如下所示。

Sniper# show cable modem 
Interface   Prim Online     Timing Rec    QoS CPE IP address      MAC address
            Sid  State      Offset Power
Cable2/0/U0 1    offline    2291    0.00  2   0   10.50.50.4      0050.7366.2223
Cable2/0/U0 2    online     2814    0.25  5   0   10.50.50.5      0001.9659.4449
Cable2/0/U0 3    online     2813    0.50  5   0   10.50.50.2      0001.9659.4477

以上的Online State列显示有线调制解调器的状态。对于设立的CPE顺利地获取IP地址和连接,有线调制解调器必须在任一个下列的状态中:

  • 联机

  • Online(pt)

除两个之外的任何状态上述表明有线调制解调器未注册与CMTS,并且,因此, CPE不能获取IP地址。

关于排除故障可能的电缆调制解调器状态的全部信息,参考针对UBR电缆调制解调器不在线问题的故障排除

检查 CPE 配置

PC运行Windows 95, 98, NT或者2000需要有适当地安装并且配置为了获取IP地址的TCP/IP协议栈。

在本文的示例屏幕画面显示客户端运行Windows 2000。其他Windows操作系统有相似的配置,虽则对话框的外观,并且发出的命令访问IP Configuration窗口可能有所不同。

注意: 此部分假设,客户端PC有适当地安装并且配置的一个以太网适配器。否则,参考您的产品文档或要求您的协助的适配器供应商。

要检查IP地址分配到PC,请使用以下步骤:

  1. 点击Start > Run

  2. 在Run窗口中,请键入winipcfg

    /image/gif/paws/15036/cpe_no_connect2.gif

  3. 单击 OK

    IP Configuration窗口出现。

    /image/gif/paws/15036/cpe_no_connect3.gif

    注意: 如果有超过在客户端PC安装的一个以太网适配器,请选择适配器连接对有线调制解调器使用适配器名称下拉箭头。

    从CMTS侧,您能检查哪个CPE在哪个有线调制解调器后坐和请检查IP地址分配到CPE通过发出show interfaces cable X/Y modem z命令。确定此命令的参数如下:

    • x是信用卡号。

    • y是下行端口端口号。

    • z是服务标识符(SID)有线调制解调器。

      您可以设置z0查看关于所有电缆调制解调器的在一个特定的下行接口的详细信息和CPE。请参阅show interface cable命令输出在本文的Sample Configuration部分结束时

    如果IP地址是0.0.0.0,则CPE失败获取IP地址。在您继续对下一步前,请点击Renew按钮设法获取IP地址。如果CPE不能获取IP地址,您将接收IpReneweAddress失败与在Windows 2000的Error 2消息。

    注意: 在Windows 98, CPE有时分配开始169.254.n.n.此种地址的IP地址是Windows分配的“假的” IP地址,并且表明一个工作的IP地址未获取。

  4. 检查CPE有适当地安装并且配置的一TCP/IP协议栈,如下所示。

    1. 选择Start > Settings > Network及Dial-up Connections > Local Area Connection

    2. 在Local Area Connection屏幕,请点击属性

      Local Area Connection属性窗口出现。

      /image/gif/paws/15036/cpe_no_connect4.gif

    3. 保证互联网协议(TCP/IP)列出和选定。

      否则,您必须安装它。

  5. 在保证以后TCP/IP协议栈安装,请检查它适当地配置,如下所示。

    1. 在Local Area Connection属性窗口,请选择互联网协议(TCP/IP)

    2. 单击 Properties

      互联网协议(TCP/IP)属性窗口出现。

      /image/gif/paws/15036/cpe_no_connect5.gif

    3. 保证获取IP地址自动地并且得到DNS服务器地址单选按钮自动地选择。

      注意: 要检查在客户端的其他类型的TCP/IP配置—例如, CPE运行UNIX操作系统—请参考您的产品文档。

MAX-CPE

在桥接模式,默认MAX-CPE条目在DOCSIS配置文件是1。因此,仅一个CPE可能在有线调制解调器后连接。一个新的配置命令允许CMTS指定允许的主机最大每个调制解调器(覆盖在DOCSIS配置文件的MAX-CPE值)。此命令是cable modem max-cpe [n|无限个]n的有效范围是1到254。

关于此命令和其关系的更多信息对MAX-CPE DOCSIS配置文件,参考使用max-cpe In命令DOCSIS和CMTS

如果在DOCSIS配置文件的MAX-CPE参数是0,并且no cable modem max-cpe命令在CMTS配置(默认情况下)没有CPE能然后获取IP地址。

Cisco 网络注册器

检查以下在Cisco网络认证(CNR) :

  • 每个CPE的适当地配置的策略。

  • 产生关联的范围与那些CPE策略。

  • 适应所有客户端的满足的IP地址空间,万一所有客户端同时来联机。

  • 没有超载DHCP服务器。

  • 有从DHCP服务器的一路由上一步到CPE的网络地址。

关于配置CNR的更多信息,参考Cisco Network Registrar配置

不使用 CNR

如果使用一个非CNR DHCP服务器,请保证正确地根据产品文档设置。用类似于上面Cisco Network Registrar部分的方法应该配置它。

与您的 ISP 协商

如果不控制IP地址分配—除保证外有线调制解调器联机—您必须检查以您的ISP排除故障CPE连接问题。您的ISP掌握IP地址分配,并且您也许必须提供他们您的CPE使用的MAC地址。

注意: 如果访问CMTS那么您能查看和排除故障是否调制解调器联机。参考的针对UBR电缆调制解调器不在线问题的故障排除。否则请检查在您的Cisco uBR900系列电缆接入路由器的指示灯状态。

IP 地址不是 ISP 分配的

必须由ISP分配IP地址通过DHCP服务器。如果您的IP地址分配使用不同的说法例如—,静态配置—您必须用您的ISP检查指定的IP地址的正确性。失败也许导致网络中断其他用户和疏忽设立连接。

检查 IP 连通性

如果您的CPE由您的ISP分配有效IP地址,但是您无法设立连接,有方式检查IP连通性。首先,请ping PC的IP地址。然后,请ping在网络的每跳一次一个,发现通过网络您多远能到达。如果对系统的其余的ping在网络的时间,您必须与您的协助的ISP技术支持人员联系。

配置示例

此配置根据Cisco IOS�软件版本12.1(5)T。

write terminal

Sniper# write terminal

Building configuration...


Current configuration : 2472 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service udp-small-servers max-servers no-limit
!
hostname Sniper
!
boot system flash slot0:ubr7200-ik1st-mz.121-5.T.bin
logging rate-limit console 10 except errors
enable password cisco
!
no cable qos permission create
no cable qos permission update
cable qos permission modems
cable time-server
ip subnet-zero
no ip finger
no ip domain-lookup
!         
!
interface FastEthernet0/0
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/0
 ip address 172.17.110.148 255.255.255.224
 half-duplex
!
interface Ethernet1/1
 no ip address
 shutdown
 half-duplex
!
interface Cable2/0
 ip address 192.168.50.1 255.255.255.0 secondary
 ip address 10.50.50.1 255.255.255.0
 no keepalive
 cable downstream annex B
 cable downstream modulation 64qam
 cable downstream interleave-depth 32
 cable downstream frequency 555000000
 cable upstream 0 frequency 30000000
 cable upstream 0 power-level 0
 no cable upstream 0 shutdown
 cable upstream 1 shutdown
 cable upstream 2 shutdown
 cable upstream 3 shutdown
 cable upstream 4 shutdown
 cable upstream 5 shutdown
 cable dhcp-giaddr policy
 cable helper-address 172.17.110.137
!
interface Cable3/0
 no ip address
 no keepalive
 shutdown
 cable downstream annex B
 cable downstream modulation 64qam
 cable downstream interleave-depth 32
 cable upstream 0 shutdown
 cable upstream 1 shutdown
 cable upstream 2 shutdown
 cable upstream 3 shutdown
 cable upstream 4 shutdown
 cable upstream 5 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.17.110.129
no ip http server
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0
 exec-timeout 0 0
 password cisco
 no login
line vty 1 4
 exec-timeout 0 0
 no login
!
end

Sniper# 

show interfaces电缆

Sniper# show interfaces cable 2/0 modem 0
SID   Priv bits  Type      State     IP address    method    MAC address
7     00         modem     up        10.50.50.5    dhcp      0001.9659.4449
8     00         host      unknown   192.168.50.3  dhcp      0010.a4e6.d04d
8     00         modem     up        10.50.50.2    dhcp      0001.9659.4477
9     00         modem     up        10.50.50.4    dhcp      0050.7366.2223

Sniper#

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息

检查 CMTS 上的状态 IP 地址不是 ISP 分配的 检查 IP 连通性 最大数量CPE 检查 CPE 配置 与您的 ISP 协商 Cisco 网络注册器 不使用 CNR


Document ID: 15036