思科接口和模块 : 思科内容交换模块

以分派模式通过 HTTP 探测器实现 IOS 服务器负载均衡的配置

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 9 月 19 日) | 反馈


目录


简介

思科IOSï ¿  ½服务器负载均衡(SLB)功能是一基于Cisco IOS的解决方案该提供服务器负载均衡。这个功能使您能够定义一个能代表真实服务器的集群的虚拟服务器,称之为一个服务器群。当客户端首次向虚拟服务器发起连接,IOS SLB对该连接进行负载平衡,以选择真实的服务器。该过程取决于已配置的负载平衡算法或预报器。

IOS SLB在以下两个模式可以配置运行。

  • 分派模式—在此模式,虚拟服务器地址为真实服务器所知。您必须配置其中每一个有环回地址的真实服务器他们的唯一回环接口的。有必要为服务器站的每台机器提供与实际虚拟服务器相同的IP地址。就象用于它自己的IP地址一样,目的地真实服务器允许使用环回地址直接回应客户端。IOS SLB对真实服务器的重定向数据包在MAC控制(MAC)层的Layer2。由于虚拟服务器IP地址未在分派模式中修改,真实服务器必须是L2(与IOS SLB相邻),或者干预路由器不能路由选择真实服务器。

  • 定向模式---在此模式中,虚拟服务器可以分配到真实服务器未知的IP地址。IOS SLB将转换在客户端和真实服务器之间交换的数据包,并通过网络地址转换(NAT),将虚拟服务器IP地址转换成真实的服务器地址。要使用定向模式,请添加nat server命令到服务器站。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • Catalyst 6000系列管理引擎1的Supervisor IOS版本12.1(6)E有MSFC1的(c6sup11-jsv-mz.121-6.E1)

  • Microsoft Windows 2000/iis Web服务器

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

配置

HTTP 探测器

IOS SLB支持超文本传输协议(HTTP)探测器、ping探测器和无线会话协议(WSP)探测器。您可以使用HTTP探测器验证连通性,监控正在进行负载平衡的真实服务器。探测器在服务器站确定每个真实服务器状态。使用TCP端口80,在本例中, HTTP探测器配置。配置HTTP探测器每八秒连接一次,并请求method get命令,以寻找服务器的200回应代码。这些配置是所有默认值。

网络图

本文档使用以下网络设置:

/image/gif/paws/15055/ios_slb-01.gif

配置

IOS SLB配置使用Catalyst 6509
Current configuration:

version 12.1

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname cat6

!

boot buffersize 126968

boot system flash slot0:c6sup11-jsv-mz.121-6.E1.bin

!

redundancy

 main-cpu

  auto-sync standard

ip subnet-zero

!

no ip finger

no ip domain-lookup

!

ip slb probe KEEPALIVE http

!

ip slb serverfarm SERVERS

 probe KEEPALIVE

 !

 real 10.1.1.3

  inservice

 !

 real 10.1.1.5

  inservice

!

ip slb vserver WEBSITE

 virtual 172.17.63.215 tcp www

 serverfarm SERVERS

 inservice

!

cns event-service server

!

interface GigabitEthernet1/1

 no ip address

 shutdown

!

interface GigabitEthernet1/2

 no ip address

 shutdown

!

interface FastEthernet2/1

 no ip address

 switchport

 switchport access vlan 100

 switchport mode access

!

interface FastEthernet2/2

 no ip address

 shutdown

!

interface FastEthernet2/3

 no ip address

 switchport

 switchport access vlan 200

 switchport mode access

!

interface FastEthernet2/4

 no ip address

 switchport

 switchport access vlan 200

 switchport mode access

!

interface FastEthernet2/5

 no ip address

 shutdown

!

interface FastEthernet2/48

 no ip address

 shutdown

!         

interface Vlan1

 no ip address

 shutdown

!

interface Vlan100

 ip address 172.17.63.211 255.255.255.192

!

interface Vlan200

 ip address 10.1.1.250 255.255.255.0

!

ip default-gateway 172.17.63.193

ip classless

ip route 0.0.0.0 0.0.0.0 172.17.63.193

no ip http server

!

line con 0

 transport input none

line vty 0 4

 password cisco

 login

!

end

show 命令与命令汇总

show ip slb mode 命令

show ip slb mode命令显示SLB模式的状况。

cat6#show ip slb mode 
     SLB forwarding mode = rp (default) 
     SLB configured mode = rp (default) 

使用show ip slb mode [csm,要运行Cisco IOS SLB软件,您必须配置模式|rp] 命令来配置 CSM 模式。在show ip slb mode命令RP参数是默认。如果有内容交换模块(CSM),您能只配置csm参数。CSM提供根据Layer4的网络设备服务器站之间的高性能的连接通过7个信息包。您可以将真实服务器组(服务器群)当作单个服务器实例(虚拟服务器),进而选择一个真实服务器来平衡数据流(服务器负载均衡),同时限制进入单个服务器(粘性连接)和服务器群(策略)的数据流。欲知更多信息,请参阅配置在内容交换模块的安全(路由器)模式

show ip slb vserver 命令

show ip slb vserver 命令显示虚拟服务器信息。以下,您还可参阅虚拟服务器的状态,以及那里多少连接:

cat6#show ip slb vserver 

slb vserver      protocol      virtual              state      conns 
------------------------------------------------------------------------ 
WEBSITE         TCP       172.16.63.215/32:80      OPERATIONAL   0 

show ip slb reals 命令

show ip slb reals命令显示每个真实服务器信息,例如每个服务器驻留的服务器群,服务器状态、阈值和连接。

cat6#show ip slb reals 

real             server farm      weight     state        conns 
------------------------------------------------------------------- 
10.1.1.5         SERVERS           8        OPERATIONAL     0 
10.1.1.3         SERVERS           8        OPERATIONAL     0 

show ip slb serverfarms 命令

show ip slb serverfarms 命令显示服务器群信息。此指令显示为负载均衡使用的预报器。在此示例循环法,是默认,使用。因为设备在分派模式,您什么都不会看到“”在NAT下。

cat6#show ip slb serverfarm 

server farm      predictor    nat        reals    redirect    bind id 
-------------------------------------------------------------------------- 
SERVERS       roundrobin     none         2          0             0 

show ip slb conns 命令

show ip slb conns [vserver virtual_server-name|客户端IP地址|firewall firewallfarm-name] [detail]命令显示活动连接。

  • vserver -显示连接的仅那些连接对一个特定的虚拟服务器。

  • 虚拟服务器NAME -虚拟服务器的名称。

  • 客户端-显示与特定的客户端IP地址的连接。

  • 客户端的ip address ip_address

  • 详细信息-显示详细的连接信息。

如果没有指定选项,show ip slb conns命令显示所有活动IOS SLB连接输出。

cat6#show ip slb conns 

vserver         prot    client             real                state            nat 
----------------------------------------------------------------------- --------------- 
WEBSITE         TCP  10.21.188.123:2187    10.1.1.5            ESTAB            none 
WEBSITE         TCP  10.21.188.123:2190    10.1.1.5            CLOSING       	none 
WEBSITE         TCP  10.21.188.123:2192    10.1.1.3            ESTAB            none 
WEBSITE         TCP  10.21.188.123:2197    10.1.1.3            CLOSING       	none 
WEBSITE         TCP  10.21.188.123:2200    10.1.1.5            SYNCLIENT        none 
WEBSITE         TCP  10.21.188.123:2201    10.1.1.5            SYNCLIENT        none 

cat6#show ip slb conns detail 

WEBSITE, client = 10.21.188.123:2187 state = ESTAB, real = 10.1.1.5, 
nat = none  v_ip = 172.17.63.215:80, TCP, service = NONE 
  client_syns = 1, sticky = FALSE, flows attached = 0 
WEBSITE, client = 10.21.188.123:2205 state = CLOSING, real = 10.1.1.5, 
nat = none v_ip = 172.17.63.215:80, TCP, service = NONE 
  client_syns = 3, sticky = FALSE, flows attached = 0 
WEBSITE, client = 10.21.188.123:2206 state = ESTAB, real = 10.1.1.5, 
nat = none v_ip = 172.17.63.215:80, TCP, service = NONE 
  client_syns = 2, sticky = FALSE, flows attached = 0 

show ip slb probe 命令

show ip slb probe命令显示关于IOS SLB的信息。

有探测器的三个操作状态:

  • 失败-探测器当前失败。

  • 可操作-探测器通常作用。

  • 测试-探测器未曾成功,由于无响应。IOS SLB不保持计数器或计时器此的状态。

显示的另一信息下列:

  • 中断-在成功的探测之间的间隔的数量。

  • 当前-时间,自从最后探测器成功。即持续时间(到目前为止)当前中断。

  • 渐增-总时间真实服务器在探测器测验下和失败。此值是当前时间与以前所有中断的总时间的总和。

cat6#show ip slb probe 

Server:Port          	State        Outages  	Current    Cumulative 
----------------------------------------------------------------------- 
10.1.1.3:80             OPERATIONAL    1        never         00:05:22 
10.1.1.5:80             OPERATIONAL    0        never         00:00:00 

分派模式环回

您在Catalyst 6500上配置了SLB功能以后,您必须为每个真实的服务器配置环回设备/接口。配置虚拟服务器的IP地址作为环回IP地址,与255.0.0.0网络屏蔽。

Route Table 
======================================================================= ==== 
Interface List 
0x1 ........................... MS TCP Loopback interface 
0x2 ...00 60 b0 87 dc 1a ...... AMD PCNET Family Ethernet Adapter 
0x1000004 ...02 00 4c 4f 4f 50 ...... MS LoopBack Driver 
======================================================================= ==== 
Active Routes: 
Network	        Destination         Netmask         Gateway     Interface   Metric 
0.0.0.0         0.0.0.0             10.1.1.250      10.1.1.3        1 
10.1.1.0        255.255.255.0       10.1.1.3        10.1.1.3        1 
10.1.1.3        255.255.255.255     127.0.0.1       127.0.0.1       1 
10.255.255.255  255.255.255.255     10.1.1.3        10.1.1.3        1 
127.0.0.0       255.0.0.0           127.0.0.1       127.0.0.1       1 
172.17.63.215   255.255.255.255     127.0.0.1       127.0.0.1       1 
224.0.0.0       224.0.0.0           10.1.1.3        10.1.1.3        1 
224.0.0.0       224.0.0.0           172.17.63.215   172.17.63.215   1 
255.255.255.255 255.255.255.255     10.1.1.3        10.1.1.3        1 
======================================================================= ==== 

检查表中能看到回环地址的每一排上的网络地址。为了使正确通信的服务器,您需要对众所周知的组播网络地址的一参考。这位于示例的第8行,因此您需要删除额外的默认路由。这是一个网络地址和集群地址一样,都始于同一个数字,后面接三个零的网络。在以上示例中,额外的路由在第二行。

下列是众所周知的组播网络地址:

224.0.0.0      224.0.0.0    172.17.63.215      172.17.63.215       1 

下列是从上表删除的自动安装的默认路由:

0.0.0.0          0.0.0.0    172.17.63.193   172.17.63.215       1

您必须删除额外的路由允许正常通信用SLB虚拟服务器。

验证

当前没有可用于此配置的验证过程。

故障排除

目前没有针对此配置的故障排除信息。


相关信息


Document ID: 15055