?????? : 思科 500 系列高速缓存引擎

如何使用 WCCP 配置 Cache Engine 以使用透明缓存

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 23 日) | 反馈


目录


简介

使用WEB缓存通信协议(WCCP),本文描述如何配置透明缓存的Cisco缓存引擎。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • Cisco Cache Engine 560

  • Cisco应用和内容联网系统软件(ACNS)版本5.1

  • 运行Cisco IOS�软件版本12.2(17)的Cisco 3600路由器

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 使用命令查找工具仅限注册用户)可获取有关本部分所使用命令的详细信息。

网络图

本文档使用以下网络设置:

/image/gif/paws/15043/transparentconfig.jpg

配置

本文档使用以下配置:

缓存/内容引擎
ce-560#write terminal
! ACNS version 5.1.9
!
hostname ce560
!
ip domain-name cisco.com
!
interface FastEthernet 0/0
 ip address 10.0.0.2 255.255.255.0
 exit
interface FastEthernet 0/1
 shutdown
 exit
!
ip default-gateway 10.0.0.1
!
primary-interface FastEthernet 0/0
!
ip name-server 10.66.86.18
!
wccp router-list 1 10.0.0.1
wccp web-cache router-list-num 1
wccp version 2
!
transaction-logs enable
!
username admin password 1 bVmDmMMmZAPjY
username admin privilege 15
!
authentication login local enable primary
authentication configuration local enable primary
!
! End of ACNS configuration

路由器
c3640#write terminal
Building configuration...
Current configuration : 1905 bytes
!
! NVRAM config last updated at 11:30:04 AEST Wed Aug 4 2004
!
version 12.2
no service password-encryption
!
hostname c3640
!
enable password cisco
!
clock timezone AEST 10
ip subnet-zero
ip wccp web-cache
ip cef
!
interface Ethernet0/0
 ip address 10.1.0.1 255.255.255.0
 ip wccp web-cache redirect in
 full-duplex
!
interface Ethernet0/1
 ip address 10.0.0.1 255.255.255.0
full-duplex
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.0.0.254
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

验证

使用本部分可确认配置能否正常运行。

命令输出解释程序仅限注册用户)(OIT) 支持某些 show 命令。使用 OIT 可查看对 show 命令输出的分析。

注意: 使用 debug 命令之前,请参阅有关 Debug 命令的重要信息

Cache Engine Debug与Show调试指令

  • show wccp cache —显示WCCP Cache Engine信息。

  • show wccp flows —显示WCCP数据包流。

  • show wccp routers —显示WCCP路由器列表。

  • show wccp services —显示配置的WCCP服务。

  • show wccp slowstart —显示WCCP缓慢的开始。

  • show wccp status —显示WCCP运行状态。

  • show statistics http savings —显示HTTP节省统计数据。

  • 调试全的WCCP打开WCCP的所有调试。

  • debug wccp events —调试WCCP事件。

  • debug wccp packets —调试WCCP包相关信息。

路由器 debug 和 show 命令

  • show ip wccp web-cache detail —显示Cache Engine和WCCP路由器统计数据特定服务组的。

  • show ip wccp web-cache view —显示服务组查阅信息。

  • debug ip wccp events —调试WCCP事件。

  • debug ip wccp packets —调试WCCP包相关信息。

命令汇总

这些是在此配置方面使用的Cache Engine命令:

  • WCCP版本{1|2}

  • wccp router-list number ip-address

  • wccp web-cache router-list-num number

这些是在此配置方面使用的路由器命令:

  • ip WCCP {web-cache|服务编号}

  • ip WCCP {web-cache|服务编号}重定向

故障排除

目前没有针对此配置的故障排除信息。

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 15043