拨号和接入 : 综合业务数字网络 (ISDN),随路信令 (CAS)

BRI 到 PRI 连接使用Data Over Voice

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 22 日) | 反馈


目录


简介

本文为在语音(DOV)的TData提供一配置示例,允许在一次语音呼叫的发送的数据与ISDN专线。

先决条件

要求

尝试进行此配置之前,请确保满足以下要求:

  • Cisco IOS软件版本12.0

  • 有四个主速率接口的(PRI) Cisco 5300

  • 有基本速率接口(BRI)的Cisco 2503

  • 每侧主机名

  • PPP认证的一个密码

  • ISDN专线的电话号码

  • 以太网接口的IP地址在两边的

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

背景信息

DOV允许在一次语音呼叫的发送的数据与ISDN专线。ISDN专线既可支持数据呼叫也可支持语音呼叫。典型地互联与ISDN专线的两路由器使用数据呼叫(64 kpbs或56 Kbps)。语音呼叫由电话或者传真机发出。语音呼叫可能由设备也生成连接对模拟调制解调器,例如, PC该拨号用普通旧式电话服务线路。

在某些情况下,特别是当数据呼叫和语音呼叫之间的价格差异考虑时,用户能联络有语音呼叫的两路由器与ISDN专线。ISDN专线通常有所有呼叫的按呼叫计费:本地、长距离和国际。在某些情况下,开销语音呼叫比开销更低数据呼叫。

为了路由器能通信与在两ISDN专线之间的语音呼叫,审慎配置是必要意识路由器呼叫需要被发起作为语音呼叫,并且必须处理入站语音呼叫作为数据呼叫。在始发端(主叫),请使用map-class选项将呼叫定义为语音呼叫:

map-class dialer name

dialer voice-call

该映射级定义一个行为,且需应用于需要这个行为的ISDN接口。这是类行为的示例在dialer mapdialer string命令的:

dialer map protocol address class map class name host name [broadcast] phone number

dialer string电话号码类映射

参考这两命令完整句法的Cisco IOS 软件文档。

在入站(呼叫的)侧,请添加isdn incoming-voice data命令在Serial<n>:23接口下。切记所有入站语音呼叫被处理作为数据呼叫。如果也要支持在同一ISDN专线的调制解调器呼叫,请使用资源池管理器(RPM)功能;否则,您能分离那两服务到用不同的电话号码的两不同的ISDN专线。如果两条线路有同一个编号,问题发生;他们是搜索组的一部分。特定接口能处理语音呼叫作为调制解调器呼叫或语音呼叫作为话上数据呼叫,但是不是两个。

请注意DOV有有限可靠性。在两条ISDN专线之间的呼叫将支持端到端数字通路。设备,线路,并且电话公司使用设置数据和语音呼叫的其他资源通常是相同的,但是他们可以不同的。数字语音的传输比数据传输更具有灵活性。对于ISDN数据呼叫,电话网络可保证在64 kbps或56 kbps的数字通路上进行传输。对于语音呼叫,电话网能路由和操作比特流进入不同的方式,不是影响语音质量。因为所有数据是损坏的,当发送这样, DOV不与一些ISDN专线一起使用。

配置

此配置以四个主速率接口(PRI)使用Cisco 5300终止呼叫和Cisco 2503以基本速率接口(BRI)发起呼叫。48 DOV呼叫、48调制解调器呼叫和96次数据呼叫的Cisco 5300提供支持。前两个PRI配置处理语音呼叫作为数据,并且最后两个配置处理语音呼叫作为调制解调器呼叫。必须为拨的每个用户配置用户名和密码。此配置不使用终端访问控制器访问控制系统(TACACS+)或远程验证拨入用户服务(RADIUS)。

本部分提供有关如何配置本文档所述功能的信息。

注意: 有关本文档所用命令的详细信息,请使用命令查找工具仅限注册用户)。

网络图

本文档使用以下网络设置:

/image/gif/paws/14962/britopri_dov.gif

配置

本文档使用以下配置:

  • 路由器 1

  • 路由器 2

路由器 1
!
version 12.0
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname Router1
!
aaa new-model
AAA authentication login default local
aaa authentication login CONSOLE none
aaa authentication ppp default if-needed local
enable password somethingSecret
!
username santiago password 0 letmein
username Router2 password 0 open4me2
ip subnet-zero
no ip domain-lookup
!
isdn switch-type primary-5ess
!
controller T1 0
 framing esf
 clock source line primary
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 1
 framing esf
 clock source line secondary
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 2
 framing esf
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 3
 framing esf
 linecode b8zs
 pri-group timeslots 1-24
!
interface Ethernet0
 ip address 10.10.1.1 255.255.255.0
 no ip directed-broadcast
!
interface Serial0:23
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 ip tcp header-compression passive
 dialer rotary-group 1
 dialer-group 1
 isdn switch-type primary-5ess
 isdn incoming-voice data
!
interface Serial1:23
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 ip tcp header-compression passive
 dialer rotary-group 1
 dialer-group 1
 isdn switch-type primary-5ess
 isdn incoming-voice data
!
interface Serial2:23
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 ip tcp header-compression passive
 dialer rotary-group 2
 dialer-group 1
 isdn switch-type primary-5ess
 isdn incoming-voice modem
!
interface Serial3:23
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 ip tcp header-compression passive
 dialer rotary-group 2
 dialer-group 1
 isdn switch-type primary-5ess
 isdn incoming-voice modem
!
interface FastEthernet0
 ip address 10.10.2.1 255.255.255.0
 no ip directed-broadcast
!
interface Group-Async1
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 async mode interactive
 ip tcp header-compression passive
 peer default ip address pool IPaddressPool
 no cdp enable
 ppp authentication chap
 group-range 1 48
 !
interface Dialer1
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 ip tcp header-compression passive
 dialer-group 1
 ppp authentication chap
!
interface Dialer2
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 ip tcp header-compression passive
 dialer-group 1
 peer default ip address pool IPaddressPool
 ppp authentication chap
!
ip local pool IPaddressPool 10.10.10.1 10.10.10.254
ip classless
ip route 10.8.186.128 255.255.255.240
no ip http server
!
line con 0
 login authentication CONSOLE
 transport input none
line 1 48
 autoselect during-login
 autoselect ppp
 modem Dialin
line aux 0
line vty 0 4
!
end

路由器 2
!
version 12.0
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname Router2
!
aaa new-model
aaa authentication login default local
aaa authentication login CONSOLE none
aaa authentication ppp default local
enable password somethingSecret
!
username Router1 password 0 open4me2
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-5ess
!
interface Ethernet0
 ip address 10.8.186.134 255.255.255.240
 no ip directed-broadcast
!
interface Serial0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface BRI0
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 dialer string 5555700 class DOV
 dialer load-threshold 5 outbound
 dialer-group 1
 isdn switch-type basic-5ess
 ppp authentication chap
!
ip classless
ip route 0.0.0.0 0.0.0.0 BRI0
no ip http server
!
!
map-class dialer DOV
 dialer voice-call
dialer-list 1 protocol ip permit
!
line con 0
 login authentication CONSOLE
 transport input none
line aux 0
line vty 0 4
!
end

验证

当前没有可用于此配置的验证过程。

故障排除

使用本部分可排除配置故障。

故障排除命令

命令输出解释程序仅限注册用户)(OIT) 支持某些 show 命令。使用 OIT 可查看对 show 命令输出的分析。

注意: 使用 debug 命令之前,请参阅有关 Debug 命令的重要信息

  • debug dialer —显示关系到所有呼叫的原因的信息

  • debug isdn q931 —检查ISDN连接作为用户拨号发现,例如,什么发生与ISDN呼叫,如果连接丢弃

  • debug ppp nego —看到PPP协商的详细信息

  • debug ppp chap —检查验证

  • show isdn status —状态必须是这:

    layer 1 = active 
        layer 2 = MULTIPLE_FRAMES_ESTABLISHED 

    如果第1层不是活跃的,电线适配器或端口可以是坏或没接通。如果Layer2在TEI_Assign的状态,路由器与交换机不对话。

  • show users —显示异步/同步用户当前连接

  • show dialer map —在ISDN联系被建立后,看到动态拨号映射是否创建。没有dialer map,您不能路由数据包。

调制解调器故障排除

  • debug modem —看到路由器是否收到从内部调制解调器的正确信号

  • debug modem csm —启用调制解调器管理呼叫交换模块(CSM)调试模式

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 14962