光纤 : Automatic Protection Switching (APS )

配置 POS/APS 冗余

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 23 日) | 反馈


目录


简介

本文讨论自动保护交换(APS)功能并且提供示例如何配置SONET上的分组(POS)冗余的APS。

本文使您知道APS如何工作,并且帮助您配置和维护在Cisco路由器的APS。图1的网络拓扑是本文的基本类型:

图1 –网络拓扑

pos-aps_14680-a.gif

先决条件

要求

Cisco 建议您了解以下主题:

  • 同步光网络(SONET)和POS技术。

  • Cisco路由器配置基础。

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • Cisco IOS�软件版本12.0(10)S。

  • Cisco 12000系列硬件平台。

APS功能的支持是可用的在Cisco 7500及12000系列硬件硬件平台和在Cisco IOS软件版本12.2(5)和以后。

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

自动保护切换

在电路故障情形下, APS功能提供冗余并且允许POS电路切换。APS的实施允许您配置线路冗余的一条成对SONET线路。当工作(w)接口发生故障时,保护(p)接口快速承担数据流负载。在光纤中断情形下,自动有效线路交换机对备用线路在60之内毫秒(10毫秒开始和50毫秒切换)。SONET APS执行切换在第1层(L1)。所以,切换显着快速比在Layer2 (L2)或第3层(L3)。

此功能使用的保护机制有1+1体系结构,正如Bellcore资料TR-TSY-000253所描述, SONET传输系统,普通的通用标准,部分5.3。SONET APS遵照GR-253和ITU-T G.783。所以, SONET APS允许Cisco路由器集成无缝地SONET添加/丢弃多路复用器(ADM)。此功能允许双向或单向的交换的配置,但是双向非反作用交换是默认。

在APS 1+1体系结构里,每个冗余的线路对包括W接口和P接口。W和P接口连接对SONET ADM,发送同一个信号有效载荷对W和P接口。W和P电路能终止在同一台适配器的两个端口,线卡,或者在两不同路由器。当信号故障(SF)情况或信号下降(SD)情况发生,从W线路的硬件交换机到P线路。有反向选项。当查出一个SF条件、硬件交换机回到W线路自动地,在W线路的修复和一个配置的周期的过去后时。在波段之内保护组协议(PGP)达到在W线路和P线路之间的协调。在非反作用选项,如果SF情况发生,对P线路的硬件交换机,并且不自动地恢复到W线路。

在P电路上,从SONET帧的线路开销(LOH)的K1/K2字节指示APS连接的当前状态,并且表达所有要求操作。连接的二末端使用此信令信道保持同步。W和P在他们终止,在独立通信信道同步的路由器或路由器内巡回自己, (使用APS PGP),隔离从W和P电路。此独立信道可以是一个不同的SONET连接、以太网或者更低带宽连接。在为APS配置的路由器中, P接口的配置包括路由器的IP地址(通常和推荐是环回地址)有W接口。

APS PGP,运行在它上面用户数据报协议(UDP),提供控制W接口和进程控制P接口的进程之间的通信。控制P电路的进程是否使用此协议处理包含W电路的进程,激活或撤销W电路,一旦信道信号下降、损耗或者人工干预。如果两进程丢失彼此的通信, W路由器采取W电路的完全控制,好象P电路没有存在。

APS 及相关命令

这是分类的APS触发层次化(从最低优先级到最高优先级) :

  • 手动交换请求。

  • SD情况(超出SD阈值)的误码率(BER)。

  • 超出用户可提供的10-3/or)的SF情况(帧丢失(LOF),信号损失(LOS)、警报指示信号线(AIS-L)和线路BER。

  • 强制交换请求。

这是IOS选项配置APS :

GSR(config-if)# aps ?
authentication  Authentication string 
force           Force channel 
group           Group association 
lockout         Lockout protection channel 
manual          Manually switch channel 
protect         Protect specified circuit 
reflector       Configure for reflector mode APS 
revert          Specify revert operation and interval 
signaling      Specify SONET/SDH K1K2 signaling 
timers          APS timers 
unidirectional  Configure for unidirectional mode 
working         Working channel number 

除APS功能的新的IOS命令之外, POS接口配置命令Pos thresholdPOS报告被添加支持BER阈值和报告的用户配置SONET警报。以下为示例输出:

GSR(config-if)# POS threshold ? 
  b1-tca  B1 BER threshold crossing alarm 
  b2-tca  B2 BER threshold crossing alarm 
  b3-tca  B3 BER threshold crossing alarm 
  sd-ber  set Signal Degrade BER threshold 
  sf-ber  set Signal Fail BER threshold 

GSR(config-if)# POS report ?
  all     all Alarms/Signals 
  b1-tca  B1 BER threshold crossing alarm 
  b2-tca  B2 BER threshold crossing alarm 
  b3-tca  B3 BER threshold crossing alarm 
  lais    Line Alarm Indication Signal 
  lrdi    Line Remote Defect Indication 
  pais    Path Alarm Indication Signal 
  plop    Path Loss of Pointer 
  prdi    Path Remote Defect Indication 
  rdool   Receive Data Out Of Lock 
  sd-ber  LBIP BER in excess of SD threshold 
  sf-ber  LBIP BER in excess of SF threshold 
  slof    Section Loss of Frame 
  slos    Section Loss of Signal 

交换模式

在双向模式,接收(Rx)和Transmit(Tx)信道交换作为一个对。在单向模式, Tx和Rx信道独立地交换。例如,在双向模式,如果在W接口的Rx信道有信道信号损耗, Rx和Tx信道交换。

双向模式(建议使用)

W路由器认可失败并且通知P路由器(通过本地互连PGP)。P路由器指示W路由器取消选定W接口(通过本地互连PGP)。P路由器请求ADM换成Tx和Rx P (通过去ADM)在P接口的K1/K2字节。P路由器选择P接口,并且ADM遵守交换请求并且发信号标准(通过在ADM的K1/K2字节对P接口光纤)。

单向模式

当有一LOS/LOF报警(失败)时在W Rx, W路由器认可失败并且通知P路由器(通过本地互连PGP)。P路由器指示W路由器取消选定W接口(通过本地互连PGP)。只要W接口取消选定强制ADM换成Rx P接口, W路由器主张线路告警指示信号(LAIS)为。P路由器请求ADM换成P接口(通过在P接口的K1/K2字节对ADM光纤)。P路由器选择P接口,并且ADM遵守交换请求。

在单向模式,路由器强制ADM交换。为了执行如此,路由器主张LAIS (不变,如果在W;一瞬间,如果在P)。所以,您看到的单向相当实时,因为单向模式遵照GR-253。然而,什么单向也是,强制第二单向的交换机,做交换机看来双向。这是在路由机制限制条件的结果(IP)深深地被嵌入,各级假设流量必须有Rx和Tx在同一个接口。总之,路由器遵照在GR-253的单向的协议,但是强制交换到型号该支持IP。因此,路由器不支持Tx和Rx在不同的光纤对。

注意: 主要偏差Cisco 12000系列从GR-253是Cisco 12000系列不桥接传送对W和P,然而每次保持一接口激活。

基本情形

工作接口到ADM 的光纤出现故障

ADM看到光纤故障并且发送SF交换请求到P路由器(通过在P接口光纤的K1/ K2字节),并且请求交换机对P接口。P路由器指示W路由器取消选定(撤销) W接口(通过本地互连)。P路由器选择(激活) P接口。P路由器通知ADM遵照交换请求(通过在P接口ADM光纤的K1/ K2字节)。

ADM 到工作接口的光纤出现故障(双向模式)

W路由器认可失败并且通知P路由器(通过本地互连)。P路由器指示W路由器取消选定W接口(通过本地互连)。P路由器请求ADM换成Tx和Rx P (通过在P接口的K1/K2字节对ADM光纤)。P路由器选择P接口,并且ADM遵守交换请求并且发信号标准(通过在ADM的K1/K2字节对P接口光纤)。

ADM 到工作接口的光纤出现故障(单向模式)

W路由器认可失败并且通知P路由器(通过本地互连)。P路由器指示W路由器取消选定W接口(通过本地互连)。W路由器主张LAIS为了100毫秒能强制ADM换成Rx P接口。P路由器请求ADM换成P接口(通过在P接口的K1/K2字节对ADM光纤)。P路由器选择P接口,并且ADM遵守交换请求。

工作接口和 ADM 链路间的 Tx 和 Rx 光纤都出现故障

两个顺序开始。P路由器是否首先发起交换机对P,或者ADM发起交换机不重要,因为结果是相同的。

配备PoS的Cisco路由器作为SONET/Synchronous数字体系(SDH)部分、线路和链路的路径分段的终端设备(TE),并且能检测和报告这些SONET/SDH错误和报警:

  • 章节:LOS、LOF和超越门限值告警(TCA) (B1)

  • 线路:AIS (线路和路径),远端缺陷指示(RDI) (线路和路径),远程错误指示(REI), TCA (B2)

  • 路径:AIS, RDI, REI, (B3), New pointer events (NEWPTR),有效填充事件(PSE),无效填充事件(NSE)

其他报表中的信息包括:

  • Sf-ber

  • SD-BER

  • C2 -信号标签(有效载荷建设)

  • J1 -路径跟踪字节

而其他例如LOS、LOF和LAIS属于报警, B1、B2和B3分类作为性能监视参数。而报警指示失败,性能监控适合于对预先警报。K1/K2字节状态为SONET APS或SDH多业务交换路径(MSP)也报告。

K1/K2 字节

当您讨论APS时,您首先需要知道SONET如何在LOH使用K1/K2字节。

每同步传输Signal-1 (STS-1)包括810个字节,包含传输开销(TOH)的27个字节和同步有效载荷包的(SPE) 783个字节。表1由90列说明STS-1帧的格式和9行。

表1 – STS-1帧的格式

路径开销
段开销 A1 成帧 A2 成帧 A3 成帧 J1 Trace
B1 BIP-8 E1通讯线 E1用户 B3 BIP-8
D1 Data Com D2 Data Com D3 Data Com C2信号标签
线路开销 H1指示器 H2指示器 H3指示器操作 G1路径状态
B2 BIP-8 K1 K2 F2用户信道
D4 Data Com D5 Data Com D6数据COM H4指示符
D7 Data Com D8 Data Com D9 Data Com Z3增长
D10 Data Com D11 Data Com D12 Data Com Z4增长
S1/Z1 Sync状态或增长 M0或M1/Z2 REI-L增长 E2通讯线 Z5串接

K1/K2字节形成16位字段。表2列出每个位使用情况。

表2 – K1位说明

比特(十六进制) 说明
K1比特12345678
比特5至8
nnnn 信道数关联与指令编码。
比特1至4
1111 (0xF) 保护请求中断。
1110 (0xE) 强制交换请求。
1101 (0xD) SF -高优先级请求。
1100 (0xC) SF -低优先级请求。
1011 (0xB) SD -高优先级请求。
1010 (0xA) SD -低优先级请求。
1001 (0x9) 没使用。
1000 (0x8) 手动交换请求。
0111 (0x7) 没使用。
0110 (0x6) 恢复请求的等待。
0101 (0x5) 没使用。
0100 (0x4) 练习请求。
0011 (0x3) 没使用。
0010 (0x2) 反向请求。
0001 (0x1) 请勿恢复请求。
0000 (0x0) 没有请求。

注意: 位1是低阶位。

表3 – K2比特说明

比特 说明
K2比特12345678  
比特1至4  
nnnn 信道数关联与指令编码。
位5  
1 一对n (1:n)体系结构。
0 一加上一(1+1)体系结构。
比特6至8  
111 线路AIS。
110 线路RDI。
101 双向操作模式。
100 单向的操作模式。
其他 保留。

注意: 在K2 (12345678)中:

  • K2[1-4] –目前桥接的信道数。

  • K2[5] –体系结构(总是0 1+1的)。

  • K2[6-8] –设置的操作模式(4 = unidir;5 = bidir)。

  • K2[6-8] –并且运载报警代码6=LRDI和7=LAIS。

注意: 在SDH中, K2[6-8]运载仅报警代码。操作模式没有发送。

注意: 例如,如果路由器接收SF,什么是K1和对应的K2的值在W ?在P侧?

注意: 答案:仅P传送并且读K1/K2,从未W。在双向模式,如果W接收SF和没有更高的请求先占有它,从P的代码到ADM是:

K1= 0xC1 (switch request, SF on 1=working, low priority) 
K2 = 0x05 (protect bridged [working bridge is incomplete];bidirectional)

注意: 在ADM答案以后:

K1 = 0x21 (Reverse request, channel 1) 
K2 = 0x15 (Working bridged; bidirectional)

注意: 保护路由器的txk1k2将是:

K1=0xC1 (switch request, SF on 1=working, low priority) 
K2 = 0x15 (working bridged; bidirectional) 

注意: 这时,交换机完成。

配置APS

图2显示从GSR的一基本APS 1+1配置到ADM (ONS15454)在双向模式,非反作用(在Cisco 12000系列的默认)。APS是线性交换式和执行在线路级上(在Cisco 12000系列和ADM与路径或端到端之间)。

注意: 因为W和P接口在同一路由器,此示例没有PGP的一条独立信道。

图2 –一基本APS 1+1配置

pos-aps_14680-a.gif

gsrA# show running-config
! 
interface Loopback0 
ip address 100.1.1.1 255.255.255.0 
no ip directed-broadcast 
! 
interface POS1/0 
ip address 10.1.1.1 255.255.255.0 
no ip directed-broadcast 
crc 16 
aps group 10 
aps working 1 
! 
interface POS1/1 
ip address 10.1.1.3 255.255.255.0 
no ip directed-broadcast 
no keepalive 
crc 16 
aps group 10 
aps revert 1 
aps protect 1 100.1.1.1
! 
router ospf 100 
network 10.1.1.0 0.0.0.255 area 0 
network 100.1.1.0 0.0.0.255 area 0 

gsrB#show running-config 
! 
interface Loopback0 
ip address 200.1.1.1 255.255.255.0 
! 
interface POS3/0
ip address 10.1.1.2 255.255.255.0 
no ip directed-broadcast 
crc 16 
aps group 10 
aps working 1 
! 
interface POS3/1 
ip address 10.1.1.4 255.255.255.0 
no ip directed-broadcast 
no keepalive 
crc 16 
aps group 10 
aps revert 1 
aps protect 1 200.1.1.1 
! 
router ospf 100 
network 10.1.1.0 0.0.0.255 area 0 
network 200.1.1.0 0.0.0.255 area 0 
! 

监控并且维护APS

为了提供关于系统进程的信息, IOS软件包括的EXEC命令详细清单开始与词显示。当您执行时这些显示命令,系统信息明细表出现。这是某些的列表共同性与输出示例:一起显示APS功能的命令, :

  • show aps

  • show controllers pos

  • show interface POS

! 
gsrA# show aps
POS1/1 APS Group 10: protect channel 0 (inactive) 
bidirectional, revertive (1 min) 
SONET framing; SONET APS signaling by default 
Received K1K2: 0x20 0x05 
Reverse Request (protect) 
Transmitted K1K2: 0xE0 0x05 
Forced Switch (protect) 
Working channel 1 at 100.1.1.1 (Enabled) 
Pending local request(s): 
0x0E (No Request, channel(s) 0 1) 
Remote APS configuration: working 
POS1/0 APS Group 10: working channel 1 (active) 

!--- Verify whether the working channel is active.

SONET framing; SONET APS signaling by default 
Protect at 100.1.1.1 
Remote APS configuration: working 

gsrA# show controllers POS 1/0
POS1/0 
SECTION 
LOF = 0          LOS    = 0                            BIP(B1) = 0 
LINE 
AIS = 0          RDI    = 0          FEBE = 0          BIP(B2) = 0 
PATH 
AIS = 0          RDI    = 0          FEBE = 0          BIP(B3) = 0 
LOP = 0          NEWPTR = 0          PSE  = 0          NSE     = 0 
Active Defects: None 
Active Alarms:  None 
Alarm reporting enabled for: SF SLOS SLOF B1-TCA B2-TCA PLOP B3-TCA 
Framing: SONET 
APS 
working (active) 

!--- Ensure that the working channel is active.

COAPS = 0          PSBF = 0 
State: PSBF_state = False 
ais_shut = FALSE 
Rx(K1/K2): 00/00  S1S0 = 00, C2 = CF 
Remote aps status working; Reflected local aps status working 
CLOCK RECOVERY 
RDOOL = 0 
State: RDOOL_state = False 
PATH TRACE BUFFER : STABLE 
Remote hostname : 12012 
Remote interface: POS3/0 
Remote IP addr  : 10.1.1.2 
Remote Rx(K1/K2): 00/00  Tx(K1/K2): 00/00    
BER thresholds:  SF = 10e-3  SD = 10e-6 
TCA thresholds:  B1 = 10e-6  B2 = 10e-6  B3 = 10e-6 
! 
gsrA# show controllers POS 1/1 
POS1/1 
SECTION 
LOF = 0          LOS    = 0                            BIP(B1) = 0 
LINE 
AIS = 0          RDI    = 0          FEBE = 0          BIP(B2) = 0 
PATH 
AIS = 0          RDI    = 0          FEBE = 0          BIP(B3) = 0 
LOP = 0          NEWPTR = 0          PSE  = 0          NSE     = 0 
Active Defects: None 
Active Alarms:  None 
Alarm reporting enabled for: SF SLOS SLOF B1-TCA B2-TCA PLOP B3-TCA 
Framing: SONET 
APS 
protect (inactive) 
COAPS = 0          PSBF = 0 
State: PSBF_state = False 
ais_shut = FALSE 
Rx(K1/K2): 20/05 Tx(K1/K2): E0/05    
Signalling protocol: SONET APS by default 
S1S0 = 00, C2 = CF 
Remote aps status working; Reflected local aps status working 
CLOCK RECOVERY 
RDOOL = 0 
State: RDOOL_state = False 
PATH TRACE BUFFER : STABLE 
Remote hostname : 12012 
Remote interface: POS3/0 
Remote IP addr  : 10.1.1.2 
Remote Rx(K1/K2): 00/00  Tx(K1/K2): 00/00 
BER thresholds:  SF = 10e-3  SD = 10e-6 
TCA thresholds:  B1 = 10e-6  B2 = 10e-6  B3 = 10e-6 
! 
gsrA# show interface p1/0 
POS1/0 is up, line protocol is up  (APS working - active) 

!--- Verify whether the working channel is active.

gsrA# show interface p1/1 
POS1/1 is up, line protocol is down  (APS protect - inactive) 

! 
gsrB# show aps
POS3/1 APS Group 10: protect channel 0 (inactive) 
bidirectional, revertive (1 min) 
SONET framing; SONET APS signaling by default 
Received K1K2: 0x00 0x05 
No Request (Null) 
Transmitted K1K2: 0x00 0x05 
No Request (Null) 
Working channel 1 at 200.1.1.1 (Enabled) 
Remote APS configuration: working 
POS3/0 APS Group 10: working channel 1 (active) 

!--- Verify whether the working channel is active.

SONET framing; SONET APS signaling by default 
Protect at 200.1.1.1 
Remote APS configuration: working 
! 
gsrB# show controllers p 3/0
POS3/0 
SECTION 
LOF = 11         LOS    = 11                           BIP(B1) = 
46701837 
LINE 
AIS = 10         RDI    = 11         FEBE = 1873       BIP(B2) = 8662 
PATH 
AIS = 14         RDI    = 27         FEBE = 460909     BIP(B3) = 
516875 
LOP = 0          NEWPTR = 11637      PSE  = 2          NSE     = 16818 
Active Defects: None 
Active Alarms:  None 
Alarm reporting enabled for: SF SLOS SLOF B1-TCA B2-TCA PLOP B3-TCA 
Framing: SONET 
APS 
working (active)

!--- Verify whether the working channel is active.

COAPS = 103        PSBF = 0 
State: PSBF_state = False 
ais_shut = FALSE 
Rx(K1/K2): 00/00  S1S0 = 00, C2 = CF 
Remote aps status working; Reflected local aps status working 
CLOCK RECOVERY 
RDOOL = 11 
State: RDOOL_state = False 
PATH TRACE BUFFER : STABLE 
Remote hostname : hswan-gsr12008-2b 
Remote interface: POS1/0 
Remote IP addr  : 10.1.1.1 
Remote Rx(K1/K2): 00/00  Tx(K1/K2): 00/00 
BER thresholds:  SF = 10e-3  SD = 10e-6 
TCA thresholds:  B1 = 10e-6  B2 = 10e-6  B3 = 10e-6 
! 
gsrB# show controllers p 3/1 
POS3/1 
SECTION 
LOF = 10         LOS    = 10                           BIP(B1) = 
250005115 
LINE 
AIS = 11         RDI    = 8          FEBE = 517        BIP(B2) = 5016 
PATH 
AIS = 14         RDI    = 25         FEBE = 3663       BIP(B3) = 7164 
LOP = 0          NEWPTR = 184        PSE  = 1          NSE     = 247 
Active Defects: None 
Active Alarms:  None 
Alarm reporting enabled for: SF SLOS SLOF B1-TCA B2-TCA PLOP B3-TCA 
Framing: SONET 
APS 
protect (inactive) 
COAPS = 538        PSBF = 0 
State: PSBF_state = False 
ais_shut = FALSE 
Rx(K1/K2): 00/05 Tx(K1/K2): 00/05 
Signalling protocol: SONET APS by default 
S1S0 = 00, C2 = CF 
Remote aps status working; Reflected local aps status working 
CLOCK RECOVERY 
RDOOL = 10 
State: RDOOL_state = False 
PATH TRACE BUFFER : STABLE 
Remote hostname : hswan-gsr12008-2b 
Remote interface: POS1/0 
Remote IP addr  : 10.1.1.1 
Remote Rx(K1/K2): 00/00  Tx(K1/K2): 00/00 
BER thresholds:  SF = 10e-3  SD = 10e-6 
TCA thresholds:  B1 = 10e-6  B2 = 10e-6  B3 = 10e-6 
! 
gsrB#show interface p3/0 
POS3/0 is up, line protocol is up  (APS working - active) 

!--- Verify whether the working channel is active.

gsrB#show interface p3/1 
POS3/1 is up, line protocol is down  (APS protect - inactive) 
! 

排除故障APS

为了排除故障与APS的问题,从这些显示和调试指令请收集输出:

  • show ver

  • show run

  • show ip int b

  • show contr POS

  • debug aps

  • show aps

进行必要的操作再现问题。发出这些命令收集最终输出和关闭调试:

  • show aps

  • no debug aps

注意: 通常情况下, debug aps命令不生成输出。当异常状况发生,此指令报告情况。

注意: 如果W和P光纤在另外路由器(当他们通常是),您必须收集在两路由器的命令输出。

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 14680