拨号和接入 : 综合业务数字网络 (ISDN),随路信令 (CAS)

ISDN配置示例- IP

2016 年 10 月 27 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

本文为ISDN提供一配置示例以使用IP。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档不限于特定的软件和硬件版本。

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 有关本文档所用命令的详细信息,请使用命令查找工具仅限注册用户)。

网络图

本文档使用以下网络设置:

/image/gif/paws/14222/40.gif

配置

本文档使用以下配置:

C2503
C2503#write terminal
######
Current configuration:
!
version 10.2
!
hostname C2503
!
enable password test
!
username C4000 password cisco

!--- See the username explanation in the 
!--- Explanation of the C2503 Configuration section of this document.

isdn switch-type basic-dms100
!
interface Ethernet0
ip address 172.16.10.1 255.255.255.0
!
interface Serial0
no ip address
shutdown
!
interface Serial1
no ip address
shutdown
!
interface BRI0
ip address 172.16.20.1 255.255.255.0
encapsulation ppp
bandwidth 56
dialer idle-timeout 300
dialer map ip 172.16.20.2 name C4000 speed 56 broadcast 14155551234
dialer map ip 172.16.20.2 name C4000 speed 56 broadcast 14155556789
dialer hold-queue 5
dialer load-threshold 100
dialer-group 1
isdn spid1 408555432101 5554321
isdn spid2 408555987601 5559876
ppp authentication chap
!
router igrp 1
network 172.16.0.0
!
ip route 192.168.24.0 255.255.255.0 172.16.20.2
access-list 100 deny ip 0.0.0.0 255.255.255.255 255.255.255.255 0.0.0.0
access-list 100 permit ip 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255
!
!
dialer-list 1 list 100
!
line con 0
line aux 0
line vty 0 4
password test
login
!
end

C4000
C4000#write terminal
######
Current configuration:
!
version 10.2
!
hostname C4000
!
enable password test
!
username C2503 password cisco

!--- See the username explanation in the 
!--- Explanation of the C4000 Configuration section of this document.

isdn switch-type basic-dms100
!
interface Ethernet0
ip address 192.168.24.65 255.255.255.0
!
interface Serial0
no ip address
shutdown
!
interface Serial1
no ip address
shutdown
!
interface BRI0
ip address 172.16.20.2 255.255.255.0
encapsulation ppp
bandwidth 56
dialer idle-timeout 300
dialer map ip 172.16.20.1 name C2503 speed 56 broadcast 14085554321
dialer map ip 172.16.20.1 name C2503 speed 56 broadcast 14085559876
dialer hold-queue 5
dialer load-threshold 100
dialer-group 1
isdn spid1 415555123401 5551234
isdn spid2 415555678901 5556789
ppp authentication chap
!
router igrp 1
network 172.16.0.0
network 192.168.24.0
!
ip route 172.16.10.0 255.255.255.0 172.16.20.1
access-list 100 deny ip 0.0.0.0 255.255.255.255 255.255.255.255 0.0.0.0
access-list 100 permit ip 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255
!
!
dialer-list 1 list 100
!
line con 0
line aux 0
line vty 0 4
password test
login
!
end

C2503配置的说明

C2503#write terminal
######
Current configuration:
!
version 10.2
!
hostname C2503
!
enable password test
!
username C4000 password cisco

用户名C4000是远程路由器的主机名。dialer map命令,此部分说明,使用此用户名。用户名在验证时不是区分大小写。然而,您用dialer map命令配置的名称区分大小写。您必须完全地匹配远程路由器的主机名,是"C4000"。

注意: 在路由器C2503,您用username命令配置的名称必须完全地匹配您用dialer map命令配置的名称。您发出username命令在全局配置模式。

质询握手验证协议(CHAP)认证过程使用密码。密码区分大小写,并且必须完全地匹配远程路由器密码。

注意: 为了避免混乱,此配置示例使用密码cisco的未加密的形式。在实际部署,密码出现以其加密形式:7个13061E010803。在此密码, 7表示加密类型,并且13061E010803是密码cisco的加密形式。当您发出或做对username命令时的变动,总是请输入密码以其未加密的形式,并且请勿进入加密类型(7)。加密类型自动地设置。

  • isdn switch-type basic-dms100 — ISDN交换机类型必须匹配您的载波的设备。如果更改交换机类型,您必须重新加载路由器为了新的交换机类型能生效。

    interface Ethernet0
    ip address 172.16.10.1 255.255.255.0
    
    interface Serial0
    no ip address
    shutdown
    !
    interface Serial1
    no ip address
    shutdown
    !
    interface BRI0
    ip address 172.16.20.1 255.255.255.0
  • encapsulation ppp —请使用PPP封装而不是高级数据链路控制(HDLC)为了允许使用CHAP认证。

  • 带宽56 — BRI接口的默认带宽设置是64 Kbps。如果配置您的与speed 56选项的拨号映射语句,请包括带宽说明

    注意: 此指令不控制您的ISDN专线的速度。命令设置正确参考点为:

    • BRI端口show interface统计信息

    • dialer load-threshold命令

    • 增强型内部网关路由协议(EIGRP) /Enhanced IGRP (EIGRP)路由度量

  • dialer idle-timeout 300 —此命令设置ISDN连接依然是开放秒钟的数量,如果关注数据流没有路由。Interesting Packets转发的计时器每次重置。

  • 拨号映射IP 172.16.20.2名称C4000 speed 56广播14155551234

    拨号映射IP 172.16.20.2名称C4000 speed 56广播14155556789

    当关注数据流转发对BRI接口时,请以CHAP认证使用dialer map命令为了发出初始呼叫到远程路由器。当连接变得激活时,拨号程序空闲Timeout命令确定连接的时间长度能依然是活动。拨号映射语句为将呼叫的每个ISDN电话号码是必要的。然而,请注意指向同一个位置的两个拨号映射语句能启动两条B信道,当您可以只要使用一个信道时。

    此示例的命令参数是:

    • 172.16.20.2 —远程路由器BRI接口的IP地址

      为了确定此地址,请发出show interface bri 0命令在远程路由器控制台提示。

    • 给出C4000 —远程路由器的主机名

      名称区分大小写,并且必须匹配您为username命令配置的名称。

    • speed 56 —设定拨号速度为不是64 Kbps端对端的ISDN电路的56 Kbps

      包括此参数在两路由器拨号映射语句。必须为56 Kbps配置多数安装在北美。

    • 广播—允许广播包转发

      除非dialer-list命令指定广播包作为Interesting Packets,数据包只转发,当ISDN链路是活跃的时。

    • 1415555123414155556789 —远程路由器ISDN电话号码

  • dialer hold-queue 5 —此命令允许将排队的Interesting Packets直到ISDN连接的建立。在本例中,五Interesting Packets将排队。

  • dialer load-threshold 100 —此命令配置按需带宽。命令在拨号程序前设置最大载荷通过第二条B信道发出另一呼叫。负荷是为该接口提供的已经计算过的加权平均负载值,其中1表示未装载,255表示完全装载。配置的实际负载值取决于您的特定网络特性。在本例中,第二条B信道激活,当负载达到最大利用率的39百分比时,是255除的100。

  • 拨号组1 —在BRI接口的dialer-group 1命令enable (event)拨号器列表1,确定哪些数据包是触发的,并且激活ISDN连接。

  • isdn spid1 408555432101 5554321

    isdn spid2 408555987601 5559876

    请使用isdn spid命令您的载波是否分配服务配置文件标识符(SPID)到您的ISDN专线。

  • ppp authentication chap —此命令启用CHAP认证。

    router igrp 1 
    network 172.16.0.0
  • ip route 192.168.24.0 255.255.255.0 172.16.20.2 —此ip route命令创建静态路由对远程路由器网络通过远程路由器BRI接口。这是需求,因为动态路由丢失,当ISDN链路发生故障时。

    此示例的命令参数是:

    • 192.168.24.0 —目标网络

    • 255.255.255.0 —目标网络掩码

      一255在八位位组位置指定该八位位组的完全匹配是必要的。一0在八位位组位置指定所有值配比。

    • 172.16.20.2 —能使用到达目标网络下一跳的地址

  • access-list 100拒绝ip 0.0.0.0 255.255.255.255 255.255.255.255 0.0.0.0

    access-list 100 permit ip 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255 —此访问列表命令确定哪些IP信息包是触发的,并且激活ISDN链路。创建的访问列表取决于您的特定网络设计。

    access-list 100拒绝ip 0.0.0.0 255.255.255.255 255.255.255.255 0.0.0.0 —此访问列表命令定义了广播包如非触发的。

    access-list 100 permit ip 0.0.0.0 255.255.255.255 0.0.0.0255.255.255.255 —此访问列表命令定义了其他IP信息包如触发的。

  • dialer-list 1列表100 —此命令指向访问列表100,确定哪些IP信息包是触发的。

    line con 0
    line aux 0
    line vty 0 4
    password test
    login
    !
    end

C4000配置的说明

C4000#write terminal
######
Current configuration:
!
version 10.2
!
hostname C4000
!
enable password test
!
username C2503 password cisco

用户名C2503是远程路由器的主机名。dialer map命令,此部分说明,使用此用户名。用户名在验证时不是区分大小写。然而,您用dialer map命令配置的名称区分大小写。您必须完全地匹配远程路由器的主机名,是"C2503"。

注意: 在路由器C4000,您用用户名配置的名称必须完全地匹配您用dialer map命令配置的名称。您发出username命令在全局配置模式。

CHAP验证过程使用密码。密码区分大小写,并且必须完全地匹配远程路由器密码。

注意: 为了避免混乱,此配置示例使用密码cisco的未加密的形式。在实际部署,密码出现以其加密形式:7个13061E010803。在此密码, 7表示加密类型,并且13061E010803是密码cisco的加密形式。当您发出或做对username命令时的变动,总是请输入密码以其未加密的形式,并且请勿进入加密类型(7)。加密类型自动地设置。

  • isdn switch-type basic-dms100 — ISDN交换机类型必须匹配您的载波的设备。如果更改交换机类型,您必须重新加载路由器为了新的交换机类型能生效。

    interface Ethernet0
    ip address 192.168.24.65 255.255.255.0
    
    interface Serial0
    no ip address
    shutdown
    !
    interface Serial1
    no ip address
    shutdown
    !
    interface BRI0
    ip address 172.16.20.2 255.255.255.0
    
    encapsulation ppp
  • encapsulation ppp —请使用PPP封装而不是HDLC为了允许使用CHAP认证。

  • 带宽56 — BRI接口的默认带宽设置是64 Kbps。如果配置您的与speed 56选项的拨号映射语句,请包括带宽说明

    注意: 此指令不控制您的ISDN专线的速度。命令设置正确参考点为:

    • BRI端口show interface统计信息

    • dialer load-threshold命令

    • IGRP/EIGRP路由度量

  • dialer idle-timeout 300 —此命令设置ISDN连接依然是开放秒钟的数量,如果关注数据流没有路由。Interesting Packets转发的计时器每次重置。

    dialer map ip 172.16.20.1 name C2503 speed 56 broadcast 14085554321
    dialer map ip 172.16.20.1 name C2503 speed 56 broadcast 14085559876 

    当关注数据流转发对BRI接口时,请以CHAP认证使用dialer map命令为了发出初始呼叫到远程路由器。当连接变得激活时,拨号程序空闲Timeout命令确定连接的时间长度能依然是活动。拨号映射语句为将呼叫的每个ISDN电话号码是必要的。然而,请注意指向同一个位置的两个拨号映射语句能启动两条B信道,当您可以只要使用一个信道时。

    此示例的命令参数是:

    • 172.16.20.1 —远程路由器BRI接口的IP地址

      为了确定此地址,请发出show interface bri 0命令在远程路由器控制台提示。

    • 给出C2503 —远程路由器的主机名

      名称区分大小写,并且必须匹配您为username命令配置的名称。

    • speed 56 —设定拨号速度为不是64 Kbps端对端的ISDN电路的56 Kbps

      包括此参数在两路由器拨号映射语句。必须为56 Kbps配置多数安装在北美。

    • 广播—允许广播包转发

      除非dialer-list命令指定广播包作为Interesting Packets,数据包只转发,当ISDN链路是活跃的时。

    • 1408555432114085559876 —远程路由器ISDN电话号码

  • dialer hold-queue 5 —此命令允许将排队的Interesting Packets直到ISDN连接的建立。在本例中,五Interesting Packets将排队。

  • dialer load-threshold 100 —此命令配置按需带宽。命令在拨号程序前设置最大载荷通过第二条B信道发出另一呼叫。负荷是为该接口提供的已经计算过的加权平均负载值,其中1表示未装载,255表示完全装载。配置的实际负载值取决于您的特定网络特性。在本例中,第二条B信道激活,当负载达到最大利用率的39百分比时,是255除的100。

  • 拨号组1dialer-group 1命令启用在BRI接口的拨号器列表1,确定哪些数据包是触发的,并且激活ISDN连接。

  • isdn spid1 415555123401 5551234

    isdn spid2 415555678901 5556789

    请使用isdn spid命令您的载波是否分配SPID到您的ISDN专线。

  • ppp authentication chap —此命令启用CHAP认证。

    router igrp 1
    network 172.16.0.0
    network 192.168.24.0
  • ip route 172.16.10.0 255.255.255.0 172.16.20.1 —此ip route命令创建静态路由对远程路由器网络通过远程路由器BRI接口。这是需求,因为动态路由丢失,当ISDN链路发生故障时。

    此示例的命令参数是:

    • 172.16.0.0 —目标网络

    • 255.255.0.0 —目标网络掩码

      一255在八位位组位置指定该八位位组的完全匹配是必要的。一0在八位位组位置指定所有值配比。

    • 172.16.20.1 —能使用到达目标网络下一跳的地址

  • access-list 100拒绝ip 0.0.0.0 255.255.255.255 255.255.255.255 0.0.0.0

    access-list 100 permit ip 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255 —此访问列表命令确定哪些IP信息包是触发的,并且激活ISDN链路。创建的访问列表取决于您的特定网络设计。

    access-list 100拒绝ip 0.0.0.0 255.255.255.255 255.255.255.255 0.0.0 —此访问列表命令定义了广播包如非触发的。

    access-list 100 permit ip 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255 —此访问列表命令定义了其他IP信息包如触发的。

  • dialer-list 1列表100 —此命令指向访问列表100,确定哪些IP信息包是触发的。

    line con 0
    line aux 0
    line vty 0 4
    password test
    login
    !
    end

验证

当前没有可用于此配置的验证过程。

故障排除

目前没有针对此配置的故障排除信息。


相关信息


Document ID: 14222