广域网 : X.25 协议

配置路由器作为XOT的PAD到异步主机

2016 年 10 月 27 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

本文呈现方面远程主机连接对在传输控制协议(TCP)网络的X.25在公共交换电话网(PSTN)拨号线路的一配置示例在。主机不发送也不收到任何X.25数据包。然而,它联络的远程路由器作为X.25信息包组合/分拆器(PAD)并且封装并且解封装主机的X.25数据包。

注意: 这没有指“反向填充位”,当X25呼叫可能从X25设备(服务器)只建立对异步主机,没有反之亦然。向前填充位要求一不同的配置。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

对我们能在协议转换服务中使用的PAD相关的功能的增强在Cisco IOSï ¿  ½软件版本11.2介绍。

以下平台支持PAD增强:

  • Cisco 2500 系列路由器

  • Cisco 26xx系列路由器

  • Cisco 36xx系列路由器

  • Cisco 4000路由器

  • Cisco 4500路由器

  • Cisco 4700路由器

  • Cisco AS5200系列路由器

  • 思科7000系列路由器

  • 思科7200系列路由器

  • 思科7500系列路由器

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

背景信息

在X.25 over TCP (XOT)的PAD启用PAD呼叫对在物理X.25接口不是可及的目的地,但是在TCP通道。此功能启用起源于在IP链路的一个路由器的PAD呼叫到达X.25设备。PAD over XOT也启用从作为PAD将接受的IP链路的流入XOT连接或在本地路由器的协议转换连接。

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 要查找本文档所用命令的其他信息,请使用命令查找工具仅限注册用户)。

网络图

本文档使用以下网络设置:

/image/gif/paws/14188/netdiag1.jpg

配置

本文档使用以下配置:

远程路由器
Current configuration:
!
version 12.0
 service pad from-xot                   

!---used for allowing incoming xot to pad connection

 service timestamps debug uptime
 service timestamps log uptime
 no service password-encryption
!
!OPTIONAL
x29 profile default 2:0, 4:1, 15:0, 7:21 

!---apply customized x29 profile as default to all incoming connections

!
hostname Remote
!
memory-size iomem 25
 ip subnet-zero
 no ip domain-lookup
!
x25 routing
!
interface Serial0
 ip address 10.10.100.2 255.255.255.0
 no ip directed-broadcast
!
interface Serial1
 ip address 10.10.175.1 255.255.255.0
 no ip directed-broadcast
!
interface FastEthernet0
 ip address 10.10.10.42 255.255.255.0
 no ip directed-broadcast
 half-duplex
!
ip classless
 no ip http server
!
x25 route ^100 xot 10.10.100.1
 x25 host remote 250                 
!---map the x25 address of 25099 to the router's
hostname
!
line con 0
 no exec
 exec-timeout 0 0
 transport input none
line aux 0                     

!---to async host

 no exec
 modem InOut
 rotary 99                   

!---enable reverse PAD

 transport input pad
 flowcontrol hardware
line vty 0 4
 login local
!

主路由器
Current configuration:
!
version 12.0
 service timestamps debug uptime
 service timestamps log uptime
 no service password-encryption
!
hostname Main
!
!
memory-size iomem 25
 ip subnet-zero
 no ip domain-lookup
!
x25 routing
!
!
!
interface Serial0
 ip address 10.10.100.1 255.255.255.0
 no ip directed-broadcast
 clockrate 800000
!
interface Serial1
 no ip directed-broadcast
 encapsulation x25 dce
 x25 address 150
 clockrate 56000
!
interface FastEthernet0
 no ip address
 no ip directed-broadcast
 half-duplex
!
ip classless
 no ip http server
!
x25 route ^250 xot 10.10.100.2
 x25 route ^100 interface Serial1
!
line con 0
 transport input none
 line aux 0
 line vty 0 4
 login local
!
no scheduler allocate
end

验证

当前没有可用于此配置的验证过程。

故障排除

本部分提供的信息可用于对配置进行故障排除。

故障排除命令

命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

注意: 在发出 debug 命令之前,请参阅有关 Debug 命令的重要信息

  • debug x25 events —显示关于所有X.25流量或一个特定X.25服务类的信息。

  • debug pad —显示所有PAD连接的调试消息。

以下debug输出为从服务器的一成功的X.25呼叫显示到主机。我们执行了在远程路由器的这些调试on命令。

Remote#debug x25 events
Remote#debug pad
WORKING CALL
2d01h: pad_ctxt_up: id 808D6F18, reason 80742B9C (event 0, impetus 10)
2d01h: [10.10.100.1,11042/10.10.100.2,1998]: XOT I P/Inactive Call (20) 8
lci 1
2d01h:   From (5): 10006 To (5): 25099
2d01h:   Facilities: (6)
2d01h:     Packet sizes: 128 128
2d01h:     Window sizes: 2 2
2d01h:   Call User Data (4): 0x01000000 (pad)
2d01h: PAD: incoming call to 25099 on line 5 CUD length 4
2d01h: PAD: Creating TTY daemon on tty5 for vc 1
2d01h: [10.10.100.1,11042/10.10.100.2,1998]: XOT O P3 Call Confirm (5) 8
lci 1
2d01h:   From (0):  To (0):
2d01h:   Facilities: (0)
2d01h: PAD5: Call completed
2d01h: PAD5: Output X29 packet type 4 (Read X.3 param) len 1
2d01h: PAD5: Control packet received.
2d01h: PAD5: Input X29 packet type 0 (Parameter indication) len 45
1:1, 2:1, 3:2, 4:0, 5:0, 6:5, 7:2,
8:0, 9:0, 10:0, 11:14, 12:1, 13:4, 14:0, 15:1,
16:8, 17:24, 18:18, 19:2, 20:255, 21:7, 22:0,
2d01h: PAD5: Setting ParamsIn, length 44
2d01h: PAD5: Output X29 packet type 6 (Set and Read) len 9 2:0, 4:1,
15:0,7:21,
2d01h: PAD5: Control packet received.
2d01h: PAD5: Input X29 packet type 0 (Parameter indication) len 9 2:0,
4:1, 15:0, 7:21,


相关信息


Document ID: 14188