语音 : Digital CCS

公共信道信令 (CCS)的VoIP

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

本文说明配置必要为本文的两路由器通信通过VoIP和公共信道信令(CCS)在数字PRI。

请注意在此配置方面,两路由器在IP分段连接背对背。然而在多数拓扑方面,支持语音的路由器能任何地方存在。通常,语音路由器通过LAN连通性与连接到WAN的其他路由器相连。这是重要注释,因为,如果您的语音路由器没有在租用线路连接,所有WAN连接配置命令配置在连接对广域网的那些路由器和不在语音路由器,因为他们在本文的配置里。

Cisco 3640路由器Cisco AS5300路由器用于此配置示例时,这些配置可能也用于Cisco 2600系列路由器

先决条件

要求

在您能配置您的Cisco路由器使用VoIP前,这是最佳,如果在思科IOSï ¿  ½软件方面了解服务质量(QoS)功能的概念。要得知更多QoS功能,参考队列,流量整形和过滤QoS信令Cisco IOS QoS页在Cisco.com。

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • Cisco2600和3640系列路由器

  • Cisco AS5300

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

T1信令:CAS和CCS

在电话中发信令可以提供下述功能,例如监督和广播线路状态,呼叫设法连接时提供给设备的告警信息,路由和寻址信息等。

有两不同种类的在T1世界内的信令信息:

  • CCS

  • 随路信令(CAS)

CCS

CCS是信令信息发射在信息波段外面。此信令类型最值得注意和最用途广泛的表是ISDN。对使用的一个缺点ISDN PRI是一个DS0删除或者语音信道。在这种情况下,发信号使用。所以,一个T1将为用户数据提供二十三个DS0,或者一个B信道;并为信令提供一个DS-0或D信道。是可能的对与单个D-channel的控制多个PRI与其中每一使用Non Facility Associated Signaling (NFAS)。所以,您在NFAS组中能配置其他PRI使用全部二十四Ds0s作为B信道。特别是随着56k调制解调器的出现,使用PRI信令保证最大可能的连接速度。这说明ISDN的纯信道功能。

使用CCS另一个缺点(如在网络图中看到)是PBX需要一个数字T1PRI卡,比E$amp;M信令卡昂贵。如果运行CAS在AS5300和PBX之间, E$amp;M信令卡用于同一个网络图

CAS

CAS是信令信息发射在信息波段内的或者带内信令。这意味着语音信号在与线路状态、地址和告警信号相同的电路上发信号传输。尽管有在完整T1线路的二十四个信道, CAS插入在语音数据包内的信令数据包。所以,有使用的全双工二十四个信道语音。

CAS发信号的多种类型是可用的在T1世界。最普通的表CAS发信号是环路启动、地面启动和E$amp;M信令。CAS信令的最大缺点是网络使用来自于信息IP包(如语音信息包)的位信息,以执行信令功能。CAS发信号经常因而指夺位信号

当一个尝试达到最高连接速度用调制解调器时, CAS不是最佳的选择。多数调制解调器能调节到信号质量和仍然给高速的可靠的连接。然而,使用56k在CAS线路的调制解调器由差不多2 K降低连接速度在通信下行方向每使用CAS发信号的中继。

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 要查找本文档所用命令的其他信息,请使用命令查找工具仅限注册用户)。

网络图

本文档使用以下网络设置:

/image/gif/paws/14079/voip_pri_cookbook_topo.gif

配置

本文档使用以下配置:

Cisco 3640 San Jose
sanjose3640A#show run
Building configuration...
 
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 3640
!
logging buffered 60000 debugging
enable password cisco
!
no ip subnet-zero
!
!
!
!
voice-port 1/0/0
!
voice-port 1/0/1
!
voice-port 3/0/0
 operation 4-wire
!
voice-port 3/0/1
 operation 4-wire
!
voice-port 3/1/0
!
voice-port 3/1/1
!
dial-peer voice 1 pots     

!--- More on dial peers.

 destination-pattern 4552468
 port 1/0/1
!
dial-peer voice 2 voip
 destination-pattern 3006
 session target ipv4:10.2.1.2
!
dial-peer voice 3 pots
 destination-pattern 5551234
 port 1/0/0
!
dial-peer voice 4 voip
 destination-pattern 4005
 fax-rate 9600
 session target ipv4:10.2.1.2
!
interface Ethernet0/0
 ip address 10.2.1.1 255.255.255.0
 no ip directed-broadcast
!
interface Serial2/0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 shutdown
 no fair-queue
 clockrate 64000
!
interface Serial2/1
 no ip address
 no ip directed-broadcast
 shutdown
 clockrate 38000
!
interface Serial2/2
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial2/3
 no ip address
 no ip directed-broadcast
 shutdown
!
ip classless
no ip http server
!
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password cisco
 login
!
end

Cisco AS5300 Raleigh
AS5300#show run
Building configuration...
 
Current configuration:
!
version 11.3
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname AS5300
!
boot system flash c5300-js-mz_113-6_na2.bin
enable password cisco
!
isdn switch-type primary-dms100
!
!
controller T1 0
 framing esf
 clock source line primary
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 1
 clock source internal
!
controller T1 2
 clock source internal
!
controller T1 3
 clock source internal
!
!
dial-peer voice 1 voip           

!--- More on dial peers.

 destination-pattern 4552468
 session target ipv4:10.2.1.1
!
dial-peer voice 2 pots
 destination-pattern 3...
 direct-inward-dial
 port 0:D
 prefix 3
!
dial-peer voice 4 pots
 destination-pattern 4...
 direct-inward-dial
 port 0:D
 prefix 4
!
dial-peer voice 3 voip
 destination-pattern 5551234
 fax-rate 9600
 session target ipv4:10.2.1.1
!
!
voice-port 0:D
!
interface Ethernet0
 ip address 10.2.1.2 255.255.255.0
!
interface Serial0:23
 no ip address
 isdn switch-type primary-dms100
 isdn tei-negotiation first-call
 isdn incoming-voice modem
 no cdp enable
!
interface FastEthernet0
 no ip address
 shutdown
!
ip classless
!
logging buffered 60000 debugging
!
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

验证

当前没有可用于此配置的验证过程。

故障排除

本部分提供的信息可用于对配置进行故障排除。

故障排除命令

命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

注意: 在发出 debug 命令之前,请参阅有关 Debug 命令的重要信息


相关信息


Document ID: 14079