语音 : H.323

了解、配置和故障排除资源分配指示

2016 年 10 月 27 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

本文简要地描述对资源分配监控程序的需要,如何工作,如何配置它和排除故障它和一些思科IOSï ¿  ½缺陷(Bug)注意。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • Cisco IOS软件版本12.2(1)

  • Cisco AS5300, 3660, 2611, 3640

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

RAI 概念

要允许网守做出智能呼叫路由决策,网关其资源可用性状况向其网守报告。监控的资源是DS0信道和DSP信道。

网关其资源状态向有使用的网守报告RAS资源可用性指示(RAI)。当受监视资源在可配置阈值之下时下降,网关发送RAI到表明的网守网关几乎是在资源外面。当可用资源在另一可配置阈值上时然后交叉,表明的网关发送RAI资源耗尽情况不再存在。

此功能在Cisco AS5300网关的其他网关的Cisco IOS软件版本12.0(5)T和Cisco IOS软件版本12.1(1)T包括在H.323版本2。

H.225 的 RAI 定义

RAI是从网关的一个通知到其每份H系列协议的当前该协议的呼叫量和数据速率网守。网守回应资源可用性确认(RAC)在接收RAI确认其接收。

RAI消息包括:

  • requestSeqNum

  • 议标识符

  • nonStandardData

  • endpointIdentifier

  • 协议

  • almostOutOfResources (特鲁,错误)

  • 令牌, cryptoTokens

  • integrityCheckValue

RAC消息包括:

  • requestSeqNum

  • 议标识符

  • nonStandardData

  • 令牌

  • cryptoTokens

  • integrityCheckValue

注意: 此定义是从H.225协议。在H.323版本2和H.323版本3, RAI用于报道网关有或没有处理的资源流入VoIP呼叫。呼叫量进来H.323版本4。

RAI 在 Cisco 网关和网守上如何正常工作

  • 通过使用resource threshold命令在网关CLI下,报告阈值的资源配置。较大和低限阈值是个别配置的防止网关间歇操作由于可用性或缺乏资源。

    resource threshold [all] [high percentage-value] [low percentage-value]

    " high "和“低值”的默认是90。

    利用率计算如被看到此处:

    • 可访问信道=在使用+自由

    • 利用率=在使用/可访问

    当您计算利用率时,请考虑到可访问信道。已禁用信道没有计数。show call resource voice stat命令显示“可寻址的信道”数量。可寻址的信道是例如关联与有效POTS拨号对等的信道(被关闭的POTS拨号对等没有被认为有效)。可寻址的信道不一定等于可访问信道,因为您能禁用可寻址的信道(控制器发生故障,或者您使忙碌某些Ds0s为例)。

    例如,假设您有四T1 :呼入呼叫的两T1,两流出的。您有占线的流出的时隙的46个时隙,并且您有在其中一个的一呼叫流出的时隙。您将有:

    • 托塔尔= 96

    • 可寻址= 48

    • 已禁用= 46

    • 在使用= 1

    • Free= 1

    利用率= 1/(1+1)= 50%。因此,如果已配置的高限阈值是90%,网关仍然接受呼叫。

    如果有"0"在使用和"0"自由信道,您立即然后点击高限阈值。万一需要维护它,这是一种方式停止发送呼叫到该网关。两个方式执行此是对忙碌在步骤的所有时隙,或者请关闭POTS拨号对等。当您使用POTS拨号对等方法时,有风险。在您关闭POTS拨号对等时候,网守也许已经已经路由一些呼叫到网关。这些呼叫断开与"no circuit available"断开原因代码。因为关闭dial-peer影响所有信道配置在它下,这发生。最佳方法是对忙碌一定数量的时隙,直到您点击高限阈值。一旦到达该点,请务必网守不发送任何呼叫,而您忙碌其他时隙。

  • 上述计算只考虑了到DS0资源。然而, DSP资源相似地监控并且计算。并且,资源(DSP或DS0)首先达到低或高限阈值,网关传送RAI信息。

  • 配置在网守没有必要激活RAI。

  • 一个RAI消息,类似所有其他RAS信息,是UDP。一旦网关传送RAI信息到网守,启动三秒计时器。如果计时器超时,在接收RAC前,网关还设法再发送RAI九倍。然后,它再放弃直到资源可用性状态变化。

  • 如果要制定优先级到某一网关, RAI是有用的。并且,一旦阈值达到,然后您路由流量到其他网关。

  • 网守选择根据优先级和资源阈值的网关。如果所有网关有同样优先级和资源,网守执行负载均衡。一旦网关被标记作为“在资源外面”,网守在优先级列表(底部放置网关更改网关优先级到"1")。如果没有有更加高优先级的其他网关或,如果所有网关在该区域有优先级"1",然后网守仍然发送呼叫到传送宣称RAI的信息的网关几乎是在资源外面。

  • 使用lrq reject-resource-low命令,如果所有网关在该区域被标记作为几乎资源,网守拒绝跨区呼叫。此命令在Cisco IOS软件版本12.1(3a)XI6集成。如果不使用此命令,网守不拒绝从其他区域的任何呼叫,当所有网关在该区域被标记作为在资源外面时。

  • 默认网关优先级是5。使用zone prefix <gatekeeper name> <E.164 prefix> gw-default-priority <priority 0-10>命令命令,并且默认值可以更改。万一要路由呼叫到某些网关该前缀的,此命令也是有用。然而,这不是其他的论点。并且,使用zone prefix <gatekeeper name> <E.164 prefix> gw-priority命令,您不要配置其他网关以优先级"0"。

案例研究

/image/gif/paws/14075/ram.gif

呼叫起源于在T1的PBX A连接到5300-4。呼叫匹配VoIP拨号对等体用RAS session target。在2611网守配置中,此呼叫由区域B.处理。2611网守送回LRQ到3660-2网守在区域B和RIP到5300-4。

3660-2网守配置路由该呼叫以优先级10到5300-3。下优先级是3640-3 (配置作为优先级9)。只要5300-3有资源,所有呼叫路由对它。

3660-2网守发送与5300-3的LCF作为目的地网关。当5300-3收到设置信息时,发送ARQ到其网守。在ACF以后,它设立第二个段,是FGB电话段往PBX B。

一旦5300-3被标记作为“out-of-resources”, 3660-2网守在区域B降低优先级5300-3到"1"并且启动路由流量到3640-3网关,因为有高优先级"9"。

在设置的这中5300-3有48个可寻址的DS0和配置与一70高限阈值。

从PBX A的前34呼叫在5300-3造成34个DS0使用。第三十五呼叫造成5300-3传送RAI信息到通知它的网守变为out-of-resources。第三十六呼叫和什么跟随路由到3640-3,只要5300-3仍然是“out-of-resources”。

5300-3 配置

!
controller T1 0
 framing esf
 clock source line primary
 linecode b8zs
 ds0-group 1 timeslots 1-24 type e&m-fgb dtmf dnis
!
controller T1 2
 framing esf
 clock source line secondary 1
 linecode b8zs
 ds0-group 1 timeslots 1-24 type e&m-fgb dtmf dnis
!
interface Ethernet0
 ip address 172.16.13.45 255.255.255.224
 load-interval 30
 h323-gateway voip interface
 h323-gateway voip id cisco_2 ipaddr 172.16.13.42 1718
 h323-gateway voip h323-id 5300-3
 h323-gateway voip tech-prefix 2#
!
voice-port 0:1
!
voice-port 2:1
!
dial-peer voice 11 pots
 incoming called-number .
 destination-pattern 2#987654
 direct-inward-dial
 port 0:1
 prefix 987654
!
dial-peer voice 12 pots
 destination-pattern 2#987654
 port 2:1
 prefix 987654
!
gateway 
 resource threshold high 70 low 60

!--- The gateway is configured for a high resource threshold 
!--- of 70% and low resource threshold of 60%.

!

3640-3 配置

!
controller T1 2/0
 framing esf
 linecode b8zs
 ds0-group 0 timeslots 1-24 type e&m-wink-start
!
interface Ethernet0/0
 ip address 172.16.13.40 255.255.255.224
 half-duplex
 h323-gateway voip interface
 h323-gateway voip id cisco ipaddr 172.16.13.50 1718
 h323-gateway voip id cisco_2 ipaddr 172.16.13.42 1718
 h323-gateway voip h323-id 3640-3
 h323-gateway voip tech-prefix 2#
!
voice-port 2/0:0
! 
dial-peer voice 987654 pots
 destination-pattern 2#987654
 port 2/0:0
 prefix 987654
!
gateway 

!--- No resource monitor is configured on this gateway in this lab setup.

!

3660-2 网守配置

!
interface FastEthernet0/0
 ip address 172.16.13.42 255.255.255.224
 duplex auto
 speed auto
!
gatekeeper
 zone local cisco_2 cisco.com 172.16.13.42
 zone remote cisco cisco.com 172.16.13.50 1719
 zone prefix cisco 1*
 zone prefix cisco_2 9* gw-priority 10 5300-3
 
!--- 5300-3 is configured for priority 10 for this prefix.

 zone prefix cisco_2 9* gw-priority 9 3640-3
 gw-type-prefix 2#* default-technology
 no shutdown
!

5300-4 配置

!
controller E1 0
 clock source line primary
 ds0-group 0 timeslots 1-15,17-31 type r2-digital r2-compelled 
 cas-custom 0
!
controller E1 1
 clock source line secondary 1
 ds0-group 1 timeslots 1-15,17-31 type r2-digital r2-compelled 
 cas-custom 1
!
controller E1 2
 clock source line secondary 2
 ds0-group 2 timeslots 1-15,17-31 type r2-digital r2-compelled 
!
controller E1 3
 clock source line secondary 3
 ds0-group 3 timeslots 1-15,17-31 type r2-digital r2-compelled 
!
interface Ethernet0
 ip address 172.16.13.46 255.255.255.224
 no ip mroute-cache
 load-interval 30
 h323-gateway voip interface
 h323-gateway voip id cisco ipaddr 172.16.13.50 1718
 h323-gateway voip h323-id 5300-4
 h323-gateway voip tech-prefix 1#
!
voice-port 0:0
 compand-type a-law
!
voice-port 1:1
 compand-type a-law
!
voice-port 2:2
 compand-type a-law
!
voice-port 3:3
 compand-type a-law
!
dial-peer voice 1234 voip
 incoming called-number .
 destination-pattern 987654
 session target ras
 tech-prefix 2#
!
dial-peer voice 9876 pots
 incoming called-number .
 direct-inward-dial
!
gateway 
!

2611- 网守 配置

!
interface Ethernet0/0
 ip address 172.16.13.50 255.255.255.224
 half-duplex
!
!
gatekeeper
 zone local cisco cisco.com 172.16.13.50
 zone remote cisco_2 cisco.com 172.16.13.42 1719
 zone prefix cisco 1* gw-priority 10 5300-4
 zone prefix cisco_2 9*
 gw-type-prefix 1#* default-technology
 no shutdown
!

当 34 个呼叫同时启用时的 5300-3 状态

请使用从"test dsprm"模式的show pool命令显示多少个DSP是在使用中。

dsprm 4> show pool
VFC-voice-pool      Total=120: free=86/86, in_use=34/34, pending=0/0, disabled=0/0

请使用从特权模式的show call resource voice stat命令显示所有资源统计信息(DSP和Ds0s)。

在此输出中, DSP利用率是34/120= 28%,并且DS0利用率是34/48= 70%。在两个案件配置的高限阈值(DSP和DS0 utitlization)没有超过。

5300-3#show call resource voice stat

Resource Monitor -  Dial-up Resource Statistics Information:

DSP Statistics:

Utilization: 0 percent
Total channels: 120
Inuse channels: 34   

!--- Number of DSP channels used.

Disabled channels: 0
Pending channels: 0
Free channels: 86

DS0 Statistics:

Utilization: 0 percent
Total channels: 96
Addressable channels: 48
Inuse channels: 34 

!--- Number of DS0 channels used.
    
Disabled channels: 24
Free channels: 14

请使用从特权模式的show call resource voice threshold命令检查网关的阈值状态如显示此处。

5300-3#show call resource voice threshold

Resource Monitor -  Dial-up Resource Threshold Information:

DS0 Threshold:

Client Type: h323
High Water Mark: 70
Low Water Mark: 60
Threshold State: low_threshold_hit

!--- DS0 threshold is still below the low value.


DSP Threshold:

Client Type: h323
High Water Mark: 70
Low Water Mark: 60
Threshold State: low_threshold_hit

!--- DSP threshold is still below the low value.

如果启用和激活,请使用show gateway命令检查H.323资源阈值的状态。它也给您已配置的低和高限阈值。

在此输出中您能看到资源阈值启用和激活。“启用”含义已配置的和“激活”意味着在IOS的H.323 RAS进程用资源监控注册。为例,如果网关没有用网守注册, H.323 RAS进程没有初始化,并且资源阈值启用,但是不活动。命令的输出显示此处。

5300-3#show gateway
 Gateway  5300-3  is registered to Gatekeeper cisco_2

Alias list (CLI configured) 
 H323-ID 5300-3
Alias list (last RCF) 
 H323-ID 5300-3

 H323 resource thresholding is Enabled and Active
 H323 resource threshold values:
  DSP: Low threshold 60, High threshold 70
  DS0: Low threshold 60, High threshold 70
5300-3#show gateway
 Gateway  5300-3  is not registered to any gatekeeper

Alias list (CLI configured) 
 H323-ID 5300-3
Alias list (last RCF) 
 H323-ID 5300-3

 H323 resource thresholding is Enabled but NOT Active
 H323 resource threshold values:
  DSP: Low threshold 60, High threshold 70
  DS0: Low threshold 60, High threshold 70

当 34 个呼叫同时启用时的 3660-2 网守状态

请使用show gatekeeper gw-type-prefix命令用网守检查注册的网关的优先级。检查其中任一是否被标记作为“out-of-resources”。

在此输出中,所有网关有资源,并且没有“(out-of-resources)”显示,含义5300-3仍然有资源。

3660-2#show gatekeeper gw-type-prefix 
GATEWAY TYPE PREFIX TABLE
=========================
Prefix: 2#*    (Default gateway-technology)
  Zone cisco_2 master gateway list:
    172.16.13.40:1720 6789 
    172.16.13.45:1720 5300-3
  Zone cisco_2 prefix 9* priority gateway list(s):
   Priority 10:
    172.16.13.45:1720 5300-3
   Priority 9:
    172.16.13.40:1720 6789 

并且,您能使用show gatekeeper endpoint命令发现其中任一个网关是否被标记和在资源外面。如果字段“F”有字母“O”在它下网关的,该网守然后接收从该网关的一个“资源不足” RAI。

3660-2#show gatekeeper endpoint
                    GATEKEEPER ENDPOINT REGISTRATION
                    ================================
CallSignalAddr       Port    RASSignalAddr    Port  Zone Name   Type  F 
-------------------- -----  ----------------  ------ ---------- -------    --
172.16.13.40         1720    172.16.13.40     52975   cisco_2   VOIP-GW  
    E164-ID: 6789
    E164-ID: 11
    E164-ID: 336699
    H323-ID: 3640-3
172.16.13.45         1720   172.16.13.45    58131   cisco_2     VOIP-GW  
    H323-ID: 5300-3
Total number of active registrations = 2

当 35 次呼叫同时启用时的 5300-3 状态

在此输出中, DSP利用率是35/120= 29%,并且DS0利用率是35/48= 73%。为DS0信道配置的高限阈值的值超过。并且,与“真”的" out-of-resource "字段的RAI信息传送到网守。这表明网关不能接受呼叫。

dsprm 4>show pool
VFC-voice-pool      Total=120: free=85/85, in_use=35/35, pending=0/0, disabled=0/0

5300-3#show call resource voice stat

Resource Monitor -  Dial-up Resource Statistics Information:

DSP Statistics:

Utilization: 0 percent
Total channels: 120
Inuse channels: 35
Disabled channels: 0
Pending channels: 0
Free channels: 85

!--- Number of used DSPs is 35.


DS0 Statistics:

Utilization: 0 percent
Total channels: 96
Addressable channels: 48
Inuse channels: 35
Disabled channels: 24
Free channels: 13

!--- Number of used DS0s is 35.

正如您上面看到的网关点击DS0信道的高限阈值。

在这中输出字母“O”在" F "字段下表明网关5300-3是out-of-resources。

5300-3#show call resource voice threshold

Resource Monitor -  Dial-up Resource Threshold Information:

DS0 Threshold:

Client Type: h323
High Water Mark: 70
Low Water Mark: 60
Threshold State: high_threshold_hit

!--- The DS0 resources reached the high threshold value.


DSP Threshold:

Client Type: h323
High Water Mark: 70
Low Water Mark: 60
Threshold State: low_threshold_hit

并且在网守,您看到网关5300-3被标记作为“out-of-resources”。

3660-2#show gatekeeper gw-type-prefix 
GATEWAY TYPE PREFIX TABLE
=========================
Prefix: 2#*    (Default gateway-technology)
  Zone cisco_2 master gateway list:
    172.16.13.40:1720 6789 
    172.16.13.45:1720 5300-3 (out-of-resources)
  Zone cisco_2 prefix 9* priority gateway list(s):
   Priority 10:
    172.16.13.45:1720 5300-3 (out-of-resources)
   Priority 9:
    172.16.13.40:1720 6789

!--- 5300-3 is out-of-resources.

3660-2#show gatekeeper endpoint
                    GATEKEEPER ENDPOINT REGISTRATION
                    ================================
CallSignalAddr     Port  RASSignalAddr  Port   Zone Name  Type    F 
-----------------  ----- -------------- ------ ---------- ------- --
172.16.13.40       1720  172.16.13.40   52975   cisco_2   VOIP-GW  
  E164-ID: 6789
  E164-ID: 11
  E164-ID: 336699
  H323-ID: 3640-3
172.16.13.45       1720  172.16.13.45   58131  cisco_2   VOIP-GW O
  H323-ID: 5300-3
Total number of active registrations = 2

调试

请打开debug rasdebug h225 asn1,如果认为网关不发送适当的RAI消息或网守不发送RAC消息。

注意: debug h225 asn1冗长。因此您必须小心,当您打开,特别是当网守或网关在制作时,并且他们处理许多呼叫。debug h225 asn1表示所有H.225消息(不仅RAS)。在三十五呼叫是UP后,这是这些调试输出在3660-2网守的:

在输出" almostOutOfResources "字段的这中“真”。是在资源外面的这意味着网关报告到网守。当网关点击低限阈值阈值时,传送另一RAI信息。然而,与“错误”此的字段,它告诉网守开始再发送呼叫。所有RAS消息作为一个序号和所有答复对这些消息运载同一个序号。

RAW_BUFFER::=
81 340000A1 06000891 
*Mar  5 11:26:02.961: PDU DATA = 60E28808

value RasMessage ::= resourcesAvailableIndicate : 
                     
!--- RAI message.

    {
      requestSeqNum 162
      
!--- Sequence number of the H.225 message.

      protocolIdentifier { 0 0 8 2250 0 2 }
      endpointIdentifier {"6165B9D400000006"}
      protocols 
      {
        voice : 
        {
          supportedPrefixes 
          {

            {
              prefix e164 : "2#"
            }
          }
        }
      }
      almostOutOfResources TRUE
      
!--The value of  almostOutOfResources.

    }
*Mar  5 11:26:02.965: RAI (seq# 162) rcvd

这是从网守的RAC发送的消息到确认其RAI消息的接收的网关。

PDU DATA = 60E28808

value RasMessage ::= resourcesAvailableConfirm : 
                     
!--- RAC message.

    {
      requestSeqNum 162
      
!--- Sequence number of the H.225 message.

      protocolIdentifier { 0 0 8 2250 0 2 }
    }


RAW_BUFFER::=
82 0A0000A1 06000891 4A0002
*Mar  5 11:26:02.965: 
*Mar  5 11:26:02.965:       RASLib::RASSendRAC: RAC (seq# 162) sent to 172.16.13.45

要注意的一些 Bug

这些是在另外平台的某些Cisco Bug ID。几乎所有是解决的,但是它将帮助您,万一获得与RAI的一个问题发现是否运作到其中每一个。

注意: 您能通过Bug Toolkit (仅限注册用户)访问这些Cisco Bug ID。

  • CSCds41207

  • CSCds79319

  • CSCds90317

  • CSCdt00087

  • CSCdt68781

  • CSCdt77870

  • CSCdt93779

  • CSCdu55874

  • CSCdu76312

  • CSCdu79860


相关信息


Document ID: 14075