语音和统一通信 : Cisco Unified Communications Manager (CallManager)

IP电话部署案例研究:新加坡国家公报

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 22 日) | 反馈


目录


简介

本文做联机给Cisco用户、合作伙伴和员工体验和所学课程由IP电话部署在国家公报在新加坡。本文尝试:

  • 描述并且评论部署的解决方案的设计。

  • 识别可能的改进对设计。

  • 突出显示在设计的交换。

NB是一家全局出版公司。新加坡操作包括大约6,000销售,打印和写入员工。NB员工位于在同一近处内查找的一定数量的办公楼。在2000年底, NB添加了另一建立,构件的DBS,到他们的校园。修建房子的此其他750名员工。而不是请部署在新的建立的一台内部交换机(PBX),被决定的NB部署IP电话解决方案。同样地,全新部署包括网络组件。

NB IP电话解决方案是单一站点设计。所有IP电话用户在构件的DBS查找和在五个楼层间被分配。思科CallManager,公共交换电话网(PSTN)网关和语音邮件在DBS构件物理的也查找。

广域网(WAN)链路连接构件对Nbap大厦的DBS少于1 Km外。此广域网链路通过运载VoIP (VoIP)流量对NBAP,网关连接到全世界NB PBX网络。此图表显示DBS和Nbap大厦。

/image/gif/paws/13968/65363.gif

校园 LAN 基础设施

DBS LAN基础架构包括在核心和九台Catalyst 4006交换机的一台Catalyst 6509交换机在配线间。此表显示Catalyst 6509交换机如何填充。

--
Slot 模块 说明
1 WS-X6K-SUP1A-MSFC 有多层交换机特性卡(MSFC)的Supervisor
2 WS-X6K-S1A-MSFC2/2 有MSFC的Supervisor
3 WS-X6416-GBIC 16端口GE模块
4 WS-X6408A-GBIC 8端口GE模块
5 WS-X6348-RJ45V 48波尔特有内嵌电源的10/100模块
6 WS-X6608-E1 8端口E1网关
7 WS-X6624-FXS 24波尔特局外交换站(FXS)网关
8 WS-X6624-FXS 24波尔特FXS网关
9

此表显示Catalyst 4006交换机如何填充。

Slot 模块 说明
1 WS-X4013 Supervisor2用两个千兆以太网(GE)端口
2 WS-X4148-RJ45V 48波尔特有内嵌电源的10/100模块
3 WS-X4148-RJ45V 48波尔特有内嵌电源的10/100模块
4 WS-X4148-RJ45V 48波尔特有内嵌电源的10/100模块
5 WS-X4148-RJ45V 48波尔特有内嵌电源的10/100模块
6 WS-X4148-RJ45V 48波尔特有内嵌电源的10/100模块

LAN基础架构的总容量是连接和供给2,160 IP电话动力。

Catalyst 4006交换机连接回到Catalyst 6509通过其中一个Supervisor的GE端口,在一个纯星型网方式。当第五楼有一台Catalyst 4006交换机时,四五个楼层有两台Catalyst 4006交换机。此图表说明交换机如何在楼层间被涂,并且他们如何连接回到Catalyst 6509交换机。

/image/gif/paws/13968/65364.gif

Catalyst 6509构成一个严重的单点故障。在可用性的一重大的改进可以通过添加秒钟Catalyst 6509完成和双归属Catalyst 4006交换机到两台核心交换机使用Catalyst 4006 Supervisor的备用的GE端口。使用此设计,有模块的复制的一点调整全部在Catalyst 6509的。相反,存在的模块(Supervisor, GE和FXS模块)可以在两个机箱间拆分。然而,应该添加其他八端口E1模块,以便PSTN连接可能在两个机箱间也拆分。此设计也允许两思科CallManager将连接对独立的交换机。这保证Catalyst 6509失败完全不隔离思科CallManager。

秒钟Catalyst 6509交换机是最初的建议的一部分。然而,由于开销考虑事项, NB决定了单个Catalyst 6509。

NB遵从思科设计建议并且有IP电话和数据设备在独立的虚拟LAN (VLAN)。每台Catalyst 4006有其自己的语音VLAN。所以,有每个楼层两语音VLAN,总共九语音VLAN的。每台Catalyst 4006有240个端口。所以,每语音VLAN是潜在家庭对240 IP电话。这是一保守的设计,但是有优点限制影响,如果发生故障的设备充斥VLAN与广播。当在VLAN之间的Catalyst 6000系列MSFC路由,第3层转发性能不是问题。

65365.gif

所有数据设备在单个,大VLAN驻留。这不遵守思科设计建议。然而这是NB更喜欢的设计由于他们的内部可操作和维护要求。由于此单个数据VLAN跨过所有交换机,在此VLAN的一场Layer2广播风暴有可能性影响所有IP电话。这在Catalyst交换机使服务质量(QoS)更加重要。QoS是讨论以后在本文。

此示例显示Catalyst 4006端口的一个典型的VLAN配置。此示例在语音VLAN 110和数据VLAN 11.的slot 5安置全部48个端口。

set port auxiliaryvlan 5/4-48 110 
set vlan 11 type ethernet state active 
set vlan 11 5/4-48

NB网络有这三个明显的Qos trust限定范围:

  • Catalyst 4006 10/100端口。

  • 连接对Cisco CallManager的Catalyst 6509 10/100端口。

  • 连接对Cisco 7200路由器的Catalyst 6509 10/100端口。

Catalyst 4000 10/100模块在使用中有单个接收(RX)队列(1q1t)和两个transmit (TX)队列(2q1t)。所有端口配置以in命令此示例启用第二个TX队列和放置有业务类别(CoS)值的帧在2和7之间在第二个队列。结果,所有实时传输协议(RTP)数据包(CoS=5)和所有skinny数据包(CoS=3)进入第二个队列,而其他流量进入第一个队列。

set qos enable
set qos map 2q1t 1 1 cos 0-1
set qos map 2q1t 2 1 cos 2-3
set qos map 2q1t 2 1 cos 4-5
set qos map 2q1t 2 1 cos 6-7

注意Catalyst 4006不支持任何管制。它委托在其端口接收的所有帧Cos。这不是问题,只要IP电话连接,因为IP电话的默认行为是不信任在PC端口接收的流量和重写它与Cos 0。然而,如果发送数据作为802.1p帧, PC连接直接地对Catalyst 4006端口能潜在使用QoS。这要求一个某种程度复杂的用户。然而, Windows 2000和标准以太网网络接口界面卡(NIC)支持802.1pq。

在Catalyst 6509的QoS配置是轻微包含,因为Catalyst 6509的端口有各种各样的队列结构,如此表所显示。

模块 接收队列 传输队列
WS-X6K-SUP1A-MSFC 1p1q4t 1p2q2t
WS-X6416-GBIC 1q4t 2q1t
WS-X6408A-GBIC 1p1q4t 1p2q2t
WS-X6348-RJ45V 1p1q4t 1p2q2t

有一个严格优先级队列默认情况下的所有端口在该队列放置有CoS=5的所有帧。然而,更喜欢有所有VoIP信令流量(有CoS=3的帧)在第二个非优先的队列。此配置启用此行为。

set qos map 1p2q2t tx 2 1 cos 3
set qos map 2q2t tx 2 1 cos 3

连接对Catalyst 4006交换机的GE端口是在我们的信任的边界里面。通常系统将委托收到的帧的Cos。因为Catalyst 4006信任的边界可以通过连接PC减弱直接地对交换机端口,从Catalyst 4006交换机的流量被处理如不信任和由Catalyst 6509管辖。管制由寻找RTP, skinny, H.225和H.245数据包的访问控制表(ACL)进行。当所有VoIP信令信息包报头以DSCP=26时,重写RTP信息包报头以DSCP=46重写。此的ACL,如此示例所显示,被映射到所有GE端口。

set qos acl ip ACL_VOIP dscp 46 udp any any range 16384 32767
set qos acl ip ACL_VOIP dscp 46 udp any range 16384 32767 any
set qos acl ip ACL_VOIP dscp 26 tcp any any range 2000 2002
set qos acl ip ACL_VOIP dscp 26 tcp any range 2000 2002 any
set qos acl ip ACL_VOIP dscp 26 tcp any any eq 1720
set qos acl ip ACL_VOIP dscp 26 tcp any eq 1720 any
set qos acl ip ACL_VOIP dscp 26 tcp any any range 11000 11999
set qos acl ip ACL_VOIP dscp 26 tcp any range 11000 11999 any
set qos acl map ACL_VOIP 3/1-16,4/1-8,

两Catalyst 6509的10/100端口用于连接到两思科CallManager。这些是根本可信端口,但是在NB网络他们对待不信任和在收到的帧的Catalyst 6509强制CoS=3。此示例显示端口配置。

set vlan 110 5/2-3
set port qos 5/2-3 cos 3

替代方案和更加干净的方法,是配置Cisco CallManager设置在VoIP信令信息包的IP差分服务代码点值。要执行此,设置服务参数IpTosCm2CmIpTosCm2Dvce为在Cisco CallManager的0x26。Catalyst 6509可能然后配置委托在该端口接收的帧的DSCP,如此示例所显示。

set port qos 5/2-3 trust trust-dscp

此方法有仅VoIP控制的帧和没有从Cisco CallManager的每帧,接收好QoS的优点。这是重要,如果Cisco CallManager升级镜像上载到CallManager服务器,或者,如果很多呼叫详细记录(CDR)定期地被拉服务器。目前,这种流量也接收高QoS。

最后, Catalyst 6509的10/100端口之一用于连接到Cisco 7200系列WAN路由器。这也是可信端口,但是在Cisco 7200路由器的当前思科IOS�在使用中不复制DSCP值对CoS字段。要解决此限制,交换机端口类似对待于GE端口(请分类流入的数据流使用同样ACL)和选择性地提供根据此的QoS。所以,路由器交换端口的配置在本例中显示。

set vlan 10 5/1
set qos acl map ACL_VOIP 5/1

WAN 基础设施

NB IP电话网络的广域网组件小。在DBS构件的Cisco 7200系列路由器有广域网链路对NBAP和大写塔。然而,对NBAP的仅链路传送语音。既使如此有DBS和NBAP之间的单独的链路语音和数据的。语音质量问题在部署的早期发现,并且被决定更改从G.729的编码到G.711。这要求额外带宽,因此,并且语音和数据在广域网被分离了。以后当时被发现的这些问题的原因与在使用中IP电话的负载。近期作为一次保守的测量, NB决定和G.711呆在一起和分离语音和数据的广域网链路。

目前语音广域网链路包括由多链路PPP的三物理E1链路(MLP)一起捆绑。由于相对高速链路,链路分段和交织(LFI)没有要求。唯一的需要的QoS功能排队。首选的排队机制是低延迟排队(LLQ)。然而,这没有工作由于与LLQ和MLP的一个Cisco IOS问题,从配置消失的service-policy命令,如果链路断开了。作为临时应急方案,优先级队列是在使用中的。此示例显示当前广域网配置。

interface Multilink88
 ip address 10.104.209.73 255.255.255.248
 priority-group 1
 ppp multilink
 ppp multilink fragment-delay 10
 ppp multilink interleave
 multilink-group 88

interface Serial4/0
 bandwidth 2000
 encapsulation ppp
 ppp multilink
 multilink-group 88

interface Serial4/1
 bandwidth 2000
 encapsulation ppp
 ppp multilink
 multilink-group 88

interface Serial4/2
 bandwidth 2000
 encapsulation ppp
 ppp multilink
 multilink-group 88

priority-list 1 protocol ip high list 121
priority-list 1 protocol ip medium list 122
priority-list 1 default low
priority-list 1 queue-limit 500 40 60 80

access-list 121 permit udp any any range 16384 32767
access-list 121 permit udp any range 16384 32767 any
access-list 122 permit tcp any any range 2000 2002
access-list 122 permit tcp any range 2000 2002 any
access-list 122 permit tcp any any eq 1720
access-list 122 permit tcp any eq 1720 any
access-list 122 permit tcp any any range 11000 11999
access-list 122 permit tcp any range 11000 11999 any

当前广域网配置是妥协和没有推荐用于其他部署。中期规划是整理语音和数据对单个广域网链路和替换优先级队列用LLQ。语音和数据的单独的链路要求静态路由或基于策略的路由,并且使用动态路由协议优点丢失。优先级队列,用分配的语音数据包高队列,不保证严格优先级给到语音数据包。系统流量,例如路由更新, Keepalive,等等仍然采取在语音数据包的首选在高队列。

验证LLQ在Cisco IOS软件版本12.2正确地运作。此示例在移动以后显示路由器QoS,对LLQ。带宽根据60同时G.729呼叫(RTP :60 x 24 Kbps = 1440 Kbps和信令:60 x 0.5 Kbps = 30 Kbps)。

interface Multilink88
 service-policy output VoIP

class-map VoIP-RTP
 match access-group 121
class-map VoIP-Sig
 match access-group 122

policy-map VoIP
 class VoIP-RTP
  priority 1440
 class skinny
  bandwidth 30

access-list 121 permit udp any any range 16384 32767
access-list 121 permit udp any range 16384 32767 any
access-list 122 permit tcp any any range 2000 2002
access-list 122 permit tcp any range 2000 2002 any
access-list 122 permit tcp any any eq 1720
access-list 122 permit tcp any eq 1720 any
access-list 122 permit tcp any any range 11000 11999
access-list 122 permit tcp any range 11000 11999 any

IP 电话

IP 电话和它们与交换机的连接

DBS构件有大约750个IP电话7960s。IP电话连接到10/100 Catalyst 4006的端口,并且接收从交换机的内嵌电源。PCs连接到交换机端口在IP电话背后,如此图表所示。

/image/gif/paws/13968/65373.gif

IP电话和PCs在独立的VLAN和IP子网。

站点规划

从Catalyst 4006线卡的所有IP电话接收内嵌电源。交换机由三件机箱内的AC电源用品供给动力。内嵌电源,然而,从Catalyst 4006辅助电源架(WS-P4603)来源外部。电源支架有三个电源。其中每一供应1050W在-52V DC。这是满足供给有Cisco IP电话的7960s一台充分填充的Catalyst 4006交换机动力连接对所有240个端口。

/image/gif/paws/13968/65366.gif

所有Catalyst 4006交换机进行不间断电源(UPS)。在电源故障情形下,这给他们继续操作两个小时。思科CallManager连接到四小时不间断电源。

Cisco CallManager

NB Callmanager部署型号是与集中的呼叫处理的单站点。一个人能争辩说,型号实际上是多站点由于广域网链路对NBAP和查找的相关的网关那里。但是此事实能(至于大部分)忽略,因为呼叫接纳控制(CAC)没有在广域网间要求。这是因为呼叫数量在广域网间的由连接网关的中继数量隐含地限制对PBX。

NB Cisco CallManager集群包括两Cisco Media Convergence Server 7835s (MCS-7835)。一CallManager执行数据库出版功能,并且其他订阅对数据库。所有IP电话向用户登记作为主Cisco CallManager,和使用发行商作为附属Cisco CallManager。

两个区域配置:NBAP和DBS。在NBAP的网关是唯一的设备在NBAP区域,所有其它设备在DBS区域。刻意的设计是使用G.711在构件的DBS内的所有仅呼叫和使用G.729在广域网间的呼叫的。目前,然而,在广域网链路间的呼叫也是G.711。

在DBS区域的IP电话有一个五位扩展名在17000到17999范围内。有有混合的四和五位扩展名的其他五个NB站点在新加坡。此表显示NB新加坡站点。

站点名称 站点代码
Department of Binding Singapore DBS 5
NB Acme正在打印 NBAP 5
Acme构件的A ABA 4
Acme构件的B ABB 5
道格拉斯正在打印 DP 4
格兰特正在打印 GP 4

扩展分配,以便第一个数字独特确定分机是否是四个或五个位。IP电话用户能通过拨号四或五位扩展名拨所有NB新加坡PBX分机。

作为讨论以后在Gateway Integration部分,有网关的三种类型:

  • 连接对传统NB PBX网络的一个Cisco7200 H.323网关。

  • 连接对PSTN的三个Catalyst 6509 E1网关。

  • 连接对语音邮件的两个Catalyst 6509 24波尔特FXS网关。

这在Cisco CallManager路由组配置里反射。一个路由组为三种网关类型中的每一种存在。此表概述每个路由组特性。

路由组 平台 插槽/端口 端口类型 优先级
DBS VM Catalyst 6509 交换机 6/1-24 7/1-24 FXS FXS 1 2
DBS PSTN Catalyst 6509 交换机 8/1 8/2 8/3 PRI PRI PRI 1 2 3
NBAP传统 Cisco 7200 路由器 5/1-2 PRI 1

对多种目的地的呼叫路由如下:

  • 对PSTN的呼叫使用DBS PSTN路由组。没有备份。

  • 对语音邮件的呼叫使用DBS VM路由组。没有备份。

  • 对NB Telnet服务的呼叫使用NBAP路由组。

  • 对NB新加坡PBX分机的呼叫使用NBAP路由组作为主要的和DBS PSTN路由组作为辅助路由组。

当前保持的所有是定义适当的路由模式和与路由组连接他们。因为仅单个路由列表要求,这为以上所列的前三个项目是直接的。事变得轻微包含与最后项目由于备份路由组。一呼叫的首选路径从一个IP电话到PBX分机是通过NBAP路由组。如果此网关不可用,呼叫通过PSTN路由通过DBS PSTN路由组。当这发生时,位必须被加前缀到已拨号分机为了创建全双工PSTN电话号码。被加前缀的位依靠呼叫的站点,因此,每个站点必须有一不同的路由列表。由于有有PBX的五个NB站点和几个PSTN前缀每个站点,他们最终获得十路由列表。

此图表显示所有NB路由列表。以多数路由列表的名义包括的2位或3位编号反射被加前缀对呼叫的分机的位,每当呼叫被发送给DBS PSTN路由组。

/image/gif/paws/13968/65367.gif

他们能呼叫的某些NB IP电话用户在编号限制。这通过安置路由模式和IP电话扩展控制在一定数量的分区。分区一起然后分组到呼叫搜索空间。IP电话在该搜索空间的分区属于呼叫搜索空间,并且能只称编号包含。此表列出NB Cisco CallManager搜索空间和分区。

搜索空间 分区 说明
访客 DBS用户DBS访客NB SGP DBS呼叫话务员 正常DBS用户电话大厅和其他公共区域电话NB新加坡PBX分机接待员
用户 DBS用户NB GSDN NB Telnet SGP PSTN DBS访客NB SGP IDD DBS呼叫话务员 正常DBS用户电话—通过全世界NB网络国内呼叫的国际呼叫在新加坡大厅和其他公共区域电话NB新加坡PBX分机国际呼叫接待员

语音邮件集成

DBS使用Octel语音邮件系统。这选择,因为它是全世界NB标准,并且在多种系统之间的语音邮件联网希望。

Cisco CallManager连接到Octel语音邮件系统通过在Catalyst 6509交换机的两个24波尔特FXS卡。48个端口使用仅30联机。9600位/秒简单信息台界面(SMDI)链路连接主Cisco CallManager到Octel设备。

Octel系统也连接对公司NB Octel网络。这通过连接到一旧有Lucent Definity PBX Octel设备的四个局外交换管理办公室端口执行。此图表显示DBS Octel系统如何连接对两个新和老式。

/image/gif/paws/13968/65368.gif

注意: 初始设计没有包括PBX。相反,想法是对网络语音邮件通过24波尔特FXS和VoIP网络。在试验期间,但是,问题遇到就象FXS处理从Octel设备的Dual Tone Multi-frequency的(DTMF)音。作为应急方案, 24波尔特FXS用Cisco IOS网关替换。这工作良好,但是NB更喜欢基于PBX的解决方案。

它值得注意语音邮件解决方案的弹性特性。除语音邮件系统之外,有其他单点故障:

  • SMDI链路不冗余:主Cisco CallManager的失败将采取语音邮件系统服务中断。如果此情况发生, NB策略是手工移动SMDI电缆向备用Cisco CallManager。或者, SMDI分离器会允许同时将连接的两CallManager,并且允许自动故障切换。

  • 目前两个24波尔特FXS卡位于同一个Catalyst 6509机箱。Catalyst 6509失败将采取语音邮件系统服务中断。如讨论前在本文,有将被获取根据弹性通过添加秒钟Catalyst 6509。

网关集成

下表列出三不同种类的在NB网络的语音网关。

平台 接口类型 端口数量 协议 连接
Catalyst 6509 PRI/E1 8个x 30个信道 skinny PSTN
Catalyst 6509 模拟FXS 2 x 24 skinny 语音邮件
7206VXR PRI/CAS/E1 2个x 30个信道 H.323 传统PBX

Catalyst 6509拥有单个八端口E1卡。三这八个端口连接对PSTN通过PRI。每个E1端口有其自己的IP地址和其端口功能作为独立网关。到/从网关的呼叫路由是由Cisco CallManager控制的通过小型协议。用户通过拨号0拨PSTN号码,跟随由PSTN编号。呼入呼叫有剥离的主导的位,并且呼叫路由到根据最后五个位的呼叫的IP电话。

用户拨'9'选择外线,并且Cisco CallManager在提交呼叫前删除此位对PSTN。NB尝试删除位两个方法。第一种方法在Cisco CallManager的路由模式包括‘小点’,并且所有点前位在提交它前丢弃对PSTN。第二和首选方法,是配置丢弃作为在Cisco CallManager设置的网关一部分。这由设置位数量剥离字段完成到一个。此第二种方法是更加好,因为保留主导的'9',当编号在IP电话时的已拨呼叫目录存储。这意味着用户能最新重拨号编号从目录,而不必按编辑和添加主导的'9'。

FXS网关仅仅使用语音邮件。这些网关是由Cisco CallManager控制的通过skinny。

Cisco7200网关提供IP电话网络在DBS和全世界NB PBX网络之间的连接。此网关是在DBS构件不物理的查找的唯一的VoIP设备:它在Nbap大厦查找,并且通过广域网链路被到达。

Cisco7200网关符合单个两端口的E1端口适配器,并且使用H.323与CallManager谈。两个E1端口连接到Nortel Meridian查找在NBAP。一个端口使用QSIG和另一用途随路信令(CAS)与PBX谈。对新加坡PBX扩展的呼叫路由在QSIG端口下,而国际呼叫,使用专用语音网络(Telnet),通过CAS端口路由。

CAS和QSIG的混合复杂化设置。CAS要求通过全世界Telnet语音网络提供存取对于personal identification number (PIN)代码保护的国际拨号。当用户拨此服务时,他们拨号313xxxxxx, xxxxxx是六位PIN代码。验证此PIN代码的Meridian应用程序不看上去通过PRI支持。因此,需要为此使用在两中继之一的CAS。

的,发信号证明的容易开始比QSIG中继线的CAS。在遇到的问题中是锁定在Meridian和分歧的时间间隙以B信道编号。几乎所有问题和配置参数有关不匹配在Cisco7200和Meridian侧的。在Cisco IOS提供了一个工作的Meridian配置后,这些问题是解决的。

Meridian配置的复制下面包括。此配置是从Meridian Option11C,运行软件版本24.24。以下软件包要求为了激活此配置。

QSIG      263
QSIGGF    305
MASTER    309
QSIG-SS   316
ETSI-SS   323

以下配置是从配置路由数据块。

TYPE  RDB     (Route Data Block)
CUST  00      (Customer Number)
DMOD
ROUT  xx      (Route Number)
DES           (Trunk Description)
TKTP  TIE     (Trunk type - Tie Line or DID)
ESN   NO 
RPA   NO
CNVT  NO
SAT   NO
RCLS  INT     (Route Class - Internal or External)
DTRK  YES     (Digital Trunk - YES)
BRIP  NO
DGTP  PRI2    (Digital Group Type - PRI 30B + D)
ISDN  YES     (YES when DGTP is PRI or PRI2)
MODE  PRA     (ISDN/PRA Route)
IFC   ESGF    (ESGF req QSIG & QSIF GF Pkgs)
SBN   NO
PNI   00000
NCNA  NO
NCRD  NO
CTYP  UKWN
INAC  NO
ISAR  NO
CPFXS YES
DAPC  NO
INTC  NO
DSEL  VOD
PTYP  DTT
AUTO  NO
DNIS  NO
DCDR  NO
ICOG  IAO     (Bothway Trunk In and Out (IAO))
SRCH  RRB
TRMB  YES
STEP
ACOD  xxxx    (Trunk access code)
TCPP  NO
TARG  03
BILN  NO
OABS
INST
ANTK
SIGO  STD
MFC   NO
ICIS  YES
OGIS  YES
PTUT  0
TIMR  ICF     512
OGF   512
EOD   13952
NRD   10112
DDL   70
ODT   4096
RGV   640
GTO   896
GTI   896
SFB   3
NBS   2048
NBL   4096
IENB  5
TFD   0
VSS   0
VGD   6
DTD   NO
SCDT  NO
2 DT  NO
DRNG  NO
CDR   NO
NATL  YES
SSL
CFWR  NO
IDOP  NO
VRAT  NO
MUS   NO
PANS  YES
FRL   0 x
FRL   1 x
FRL   2 x
FRL   3 x
FRL   4 x
FRL   5 x
FRL   6 x
FRL   7 x
OHQ   NO
OHQT  00
CBQ   NO
AUTH  NO
TTBL  0
PLEV  2
OPR   NO
ALRM  NO
ART   0
PECL  NO
DCTI  0
TIDY  xx
SGRP  0
AACR

此配置是从D-channel。

ADAN  DCH 12      (D-Channel Number assigned by programmer)
CTYP  MSDL        (D-Channel Card type) 
CARD  02          (Card Location)
PORT  1           (Port Number) 
DES   CISCO_5300  (Description)
USR   PRI         (User type - PRI for ISDN PRA only)
DCHL  2           (Loop the D-Channel will be associated with)
OTBF  32          (Output request buffer)
PARM  RS422 DTE   (Default)
DRAT  64KC        (64kb/s Clear - Don't change) 
CLOK  EXT         (Clock Source - External)
NASA  NO          (Default NO)
IFC   ESIG        (ETSI Q Reference Signaling - MSDL D-Channel ONLY) 
ISDN_MCNT  300    (Default)
CLID  OPT0        (Opt0 is default for ESIG and ISIG interfaces)
CO_TYPE  STD      (100% Compatible)
SIDE  NET         (Network or User Side)
CNEG  2           (2 = Channel is indicated - alternative is accepted)
RLS   ID  **      (Default)
RCAP  COLP        (COLP is default for ESIG, ISIG interfaces)
MBGA  NO          (Default)
OVLR  NO          (Default)
OVLS  NO          (Default)
T310  120         (Default)
T200  3           (Default)
T203  10          (Default)
N200  3           (Default)
N201  260         (Default)
K     7           (Default)

这是环路计时器的一配置PRI专用线路接口的。

LOOP 2

MFF    AFF
ACRC   NO
ALRM   REG
RAIE   NO
G1OS   YES
SLP    5       24 H    30    1 H
BPV    128    122
CRC    201     97
FAP    28       1
RATS   10
GP2    20     100 S    12 S    12 S    4 S
MNG1   60 S
NCG1   60 S
OSG1   60 S
MNG2   15 S
NCG2   15 S
OSG2   15 S
PERS   50
CLRS   50
OOSC   0

此配置是从B信道。

TN     00x 0x      (LEN, TN (Terminal Number))
TYPE   TIE         (Trunk Type - Tie Line)
CDEN   SD          (Single Density Card
CUST   0           (Customer 0)
TRK    PRI2        (Trunk Type)
PDCA   x           (Pad Category Table)
PCML   A           (A-law or Mu-Law)
NCOS   0           (Network Class of Service)
RTMB   x y         (Route Member- x is router no., y is member no.)
B-CHANNEL SIGNALING
TGAR   0           (TGAR Restricted Dialing Leave as 0)
AST    NO          (Default)
IAPG   0           (Default)
CLS    CTD DIP WTA LPR APN THFD XREP BARD
P10    VNL         (Class of services)
TKID

两E1中继的网关配置显示此处。注意网关作为网络端,而Meridian是用户端。

controller E1 5/0
 pri-group timeslots 1-31

!-–– Defines PRI trunk.


controller E1 5/1
 framing NO-CRC4
 ds0-group 0 timeslots 1-15,17-31 type e&m-wink-start

!-–– CAS trunk.


interface Serial5/0:15
 isdn switch-type primary-qsig

!-–– Defines Q.SIG signaling.

 isdn protocol-emulate network

!-–– The network side.

 isdn incoming-voice voice
 isdn send-alerting
 isdn sending-complete

网关有15 POTS拨号对端。大多拨号对端指出QSIG中继线,反射是可及的在PBX侧的多种PBX扩展。

剩余的拨号对端指出CAS中继,直接呼叫对Telnet语音网络。并且请注意QSIG中继线配置包括与值的一进度指示器为8,当送回一个警报消息到PBX时。这告诉PBX网关提供带内回铃音,并且PBX打开音频路径,在呼叫由IP电话以前应答。

dial-peer voice 33 pots
 preference 1
 destination-pattern 33.......
 direct-inward-dial
 port 5/1:0

!-–– Calls routed out of the CAS trunk.

 forward-digits all
!
dial-peer voice 313 pots
 destination-pattern 313......
 direct-inward-dial
 port 5/1:0
 forward-digits all
!
dial-peer voice 40000 pots
 destination-pattern 4....
 progress_ind alert enable 8

!-–– Gateway to provide ringback.

 direct-inward-dial
 port 5/0:15

!-–– Calls routed out of the QSIG trunk.

 forward-digits all
!
dial-peer voice 8 pots
 destination-pattern 8T
 progress_ind alert enable 8
 direct-inward-dial
 port 5/0:15
 forward-digits all
!
dial-peer voice 7 pots
 destination-pattern 7T
 progress_ind alert enable 8
 direct-inward-dial
 port 5/0:15
 forward-digits all
!
dial-peer voice 6 pots
 destination-pattern 6T
 progress_ind alert enable 8
 direct-inward-dial
 port 5/0:15
 forward-digits all
!
dial-peer voice 5 pots
 destination-pattern 5T
 progress_ind alert enable 8
 direct-inward-dial
 port 5/0:15
 forward-digits all
!
dial-peer voice 16 pots
 destination-pattern 16...
 progress_ind alert enable 8
 direct-inward-dial
 port 5/0:15
 forward-digits all
!
dial-peer voice 13 pots
 destination-pattern 13...
 progress_ind alert enable 8
 direct-inward-dial
 port 5/0:15
 forward-digits all
!
dial-peer voice 2 pots
 destination-pattern 2T
 progress_ind alert enable 8
 direct-inward-dial
 port 5/0:15
 forward-digits all
!
dial-peer voice 1000 pots
 destination-pattern 1...
 progress_ind alert enable 8
 direct-inward-dial
 port 5/0:15
 forward-digits all
!
dial-peer voice 10 pots
 destination-pattern 0...
 progress_ind alert enable 8
 direct-inward-dial
 port 5/0:15
 forward-digits all
!
dial-peer voice 3 pots
 destination-pattern 3...
 progress_ind alert enable 8
 direct-inward-dial
 port 5/0:15
 forward-digits all
!
dial-peer voice 508200 pots
 destination-pattern 5082..
 progress_ind alert enable 8
 port 5/0:15
 forward-digits all

只有两个VoIP拨号对等体,一个指向每Cisco CallManager。拨号对端是相同的除了首选,保证呼叫路由对主Cisco CallManager,当联机时。progress_ind设置enable (event) 3通知网关发信号到PBX,通过在设置信息的一进度指示器,主叫方是非ISDN。最后,当建立一个H.225会话用Cisco CallManager时, h225 timeout tcp建立3通知网关等待最多三秒。如果Cisco CallManager不响应在三秒以内,网关尝试附属Cisco CallManager。

dial-peer voice 17000 voip
 preference 1

!-–– Route to primary Cisco CallManager is preferred.

destination-pattern 17...
 progress_ind setup enable 3

!-–– Progress indicator = non-ISDN.

 voice-class h323 10
 session target ipv4:10.66.184.13
 dtmf-relay cisco-rtp h245-signal h245-alphanumeric
 codec g711ulaw
 ip precedence 5
 no vad
!
dial-peer voice 17001 voip
 preference 2
 destination-pattern 17...
 progress_ind setup enable 3
 voice-class h323 10
 session target ipv4:10.66.184.14
 dtmf-relay cisco-rtp h245-signal h245-alphanumeric
 codec g711ulaw
 ip precedence 5
 no vad

voice class h323 10
 h225 timeout tcp establish 3

在NB IP电话项目的rollout期间遇到的某些最不变的问题适合于响应。当他们呼叫某些编号到Cisco7200网关,主要响应问题由IP电话用户遇到。进入减少响应的尝试的努力是广泛和以下信息尝试捕获可能是有用的对其他部署此体验的部分。

由IP电话设计团队的最初的所需的是为了Cisco7200网关能提供VoIP侧和单个PBX之间的连接在NBAP。结果是,实际上提供什么是VoIP侧和非常大,全世界NB语音网络之间的连接。NB语音网络有其自己的传统,包括一定数量的回声问题。以前, NB尝试调整多种节点的功率电平在此网络的最小化相当数量响应。Cisco7200网关连接的网络是与现有回声问题的网络。它也有不同电平信号功率,根据呼叫的目的地。这是困难集成。

通过介绍分组的语音解决方案,与其另外的延迟,回声问题被恶化了。处理此,以下调整做了。

  • Cisco7200回波取消器调节对他们的多数进取的设置。

  • 输入收益降低。

  • 输出衰减在两E1中继增加。

当这减少了响应时,有音量级别,当呼叫在NB语音网络时的某些目的地,太低,并且用户抱怨的不理想的副作用。由于信号电平不匹配在传统侧的,有到/从所有目的地配合呼叫增益和衰减的没有组合。为呼叫工作的良好什么到香港创建在呼叫的响应到大韩。为大韩工作的什么导致香港的低音量问题。下面的配置显示语音端口的当前妥协配置Cisco7200网关的。

voice-port 5/0:15
 input gain 0
 output attenuation 3
 echo-cancel coverage 32
 compand-type u-law
 cptone SG

voice-port 5/1:0
 input gain -2
 echo-cancel coverage 32
 compand-type u-law
 cptone SG
 timeouts interdigit 5
 timeouts wait-release infinity
 timing percentbreak 60

开发工程在改善当前工作一些思科产品的响应取消功能。NB等候这些改进为了进一步减少响应。

其它方案报价对NB,但是客户决定等待思科改进。两报价的应急方案如下讨论希望其他项目能从他们有益于的。从NB了解的一般课程是应该及早上升红旗警报,如果报价的IP电话解决方案连接对一个大私有老式语音网络。通过该执行,这些应急方案可以从开始设计和开销到解决方案。

  • 应急方案1 —插入在Cisco网关和PBX之间的第三方回波取消器。Cisco回音消除技术能当前取消延迟较少然后32毫秒的响应尾标。响应的信号必须是受至少6 dB支配回应返回丢失(ERL),即,已接收响应信号比传送的信号必须最初是至少6 dB更低。为了它能是值得的,第三方取消者的性能应该超过上述值。

  • 应急方案2 —增加中继数量在Cisco网关和PBX之间的。这允许将配置的每中继与一个不同的收益/衰减设置。呼叫可能在有最适当的响应特性的中继间然后路由。例如,当呼叫向大韩通过中继2.时,呼叫向香港可能通过中继1。PBX也需要能路由在呼叫产生的正确中继间的呼叫,根据。

针对会议及编码转换的 DSP 供应

虽然G.711当前使用在网络中,目的将使用在广域网链路间的G.729在DBS和NBAP之间。设计通过指定硬件数字信号会议的信号处理器(DSP)资源考虑了到此。硬件资源在Catalyst 6509驻留。收回仅三八个E1端口为PSTN连接是在使用中的。三剩余的五个端口使用会议。

有设置作为转码资源Catalyst 6509 E1模块的两个未使用的端口。当前没有对转码的需要,但是需要将出现,如果NB决定部署IP交互语音应答(IVR)服务器。

软件版本

在本文写入时候,下表列出用于NB网络的软件版本。

设备 version
Catalyst 6509 5.5(3)
Catalyst 4006 6.1(1)
思科7260VXR 12.1(3a)XI5
Cisco CallManager 3.0(8)
IP电话7960 P003Q301
WS-X6608-E1 C001W300
WS-X6624-FXS A002S300

网络管理

网络管理工具当前没有用于管理NB IP电话网络。

所学课程

发现的异常、警告和解决方法

下表汇总在部署期间遇到的主要问题。这些问题详细信息在本文讨论前。

警告 解决方法
当建立接口分组语音网络对一个大老式语音网络时,请响应。 委员会另外的中继和变化增益/衰减,以便呼叫可以在有适当的设置的一中继间路由。用于第三方回波取消器。await改善Cisco回音消除技术。
在网关的不匹配的QSIG参数和PBX支持。 使用一个相似的设置,从现有的站点获取工作PBX配置。
选择外线的位没存储在放置呼叫目录。 丢弃开头数字在网关配置里,并且请勿使用一点前丢弃操作在路由模式。

TAC 案例

下表列出导致TAC案例的所有问题。并且包括部署小组解决本地的其他重大的问题。

-- -- -- -- -- -- -- -- -- --
案件# 说明 状态和解决方法
B124306 QSIG信道中断。 最初解决通过重新配置在Nortel PBX的LD17 Channel Negotiation (CNEG)参数从Option(2)到Option(1)。然而,问题症状在一些时间以后再现了。随后, PBX供应商更改在PBX的PRI QSIG设置从ESIG (GF QSIG设置)对ESGF (欧洲QSIG设置)。在修改以后,信道中断停止的发生,但是仅上面的15个信道是工作。要纠正问题, ISDN contiguous-bchan命令从VoIP路由器删除。
A612818 B信道不匹配Nortel PBX用途开辟31作为控制通道,当Cisco语音网关PRI用途信道16时的地方。 解决通过配置ISDN contiguous-bchan命令在PRI QSIG接口。此命令用于指定连续承载信道处理,以便B信道1至30 (跳过的信道16)映射对时间间隙1至31。通过使用isdn switch-type命令时,只有当主要的QSIG交换机类型选项配置这为E1PRI接口是可用的。
B124306 响应。有7200回波取消器可能不能删除响应的两个方案。情形 1:响应太大声为了取消者能取消。方案 2:响应由超过32毫秒延迟,是在7200个取消者的覆盖之外。 情形 1:对输出衰减和输入收益的进行的调整在语音网关和填充在PBX非常地改善响应情况。最终设置是:
  • Cisco7200 PRI输入收益= 0
  • Ciisco 7200 PRI输出衰减= 3
  • Cisco7200 CAS输入收益= -2
  • Cisco7200 CAS输出衰减= 0
  • PBX PRI TX衰减= 2
  • PBX PRI RX衰减= 4
  • PBX CAS TX衰减= 0
  • PBX CAS RX衰减= 5
残余回音发生作为静态噪声在RTP数据流的前1到2秒内。持续时间是不可避免为了可适应算法能培训在音频流和描出一个有效取消。方案 2:超过32毫秒响应尾标是不太可能的在模拟语音网络。然而,它在分组语音网络能发生。因为回波消除范围当前在最多32毫秒,开发工作是进行中导致将集成第三方G.168兼容回波取消器的代码(与尾标长度至少64毫秒)。
骇客噪声,拙劣语音质量(电话负载)。 已加载P003Q301固件到IP电话里。问负载是稳健往抖动和延迟。
对IP电话的没有回铃,当呼叫外线号码通过QSIG时。 网关不生成回令音,除非设置信息包含进度指示器(PI) 3 (始发地址是非ISDN)。这是因为网关假设那,不用PI 3,始发交换机是ISDN并且盼望交换机生成回令音。没有PI 3设置,网关盼望ISDN交换机生成环,但是ISDN交换机不生成环。这可能归结于ISDN网际互联问题。要使网关生成回令音,请配置在VoIP拨号对等体的progress_ind
dial-peer voice 1 voip
 destination-pattern 8...
  progress_ind setup enable 3
  session target ipv4:192.168.2.10
  dtmf-relay h245-alphanumeric
  codec g711ulaw
  ip precedence 5
以上然后将强制网关为出来在ISDN的呼叫提供回令音VoIP拨号对等体的该纵排。
A695422 有一差异在DTMF持续时间内。这可能由事实造成Catalyst不正确地认可语音邮件系统发送的DTMF音。默认情况下当来自Catalyst卡时, DTMF持续时间是300毫秒。当来自语音邮件时,持续时间是130毫秒。Octel规格要求至少五个位每秒是需要的为了握手能适当地运作。Cisco CallManager当前发送与300毫秒的持续时间的H245-SIGNALLING,进行的总共300*5 = 1.5秒。在此持续时间,在语音邮件联网报头完全接收前, Octel语音邮件计时了。 绕过24波尔特FXS模块(小设备)用Cisco 3640网关(H.323设备)装载与FXS。
呼叫的单向音频在语音网关间。 问题是由选择IP地址的网关引起的除那回环接口之外。环回是Callmanager数据流离开路由器的接口。放置h323-gateway voip捆绑srcaddr IP地址在此接口强制路由器使用指定的IP地址作为RTP源地址。
interface Loopback0
 description ::: Loopback for BGP peering
 ip address 192.170.94.34 255.255.255.255
 h323-gateway voip interface
 h323-gateway voip bind srcaddr 192.170.94.34
在Cisco CallManager上,请更换从名称的H.323网关设备到IP地址。这也防止与反向DNS/hosts查找的所有未预期的问题。
Cisco CallManager有其服务随着时间的推移迟缓地恶化由于内存损失的已知的问题。一个临时修正是每星期重新启动思科CallManager。 已安装Windows 2000服务包1和对CallManager服务器的虚拟内存修正。作为额外预防措施, NB建议重新启动CallManager每周在随后的月保证最大稳定性。NB应该决定终止每周重新启动,当视为适当。
A944914 WFQ不在多条2 Mbps链路的多PPP工作。Service-policy命令LLQ实施的一会后消失给不确定的广域网行为。 三个选项为处理此问题是可用的:
  • 对于在MPPP套件的所有接口,设置在serial interfaces的带宽到至少4800 (4/3 x 3600)。
  • 是prerelease版本12.2的升级到12.2.018。这是支持的DE (不是TAC)。问题在此版本修复。
  • 实现广域网QoS另一个类似的优先级队列。
Message按钮在电话最初没有工作。 以下设置要求启用Message按钮:
  • 在服务参数,请输入语音邮件分机号作为VoiceMailDN字段的值。
  • 在企业参数,请输入语音邮件分机号作为MessageDirectoryNumber字段的值。
高层次从E1卡(WS-X6608)的广播数据流由于在地址解析服务(ARP)代码的一bug在Catalyst 6509小型网关模块。 作为应急方案, E1卡(WS-X6608)在独立的VLAN配置。这使ARP缓存的大小降低到最多三个条目。同时,新的小型网关固件升级(D004R300)装载到模块解决问题。
Cos损耗在广域网链路间的。 其中一新特性Cisco IOS软件12.1是TOS对COS映射。使用此,路由器能在发送任何东西前设置CoS=ToS对Catalyst 6509。Catalyst 6509为trust-cos路由器端口然后配置,并且拾起从那里的内部DSCP值。使用DSCP,思科QoS维护Tos和Cos值。
当访问语音邮件系统通过WS-X6624卡时, ARP表是损坏的,造成音频流损耗。 作为应急方案, FXS卡(WS-X6624)在独立的VLAN配置。这使ARP缓存的大小降低到最多三个条目。同时,新的小型网关固件升级(A002S300)装载到模块。
常见暂停对Octel语音邮件设备的FXS连接的端口。 此问题似乎普通用有模拟(FXO)连接的Octel语音邮件系统。当语音邮件设备建立接口用不同的PBX系统时,暂停的端口数量可能变化。传统PBX通常有能力重置个人暂停的端口,无需影响整体语音邮件操作。思科实现使用户重置和监控FXS的单个端口的DickTracy程序。DickTracy程序在网络的所有PC可以安装。运行它,并且连接对您的WS-X6624的IP地址。一旦连接,请点击选项。开始录音,然后输入以下in命令line命令字段:要得到端口状态,输入5显示状态(此提供每个端口状态。使用DickTracy,端口号是基于的0 :在刀片的Port1是端口0在DickTracy)。要重置端口,请输入以下:
4 set kill port[x] 

!--- Where x is the 0-based port number.

5 disable port x
5 enable port x
多链路设置的没有监听联机。各自的串行链路不可以是启用IP。 建议是使用简单网络管理协议(SNMP)轮询接口状态。实现的方式有几种。测试的选项是创建UNIX脚本使用snmpget命令收集接口状态方式和一样ping script命令。另一个选项是扩大MRTG的功能(这是收集接口利用率的免费软件SNMP工具)收集接口状态。选项是使用一个基于SNMP的网络管理应用程序。
B300309 路由器周期地重新启动由于总线错误。 异常的分组处理操作在PA-2FEISL硬件的早版本检测正如Cisco Bug ID问题CSCdm74172 (仅限注册用户)所描述。问题通过对2端口快速以太网/ISL端口适配器的一次硬件变更解决了。PA-2FEISL-xx卡用硬件修订版编号相等与或以后比如下所示的硬件修订版不受影响。PA-2FEISL-TX和PA-2FEISL-FX硬件修订版1.2硬件修订版2.0 NB使用硬件修订版1.1。
A953213 无法访问Cisco CallManager User页。 此问题使用以下步骤是解决的。
  1. 去Ccmadmin页。点击在主菜单的系统然后单击企业参数
  2. 从Enterprise Parameter页,请检查LDAP :Cisco Base和LDAP :用户群参数。(LDAP :Cisco Base应该是o=cisco.com和LDAP :用户群应该是ou=users, o=cisco.com。)
在更新这些参数以后,所有用户能从用户页登录。问题在Cisco CallManager 3.0.4被找到上述参数是NULL的地方。

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 13968