语音和统一通信 : Cisco Unified Communications Manager (CallManager)

IP电话部署案例研究:澳大利亚天主教大学

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 22 日) | 反馈


目录


简介

互联37所澳大利亚大学以及Commonwealth Scientific and Industrial Research Organization (CSIRO)的澳大利亚院和研究网络(AARNet)是一个全国性高速的IP网络。

AARNet最初被构件作为数据网,但是运载了VoIP从早期2000年。当前部署的VoIP网络是传送在大学和CSIRO专用自动小交换机的收费绕路解决方案(PABX)之间的VoIP呼叫。它也提供允许PSTN到跳离至多经济的点的公共交换电话网(PSTN)网关。例如,从一个PABX电话的一呼叫在对一个PSTN电话的Melbourne在悉尼被传送作为从Melbourne的VoIP到悉尼PSTN网关。它那里连接对PSTN。

澳大利亚天主教大学(ACU)是连接对AARNet的其中一所大学。在2000年底, ACU开始部署大约在六所大学校园间的2,000 IP电话的IP电话部署。

此案例研究包括ACU IP电话部署。项目完成。然而,有寻址的重大的结构上问题在AARNet骨干网,如果网络是扩展,当其他大学跟随ACU时脚步。本文描述这些问题并且报价并且讨论多种解决方案。ACU IP电话部署可能调节的以后为了根据最终推荐的体系结构落。

注意: 迪肯大学是部署IP电话的第一所澳大利亚大学。然而,迪肯大学不使用AARNet运载IP电话流量。

AARNet

澳大利亚大学和CSIRO在1990年构件AARNet通过Australian Vice-Chancellors' Committee (AVCC)。在最初的少数年期间,澳大利亚互联网数据流的九十九百分比是到建立的成员。少量的商业流量是从有有第三和研究部门的一个接近的关联的组织。由非AARNet用户规模请使用增加对总流量的20百分比在1994年末之前。

AVCC出售AARNet企业客户基础对在七月的Telstra 1995年。此事件产生了什么最终将变为Telstra BigPond。这在澳大利亚刺激了商业和私有使用的进一步增长互联网。知识产权和专业技术转移导致互联网的开发在澳大利亚。否则,这不会发生以这样快速。

AVCC在1997年初开发AARNet2。它是互联网的进一步提炼在澳大利亚,雇用高带宽ATM链路和网络服务在合同下与被限制的Cable & Wireless Optus (CWO)。IP服务迅速部署由符合AARNet2要求的CWO的是由于的一部分对知识和专业技术转移从AARNet。

ACU

ACU是在1991年被建立的一所公立大学。大学有大约10,000名学员和1,000员工。有澳大利亚的东海岸的六个校园。此表显示ACU校园和他们的位置:

校园 城市 状态
登上圣玛丽 Strathfield New South Wales (NSW)
MacKillop 北部悉尼 New South Wales (NSW)
帕特里克 Melbourne 维多利亚(VIC)
阿奎奈 Ballarat 维多利亚(VIC)
Signadou 堪培拉 澳大利亚首都区域(ACT)
McAuley 布里斯班 Queensland (QLD)

在Telstra光谱(Centrex)解决方案取决于的ACU在此案例研究描述IP电话解决方案的rollout前。向IP电话主要希望驱动移动降低开销。

CSIRO

CSIRO有大约6,500员工在许多站点在澳大利亚。CSIRO品行研究在区域例如农业、矿物、能量、制造、通信、建筑、健康和环境。

CSIRO是使用AARNet的第一个组织VoIP。组织作早期工作在此区域完成的早期工作。

AARNet

AARNet骨干网是在所有大学IP电话部署的一重要组件。它提供大学的互连两主要服务在语音区域:

  • VoIP实时传输协议(RTP)数据包传输有服务质量(QoS)保证的适当对语音

  • 对PSTN的便宜的hopoff点在国家周围

此部分描述当前AARNet体系结构,并且如何提供这些服务。它也概述出现的某些可扩展性问题,当更多大学部署IP电话解决方案。最后,它讨论这些可扩展性问题的可能的解决方案。

AARNet 拓扑

AARNet在每状态包括单个POP (入网点)。POPs指区域网操作(RNOs)。大学连接对RNO在他们的各自状态。RNOs反之由Optus ATM PVC全网状互联。同时他们构成AARNet。

典型RNO包括一台思科LS1010 ATM交换机和一个与ATM连接的路由器。RNO路由器连接到每个大学路由器由在E3微波链路间的单个ATM PVC。每个RNO路由器也有Optus ATM网络提供给其他RNOs ATM PVC的全网状。此图表代表网络的一般AARNet拓扑:

/image/gif/paws/13913/60550.gif

有许多例外到拓扑。有些是重大的从语音方面看。这些是一些例外:

  • RNO在维多利亚使用经典IP over ATM (RFC 1577)而不是PVC连接大学到RNO。

  • 城外大学典型地连接回到RNO由帧中继或ISDN。

  • 一些大大学有超过一条链路回到RNO。

此表显示当前有RNO的状态和领土。表包括不熟悉澳大利亚地理的读者的首都。

状态 首都 RNO ? 校园连接
新南威尔士 悉尼 TBD
维多利亚 Melbourne TBD
昆士兰 布里斯班 TBD
南澳大利亚 阿德莱德 TBD
澳大利亚西部 珀斯 TBD
澳大利亚首都特区 堪培拉 TBD
北部地区 达尔文 --
塔斯马尼亚 霍巴特 --

服务质量

AARNet的部分为语音已经是支持QoS的由于VoIP收费绕路项目。QoS为语音流量是必要为了提供这些功能,最小化延迟和抖动并且排除包丢失:

  • 修正—标记在从非信任的来源的语音流量下。

  • 排队—必须给语音在最小化延迟的其他流量的优先级在链路拥塞时。

  • 链路分段和交织(LFI) —必须分段数据包,并且语音数据包插入在低速链接。

必须分类流量适当地修正和排队语音数据包。此部分描述分类如何在AARNet完成。随后的章节描述管制和排队实施。

分类

不是所有的流量获得同样QoS。流量分类到这些类别选择性地提供QoS :

  • 数据

  • 从知道的语音和可信的源

  • 从未知源的语音

仅可信的设备给在AARNet的优质QoS。这些设备是IP地址识别的主要网关。访问控制表(ACL)用于识别语音这些可信的源。

access-list 20 permit 192.168.134.10 
access-list 20 permit 192.168.255.255

IP优先级用于与数据流区分语音流量。语音有IP优先级5。

class-map match-all VOICE
match ip precedence 5

结合前面的示例识别从可信的源的数据包。

class-map match-all VOICE-GATEWAY
match class-map VOICE
match access-group 20

请使用同样原理识别从未知源的语音数据包。

class-map match-all VOICE-NOT-GATEWAY
match class-map VOICE
match not access-group 20

修正

当流量在接口时,到达从一非信任的来源的语音流量分类并且被标记在下。这两示例显示修正如何根据什么类型的流量执行在指定接口预计到达:

如果有委托下行,语音来源路由器寻找非信任的语音数据包并且更改他们的IP优先级到0。

policy-map INPUT-VOICE
class VOICE-NOT-GATEWAY
set ip precedence 0

interface FastEthernet2/0/0
description Downstream voice gateways 
service-policy input INPUT-VOICE

如果没有下行,已知语音来源路由器寻找语音数据包并且更改他们的IP优先级到0。

policy-map INPUT-DATA
class VOICE
set ip precedence 0

interface FastEthernet2/0/1
description No downstream voice gateways
service-policy input INPUT-DATA

无声的队列

在AARNet的所有VoIP近来是收费绕路。此情况导致相对少量VoIP终端。当前排队设计区分在有VoIP设备下行和接口不的接口之间。此部分讨论排队在非VoIP接口。

一个无声的接口为加权公平排队(WFQ)或加权随机早期检测(WRED)配置。这些直接地在接口可以配置。然而,排队机制通过策略映射应用为了使容易更换在指定接口类型的排队机制。有每种接口类型一个策略映射。这反映事实不是所有接口支持所有的排队机制。

policy-map OUTPUT-DATA-ATM
class class-default 
fair-queue

policy-map OUTPUT-DATA-VIP-ATM
class class-default
random-detect

policy-map OUTPUT-DATA-ETHERNET
class class-default 
fair-queue

policy-map OUTPUT-DATA-VIP-ETHERNET
class class-default 
random-detect

policy-map OUTPUT-DATA-SERIAL
class class-default 
fair-queue

policy-map OUTPUT-DATA-VIP-SERIAL
class class-default
random-detect

策略映射附加对各自的接口并且是特定对接口类型。例如,这简化更改在多功能接口基于处理器的(基于VIP的)以太网端口的排队机制进程从WRED到WFQ。它要求在策略映射上的单个变化。变动做对所有基于VIP的以太网接口。

interface ATM0/0
service-policy output OUTPUT-DATA-ATM

interface ATM1/0/0
service-policy output OUTPUT-DATA-VIP-ATM

interface Ethernet2/0
service-policy output OUTPUT-DATA-ETHERNET

interface Ethernet3/0/0
service-policy output OUTPUT-DATA-VIP-ETHERNET

interface Serial4/0
service-policy output OUTPUT-DATA-SERIAL

interface Serial5/0/0
service-policy output OUTPUT-DATA-VIP-SERIAL

低延迟排队

有下行可信的VoIP设备的所有接口为低延迟排队(LLQ)配置。通过流入接口分类做它并且保留优先5的所有数据包是受LLQ支配。其他数据包是受WFQ或WRED支配。这取决于接口类型。

独立的政策地图为每种接口类型创建为了使QoS更加容易管理。这类似于无声的排队设计。然而,多项策略地图为每种接口类型存在。这是因为接口类型的产能运载的语音流量根据链路速度变化, PVC设置,等等。在策略映射映射名字的编号反射呼叫数量顾及了30呼叫, 60呼叫,等等。

policy-map OUTPUT-VOICE-VIP-ATM-30
class VOICE
priority 816
class class-default
random-detect

policy-map OUTPUT-VOICE-VIP-ATM-60
class VOICE
priority 1632
class class-default
random-detect

policy-map OUTPUT-VOICE-ATM-30
class VOICE
priority 816
class class-default
random-detect 

policy-map OUTPUT-VOICE-ATM-60
class VOICE
priority 1632
class class-default
random-detect

policy-map OUTPUT-VOICE-ETHERNET-30
class VOICE
priority 912
class class-default
fair-queue

policy-map OUTPUT-VOICE-VIP-ETHERNET-30
class VOICE
priority 
class class-default
random-detect

policy-map OUTPUT-VOICE-HDLC-30
class VOICE
priority 768
class class-default
fair-queue

策略映射附加对各自的接口。在本例中,策略映射是特定对接口类型。目前特殊处理没有给对语音信令。如果这以后变为一个需求在指定接口类型,策略映射可能在一个地方容易地被修正。更改采取该类型所有接口的影响。

Interface ATM0/0
service-policy output OUTPUT-VOICE-ATM-30

interface ATM1/0/0
service-policy output OUTPUT-VOICE-VIP-ATM-30

interface Ethernet2/0
service-policy output OUTPUT-VOICE-ETHERNET-60

interface Ethernet3/0/0
service-policy output OUTPUT-VOICE-VIP-ETHERNET-60

interface Serial4/0
service-policy output OUTPUT-VOICE-SERIAL-30

interface Serial5/0/0
service-policy output OUTPUT-VOICE-VIP-SERIAL-60

LLQ可扩展性

排队机制有一些可扩展性问题。主要问题是依靠认识每委托VoIP设备的IP地址在网络的。当有处理收费绕路的VoIP网关有限数量这以前是一个合理的限制。VoIP终端数量巨大增加,并且变得越来越不切实际与IP电话的部署。ACL变得太长和太难以至于不能管理。

ACL被添附在每个ACU校园信任从特定语音IP子网的流量一旦ACU。这是临时解决方案。这些长期解决方案调查:

  • H.323代理

  • QoS入口管制

在H.323代理解决方案后的主要想法是有从一个给的校园的所有RTP流量回车AARNet通过代理。因为此图表显示, AARNet看到从一个给的校园的所有RTP流量用单个IP地址:

/image/gif/paws/13913/60551.gif

如果此方案一致,部署条目数量在QoS ACL的对每个校园一条线路被限制。此方案仍然有潜在的添加对100个或更多条目,因为有有多个园区的37所大学。这不也可扩展。移动向与单个一共享超级代理设计或有限数量在每个RNO也许是必要的。这使委托IP地址降低数量到六。然而,这打开在路径的一个QoS策略问题从校园到代理在RNO。

注意: 因为簇之间信令不是本地H.225, Cisco CallManager集群间中继线不通过H.323代理当前运转。

QoS入口管制是其它方案。信任的边界设立在校园连接对与此设计的RNO的点。输入AARNet的流量由在此边界的思科IOS�承诺接入速率(CAR)功能管辖。使用AARNet VoIP的大学订阅对一定数量的AARNet QoS带宽。CAR然后监控输入AARNet的流量。如果相当数量与IP优先级5的RTP流量超出订阅的带宽,超额流量有IP优先级标下来到0。

此图表显示CAR配置:

/image/gif/paws/13913/60552.gif

此示例显示CAR配置如何处理此管制:

Interface a1/0.100
rate-limit input access-group 100 2400000 0 0 conform-action set-prec-transmit 5
exceed-action set-prec-transmit 0

access-list 100 permit udp any range 16384 32767 any range 
 16384 32767 precedence critical

这些是CAR配置方法的一些优点:

  • 核心不再需要处理管制。它在信任的边界当前被处理。所以,在核心的LLQ不需要知道关于委托IP地址。因为已经通过管制在入口,有IP优先级的所有数据包5在核心可以安全是受LLQ支配。

  • 假定没有被做关于各自的大学选择的VoIP体系结构、设备和协议。不工作与H.323代理的大学能选择部署会话初始化协议(SIP)或介质网关控制协议(MGCP)。只要他们有IP优先级5., VoIP信息包接收在核心的适当的QoS。

  • CAR对QoS拒绝服务攻击是有弹性。起源于大学的QoS DOS攻击不能损坏核心。CAR限制攻击,不能生成更多流量比什么是存在,当允许VoIP呼叫最大是活跃的时。

    在攻击期间,到/从该校园的VoIP呼叫能遭受。然而,它是至保护的单个大学内部地。大学能拉紧在路由器的CAR ACL,以便几乎选定VoIP子网有标的IP优先级下来。

    每个校园有一个内部信任的边界在用户连接对在最终设计的园区LAN的点。与此信任的边界接收的IP优先级的流量5对每交换机端口160 Kbps或者两次G.711 VoIP呼叫被限制。超出此速率的流量标得下来。此方案的实施要求Catalyst 6500交换机或事类似与限制功能的速率。

  • 当每所大学预订对一定量的QoS带宽,在核心的带宽供应简化。因为每所大学能付根据QoS带宽订阅的平面的月费这也简化QoS发单。

在此设计的主要弱点是信任的边界查找在大学路由器,因此大学一定能正确地管理CAR。信任的边界被拉回到RNO。RNO执行的设备处理在最终设计的管制。此设计要求限制例如Catalyst 6000交换机或Cisco7200网络服务引擎(Cisco 7200 NSE-1)处理器的基于硬件的速率。然而,它给对QoS策略的AARNet和RNOs完全控制。此图表显示此设计:

/image/gif/paws/13913/60553.gif

Link Fragmentation and Interleaving

VoIP在高速ATM虚拟电路(VC)间相对只运载。所以, LFI没有要求。VoIP可能在帧中继论坛(FRF)或租用的线路间在将来也传输对城外大学。这要求LFI机制例如多链路PPP (MLP)与交错存取或FRF.12。

网关

有两在AARNet的H.323网关:

  • PSTN —对VoIP网关的PSTN

  • PABX —对VoIP网关的PABX

PSTN和PABX网关之间的差异是基本工作的。PSTN网关提供连接给PSTN。PABX网关连接大学PABX到VoIP骨干网。同一个物理方框在许多情况下作为PSTN和PABX网关。当前有在ACU IP电话解决方案的31个网关。大多这些网关是Cisco AS5300通用接入服务器。其他网关是Cisco 3600系列路由器或Cisco 2600系列路由器。在Q2CY01期间,至少十个另外的网关预计被添加。AARNet传送了大约在April的145,000次VoIP呼叫2001年。

因为此图表显示, AARNet在多数主要城市部署PSTN附属的H.323网关:

/image/gif/paws/13913/60554.gif

大学能使用这些网关做呼出到PSTN。因为当前不支持,大学必须维护他们呼入呼叫的自己的中继他们。AARNet能协商非常竞争价格用载波由于通过这些网关的音量呼叫。呼叫可能也丢弃至多经济的点。例如,呼叫珀斯编号的某人在悉尼可能使用珀斯网关和对本地呼叫只收费。亦称这是尾端跳离(TEHO)。

单个关守设置执行E.164到IP地址解决方法。对PSTN的所有呼叫被发送到网守,然后返回最适当的网关的IP地址。参考拨号计划网守部分关于网守的更详细信息。

计费和核算

PSTN网关使用RADIUS和验证、授权和统计(AAA)计费目的。每呼叫通过网关生成一个呼叫详细信息详情记录(CDR)每个呼叫段的。这些CDR被张贴到RADIUS服务器。Cisco CallManager的IP地址在CDR的独特识别大学并且保证正确当事人被发单。

网关安全

保护DOS攻击和欺骗的PSTN网关是主要问题。H.323客户端广泛可用的。Microsoft NetMeeting与Microsoft Windows 2000捆绑在一起,因此发出自由呼叫通过这些网关一个非技术性的用户是相对容易的。配置允许发信号从委托IP地址的H.225保护这些网关的入站ACL。此方法有QoS部分描述的完会一样的可扩展性问题。当委托H.323终端数量增长,条目数量在ACL的增长。

H.323代理在此区域提供若干替补。如果所有呼叫通过PSTN网关穿过校园代理,网关ACL需要允许每所大学校园一个IP地址。两个IP地址作为一个冗余代理是理想在大多数情况下。与代理, ACL能包含超过100个条目。

因为所有H.323能通过代理,设置呼叫代理必须通过ACL保护。代理ACL必须允许本地H.323设备,当本地策略要求,因为这执行根据每校园基本类型。

如果校园要允许从IP电话的仅呼叫使用AARNet PSTN网关,在网关ACL必须包括两思科CallManager的IP地址。在这种情况下代理不添加任何值。需要的ACL条目不管怎样数量是两。

注意校园之间的IP电话到IP呼叫不需要穿过代理。

拨号方案

当前VoIP拨号计划是直接的。用户能放置呼叫的这两种类型从VoIP网关方面:

  • 呼叫电话在一个不同的校园,但是在同一所大学。

  • 在一所不同的大学呼叫PSTN电话或电话。

网关拨号对等体反映事实只有呼叫的两种类型。基本上,因为此示例显示,有两个VoIP拨号对等体类型:

dial-peer voice 1 voip
destination-pattern 7…
session-target ipv4:x.x.x.x

dial-peer voice 1 voip
destination-pattern 0………
session-target ras

第一拨号对端,如果某人在本例中的另一个校园呼叫分机7…使用。此呼叫路由直接地对远程网关的IP地址。因为网守绕过,呼叫接纳控制(CAC)没有执行。

第二拨号对端,当呼叫是为PSTN编号时,使用。这可以是二者之一这些项目之一:

  • 一个电话的编号在PSTN的

  • 一个电话的完全合格的PSTN编号在一所不同的大学的

呼叫被发送到网守通过在第一个案件的一个Admission Request (ARQ)消息。网守返回最好的PSTN网关的IP地址在准入确认(ACF)消息的。

呼叫也被发送到网守通过在第二个案件的一个ARQ消息。然而,网守在收到呼叫的大学返回一个ACF消息用VoIP网关的IP地址。

网守

AARNet当前操作单个关守。此网守唯一目的将执行呼叫路由以E.164的形式对IP地址解决方法。网守不执行CAC。PABX中继数量连接到网关限制同步呼叫数量。核心带宽立即顾及所有中继在使用中。这随IP电话rollout改变在ACU和其他大学。没有在这中可以来源或在一个给的校园外面新建的环境同时VoIP呼叫的数量的自然限制。如果许多呼叫被发起,联机QoS带宽可以是订购过量的。所有呼叫能遭受质量差在此情况下。请使用网守提供CAC。

大学语音网络的分布式特性和潜在的大小借自己对一个分布式关守体系结构。一个可能的解决方案将有每所大学维护其自己的网守的一种两层分层的关守设计。此大学网守指第2层网守。AARNet操作指第1层网守的目录关守

大学必须使用此两层方法使用网守在Cisco CallManager集群之间的呼叫路由。网守路由根据在此方案的一4或5位分机的呼叫。每所大学要求其自己的网守。这是因为扩展范围交迭在大学之间,因为这是一个本地被管理的地址空间。

大学第2层网守到/从仅该大学执行呼叫的CAC。它也执行呼叫的E.164解决方法在该大学之间仅校园。如果某人在另一所大学呼叫IP电话或通过AARNet网关,呼叫PSTN呼叫由第2层网守路由到第1层网守通过位置请求(LRQ)消息。如果呼叫是为另一所大学, LRQ转发到该大学第2层网守。此网守然后返回ACF消息到第2层网守在呼叫产生的大学。两第2层网守执行CAC。如果有充足的带宽联机在两个呼叫和呼叫的区域,他们只继续进行呼叫。

AARNet能选择对待AARNet PSTN网关类似那些所有大学。他们自己的第2层网守照看他们。如果负载和性能允许,第1层网守能也作为这些网关的第2层网守。

其中每一网守(包括AARNet目录关守)需要复制,因为网关是这样关键组件。每所大学需要有两网守。有备选网守,和一旦Cisco IOS软件版本12.0(7)T Cisco IOS网关是可能的。然而, Cisco CallManager或其他第三方H.323设备当前不支持这。请勿此时使用此功能。请使用一简单热备件路由器基于协议的(基于HSRP的)解决方案。这要求两网守坐同样IP子网。HSRP确定哪网守是活跃的。

ACU IP 电话网络

此表显示IP电话近似编号安装在ACU校园:

校园 城市 近似IP电话
登上圣玛丽 Strathfield 400
MacKillop 北部悉尼 300
帕特里克 Melbourne 400
阿奎奈 Ballarat 100
Signadou 堪培拉 100
McAuley 布里斯班 400
  托塔尔: 1700

ACU最近部署IP电话解决方案。解决方案在每个校园包括两思科CallManager集群, Cisco 3640网关和IP电话。AARNet互联校园。此图表表示高层次拓扑和ACU IP电话网络的多种组件:

/image/gif/paws/13913/60555.gif

ACU 网络拓扑结构

此图表显示典型ACU校园。每个校园有Catalyst交换机三块层。配线间安置更旧的Catalyst 1900交换机。Catalyst 1900交换机连接回到Catalyst 3500xl交换机通过扩展成帧。这些连接回到单个Catalyst 6509交换机通过千兆以太网(GE)。单个Cisco 7200 VXR路由器连接校园对AARNet由ATM VC对本地RNO。

/image/gif/paws/13913/60556.gif

因为此表显示,对RNO的连接方法与状态轻微有所不同陈述。维多利亚根据经典IP over ATM (RFC 1577)。另一RNOs有直通PVC设置RFC 1483封装。开放最短路径优先(OSPF)是路由协议使用在ACU和RNOs之间。

校园 状态 对RNO的连接 路由协议
登上圣玛丽 NSW RFC 1483 PVC OSPF
MacKillop NSW RFC 1483 PVC OSPF
帕特里克 VIC RFC 1577经典IP over ATM OSPF
阿奎奈 VIC RFC 1577经典IP over ATM OSPF
Signadou ACT RFC 1483 PVC OSPF
McAuley QLD RFC 1483 PVC OSPF

在仅uplink端口的Catalyst 1900系列交换机支持中继。所以, IP电话和PCs是全部在一个大VLAN。实际上,整个校园是一大VLAN和广播域。附属IP子网使用由于很大数量的设备。IP电话在一IP子网,并且PCs在别的。AARNet核心委托IP电话子网,并且到/从此IP子网的流量是受LLQ支配。

在主要的和附属IP子网之间的Cisco 7200路由器路由。在Catalyst 6500交换机当前没有使用多层交换功能卡(MSFC)。

Catalyst 3500xl及Catalyst 6500交换机有QoS功能,但是他们当前没有启用。

校园里的 QoS

当前园区网设计不遵照IP电话的Cisco建议的设计指南。这些是关于QoS的一些注意事项:

  • 广播域非常大。过多的广播流量能影响IP电话性能,必须处理他们。

  • Catalyst 1900交换机不支持QOS的。如果IP电话和PC连接到同一交换机端口,语音数据包可以丢弃,如果PC以高速率接收数据。

重新设计校园基础设施的部分完成重大的改进。硬件升级没有要求。此图表说明在推荐的再设计后的原理:

60557.gif

必须拆分校园到语音VLAN和数据VLAN。连接到Catalyst 1900交换机的电话和PCs必须当前接通到不同的端口为了达到VLAN分离。从每台Catalyst 1900交换机的一另外的上行链路到思科3500XL交换机被添加。两uplink端口之一是语音VLAN的成员。另一上行链路是数据VLAN的成员。请勿使用建立中继作为替代方案的交换机间链路(ISL)对两uplink端口。这不提供语音和数据流量独立队列。必须也转换从Catalyst 3500xl交换机的GE链路到Catalyst 6000交换机到802.1q中继,以便语音和数据VLAN可以在此核心交换机间运载。

在数据VLAN Catalyst 3500xl交换机的端口有默认业务类别(CoS)零。是语音VLAN的成员结果的端口有默认Cos 5.,语音流量正确地优先安排,一旦到达在Catalyst 3500或Catalyst 6500核心。Catalyst 3500 QoS交换机端口配置根据哪VLAN交换机端口稍有变化是成员,因为此示例显示:

Interface fastethernet 0/1
description Port member of voice VLAN
switchport priority 5
switchport access vlan 1

Interface fastethernet 0/2
description Port member of data VLAN
switchport priority 0
switchport access vlan 2

您能连接PC到IP电话的后方交换机端口在IP电话连接直接地到Catalyst 3500xl交换机的少见的情况。IP电话在这种情况下连接到交换机通过802.1Q中继。这在独立的VLAN允许语音和数据信息包移动,并且您能给数据包正确Cos在入口。用Catalyst 3500xl交换机或其他支持QOS的交换机替换Catalyst 1900交换机,他们到达生命周期终止。此拓扑然后变为连接IP电话和PCs标准方法对网络。此方案显示Catalyst 3500xl交换机QoS配置:

Interface fastethernet 0/3
description Port connects to a 79xx IPhone
switchport trunk encapsulation dot1q
switchport priority extend 0

最后,连接对两思科CallManager的两个端口应该有Cos硬编码对3. Cisco CallManager设置IP优先级到3在所有语音信令数据包。然而,从Cisco CallManager的链路到Catalyst 3500xl交换机不使用801.1p。所以,当此示例显示, Cos值是牵强的在交换机:

Interface fastethernet 0/1
description Port member of voice VLAN
switchport priority 3
switchport access vlan 1

与此设计的主要障碍是两交换机端口要求在桌面。帕特里克校园也许要求400 IP电话的额外400交换机端口。另外的Catalyst 3500xl交换机,如果足够的端口不是可用的,必须部署。仅一个Catalyst 3500xl交换机端口为每两个缺少Catalyst 1900交换机端口要求。

当前ACU Catalyst 6500交换机有QoS功能,但是他们当前没有启用。这些模块是存在ACU Catalyst 6000交换机以这些排队功能:

-- --
Slot 模块 端口 接收队列 发送队列
1 WS-X6K-SUP1A-2GE 2 1p1q4t 1p2q2t
3 WS-X6408-GBIC 8 1q4t 2q2t
4 WS-X6408-GBIC 8 1q4t 2q2t
5 WS-X6248-RJ-45 48 1q4t 2q2t
15 WS-F6K-MSFC 0

完成这些步骤激活在Catalyst 6000交换机的适当的QoS功能:

  1. 通知交换机提供QoS在基础上以此命令:

    Cat6K>(enable)set port qos 1/1-2,3/1-8,4/1-8 vlan-based
    
  2. 通知交换机委托从Catalyst 3500xl交换机接收的Cos值用此命令:

    Cat6K>(enable)set port qos 1/1-2,3/1-8,4/1-8 trust trust-cos
    

必须当前设置Cos到差分服务代码点映射。因为Catalyst 6000交换机重写在根据已接收Cos值的IP报头的DSCP值这要求。VoIP信令信息包必须有Cos 3,重写以DSCP AF31 (26)。RTP数据包必须有Cos 5,重写以DSCP EF (46)。发出以下命令:

Cat6K>(enable)set qos cos-dscp-map 0 8 16 26 32 46 48 56

请使用此示例验证CoS-to-DSCP映射。

Cat6K> (enable) show qos map run COs-DSCP-map
CoS - DSCP map:
CoS DSCP
--- ----
 0   0
 1   8
 2   16
 3   26
 4   32
 5   46
 6   48
 7   56

配置MSFC路由在多种IP子网之间。

RNO 中的 QoS

当前RNO设计不遵照IP电话的Cisco建议的设计指南。这些注意事项关于QoS存在:

  • LLQ在Cisco ACU 7200系列广域网路由器没有应用。

  • 帕特里克和阿奎奈校园连接对RNO通过ATM交换的VC (SVC)。SVC不支持LLQ。

一个快速以太网附属的Cisco 7200路由器连接校园对RNO通过34 Mbps E4 ATM链路。流量能潜在排队出站在34M链路由于4M与100M速度不匹配。所以,指定优先级语音流量是必要的。请使用LLQ。Cisco 7200路由器配置类似于此示例:

class-map VoiceRTP
match access-group name IP-RTP

policy-map RTPvoice
class VoiceRTP
priority 10000

interface ATM1/0.1 point-to-point
description ATM PVC to RNO
pvc 0/100 
tx-ring-limit 3
service-policy output RTPvoice

ip access-list extended IP-RTP
deny ip any any fragments
permit udp any range any range 16384 32768 precedence critical

带宽分配到LLQ必须是N x 24Kbps,其中N是同时G.729呼叫数量。

设置从其中每一的一个PVC帕特里克和阿奎奈Cisco 7200路由器到AARNet路由器。ATM SVC在维多利亚RNO不支持LLQ,因为根据经典IP over ATM (RFC 1577)。其他大学在维多利亚RNO能继续暂时使用RFC 1577。然而,最终请替换经典IP over ATM基础设施。

网关

作为H.323网关的其中每一个ACU校园有一个Cisco 3640路由器。这些网关连接对PSTN通过ISDN。主速率接口(PRI)和B信道数量取决于校园的大小。此表列出PRI和B信道数量每个校园的:

校园 PRI数量 B信道数量
登上圣玛丽 2 30
MacKillop 2 50
帕特里克 2 50
阿奎奈 1 20
Signadou 1 20
McAuley 1 30

这些网关仅使用作为附属网关DOD (直接向外拨号)。AARNet网关是主网关。ACU网关总是使用DID (直接拨入)。

拨号方案

拨号计划根据四位数字的分机号。分机也是DID号码的最后四个位。此表列出扩展范围和DID的编号每个校园的:

校园 分机 DID
登上圣玛丽 9xxx 02 9764个9xxx
MacKillop 8xxx 02 9463个8xxx
帕特里克 3xxx 03 8413个3xxx
阿奎奈 5xxx 03 5330个5xxx
Signadou 2xxx 02 6123个2xxx
McAuley 7xxx 07 3354 7xxx

在传递它到Cisco CallManager前,在网关的一个简单扩充数项削DID号码对四位数字的分机。例如,帕特里克校园网关有此条目:

num-exp 84133... 3...

用户拨零选择外线。此前导零通过到网关。单个POTS拨号对端路由ISDN端口根据前导零的召集。

Dial-peer voice 100 pots
destination-pattern 0
direct-inward-dial
port 2/0:15

呼入呼叫使用此扩充数项变换被叫号码到一四位数字的分机。呼叫然后匹配两个VoIP拨号对等体。凭更低优先权,它偏好此路由给Cisco CallManager用户:

dial-peer voice 200 voip
preference 1
destination-pattern 3...
session target ipv4:172.168.0.4

dial-peer voice 201 voip
preference 2
destination-pattern 3...
session target ipv4:172.168.0.5

Cisco CallManager

其中每一个校园有包括两个Cisco CallManager服务器的一集群。Cisco CallManager服务器是媒体汇聚服务器7835 (MCS-7835)的混合和媒体汇聚服务器7820 (MCS-7820)。两个服务器在此出版物时运行了版本3.0(10)。一Cisco CallManager是发行商,并且另一Cisco CallManager是用户。用户作为所有IP电话的主Cisco CallManager。此表列出硬件部署在每个校园:

校园 平台 CallManager
登上圣玛丽 MCS-7835 2
MacKillop MCS-7835 2
帕特里克 MCS-7835 2
阿奎奈 MCS-7820 2
Signadou MCS-7820 2
McAuley MCS-7835 2

每集群配置与两个地区:

  • 一intracampus呼叫的(G.711)

  • 一校园之间的呼叫的(G.729)

因为每集群为服务的所有IP电话在单个校园,基于位置的CAC为ACU不是适当的。有优点对校园之间的呼叫的基于关守的CAC,但是这当前没有实现。然而,有规划那么在不久的将来执行。

每Cisco CallManager配置与22 H.323网关。这撰写对五其他Cisco CallManager集群、六个AARNet PSTN网关和一个ACU网关的集群间中继线在每个校园。

H.323设备类型 数量
校园之间的CallManager 2 x 5 = 10
AARNet PSTN网关 6
ACU PSTN网关 6
托塔尔: 22

路由列表和路由组用于分级PSTN网关。例如,此表显示从帕特里克Cisco CallManager的呼叫在对悉尼PSTN的Melbourne如何能使用四个网关与路由组一起附加呼叫。

网关 优先级
AARNet悉尼 1
ACU悉尼 2
AARNet Melbourne 3
ACU Melbourne 4

因为此表显示,思科CallManager配置与大约30个路由模式。路由模式设计那么那里是特定对手对于所有国内澳大利亚编号。在Cisco CallManager发起呼叫前,这样,用户不必须等待拨号间隔超时超时。通配符“!”在路由模式仅使用国际号码。用户必须等待,直到拨号间隔超时(默认10秒)在呼叫过程前到期,当他们拨号国际目的地时。用户能也添加路由模式"0.0011!#"。用户能然后输入“#”,在表明对Cisco CallManager后的最后一数字呼叫号码完成。此操作加快国际拨号。

--
路由模式 说明
本地呼叫
0.00 紧急呼叫-,如果用户忘记拨0外线的
0.000 紧急呼叫
0.013 查号辅助
0.1223
0.0011! 国际呼叫
呼叫向新南威尔斯
呼叫向维多利亚
对移动电话的呼叫
呼叫向昆士兰
对澳大利亚西部的呼叫
呼叫向南澳洲和北部地区
呼叫到1800 xxx xxx和1900年xxx xxx
0.1144X 紧急
0.119[4-6] 时间和天气
0.1245X 目录
0.13[1-9]XXX 对13xxxx编号的呼叫
对1300 xxx xxx编号的呼叫
2[0-1]XX 对Signadou的集群间呼叫
3[0-4]XX 对帕特里克的集群间呼叫
5[3-4]XX 对阿奎奈的集群间呼叫
7[2-5]XX 对McAuley的集群间呼叫
8[0-3]XX 对MacKillop的集群间呼叫
9[3-4]XX 装载圣玛丽的集群间呼叫
9[6-7]XX 装载圣玛丽的集群间呼叫

配置的网关、路由组、路由列表和路由模式数量在ACU思科CallManager有可能性成长为大量。如果一个新的RNO网关配置,必须重新配置全部五Cisco CallManager集群一个另外的网关。更坏,数百网关是否需要被添加ACU思科呼叫管理器路由VoIP呼叫直接地到其他大学并且一共绕过PSTN。清楚地这不很好扩展。

解决方案将使思科CallManager关守控制的。当新网关或Cisco CallManager在AARNet时,被添加某处您必须只更新网守。当这发生时,每Cisco CallManager必须有本地园区网网关和仅匿名已配置设备。您能设想此设备作为一点对多点中继。它删除网状连接的PPP中继的必要在Cisco CallManager拨号计划型号。单个路由组指向匿名设备作为首选的网关和本地网关作为备份网关。如果网守变得不可用,本地PSTN网关使用某些本地呼叫并且一般网外呼叫。目前,匿名设备可以同时是簇之间或H.225,但是不是两个。

Cisco CallManager比当前有需要少量路由模式用网守。原则上, Cisco CallManager需要仅单个路由模式“!”指向网守。实际上,呼叫路由的方式需要是更多特定对于这些原因:

  • 一些呼叫(例如呼叫到1-800或紧急事件号码)需要通过地理本地网关路由。拨号police或一家连锁饭店例如必胜客的某人Melbourne的不在珀斯要连接到police或必胜客。特定路由模式是需要的点直接地对这些编号的本地园区网PSTN网关。

    计划进行将来IP电话部署的大学在AARNet网关能选择独自地取决于和不管理他们自己的本地网关。这些编号必须有Cisco CallManager加在前面的一个虚拟区域代码在发送它前对网守为了使此设计为需要丢弃本地的呼叫工作。例如, Cisco CallManager能加在前面003到从一个基于墨尔本的电话的呼叫到必胜客1-800号码。这允许网守路由呼叫到一个基于墨尔本的AARNet网关。在发出呼叫到PSTN前,网关剥去导致的003。

  • 在呼叫被发起前,请以特定匹配使用路由模式所有国内编号为了避免有用户等待拨号间隔超时。

此表显示关守控制的Cisco CallManager的路由模式:

--
路由模式 说明 路由 网守
本地呼叫 路由列表 AARNet
0.00 紧急呼叫 本地网关
0.000 紧急呼叫 本地网关
0.013 查号辅助 本地网关
0.1223 本地网关
0.0011! 国际呼叫 路由列表 AARNet
0.0011!# 国际呼叫 路由列表 AARNet
对新南威尔斯、维多利亚和移动电话的呼叫 路由列表 AARNet
呼叫向南澳洲、澳大利亚西部和北部地区 路由列表 AARNet
呼叫到1800 xxx xxx和1900年xxx xxx 本地网关
0.1144X 紧急 本地网关
0.119[4-6] 时间和天气 本地网关
0.13[1-9]XXX 对13xxxx编号的呼叫 本地网关
对1300 xxx xxx编号的呼叫 本地网关
[2-3]XXX 对Signadou的呼叫 路由列表 ACU
5XXX 对阿奎奈的呼叫 路由列表 ACU
[7-9]XXX 对McAuley、MacKillop和登上圣玛丽的呼叫 路由列表 ACU

网守路由国际呼叫,没有通过本地网关被发送。因为AARNet能在将来,配置国际网关这是重大的。如果网关在美国配置,简单网守配置配置更改允许大学发出呼叫到美国以美国本地速率。

网守执行根据四位数字的ACU分机的集群间呼叫路由。此地址空间与其他大学很可能交迭。这指明ACU管理其自己的网守并且使用AARNet网守作为目录关守。网守列在此表里指示呼叫路由是否由ACU网守或AARNet网守执行。

注意: 与报价的网守解决方案的唯一的警告同时是匿名设备可以当前是簇之间或H.225,但是不是两个。Cisco CallManager依靠网守路由呼叫到两个网关(H.225)和其他思科CallManager (簇之间)与提议的设计。此问题的应急方案是对不是使用簇之间路由的网守或通过网守处理所有呼叫作为H.225。更加更高的应急方案意味着一些附加功能也许是不可用在集群间呼叫。

语音邮件

ACU有有对话电话板的三个Active Voice Repartee基于OS/2的语音邮件服务器在迁移之前对IP电话。规划是重新使用在IP电话环境的这些服务器。当实现,每个Repartee服务器连接到Cisco CallManager通过简单信息台界面(SMDI)和Catalyst 6000 24波尔特局外交换站(FXS)卡。三的此提供语音邮件六个校园,离开三个校园,不用语音邮件。适当地共享在用户之间的一个Repartee服务器两Cisco CallManager集群的,因为没有办法传播在簇之间H.323中继间的消息等待指示符(MWI)是不可能的。

ACU也许采购保持的校园的三个Cisco Unity服务器。这些服务器基于膜状的,因此网关没有要求。在ACU采购另外的语音邮件服务器情况下,此表列出语音邮件解决方案:

-- -- --
校园 语音邮件系统 网关
登上圣玛丽 Active Voice Repartee Catalyst 6000 24波尔特FXS
MacKillop Active Voice Repartee Catalyst 6000 24波尔特FXS
帕特里克 Active Voice Repartee Catalyst 6000 24波尔特FXS
阿奎奈 Cisco Unity
Signadou Cisco Unity
McAuley Cisco Unity

六个语音邮件服务器运行作为此规划的隔离语音邮件海岛。没有语音邮件联网。

介质资源

硬件数字信号处理器(DSP)当前没有部署在ACU。会议使用在Cisco CallManager的基于软件的会议桥。当前不支持簇之间会议。

转码当前没有要求。使用仅G.711和G.729编码器译码器,并且所有部署的终端设备支持他们。

传真和调制解调器支持

ACU IP电话网络当前不支持传真和调制解调器数据流。大学计划为此使用Catalyst 6000 24波尔特FXS。

软件版本

此表列出在此出版物时使用的软件版本ACU :

--
平台 功能 软件版本
CallManager IP-PBX 3.0(10)
Catalyst 3500XL 分布式交换机 12.0(5.1)XP
Catalyst 6500 核心交换机 5.5(5)
Catalyst 1900 布线室交换机
Cisco 7200处理器 WAN路由器 12.1(4)
Cisco 3640路由器 H.323网关 12.1(3a)XI6

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 13913