IP : 边界网关协议(BGP)

BGP策略统计和BGP策略统计输出接口统计

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 23 日) | 反馈


目录


简介

边界网关协议(BGP)策略统计(PA)功能允许您占IP数据流有差别地通过分配根据属性列表、AS编号,并且/或者AS_PATH的计数器在a每个输入接口基本类型。

BGP PA输出接口核算引入几扩展启用在输出接口的BGP PA和包括根据两的源地址的核算在接口的输入和输出流量。根据参数的计数器例如属性列表、自治系统编号或者自治系统路径分配识别IP数据流。

先决条件

要求

在您使用BGP PA功能前,请启用思科快速转发(CEF)或Distributed Cisco Express Forwarding (DCEF)在路由器。

使用的组件

支持Cisco IOS版本12.0(9)S的以下平台首先支持BGP PA功能。

  • Cisco 7200、7500及12000系列路由器

支持在Cisco IOS版本12.2(13)T的此功能平台的编号更加大。平台包括:

  • 1400, 1600, 1700, 2600, 3600, 7100, 7200, 7500, AS5300, AS5350,AS5400,AS5800, AS5850, ICS7750, IGX 8400 URM, MGX8850, uBR7200。

BGP PA输出接口核算在12.0(22)S被添加了和首先介绍作为新特性在12.3(4)T。有支持此功能的许多Cisco平台。

注意: 获得关于平台支持的更新信息此功能的,访问Cisco Feature Navigator II (仅限注册用户)。

本文档中的信息都是基于特定实验室环境中的设备创建的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您是在真实网络上操作,请确保您在使用任何命令前已经了解其潜在影响。

背景理论

此功能是在Cisco IOS 软件版本12.0(9)S ED的第一联机。为了使工作的策略记帐功能,您必须启用BGP和CEF/dCEF在路由器。

使用BGP策略统计,您能占流量(和应用横断的计费)根据路由。例如,您能占是路由的国内的,国际,地球的流量,或者卫星。这样,您能识别和占在逐个客户的所有流量。

此功能利用bgp table-map命令,分类前缀放到路由表根据属性列表, AS编号, AS_PATH,等。凭这些匹配标准, BGP记帐策略设置桶编号(当前1到64)会计表关联与每个接口。每个桶代表数据流分类,允许将占有差别地IP数据流由属性列表、AS编号或者AS_PATH每个输入接口。

欲知更多信息,参考BGP策略统计

注意: BGP PA测量并且分类发送或者接收从的IP数据流,不同的对等体。PA是以前提供的在仅输入接口。

BGP策略统计输出接口记帐功能引入几扩展启用在输出接口的BGP PA和包括根据两的源地址的核算在接口的输入和输出流量。根据参数的计数器例如属性列表、自治系统编号或者自治系统路径分配识别IP数据流。输出接口核算在Cisco IOS版本12.0(22)S被添加了。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

配置 BGP 策略统计

  1. 指定分类核算的流量的属性列表的社区(或请定义AS_PATH列表)。

    ip community-list 30 permit 100:190
      ip community-list 40 permit 100:198
      ip community-list 50 permit 100:197
      ip community-list 60 permit 100:296
      ip community-list 70 permit 100:201
      !
  2. 定义route-map匹配属性列表和设置适当的桶编号。

    route-map set_bucket permit 10
    match community 30
    set traffic-index 2
    !
    route-map set_bucket permit 20
    match community 40
    set traffic-index 3
    !
    route-map set_bucket permit 30
    match community 50
    set traffic-index 4
    !
    route-map set_bucket permit 40
    match community 60
    set traffic-index 5
    !
    route-map set_bucket permit 50
    match community 70
    set traffic-index 6 
  3. 当IP路由表更新与从BGP时的获知的路由请使用table-map命令下面BGP修改桶编号。

    router bgp 110
      table-map set_bucket
      network 15.1.1.0 mask 255.255.255.0
      neighbor 14.1.1.1 remote-as 100
      !
      ip classless
      ip bgp-community new-format 
  4. 启用在输入接口的策略记帐功能连接对客户。

    interface POS7/0
      ip address 15.1.1.2 255.255.255.0
      no ip directed-broadcast
      bgp-policy accounting
      no keepalive
      crc 32
      clock source internal

配置BGP策略统计输出接口核算

BGP PA输出接口核算的配置非常类似于BGP PA。在前面部分描述的第一三步正确地是相同的。唯一的更改是在bgp-policy accounting命令使用启用在接口的PA功能。在下面的示例中BGP PA在POS接口7/0启用。PA标准根据输出流量的源地址

interface POS7/0
 ip address 10.15.1.2 255.255.255.0
 bgp-policy accounting output source
 no keepalive
 crc 32
 clock source internal

监视策略统计的 show 命令

检查前缀分配桶,并且的社区(或社区),使用show ip cefshow ip bgp命令。

Router# show ip cef 196.240.5.0 detail
196.240.5.0/24, version 21, cached adjacency to POS7/2
0 packets, 0 bytes, traffic_index 4
  via 14.1.1.1, 0 dependencies, recursive
   next hop 14.1.1.1, POS7/2 via 14.1.1.0/30
   valid cached adjacency

Router# show ip bgp 196.240.5.0
BGP routing table entry for 196.240.5.0/24, version 2
Paths: (1 available, best #1)
  Not advertised to any peer
  100
    14.1.1.1 from 14.1.1.1 (32.32.32.32)
      Origin IGP, metric 0, localpref 100, valid, external, best
      Community: 100:197

要查看单个接口的流量统计,请使用show cef interface policy-statistics命令

LC-Slot7# show cef interface policy-statistics
:
POS7/0 is up (if_number 8)
Bucket    Packets               Bytes

1          0                      0
2          0                      0
3          50                     5000
4          100                    10000
5          100                    10000
6          10                     1000
7          0                      0
8          0                      0

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 13760