IP : IP 组播

为什么 PIM 稀疏模式使用到 HSRP 地址的静态路由?

2016 年 10 月 27 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

本文解释组播信息包为什么没有转发,当您配置静态路由对独立于协议的组播(PIM)稀疏模式邻居的热备份路由协议(HSRP)地址时。

先决条件

要求

本文档的读者应掌握以下这些主题的相关知识:

  • HSRP

  • PIM 稀疏模式

使用的组件

本文档不限于特定的软件和硬件版本。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

网络图

http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-multicast/13783-hsrpmcasta.gif

在以上图,路由器2和3谈在子网10.1.3.0的HSRP,并且Router2是活动路由器。路由器1, 2,并且3谈增强的内部网关路由选择协议(EIGRP)和Router4有静态默认路由对HSRP虚拟地址。

配置

路由器 1 路由器 2
Current configuration:

! 
ip multicast-routing 
! 
! 
interface Loopback0 
ip address 10.10.10.10 255.255.255.255 
no ip directed-broadcast 
! 
interface Ethernet0 
no ip address 
no ip directed-broadcast 
shutdown 
! 
interface Ethernet1 
ip address 10.1.1.1 255.255.255.0 
no ip directed-broadcast 
ip pim sparse-mode 
! 
interface Serial1 
no ip address 
no ip directed-broadcast 
encapsulation frame-relay 
! 
interface Serial1.1 point-to-point 
ip address 10.1.2.1 255.255.255.252 
no ip directed-broadcast 
ip pim sparse-mode 
frame-relay interface-dlci 612 
! 
! 
interface Serial1.2 point-to-point 
ip address 10.1.2.5 255.255.255.252 
no ip directed-broadcast 
ip pim sparse-mode 
frame-relay interface-dlci 613 
! 
router eigrp 1 
network 10.0.0.0 
no auto-summary 
! 
ip classless 
no ip http server 
ip pim rp-address 10.10.10.10 
! 

end
Current configuration:

! 
ip multicast-routing 
ip dvmrp route-limit 20000 
! 
! 
interface Ethernet1 
ip address 10.1.3.1 255.255.255.0 
no ip redirects 
ip pim sparse-mode 
standby 1 priority 110 preempt 
standby 1 ip 10.1.3.3 
! 
interface Serial1 
no ip address 
encapsulation frame-relay 
! 
interface Serial1.1 point-to-point 
ip address 10.1.2.2 255.255.255.252 
ip pim sparse-mode 
frame-relay interface-dlci 621 
! 
router eigrp 1 
network 10.0.0.0 
no auto-summary 
! 
ip classless 
ip pim rp-address 10.10.10.10 
!

end
路由器 3 Router4
Current configuration:

! 
ip multicast-routing 
ip dvmrp route-limit 20000 
! 
interface Ethernet1 
ip address 10.1.3.2 255.255.255.0 
no ip redirects 
ip pim sparse-mode 
standby 1 priority 100 preempt 
standby 1 ip 10.1.3.3 
! 
interface Serial1 
no ip address 
encapsulation frame-relay 
! 
interface Serial1.2 point-to-point 
ip address 10.1.2.6 255.255.255.252 
ip pim sparse-mode 
frame-relay interface-dlci 631 
! 
router eigrp 1 
network 10.0.0.0 
no auto-summary 
eigrp log-neighbor-changes 
! 
ip classless 
no ip http server 
ip pim rp-address 10.10.10.10 
!

end
Current configuration:

ip multicast-routing 
ip dvmrp route-limit 20000 
! 
! 
! 
interface Ethernet0 
ip address 10.1.4.1 255.255.255.0 
no ip directed-broadcast 
ip igmp join-group 239.1.2.3 
! 
interface Ethernet1 
ip address 10.1.3.4 255.255.255.0 
no ip directed-broadcast 
ip pim sparse-mode 
! 
no ip http server 
ip classless 
ip route 0.0.0.0 0.0.0.0 10.1.3.3 
ip pim rp-address 10.10.10.10 
!

end

为了模拟在Ethernet0的一台主机, ip igmp join-group命令在Router4的此接口配置:

router4# ip igmp join-group 

IGMP Connected Group Membership 
Group Address Interface Uptime Expires Last Reporter 
224.0.1.40 Ethernet1 4d23h never 10.1.3.1 
239.1.2.3 Ethernet0 4d23h never 10.1.4.1 

Router4能也ping聚合点(RP)地址:

Type escape sequence to abort. 

Sending 5, 100-byte ICMP Echos to 10.10.10.10, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 60/61/68 ms

查看组播路由(mroute)表:

Router4# show ip mroute 239.1.2.3 

IP Multicast Routing Table 

Flags: D - Dense, S - Sparse, C - Connected, L - Local, P - Pruned 
R - RP-bit set, F - Register flag, T - SPT-bit set, J - Join SPT 
X - Proxy Join Timer Running 

Timers: Uptime/Expires 
Interface state: Interface, Next-Hop or VCD, State/Mode 
(*, 239.1.2.3), 00:04:28/00:00:00, RP 10.10.10.10, flags: SJCL 
Incoming interface: Ethernet1, RPF nbr 10.1.3.3 
Outgoing interface list: 
Ethernet0, Forward/Sparse, 00:02:12/00:02:53 

由于有此组的一个接收方(由于用于路由器的ip igmp join-group命令4),构件a (*, G)条目在mroute表里。注释的反向路径转发(RPF)邻居(*, G)条目是10.1.3.3,是HSRP备用地址。然而,没有a (S, G)条目,含义流量没有从来源接收。

因为Router4有组的一个感兴趣接收方,应该当前传送PIM汇合/消减消息对其PIM邻居。请使用show ip pim neighbor命令观看路由器4's PIM邻居,如下所示:

Router4# show ip pim neighbor 

PIM Neighbor Table 
Neighbor Address Interface Uptime Expires Ver Mode 
10.1.3.1 Ethernet1 4d23h 00:01:41 v2 
10.1.3.2 Ethernet1 4d23h 00:01:36 v2

如果debug ip pim 239.1.2.3命令启用, Router4建立此PIM汇合/消减消息,但是实际上不发送它:

*Mar 6 18:32:48 :PIM :已接收路由处理器可及的在从10.10.10.10 *Mar 6 18:32:48的Ethernet 1 :组239.1.2.3 *Mar 6 18:33:14 :PIM :建立239.1.2.3 *Mar的6 18:34:13汇合/消减消息:PIM :建立239.1.2.3的汇合/消减消息

路由器为什么不发送汇合/消减消息?RFC 2362leavingcisco.com 阐明, “路由器传送一个定期汇合/消减消息给每个明显的RPF邻居关联与每(S, G), (*, G)和(*, *, RP)条目。汇合/消减消息传送,只有当RPF邻居是PIM邻居”。

在示例中, RPF邻居是10.1.3.3,是默认静态路由使用的HSRP备用地址。然而,此地址没有列出作为PIM邻居。HSRP备用地址没有列出作为PIM邻居的原因是,因为运行HSRP的两路由器(路由器2和3)从HSRP备用地址不会来源PIM邻接消息。

要解决问题,更改路由器4's配置,因此RPF邻居也是PIM邻居。通过包括Router4执行此在EIGRP进程,以便通过EIGRP当前了解RP地址。

注意: 因为Router4有功能运行路由协议不应该必须依靠连接的HSRP备用地址。HSRP的开发打算提供主机的一个方式能获取快速和高效的冗余或者故障切换。

下面与启用的EIGRP的新的路由器配置4。

ip multicast-routing 
ip dvmrp route-limit 20000 
! 
! 
! 
interface Ethernet0 
ip address 10.1.4.1 255.255.255.0 
no ip directed-broadcast 
ip igmp join-group 239.1.2.3 
! 
interface Ethernet1 
ip address 10.1.3.4 255.255.255.0 
no ip directed-broadcast 
ip pim sparse-mode 
!
router eigrp 1
network 10.0.0.0
no auto-summary
! 
no ip http server 
ip classless 
ip route 0.0.0.0 0.0.0.0 10.1.3.3 
ip pim rp-address 10.10.10.10 
!
end 

注意: 而不是包括Router4在EIGRP进程(首选方法),请添加静态mroutes到Router4做它RPF到真正的路由器的IP地址,因为mroutes在RPF检查的单播路由表更喜欢。例如,请添加ip mroute 0.0.0.0 0.0.0.0 10.1.3.2


相关信息


Document ID: 13783