多协议标签交换 (MPLS) : MPLS

客户侧使用 RIP 时配置 MPLS 基本 VPN

2016 年 10 月 27 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

当路由信息协议(RIP)是存在用户侧时,此配置示例显示多协议标签交换(MPLS)虚拟专用网络(VPN)。

VPN功能,当使用与MPLS,允许几个站点透明地通过服务提供商的网络互联。一个服务提供商网络可以支持多个不同的 IP VPN。每个IP VPN出现作为私有网络,分别于所有其它网络。VPN的每个站点发送IP信息包到同样VPN的其他站点。

每个 VPN 均与一个或多个 VPN 路由或转发实例 (VRF) 相关联。VRF包括IP路由表、派生的Cisco express forwarding (CEF)表和使用转发表的一套接口。

路由器针对每个 VRF 维护一个单独的路由和 CEF 表。这防止信息发送VPN的外部并且允许用于几个VPN的相同子网,无需引起重复IP地址问题。

使用BGP扩展属性,使用边界网关协议(BGP)的路由器分配VPN路由线信息。

关于更新传播的更多信息通过VPN请参阅VPN路由目标属性、VPN路由信息的BGP分配和MPLS转发部分在MPLS虚拟专用网络

先决条件

要求

本文档没有任何特定的前提条件。

使用的组件

我们开发并且测试了此配置使用下面软件和硬件版本:

  • PE路由器:MPLS VPN功能位于PE路由器。请使用功能导航II (仅限注册用户)确定哪些硬件与软件组合您能使用。

  • CE路由器:请使用能所有的路由器交换与其PE路由器的路由信息。

  • P路由器和切换:在本文中,使用了ATM交换机例如MSR, BPX和MGX。然而,因为本文着重MPLS VPN功能我们在核心可能也使用了帧基于MPLS用路由器,例如Cisco 12000。

本文档中的信息都是基于特定实验室环境中的设备创建的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您是在真实网络上操作,请确保您在使用任何命令前已经了解其潜在影响。

网络说明

我们设置标准MPLS ATM骨干网使用开放最短路径优先(OSPF) area 0作为内部网关路由协议(IGP)。使用此骨干网,我们配置两个不同的VPN。第一个VPN使用RIP作为其用户边缘对运营商边缘(CE-PE)路由协议;另一个VPN使用BGP作为其PE-CE路由协议。我们配置多种环回和静态路由在CE路由器模拟其他路由器和网络出现。

注意: 因为曾经BGP扩展属性是传输VPN的路由信息的唯一方法在PE路由器之间,必须使用BGP作为在PE路由器之间的VPN IGP。

注意: ATM网络用于作为骨干网络做此配置。此配置运用对ATM (和其他)协议。PE路由器一定能互相到达使用VPN配置的MPLS网络能工作。

规则

下面的字母代表使用的不同种类的路由器和交换机:

  • P :供应商的核心路由器

  • PE :供应商的边界路由器

  • CE :客户的边界路由器

  • C :客户路由器

说明这些规则的典型配置在下图所示中显示:

http://www.cisco.com/c/dam/en/us/support/docs/multiprotocol-label-switching-mpls/mpls/13732-mpls-vpn-rip-mplsvpn.gif

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

配置过程

本部分提供有关如何配置本文档所述功能的信息。在MPLS虚拟专用网络找到的Cisco IOS文档也描述此配置程序。

注意: 要寻找关于用于本文的命令的其他信息,请使用IOS命令查找工具(仅限注册用户)

网络图

本文档使用下图所示的网络设置。

http://www.cisco.com/c/dam/en/us/support/docs/multiprotocol-label-switching-mpls/mpls/13732-mpls-vpn-rip-mv-rip.gif

第 I 部分

下面步骤将帮助您正确地配置。

启用ip cef命令。如果使用Cisco 7500路由器,请保证ip cef distributed命令启用,其中联机,提高在PE的性能,一旦MPLS设置。

  1. 使用IP VRF [VPN路由,创建每个VPN的VRF|转发实例名字]命令。当创建VRF时,请务必对:

    • 指定用于该VPN的正确路由辨别器使用下面命令。标志用于扩大IP地址并且允许您识别到哪个VPN属于。

      rd [VPN route distinguisher]
      
    • 设置BGP扩展属性的导入和出口属性使用下面命令。这些属性使用过滤导入和出口进程。

      route-target {export | import | both} [target VPN extended community] 
      
  2. 配置各自的接口的转发细节使用ip vrf forwarding [table name]命令并且切记之后设置IP地址。

  3. 根据使用的PE-CE路由协议,请执行一个或很多的下列:

    • 配置静态路由如下:

      ip route vrf vrf-name prefix mask [next-hop-address] [interface {interface-number}] 
      
    • 使用以下命令,配置RIP :

      address-family ipv4 vrf [VPN routing | forwarding instance name] 
      

      一旦完成以上其中一个或两个的步骤,请输入正常RIP配置命令。

      注意: 这些仅apply命令对当前VRF的转发接口。重新分配正确BGP到RIP并且切记指定使用的度量。

    • 宣称BGP邻居信息。

    • 使用新ios命令,配置OSPF :

      router ospf process-id vrf [VPN routing | forwarding instance name] 
      

    注意: 此命令仅适用对转发接口为当前VRF。重新分配正确BGP路由信息到OSPF并且指定使用的度量。一旦对VRF的OSPF程序完成,即使OSPF程序在line命令没有指定,此进程ID总是使用此特定VRF。

第 II 部分

配置在PE路由器之间的BGP。有几个方式配置 BGP,例如使用路由反射器或联盟方法。显示的方法此处是直接邻居配置。它最简单和最不可扩展。

  1. 声明不同的邻居。

  2. 输入address-family ipv4 vrf [VPN路由|每个VPN的转发实例名字]命令现在此PE路由器。根据需要执行以下一个或多个步骤:

    • 重新分配静态路由信息。

    • 重新分配RIP路由信息。

    • 重新分配OSPF路由信息。

    • 激活与 CE 路由器相邻的 BGP。

  3. 输入地址家族vpnv4模式和:

    • 激活邻居。

    • 指定必须使用扩展团体。这是强制性的。

配置示例

在Alcalzaba配置中,线路特定对VPN配置在粗体显示。

Alcazaba
!
ip vrf vrf101
 rd 1:101
 route-target export 1:101
 route-target import 1:101
!
ip cef
!
interface Loopback0
 ip address 223.0.0.3 255.255.255.255
!
interface Ethernet1/1
 ip vrf forwarding vrf101
 ip address 150.150.0.1 255.255.255.0
!
interface ATM3/0
 no ip address
 no ip mroute-cache
 no ATM ilmi-keepalive
 PVC qsaal 0/5 qsaal
 PVC ilmi 0/16 ilmi
 !
!
interface ATM3/0.1 tag-switching
 ip address 10.0.0.17 255.255.255.252
 tag-switching ATM vpi 2-4
 tag-switching ip
!
interface ATM4/0
 no ip address
 no ATM ilmi-keepalive
!
interface ATM4/0.1 tag-switching
 ip address 10.0.0.13 255.255.255.252
 tag-switching ATM vpi 2-4
 tag-switching ip 
!
router ospf 1
 network 10.0.0.0 0.0.0.255 area 0
 network 223.0.0.3 0.0.0.0 area 0
!
router rip
 version 2
 !
 address-family ipv4 vrf vrf101
 version 2
 redistribute bgp 1 metric 0
 network 150.150.0.0
 no auto-summary
 exit-address-family
!
router bgp 1
 no synchronization
 neighbor 125.2.2.2 remote-as 1
 neighbor 125.2.2.2 update-source Loopback0
 neighbor 223.0.0.21 remote-as 1
 neighbor 223.0.0.21 update-source Loopback0
 no auto-summary
 !
 address-family ipv4 vrf vrf101
 redistribute rip
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family vpnv4
 neighbor 125.2.2.2 activate
 neighbor 125.2.2.2 send-community extended
 neighbor 223.0.0.21 activate
 neighbor 223.0.0.21 send-community extended
 no auto-summary
 exit-address-family
!

Kozel
!
ip vrf vrf101
 rd 1:101
 route-target export 1:101
 route-target import 1:101
!
ip cef
!
interface Loopback0
 ip address 223.0.0.21 255.255.255.255
!
interface Ethernet1/1
 ip vrf forwarding vrf101
 ip address 200.200.0.1 255.255.255.0
!
interface ATM4/0
 no ip address
 no ATM scrambling cell-payload
 no ATM ilmi-keepalive
 PVC qsaal 0/5 qsaal     
 PVC ilmi 0/16 ilmi
!
interface ATM4/0.1 tag-switching
 ip address 10.0.0.6 255.255.255.252
 tag-switching ATM vpi 2-4
 tag-switching ip
!
router ospf 1
 log-adjacency-changes
 network 10.0.0.0 0.0.0.255 area 0
 network 223.0.0.21 0.0.0.0 area 0
!
router rip
 version 2
 !
 address-family ipv4 vrf vrf101
 version 2
 redistribute bgp 1 metric 1
 network 200.200.0.0
 no auto-summary
 exit-address-family
!
router bgp 1
 no synchronization
 neighbor 125.2.2.2 remote-as 1
 neighbor 125.2.2.2 update-source Loopback0
 neighbor 223.0.0.3 remote-as 1
 neighbor 223.0.0.3 update-source Loopback0
 no auto-summary
 !
 address-family ipv4 vrf vrf101
 redistribute rip
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family vpnv4
 neighbor 125.2.2.2 activate
 neighbor 125.2.2.2 send-community extended
 neighbor 223.0.0.3 activate
 neighbor 223.0.0.3 send-community extended
 no auto-summary
 exit-address-family
!

Medina
Current configuration:
!
ip vrf vrf101
 rd 1:101
 route-target export 1:101
 route-target import 1:101
ip cef
!
interface Loopback1
 ip vrf forwarding vrf101
 ip address 11.2.2.2 255.255.255.252
!
interface ATM2/0
 no ip address
 no ATM ilmi-keepalive
!
interface ATM2/0.66 tag-switching
 ip address 125.1.4.2 255.255.255.252
 tag-switching ip
!
interface Ethernet1/1
 ip vrf forwarding vrf101
 ip address 11.3.3.1 255.255.255.252
!
router ospf 1
 
 network 125.1.4.0 0.0.0.3 area 0
 network 125.2.2.2 0.0.0.0 area 0
!
router rip
 version 2
 network 11.0.0.0
 !
 address-family ipv4 vrf vrf101
 version 2
 redistribute bgp 1 metric 1
 network 11.0.0.0
 no auto-summary
 exit-address-family
!
router bgp 1
 no synchronization
 neighbor 223.0.0.3 remote-as 1
 neighbor 223.0.0.3 update-source Loopback0
 neighbor 223.0.0.21 remote-as 1
 neighbor 223.0.0.21 update-source Loopback0
 !
 address-family ipv4 vrf vrf101
 redistribute connected
 redistribute static
 redistribute rip
 default-information originate
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family vpnv4
 neighbor 223.0.0.3 activate
 neighbor 223.0.0.3 send-community extended
 neighbor 223.0.0.21 activate
 neighbor 223.0.0.21 send-community extended
 exit-address-family
!

迅速
Current configuration:


!
interface Loopback0
 ip address 223.0.0.12 255.255.255.255
!         
interface Loopback2
 ip address 7.7.7.7 255.255.255.0
!
interface FastEthernet0/1
 ip address 150.150.0.2 255.255.255.0
 duplex auto
 speed auto
!
router rip
 version 2
 redistribute static
 network 7.0.0.0
 network 10.0.0.0
 network 150.150.0.0
 no auto-summary
!
ip route 158.0.0.0 255.0.0.0 Null0
!

Damme
!
interface Loopback1
 ip address 6.6.6.6 255.0.0.0
!
interface FastEthernet0/0
 ip address 10.200.10.14 255.255.252.0
 duplex auto
 speed autoa
!
router bgp 158
 no synchronization
 network 6.0.0.0
 network 10.200.0.0 mask 255.255.252.0
 neighbor 10.200.10.3 remote-as 1
 no auto-summary
!

Pivrnec
Current configuration:
!
interface Loopback0
 ip address 223.0.0.22 255.255.255.255
!
interface Loopback1
 ip address 6.6.6.6 255.255.255.255
!
interface FastEthernet0/1
 ip address 200.200.0.2 255.255.255.0
 duplex auto
 speed auto
!
router rip
 version 2
 redistribute static
 network 6.0.0.0
 network 200.200.0.0
 no auto-summary
!
ip route 69.0.0.0 255.0.0.0 Null0
!

Guilder
!
interface Loopback2
 ip address 150.150.0.1 255.255.0.0
!
interface Ethernet0/2
 ip address 201.201.201.2 255.255.255.252
!
router bgp 69
 no synchronization
 network 7.7.7.0 mask 255.255.0.0
 network 150.150.0.0
 network 201.201.201.0 mask 255.255.255.252
 redistribute connected
 neighbor 201.201.201.1 remote-as 1
 no auto-summary
!

Purkmister
Current configuration:
!
interface Loopback0
 ip address 11.5.5.5 255.255.255.252
!
interface FastEthernet0/1
 ip address 11.3.3.2 255.255.255.252
 duplex auto
 speed auto
!
router rip
 version 2
 network 11.0.0.0
!

debug 和 show 命令

使用 debug 命令之前,请参阅有关 Debug 命令的重要信息。列出得路由特定命令此处:

  • show ip rip database vrf -显示在特定的VRF RIP数据库包含的信息。

  • show ip bgp vpnv4 vrf -显示从BGP表的VPN地址信息。

  • show ip route vrf -显示IP路由表关联与VRF。

  • show ip route -显示所有静态IP使用验证、授权和统计(AAA)路由下载功能安装的路由或者那些。

命令输出解释程序工具(仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

在PE路由器, PE-CE路由选择法例如RIP, BGP或者静态和PE-PE BGP更新指示用于特定的路由表VRF。您能显示特定的VRF RIP信息如下:

Alcazaba# show ip rip database vrf vrf101
 0.0.0.0/0 auto-summary  
 0.0.0.0/0
 [2] via 150.150.0.2, 00:00:12, Ethernet1/1
 6.0.0.0/8 auto-summary
 6.6.6.6/32 redistributed
 [1] via 223.0.0.21,
 7.0.0.0/8 auto-summary
 7.7.7.0/24
 [1] via 150.150.0.2, 00:00:12, Ethernet1/1 
 10.0.0.0/8 auto-summary
 10.0.0.0/8 redistributed
 [1] via 125.2.2.2,
 10.0.0.0/16
 [1] via 150.150.0.2, 00:00:12, Ethernet1/1 
 10.200.8.0/22
 [1] via 150.150.0.2, 00:00:12, Ethernet1/1 
 11.0.0.0/8 auto-summary
 11.0.0.4/30 redistributed
 [1] via 125.2.2.2,
 11.1.1.0/30 redistributed
 [1] via 125.2.2.2,
 11.3.3.0/30 redistributed
 [1] via 125.2.2.2,
 11.5.5.4/30 redistributed
 [1] via 125.2.2.2,
 69.0.0.0/8 auto-summary
 69.0.0.0/8 redistributed
 [1] via 223.0.0.21,
 150.150.0.0/16 auto-summary
 150.150.0.0/24 directly connected, Ethernet1/1
 158.0.0.0/8
 [1] via 150.150.0.2, 00:00:17, Ethernet1/1
 200.200.0.0/24 auto-summary 
 200.200.0.0/24 redistributed 
 [1] via 223.0.0.21,

使用show ip bgp vpnv4 vrf命令,您能显示特定的VRF BGP信息。从内部BGP (iBGP)的PE-PE结果由i在下面输出中表示。

Alcazaba# show ip bgp vpnv4 vrf vrf101 
   BGP table version is 46, local router ID is 223.0.0.3 
   Status codes: s suppressed, d damped, h history, * valid, best, i - internal    
   Origin codes: i - IGP, e - EGP, ? - incomplete  
 Network Next Hop Metric LocPrf Weight Path 
   Route Distinguisher: 1:101 (default for vrf vrf101) 
   *i6.6.6.6/32 223.0.0.21 1 100 0 ? 
   * 7.7.7.0/24 150.150.0.2 1 32768 ? 
   * 10.0.0.0/16 150.150.0.2 1 32768 ? 
   * 10.200.8.0/22 150.150.0.2 1 32768 ? 
   *i11.2.2.0/30 125.2.2.2 0 100 0 ? 
   *i11.3.3.0/30 125.2.2.2 0 100 0 ? 
   *i11.5.5.4/30 125.2.2.2 1 100 0 ? 
   *i69.0.0.0 223.0.0.21 1 100 0 ? 
   * 150.150.0.0/24 0.0.0.0 0 32768 ? 
   * 158.0.0.0/8 150.150.0.2 1 32768 ? 
   *i200.200.0.0 223.0.0.21 0 100 0 ?

检查全球路由表在PE和CE路由器的VRF。这些VRF应该配比。使用show ip route vrf命令,对于PE路由器,您必须指定VRF :

Alcazaba# show ip route vrf vrf101
   Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP   
   D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
   N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
   E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP 
   i - ISIS, L1 - ISIS level-1, L2 - ISIS level-2, IA - ISIS inter area    
   * - candidate default, U - per-user static route, o - ODR
   P - periodic downloaded static route
    Gateway of last resort is not set
   B 69.0.0.0/8 [200/1] via 223.0.0.21, 00:11:03
   B 200.200.0.0/24 [200/0] via 223.0.0.21, 00:11:03
    6.0.0.0/32 is subnetted, 1 subnets
   B 6.6.6.6 [200/1] via 223.0.0.21, 00:11:03 
    7.0.0.0/24 is subnetted, 1 subnets
   R 7.7.7.0 [120/1] via 150.150.0.2, 00:00:05, Ethernet1/1 
    10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
   R 10.0.0.0/16 [120/1] via 150.150.0.2, 00:00:05, Ethernet1/1 
   R 10.200.8.0/22 [120/1] via 150.150.0.2, 00:00:05, Ethernet1/1 
    11.0.0.0/30 is subnetted, 3 subnets
   B 11.3.3.0 [200/0] via 125.2.2.2, 00:07:05
   B 11.2.2.0 [200/0] via 125.2.2.2, 00:07:05
   B 11.5.5.4 [200/1] via 125.2.2.2, 00:07:05
    150.150.0.0/24 is subnetted, 1 subnets
   C 150.150.0.0 is directly connected, Ethernet1/1
   R 158.0.0.0/8 [120/1] via 150.150.0.2, 00:00:06, Ethernet1/1

在Pivrnec的等效命令show ip route命令,因为每个客户(和用户边缘)路由器的这是标准路由表。

Pivrnec# show ip route 
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP  
  D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
  N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 
  E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP 
  i - ISIS, L1 - ISIS level-1, L2 - ISIS level-2, IA - ISIS inter area  
  * - candidate default, U - per-user static route, o - ODR 
  P - periodic downloaded static route Gateway of last resort is not 
  set S 69.0.0.0/8 is directly connected, Null0 
  223.0.0.0/32 is subnetted, 1 subnets 
 C 223.0.0.22 is directly connected, Loopback0 
 C 200.200.0.0/24 is directly connected, FastEthernet0/1 
  6.0.0.0/32 is subnetted, 1 subnets 
 C 6.6.6.6 is directly connected, Loopback1 
  7.0.0.0/24 is subnetted, 1 subnets 
 R 7.7.7.0 [120/1] via 200.200.0.1, 00:00:23, FastEthernet0/1 
  10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks 
 R 10.0.0.0/16 [120/1] via 200.200.0.1, 00:00:23, FastEthernet0/1 
 R 10.200.8.0/22 [120/1] via 200.200.0.1, 00:00:24, FastEthernet0/1 
  11.0.0.0/30 is subnetted, 3 subnets 
 R 11.3.3.0 [120/1] via 200.200.0.1, 00:00:24, FastEthernet0/1 
 R 11.2.2.0 [120/1] via 200.200.0.1, 00:00:25, FastEthernet0/1 
 R 11.5.5.4 [120/1] via 200.200.0.1, 00:00:25, FastEthernet0/1 
  150.150.0.0/24 is subnetted, 1 subnets 
 R 150.150.0.0 [120/1] via 200.200.0.1, 00:00:25, FastEthernet0/1 
 R 158.0.0.0/8 [120/1] via 200.200.0.1, 00:00:25, FastEthernet0/1

MPLS 标签

检查用于所有路由的标签栈如下:

Alcazaba# show tag-switching forwarding-table vrf vrf101 11.5.5.5 detail    
   Local Outgoing Prefix Bytes tag Outgoing Next Hop
   tag tag or VC or Tunnel Id switched interface
   None 2/91 11.5.5.4/30 0 AT4/0.1 point2point
    MAC/Encaps=4/12, MTU=4466, Tag Stack{2/91(vcd=69) 37} 
    00458847 0004500000025000

您能使用正常命令查看标记分配与虚拟路径标识符和虚拟信道标识符(VPI/VCI)如如何排除故障MPLS VPN所显示,关系一起。

地址 重叠

您能使用同一个地址用不同的VPN,无需干涉其他VPN。在本例中, 6.6.6.6地址连接两次,对在VPN 101的Pivrnec和对在VPN 102的Damme。使用ping命令在一个站点和debug ip icmp命令在另一个站点,我们能检查此。

Guilder# ping 6.6.6.6
   Type escape sequence to abort.
   Sending 5, 100-byte ICMP Echos to 6.6.6.6, timeout is 2 seconds:
   !!!!!
   Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms

Damme# debug ip icmp
   ICMP packet debugging is on
   6d22h: ICMP: echo reply sent, src 6.6.6.6, DST 201.201.201.2
   6d22h: ICMP: echo reply sent, src 6.6.6.6, DST 201.201.201.2
   6d22h: ICMP: echo reply sent, src 6.6.6.6, DST 201.201.201.2
   6d22h: ICMP: echo reply sent, src 6.6.6.6, DST 201.201.201.2
   6d22h: ICMP: echo reply sent, src 6.6.6.6, DST 201.201.201.2

调试输出示例

看到输出示例:的MPLS VPN环境的参考的数据包流使用相同的配置。

故障排除

目前没有针对此配置的故障排除信息。


相关信息


Document ID: 13732