IP : 按需路由 (ODR)

用 ODR 设计大规模末节网络

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

按需路由(ODR)是增强对思科设备发现协议(CDP),用于的协议发现在广播的其他Cisco设备或非广播媒介。在CDP帮助下,查找设备类型, IP地址,在邻接Cisco设备的Cisco IOS�版本运行,邻接设备的功能,等等是可能的。在Cisco IOS软件版本11.2, ODR被添加到CDP通过CDP通告终端路由器的已连接IP前缀。此功能取走每网络或子网的额外的五个字节, IP地址的四个字节和通告子网掩码的一个字节与IP一起。ODR能传播Variable Length Subnet Mask (VLSM)信息。

ODR为不要使用他们的网络带宽路由协议更新的企业零售顾客设计。在X.25环境,例如,它经常是非常昂贵的运行在该链路的一个路由协议。静态路由是理想选择,但是有手工维护静态路由的许多笔开销。ODR不CPU密集型,并且用于在Layer2动态地传播IP路由。

当配置它时, ODR不是路由协议,并且不应该对待这样。不同的IP路由协议的传统配置在ODR不会工作, ODR使用在Layer2的CDP。要配置ODR,请使用router odr命令在中心路由器。ODR的设计、实施和交互作用与其他IP路由协议的可以是困难。

除LAN仿真(LANE)外, ODR不会运行在Cisco 700系列路由器或在ATM链路。

末节网络与转接网络

当信息不通过网络时通过,它是末端网络。星型拓扑是末端网络的好的实例。与许多站点的大组织连接对数据中心使用此种拓扑。

低端路由器例如Cisco 2500、1600及1000系列路由器在辐射端使用。如果信息穿过分支路由器达到某其他网络,该终端路由器变为转接路由器。当分支连接到除中心路由器以外时的另一个路由器此配置出现。

常见的考量是ODR更新分支多大能发送。通常, spoke仅连接到集线器。如果spoke连接到其他路由器,他们不再是残余部分并且变为转接网络。低端方框通常有一两个LAN接口。例如, Cisco2500可以支持两个LAN接口。在正常情况下, 10字节数据包发送(万一有在辐射端的两个LAN)作为CDP的部分。默认情况下CDP启用,那么那里是额外的开销没有问题。不会有有一次大ODR更新的情况。大小ODR更新不会是在真正的星型环境的一问题。

集中星形网络与 ODR

集中星型网络是集线器的典型的网络(高端路由器)服务许多spoke (低端路由器)。在特殊情况下,那里可能为冗余目的是超过一台集线器,或通过单独的集线器支持另外的spoke。在这种情况下,在两集线器的enable (event) ODR。有交换的路由协议在两集线器之间的ODR路由信息也是必要的。

图 1:星型拓扑

odrhs.jpg

有单一出口点的分支

在以上的图1, spoke连接到一台集线器,以便他们能依靠默认网关而不是接收集线器的所有路由信息用一出口点。因为分支不会必须做出智能路由决策,给spoke传递所有信息是不必要的。分支永远将发送流量到集线器,因此spoke需要指向集线器的仅默认路由。

必须有spoke的子网信息的一个方式能发送对集线器。在Cisco IOS 11.2前,达到此的唯一方法是启用路由协议在分支。使用ODR,然而,路由协议在辐射端不需要启用。使用ODR, Cisco IOS 11.2和指向集线器的仅静态默认路由在分支必要。

有多个出口点的分支

万一主链路发生故障,分支可能有对集线器的多个连接冗余或备份目的。单独的集线器为此冗余经常要求。在这种情况下, spoke有多个出口点。ODR在此网络也工作良好。

Spoke一定点到点,否则浮动静态默认路由不会运转。在一种多点配置中,没有办法检测下一跳的失败,正如在广播价质。

用单台集线器实现负载平衡或备份

要达到负载均衡,请定义在spoke的两静态默认路由与同一个距离,并且分支将执行在那两个路径之间的负载均衡。如果有两个路径对目的地, ODR在路由表将保留两个路由,并且请执行在集线器的负载均衡。

对于备份,比其他请定义有距离的两静态默认路由一个好。分支将使用主链路,并且,当主链路断开,浮动静态路由将工作。在中心路由器中,比其他请使用distance命令每个CDP邻居地址并且使一个距离更好。使用此配置, ODR获知的路由通过一条链路在其他将更喜欢。此配置是有用的在有快速主链路并且减慢的环境(低带宽)备份链路,并且负载均衡没有希望的地方。

注意: 今天,那里是在更喜欢在其他的一条链路的辐射端的没有其他方法在一个单台集线器情况,除了如上所述。如果使用IOS 12.0.5T或以上,集线器通过两条链路自动地发送默认路由,并且分支在其路由表里不能区分在两个路径之间和安装两个。更喜欢在其他的一个默认路由的唯一方法是使用有有更低管理距离的一个路径您要更喜欢在分支的静态默认路由。这自动地改写在spoke来通过ODR的默认路由。目前,想法提供分支瘤,能更喜欢在其他的一条链路,在考虑中。

图 2:Spoke用多个出口点和单台集线器

/image/gif/paws/13710/odr3.jpg

用多台集线器实现负载平衡或备份

当有多个集线器时,这些配置可能也用于负载均衡或备份。必须充分地网状连接所有集线器,以便,如果其中一条从spoke的链路失败,目的地可能通过第二台集线器仍然到达。请参阅ODR与本文的其他路由协议部分更多详细说明的。同样地,一旦多个集线器,如果IOS 12.0.5T或以后在使用,集线器发送ODR默认路由于spoke和spoke在路由表里安装两个。将来增强将允许发言更喜欢在其他的一台集线器。目前,这可以通过在辐射路由器和使用定义的静态默认路由执行在静态路由命令的管理距离更喜欢在其他的一台集线器。这不影响负载均衡情况。

图 3:Spoke用多个出口点和多个集线器

/image/gif/paws/13710/odr4.jpg

ODR与其他路由协议

最大的ODR的优点超过IP路由是中心路由器将了解IP前缀,无需启用在第3层的路由协议。ODR更新是CDP的一部分在Layer2的。

ODR 与 EIGRP

在真正的星型环境,给所有spoke传递所有路由信息是多余的。慢链接spoke浪费在路由更新的带宽和维护邻接关系。通过启用在spoke的增强的内部网关路由选择协议(EIGRP),路由更新被发送对spoke。在大型网络中,这些更新变为巨大,废CPU带宽,并且可能要求在分支路由器的更多的内存。

与EIGRP的一更加好的方法将应用过滤器在集线器。路由信息被控制,以便集线器只发送动态默认路由对spoke。这些过滤器帮助减少路由表的大小在辐射端的,但是,如果集线器失去邻居,将派出查询给所有其他邻居。因为集线器从邻居,不会得到回复这些查询是多余的。

最好的方法将排除EIGRP查询和邻接维护的开销使用ODR。通过调节ODR计时器,收敛时间可以增加。

今天,我们有扩展EIGRP好在一个星型网情况的一新特性在EIGRP。关于EIGRP残余部分功能的更多信息参考的高级IGRP残余部分路由

ODR 与 OSPF

开放最短路径优先(OSPF)提供星型网环境的几个选项,并且stub no-summary选项有最少开销。

当运行在大规模集中星型网络的OSPF您可以遇到问题。因为它是最普通的星型拓扑,在此部分的示例使用帧中继。

OSPF 点对点末节网络

在本例中, OSPF在点对点配置连接的100个spoke启用。首先,有很多浪费的IP地址,即使我们分支子网与/30网络掩码。其次,如果我们在一个区域中包括那些100个spoke,并且一分支拍动, Shortest Path First (SPF)算法将运行并且能变得CPU密集型。如果链路经常,拍动此情况是准确无误的对分支路由器。更多邻接飘荡能引起问题,就分支路由器而言。

在OSPF中,区域是残余部分而不是接口。如果有末端网络的100路由器,更多的内存是必要在spoke拿着大数据库。此问题可以通过分开一大末节区域解决成小范围。然而,一摆动在一末节区域中在spoke仍然触发SPF运行,因此此开销不可能治疗由进行一小末节区域没有摘要和没有外部。

另一个选项是包括每条链路到一个区域。使用此选项,中心路由器在区域将必须运行各个领域的一种分开的SPF算法和创建一个汇总链路状态公告(LSA)路由的。此选项能损害中心路由器的性能。

升级对一个更加好的平台不是永久解决方案;然而, ODR提供一解决方案。获知的路由通过ODR可以重新分配到OSPF通知关于这些路由的其他中心路由器。

OSPF 点对多点末节网络

在点到多点网络中, IP地址空间通过放置每分支保存在相同子网。并且,生成路由器LSA集线器的大小将被对分,因为只将形成所有点对点链路的一条残余部分链路。点到多点网络将强制全部子网包括到一个区域。在链路抖动的情况下,分支将运行SPF,可以CPU密集型。

Hello风暴

OSPF Hello数据包小,但是,如果有许多邻居,他们的大小能变得大。因为hello是组播,路由器进程数据包。OSPF集线器发送并且收到Hello数据包由20字节的IP报头, 24字节的OSPF报头, 20字节的Hello参数和每个邻居的4个字节组成被看到。从一台集线器的一OSPF Hello数据包在与100个邻居的一个点到多点网络能变为长464个的字节,并且被充斥对所有spoke每30秒。

表 1:100个邻居的OSPF Hello数据包

20位元组IP表头
24个字节OSPF报头
20个字节Hello参数
4个字节每个邻接路由器ID (RID)
....
....
....
....
....

因为额外信息没有从集线器发送到spoke,开销在ODR被解决。spoke发送5个字节IP前缀每子网到中心路由器。就Hello数据包的大小而论,比较在ODR (发送一连接的子网的信息)的分支的5个字节对68个OSPF字节(小的hello数据包大小包括从发送的IP报头发言到集线器)加上68个字节(从集线器发送的小的hello数据包到分支)在一个30秒间隔期间。并且,当ODR更新在Layer2时,出现OSPF hello在第3层发生。使用ODR,较少信息被派出,因此链路带宽可以用于重的数据。

ODR 与 RIPv2

路由信息协议版本2 (RIPv2)也是星型网环境的一理想选择。要设计RIPv2,请发送从集线器的默认路由到spoke。spoke通过RIP然后通告他们的连接的接口。可以使用RIPv2,当有在需要通告的spoke时的备用地址或,如果使用几供应商路由器或,如果情况真不是星型网。

需求电路上的 RIPv2

版本2有一些修改,但是不彻底更改协议。此部分讨论一些增强对需求电路的RIP。

今天互联网络朝主站点的方向拨号网络或备份移动提供对很大数量的远程站点的连接。这样连接类型可能在正常操作时通过很少或没有数据流。

定期RIP行为引起在这些电路的问题。RIP有问题低带宽,点对点接口。更新被发送与使用高带宽的大路由表的每30秒。在这种情况下,使用触发RIP是最佳的。

触发 RIP

触发RIP为交换与他们的邻居的所有路由信息的路由器设计。如果在路由上的变化发生,只有传播更改对邻居。接收路由器立即应用更改。

触发RIP更新被发送,只有当:

  • 一个要求路由更新接收。

  • 最新信息接收。

  • 目的地从电路更改下来巡回。

  • 路由器首先启动。

以下触发RIP的配置示例:

Spoke# configure terminal 
Enter configuration commands, one per line.  End with CNTL/Z. 
Spoke(config)# int s0.1 
Spoke(config-if)# ip rip triggered 
Spoke(config)# int s0.2 
Spoke(config-if)# ip rip triggered 
       
interface serial 0 
encapsulation frame-relay 
       
interface serial 0.1 point            /* Primary PVC */ 
ip address 10.x.x.x 255.255.255.0 
ip rip triggered 
frame-relay interface-dlci XX 
       
interface serial 0.2 point       /* Secondary PVC */ 
ip address 10.y.y.y 255.255.255.0 
ip rip triggered 
frame-relay interface-dlci XX 

router rip 
  network 10.0.0.0 
       

Spoke# show ip protocol 
Routing Protocol is "rip" 
  Sending updates every 30 seconds, next due in 23 seconds 
  Invalid after 180 seconds, hold down 180, flushed after 240 
  Outgoing update filter list for all interfaces is not set 
  Incoming update filter list for all interfaces is not set 
  Redistributing: rip 
  Default version control: send version 1, receive any version 
    Interface        Send  Recv    Triggered RIP    Key-chain 
    Ethernet0           1        1 2 
    Serial0.1             1        1 2               Yes 
    Serial0.2             1        1 2               Yes 
  Routing for Networks: 
    10.0.0.0 
  Routing Information Sources: 
    Gateway         Distance      Last Update 
  Distance: (default is 120) 

在连接对spoke的中心路由器的接口必须配置ip rip triggered命令

当比较RIPv2与ODR时, ODR是一更加好的选择,因为RIPv2在第3层工作,并且ODR在Layer2发生。当集线器发送RIPv2更新对超过1000个spoke时,必须复制在第3层的数据包每分支的。ODR什么都不从除了通常CDP更新的集线器每分钟发送在Layer2,根本不强化中央处理。发送在Layer2的连接的子网信息从分支比发送在第3层的RIPv2较不强化中央处理。

用 ODR 进行大型网络设计

ODR工作好在大规模网络比其他路由协议。最大的ODR的优点是路由协议在已连接串行链路不必须启用。目前,没有能的路由协议发送路由信息,无需启用他们在连接的接口。

在集线器上运行 EIGRP 时的 ODR

当运行EIGRP,请建立对集中星型网络的无源接口联系,以便不会发送在链路的多余的EIGRP问候信息。若可能,不放置网络的网络声明在星型网之间最好的,因为,如果链路断开, EIGRP不会派出多余的查询给核心邻居。总是请选择在星型网之间的假网络,因此那些链路在EIGRP域不会包括,因为您不会在配置里放置网络声明。

冗余和汇总

在单台集线器情况下,额外的设置没有要求。汇总特定, spoke的连接的子网并且漏他们到核心。查询的开销,然而,永远在那里。如果特定路由从其中一个spoke丢失,请派出查询给核心路由器的所有邻居。

一旦多个集线器,重要的是非常两集线器连接,并且EIGRP运行在集线器之间。若可能,此链路应该是一个唯一主网,以便不会干涉去spoke的其他链路。此配置是必要的,因为EIGRP在一个特定接口不可能启用,因此,即使我们做接口被动,通过EIGRP将通告。如果接口汇总,查询将被派出,如果一分支丢失。只要两集线器之间的链路不在主网里和spoke一样,配置应该适当地工作。

图 4:冗余和汇总:核心接收汇总路由

/image/gif/paws/13710/odr7.jpg

EIGRP优点是在接口级上能汇总,因此星型子网汇总路由将发送到核心,并且将发送具体的路由到另一台集线器。如果星型网之间的链路断开,通过第二台集线器到达目的地是可能的。

在集线器上运行 OSPF 时的 ODR

在此方案中, OSPF在连接spoke的链路不必须启用。在一个正常方案,如果OSPF在链路启用和一条特定链路经常拍动,它能引起几问题,包括SPF执行,路由器LSA重新生成,汇总LSA重新生成,等等。当运行ODR,请勿包括已连接串行链路在OSPF域。主要问题是获得spoke的LAN分段信息。此信息可以通过ODR得到。如果一条链路经常拍动,不会干涉路由协议在中心路由器。

冗余和汇总

所有特定链路可以在到核心避免前路由计算的漏汇总,如果其中一个分支的连接的接口断开。如果核心路由器信息汇总,它不可能检测。

图 5:冗余和汇总:核心路由器接收汇总路由

/image/gif/paws/13710/odr6.jpg

在本例中,为冗余目的彼此连接集线器是非常重要的。此连接在漏前也将汇总星型连接的子网到OSPF核心。

与将来增强的NSSA

最终将有将允许不仅汇总到核心的OSPF次末节区域(NSSA)在集线器间的功能,而且特定信息通过NSSA链路。运行NSSA优点是汇总路由可以发送到核心。然后,核心能发送流量到任一台集线器到达spoke的目的地。如果集线器和分支之间的链路断开,将有更加特定的类型7 LSA在到达目的地的两集线器通过其他集线器。

使用NSSA,以下配置示例:

N2507: Hub 1 

router odr 
  timers basic 8 24 0 1 
! 
router ospf 1 
  redistribute odr subnets 
  network 1.0.0.0 0.255.255.255 area 1 
  area 1 nssa 
       

N2504: Hub 2 

router odr
  timers basic 8 24 0 1 
! 
router ospf 1 
  redistribute odr subnets 
  network 1.0.0.0 0.255.255.255 area 1 
  area 1 nssa 

N2507# show ip route 
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP 
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP 
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default 
       U - per-user static route, o - ODR 
       
Gateway of last resort is not set 
       
C    1.0.0.0/8 is directly connected, Serial0 
C    2.0.0.0/8 is directly connected, Serial1 
     3.0.0.0/24 is subnetted, 1 subnets 
C       3.3.3.0 is directly connected, Ethernet0 
o    150.0.0.0/16 [160/1] via 3.3.3.2, 00:00:23, Ethernet0 
o    200.1.1.0/24 [160/1] via 3.3.3.2, 00:00:23, Ethernet0 
o    200.1.2.0/24 [160/1] via 3.3.3.2, 00:00:23, Ethernet0

N2504# show ip route 
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP 
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP 
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default 
       U - per-user static route, o - ODR 
       
Gateway of last resort is not set 
       
C    1.0.0.0/8 is directly connected, Serial0 
C    2.0.0.0/8 is directly connected, Serial1 
     3.0.0.0/24 is subnetted, 1 subnets 
C       3.3.4.0 is directly connected, TokenRing0 
C    5.0.0.0/8 is directly connected, Loopback0 
C    6.0.0.0/8 is directly connected, Loopback1 
O N2 150.0.0.0/16 [110/20] via 1.0.0.1, 00:12:06, Serial0 
O N2 200.1.1.0/24 [110/20] via 1.0.0.1, 00:12:06, Serial0 
O N2 200.1.2.0/24 [110/20] via 1.0.0.1, 00:12:06, Serial0 

与NSSA的汇总和未来增强

分配子网邻近块到spoke,以便那些子网可以适当地汇总到OSPF核心,如以下示例所显示。如果子网没有汇总,并且一连接的子网断开,则整个核心将检测它和重新计算路由。通过发送邻近块的汇总路由,如果星型子网摆动,核心不会检测它。

N2504# configure terminal 
Enter configuration commands, one per line.  End with CNTL/Z. 
N2504(config)# router ospf 1 
N2504(config-router)# summary-address 200.1.0.0 255.255.0.0 
       

N2504# show ip ospf database external 
       
       OSPF Router with ID (6.0.0.1) (Process ID 1) 
       
       
                Type-5 AS External Link States 
       
  LS age: 1111 
  Options: (No TOS-capability, DC) 
  LS Type: AS External Link 
  Link State ID: 200.1.0.0 (External Network Number ) 
  Advertising Router: 6.0.0.1 
  LS Seq Number: 80000001 
  Checksum: 0x2143 
  Length: 36 
  Network Mask: /16 
        Metric Type: 2 (Larger than any link state path) 
        TOS: 127 
        Metric: 16777215 
        Forward Address: 0.0.0.0 
        External Route Tag: 0

距离问题

在本例中,特定信息从两集线器接收。因为OSPF距离是110,并且ODR距离是160,信息将干涉ODR,当从另一集线器大致同样的子网接收。另一台集线器永远将更喜欢达到分支目的地,将导致不最理想的路由。要修正情况,请减小ODR距离对少于110用distance命令,因此ODR路由在OSPF路由永远将被偏好。如果ODR路由出故障, OSPF外部路由将安装到从数据库的路由表。

N2504(config)# router odr 
N2504(config-router)# distance 100 
N2504(config-router)# end 

N2504# show ip route 
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP 
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP 
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default 
       U - per-user static route, o - ODR 
       
Gateway of last resort is not set 
       
C    1.0.0.0/8 is directly connected, Serial0 
C    2.0.0.0/8 is directly connected, Serial1 
     3.0.0.0/24 is subnetted, 1 subnets 
C       3.3.4.0 is directly connected, TokenRing0 
C    5.0.0.0/8 is directly connected, Loopback0 
C    6.0.0.0/8 is directly connected, Loopback1 
o    150.0.0.0/16 [100/1] via 3.3.4.1, 00:00:39, TokenRing0 
o    200.1.1.0/24 [100/1] via 3.3.4.1, 00:00:39, TokenRing0 
o    200.1.2.0/24 [100/1] via 3.3.4.1, 00:00:39, TokenRing0 
O    200.1.0.0/16 is a summary, 00:04:38, Null0 

如果对分支的主集线器链路断开, N2路由仍然是在数据库,并且变得活跃的。

N2504# show ip ospf database nssa 
       
       OSPF Router with ID (6.0.0.1) (Process ID 1) 
       
       
                Type-7 AS External Link States (Area 1) 
       

  LS age: 7 
  Options: (No TOS-capability, Type 7/5 translation, DC) 
  LS Type: AS External Link 
  Link State ID: 150.0.0.0 (External Network Number ) 
  Advertising Router: 6.0.0.1 
  LS Seq Number: 80000002 
  Checksum: 0x965E 
  Length: 36 
  Network Mask: /16 
        Metric Type: 2 (Larger than any link state path) 
        TOS: 0 
        Metric: 20 
        Forward Address: 1.0.0.2 
        External Route Tag: 0 

使用对NSSA的增强,类型7更加特定的LSA在NSSA数据库。而不是汇总路由, NSSA数据库的输出将出现如下所示:

LS age: 868 
Options: (No TOS-capability, Type 7/5 translation, DC) 
LS Type: AS External Link 
Link State ID: 200.1.1.0 (External Network Number) 
Advertising Router: 3.3.3.1 
LS Seq Number: 80000001 
Checksum: 0xDFE0 
Length: 36 
Network Mask: /24 
        Metric Type: 2 (Larger than any link state path) 
        TOS: 0 
        Metric: 20 
        Forward Address: 1.0.0.1 
        External Route Tag: 0 
       
LS age: 9 
Options: (No TOS-capability, Type 7/5 translation, DC) 
LS Type: AS External Link 
Link State ID: 200.1.2.0 (External Network Number) 
Advertising Router: 3.3.3.1 
LS Seq Number: 80000002 
Checksum: 0xFDC3 
Length: 36 
Network Mask: /24 
        Metric Type: 2 (Larger than any link state path) 
        TOS: 0 
        Metric: 20 
        Forward Address: 1.0.0.2 
        External Route Tag: 0 

需求电路

需求电路是在集中星型网络能也使用的Cisco IOS 11.2功能。此功能是典型地有用的在拨号备用方案和在X.25或帧中继交换虚拟电路(SVC)环境。以下需求电路的配置示例:

router ospf 1 
network 1.1.1.0 0.0.0.255 area 1 
area 1 stub no-summary 

interface Serial0                   /* Link to the hub router  */ 
  ip address 1.1.1.1 255.255.255.0 
  ip ospf demand-circuit 
  clockrate 56000 

Spoke#show ip o int s0 
Serial0 is up, line protocol is up 
  Internet Address 1.1.1.1/24, Area 1 
  Process ID 1, Router ID 141.108.4.2, Network Type POINT_TO_POINT, Cost: 64 
  Configured as demand circuit. 
  Run as demand circuit. 
  DoNotAge LSA not allowed (Number of DCbitless LSA is 1). 
  Transmit Delay is 1 sec, State POINT_TO_POINT, 
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5 
    Hello due in 00:00:06 
  Neighbor Count is 1, Adjacent neighbor count is 1 
    Adjacent with neighbor 130.2.4.2 
  Suppress hello for 0 neighbor(s) 

使用在集中星型网络的需求电路特性,如果有任何变化在拓扑上,将带动电路并且形成新建的邻接。例如,如果有摆动在分支的一子网,需求电路将启动邻接并且充斥此信息。在未节区域环境,此信息将被充斥在末节区域中。ODR通过不泄漏此信息解决此问题对其他spoke。参考的OSPF需求电路特性欲知更多信息。

点对点网络中的 ODR

在接口描述符模块(IDB)限额的当前Cisco IOS 12.0状态如下:

路由器 限制
1000 300
2600 300
3600 800
4x00 300
5200 300
5300 700
5800 3000
7200 3000
RSP 1000

在IOS 12.0之前,集线器可能支持的最大的辐射点数是300由于IDB限额。如果网络要求超过300个spoke,则点对点配置不是理想选择。并且,单独的CDP信息包为每条链路生成。发送的CDP更新时间复杂性在点对点链路是N2。以上的表给我们另外平台的IDB限额。支持每个平台最大的辐射点数变化,但是创建每条链路的一个单独的CDP信息包的开销仍然是问题。所以,在一个大星型网情况,配置点到多点接口比点对点接口是一更加好的解决方案。

点对多点网络中的 ODR

在集线器支持多个spoke的点到多点网络中,有三个主要问题:

  • 集线器可以容易地支持超过300个spoke。例如, 10.10.0.0/22网络能支持与多点接口的1024-2个spoke。

  • 在多点环境,一CDP数据包为所有邻居在Layer2生成和复制。CDP更新的时间复杂性减少到n。

  • 在单点对多点配置中,您只能分配一子网到所有spoke。

ODR 与多供应商

一种常见的误解是ODR不会工作,如果使用多个供应商。只要网络是一个真的集中星型网络, ODR将工作。例如,如果有100个spoke,并且两spoke是从不同厂商的路由器,然后启用在连接对另外路由器的那些链路的一个路由协议和仍然运行在剩余的ODR 98个思科spoke是可能的。

图 6:与多个供应商的ODR

odr10.jpg

中心路由器连接对98个Cisco路由器通过ODR将接收子网更新并且从剩余的两不同路由器的接收路由协议更新。连接对另外路由器的链路必须在分开的点对点或点对多点子网。

未来增长问题

如果组织运行在100个spoke的ODR,他们可能最终要更改他们的从集中星型网络的拓扑。例如,他们可能决定升级一发言到发言20其他的一台集线器新建的spoke的一个更大的平台,进行。

图 7:未来的发展

/image/gif/paws/13710/odr9.jpg

照原样,运行在新的集线器的一个路由协议和仍然保持ODR设计是可能的。如果新的集线器支持20或更多新建的spoke, ODR在新的集线器能运行。新的集线器能得知那些新建的星型子网通过ODR和重新分配此信息到原始集线器通过另一个路由协议。

当ODR用两集线器时,开始此情况是类似的。没有更改协议的开销。基本上,只要路由器是残余部分, ODR能运行。

性能

当运行ODR,几几设置能为快速收敛调节和改善性能。

为达到更快收敛而进行的计时器调整

在一个大ODR环境,请调整快速收敛的ODR计时器并且增加CDP更新的计时器从集线器的到发言最小化集线器的CPU性能。

中心路由器

CDP更新计时器应该默认为60秒减小从集线器的流量总量到spoke。应该增加维持时间到最大数量(255秒)。因为中心路由器必须维护许多CDP邻接表,并且,万一一些个邻居断开,请勿删除从内存的CDP条目255秒(允许的最大保持时间)。此配置将提供灵活性到中心路由器,因为,如果邻居在四分钟内恢复, CDP邻接不会必须被再创。可以使用旧有条目,并且抑制计时器可以更新。

以下一个IP配置模板的示例中央路由器的:

cdp holdtime 255 
       
      router odr 
        timers basic 8 24 0 1  /* odr timer's are update, invalid, hold down, flush 
       
        router eigrp 1 
        network 10.0.0.0 
        redistribute odr 
        default-metric 1 1 1 1 1

有三永久虚电路(PVC)从每个远程站点(仓库、区域和维修站)。两PVC去两个独立的中央路由器。第三个PVC去PayPoint路由器。要求对PayPoint路由的PVC使用为PayPoint网络注定的流量。另外两PVC发挥其他流量的主要和备用的功能。凭这些需求,请参阅下面配置模板关于每个远程路由器。

调整ODR计时器例如无效抑制充足快速收敛的是非常重要的。即使CDP一次不派出IP前缀router ODR配置, ODR更新计时器应该匹配邻接CDP更新计时器,因为收敛计时器可能只设置,如果有更新计时器。此计时器跟CDP计时器不同,并且可能只用于快速收敛。

分支路由器

因为spoke发送在CDP数据包的ODR更新,应该保持CDP更新的计时器非常小为快速收敛。在一个真的星型的环境,因为有的一些个条目发言保留在其CDP表,没有抑制计时的限制CDP邻居的。推荐最大保持时间255秒,以便,如果集线器PVC断开并且在四分钟内回来,新的CDP邻接不是需要的,因为可以使用旧有条目。

以下一个IP配置模板的示例远程站点的:

cdp timer 8 
cdp holdtime 255 
       
interface serial 0 
encapsulation frame-relay 
cdp enable 
            
interface serial 0.1 point                      /* Primary PVC */ 
ip address 10.x.x.x 255.255.255.0 
frame-relay interface-dlci XX 
      
interface serial 0.2 point                      /* Secondary PVC */ 
ip address 10.y.y.y 255.255.255.0 
frame-relay interface-dlci XX 
      
       
interface bri 0 
interface BRI0 
description Backup ISDN for frame-relay 
ip address 10.c.d.e 255.255.255.0 
encapsulation PPP 
dialer idle-timeout 240 
dialer wait-for-carrier-time 60 
dialer map IP 10.x.x.x name ROUTER2 broadcast xxxxxxxxx 
ppp authentication chap 
dialer-group 1 
isdn spid1 xxxxxxx 
isdn spid2 xxxxxxx 
      
access-list 101 permit ip 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255 
dialer-list 1 LIST 101 
       
       
/* following are the static routes that need to be configured on the remote routers 
       
ip route 0.0.0.0 0.0.0.0 10.x.x.x 
ip route 0.0.0.0 0.0.0.0 10.y.y.y 
ip route 0.0.0.0 0.0.0.0 bri 0 100 
ip classless 

静态默认路由没有要求,如果使用IOS 12.0.5T或以上,因为中心路由器发送自动默认路由往所有spoke。

ODR 路由的过滤与汇总

在他们漏到核心前, ODR路由可以被过滤。请使用distribute-list in命令。spoke的所有连接的子网,当漏到核心时,应该汇总。如果汇总不是可能的,则多余的路由可以被过滤在中心路由器。在多个集线器网络中, spoke可能通告是链路到另一台集线器的连接的接口。

在这种情况下,必须应用distribute-list命令,以便集线器不放那些路由到路由表。当ODR重新分配到集线器时,该信息没有泄漏到核心。

Telco 定时器调整

调整电信计时器增加spoke的收敛时间是重要的。如果从集线器端的PVC断开, spoke应该能迅速检测它换成第二台集线器。

CPU 性能

ODR进程不采取批次CPU利用率。ODR为大约有三到四百分比CPU利用率的1000个邻居测试了。ODR的主动计时器设置在集线器的帮助与快速收敛。如果使用默认设置, CPU利用率保持在零到一百分比。

用积极的ODR和CDP计时器,下面的输出显示没有高CPU利用率。此测验用在Cisco 7206的一个150兆赫处理器执行了。

Hub# show proc cpu 
CPU utilization for five seconds: 4%/0%; one minute: 3%; five minutes: 3% 
PID  Runtime(ms)  Invoked  uSecs    5Sec   1Min   5Min TTY Process 
   . 
   . 
  18    11588036  15783316   734   0.73%  1.74%  1.95%   0 CDP Protocol 
   . 
   . 
  48    3864      5736        673  0.00%  0.00%  0.00%   0 ODR Router 
     

Hub# show proc cpu 
CPU utilization for five seconds: 3%/0%; one minute: 3%; five minutes: 3% 
PID  Runtime(ms)  Invoked  uSecs    5Sec   1Min   5Min TTY Process 
    . 
    . 
   18    11588484  15783850    734   2.21%  1.83%  1.96%   0 CDP Protocol 
    . 
    . 
   48        3864     5736     673   0.00%  0.00%  0.00%   0 ODR Router 

Hub# show proc cpu 
CPU utilization for five seconds: 2%/0%; one minute: 3%; five minutes: 3% 
PID  Runtime(ms)  Invoked  uSecs    5Sec   1Min   5Min TTY Process 
  . 
  . 
 18    11588676  15784090    734   1.31%  1.79%  1.95%   0 CDP Protocol 
  . 
  . 
 48        3864      5736    673   0.00%  0.00%  0.00%   0 ODR Router 
       

Hub# show proc cpu 
CPU utilization for five seconds: 1%/0%; one minute: 3%; five minutes: 3% 
PID  Runtime(ms)  Invoked  uSecs    5Sec   1Min   5Min TTY Process 
  . 
  . 
 18    11588824  15784283    734   0.65%  1.76%  1.94%   0 CDP Protocol 
  . 
  . 
 48        3864      5737    673   0.00%  0.00%  0.00%   0 ODR Router 

Hub# show proc cpu 
CPU utilization for five seconds: 3%/0%; one minute: 3%; five minutes: 3% 
PID  Runtime(ms)  Invoked  uSecs    5Sec   1Min   5Min TTY Process 
  . 
  . 
 18    11589004  15784473    734   1.96%  1.85%  1.95%   0 CDP Protocol 
  . 
  . 
 48        3864      5737    673   0.00%  0.00%  0.00%   0 ODR Router 
       

Hub# show proc cpu 
CPU utilization for five seconds: 3%/0%; one minute: 3%; five minutes: 3% 
PID  Runtime(ms)  Invoked  uSecs    5Sec   1Min   5Min TTY Process 
  . 
  . 
 18    11589188  15784661    734   1.63%  1.83%  1.94%   0 CDP Protocol 
  . 
  . 
 48        3864      5737    673   0.00%  0.00%  0.00%   0 ODR Router

增强

ODR版本在Cisco IOS 12.0.5T之前的有一些个限制。以下增强列表在Cisco IOS 12.0.5T的和高:

  • 在CSCdy48736之前,二级子网作广告作为在CDP更新的/32。这在12.2.13T修复和以后。

  • CDP集线器当前传播默认路由对spoke,那么那里是在spoke的没有需要添加静态默认路由。收敛时间极大增加。当下一跳断开时,分支通过ODR迅速检测它并且聚合。此功能在12.0.5T被添加通过bug CSCdk91586。

  • 如果星型网之间的链路是Ip unnumbered,集线器发送的默认路由不可以被看到在spoke。此bug, CSCdx66917,在IOS 12.2.14修复, 12.2.14T和以后。

  • 要增加/请减小在spoke的ODR距离,因此他们能更喜欢在其他的一台集线器,通过CSCdr35460被跟踪的建议做。代码已经测试了和为客户很快是可用的。


相关信息


Document ID: 13710