IP : 增强的内部网关路由选择协议 (EIGRP)

EIGRP“not on common subnet”消息意味着什么?

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

本文解释思科IOSï ¿  ½路由器为什么能体验a不在普通的子网错误消息,当路由器配置与增强的内部网关路由选择协议(EIGRP)时。

EIGRP使用组播Hello信息包为了通信对其他EIGRP邻居。如果EIGRP收到从IP地址被发出在子网在EIGRP接收接口没有配置的Hello数据包, EIGRP生成此错误消息:

timestamp: IP-EIGRP: Neighbor neighbor_IP_address not on common subnet for interface

先决条件

要求

本文一般来说要求IP路由协议和EIGRP路由协议基本的了解。要了解有关 IP 路由协议和 EIGRP 的更多信息,请参考下列文档:

使用的组件

本文档中的信息根据在思科2500系列路由器的Cisco IOS软件版本12.2(10b)。

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 有关本文档所用命令的详细信息,请使用命令查找工具仅限注册用户)。

网络图

思科建议您配置一个网段的所有路由器用在相同子网的主要IP地址。此示例显示一个普通的EIGRP配置:

/image/gif/paws/13674/15a1.gif

配置

本文档使用以下配置:

R1
hostname R1
!
interface Ethernet0
ip address 10.1.1.1 255.255.255.0
!
router eigrp 1
network 10.0.0.0
!
end

R2
hostname R2
!
interface Ethernet0
ip address 10.1.1.2 255.255.255.0
!
router eigrp 1
network 10.0.0.0
!
end

验证

使用本部分可确认配置能否正常运行。

命令输出解释程序仅限注册用户)(OIT) 支持某些 show 命令。使用 OIT 可查看对 show 命令输出的分析。

发出show ip eigrp neighbor命令为了验证两路由器互相看到。

R1#show ip eigrp neighbor

IP-EIGRP neighbors for process 1

H   Address                 Interface   Hold Uptime   SRTT   RTO  Q  Seq

                                        (sec)         (ms)       Cnt Num

0   10.1.1.2                Et0           12 00:00:16    0  3000  0  23
R2#show ip eigrp neighbor

IP-EIGRP neighbors for process 1

H   Address                 Interface   Hold Uptime   SRTT   RTO  Q  Seq

                                        (sec)         (ms)       Cnt Num

0   10.1.1.1                Et0           14 00:01:19   12   200  0  11

故障排除

使用本部分可排除配置故障。

不再相邻

如果一切适当地配置,您看到EIGRP邻居关系表。更改R2的配置。安置R2 Ethernet0接口在一不同的子网。

R2#configure terminal

R2(config)#interface ethernet0

R2(config-if)#ip address 10.1.2.2 255.255.255.0

R2(config-if)#end

当前查看R2配置:

hostname R2
!
interface Ethernet0
ip address 10.1.2.2 255.255.255.0
!
router eigrp 1
network 10.0.0.0
!
end

现在您开始对接收错误消息在EIGRP Hello信息包的接收。在这种情况下,消息发生近似每15秒,在R1和R2 :

R1

3w0d: IP-EIGRP: Neighbor 10.1.2.2 not on common subnet for Ethernet0 

01:05:01: IP-EIGRP: Neighbor 10.1.2.2 not on common subnet for Ethernet0 (10.1.)
01:05:15: IP-EIGRP: Neighbor 10.1.2.2 not on common subnet for Ethernet0 (10.1.)
01:05:30: IP-EIGRP: Neighbor 10.1.2.2 not on common subnet for Ethernet0 (10.1.)
01:05:44: IP-EIGRP: Neighbor 10.1.2.2 not on common subnet for Ethernet0 (10.1.)
R2

3w0d: IP-EIGRP: Neighbor 10.1.1.1 not on common subnet for Ethernet0 

00:48:40: IP-EIGRP: Neighbor 10.1.1.1 not on common subnet for Ethernet0 (10.1.)
00:48:54: IP-EIGRP: Neighbor 10.1.1.1 not on common subnet for Ethernet0 (10.1.)
00:49:08: IP-EIGRP: Neighbor 10.1.1.1 not on common subnet for Ethernet0 (10.1.)
00:49:22: IP-EIGRP: Neighbor 10.1.1.1 not on common subnet for Ethernet0 (10.1.)

尽管错误消息, EIGRP正确地运作与其他R1或R2邻居。updated show ip eigrp neighbor命令输出显示错误消息指示在R1和R2之间的一个严重问题。路由器不再是邻居和不再交换路由信息。

R1

R1#show ip eigrp neighbor
IP-EIGRP neighbors for process 1
R2

R2#show ip eigrp neighbor
IP-EIGRP neighbors for process 1

备用 IP 地址

您能也看到在使用备用IP地址的网络的此问题,如果网络没有适当地配置。添加对R2的一备用地址:

R2

R2#configure terminal

R2(config)#interface ethernet0

R2(config-if)#ip address 10.1.1.2 255.255.255.0 secondary

R2(config-if)#end

R2配置当前如下所示:

hostname R2
!
interface Ethernet0
ip address 10.1.2.2 255.255.255.0


ip address 10.1.1.2 255.255.255.0 secondary
!
router eigrp 1
network 10.0.0.0
!
end

由于R2当前认可10.1.1.0/24作为接口Ethernet0的一有效的子网,您不再看到在R2的普通的子网错误消息。R2显示R1作为EIGRP邻居,并且R2收到并且接受R1 Hello数据包。

Router2#show ip eigrp neighbor
IP-EIGRP neighbors for process 1
H   Address                 Interface   Hold Uptime   SRTT   RTO  Q  Seq Type
                                        (sec)         (ms)       Cnt Num
0   10.1.1.1                Et0           12 00:00:35    1  5000  1  0

然而, R1不显示R2作为邻居,并且R1不接受从R2的路由更新。这意味着R2连续重置其与R1的邻接。在R1,您继续发现不在普通的子网错误消息,并且您看不到在EIGRP邻居列表里列出的R2。

R1#show ip eigrp neighbor

IP-EIGRP neighbors for process

01:20:54: IP-EIGRP: Neighbor 10.1.2.2 not on common subnet for Ethernet0 (10.1.)
01:21:08: IP-EIGRP: Neighbor 10.1.2.2 not on common subnet for Ethernet0 (10.1.)
01:21:22: IP-EIGRP: Neighbor 10.1.2.2 not on common subnet for Ethernet0 (10.1.)
01:21:36: IP-EIGRP: Neighbor 10.1.2.2 not on common subnet for Ethernet0 (10.1.)

因为EIGRP更新总是使用流出接口的主IP地址作为源地址,这发生。更改在R1的主要地址匹配R2一级子网,是10.1.2.1/24在本例中。

您能配置与两个独立子网的一些网络在同一物理分段。在这种情况下,一子网的EIGRP路由器可能不能用另一子网的EIGRP路由器连通。如果运行Cisco IOS软件版本11.3, 12.0或者以后,您能禁用不在与使用的普通的子网错误消息no eigrp log-neighbor-warnings命令

注意: Cisco一般不建议使用no eigrp log-neighbor-warnings命令。命令禁用在EIGRP进程使用的所有接口的普通的子网错误消息。以谨慎使用命令。

配置no eigrp log-neighbor-warnings命令在EIGRP路由器配置模式。

Router#configure terminal

Router(config)#router eigrp 1

Router(config-router)#no eigrp	log-neighbor-warnings

错误消息的一般原因

EIGRP使用组播Hello信息包为了通信对其他EIGRP邻居。EIGRP生成不在普通的子网错误消息,当收到从IP地址发出的EIGRP Hello信息包在其接收接口没有配置的子网时。

这些是此错误消息的一般原因:

  • 接口的误配置或交换机端口或者布线问题。

  • 首选/备用的IP地址不匹配在邻接接口的。

  • 交换机/集线器漏组播信息包到其他端口。

  • 如果使用LAN交换机, VLAN可能一起加入路由器。

  • 另一个路由器使用通告在相同子网/VLAN的EIGRP作为此路由器和用一个不正确AS编号不正确配置。

为了排除故障此问题,请检查这些项目:

  • 验证电缆正确地连接。

  • 复核不正确的配置的IP地址的接口配置在本地和相邻路由器。

  • 验证接口的主要地址在相同子网作为邻接路由器的主要地址。

  • 如果EIGRP邻居连接通过LAN集线器加入,请使用单独的集线器为了破坏每逻辑LAN分段的广播域或者请勿配置eigrp log-neighbor-warnings排除错误。

  • 如果有介入的交换机,请检查交换机配置确保共享同一广播域的不同的LAN分段没有配置在同样VLAN。


相关信息


Document ID: 13674