长距离以太网 (LRE) 和数字用户线 (xDSL) : 非对称数字用户线 (ADSL)

配置 Cisco 1700/2600/3600 ADSL WIC 以使用单个 IP 地址、DHCP、PPPoA 以及 PPP-PAP

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 22 日) | 反馈


目录


简介

Cisco 1700、2600 和 3600 系列路由器支持非对称数字用户线 (ADSL) WAN 接口卡 (WIC)。所有三平台相似地配置。然而,有差异在硬件里和在为每一个要求的Cisco IOS软件版本。在本文中Cisco 1700/2600/3600称“Cisco ADSL WIC”。

本文显示Cisco ADSL WIC连接对Cisco 6130 DSL接入复用器。它在思科 6400 统一访问集中器 (UAC) 上终止。Cisco ADSL WIC配置作为有PPP over ATM的(PPPoA)一个动态主机配置协议(DHCP)服务器。

互联网服务提供商给用户单个IP地址, 172.18.0.1, Internet连接的。然而,用户有PCs小型网络并且要访问所有设备的互联网访问。

解决方案是对configure network地址转换(NAT)在Cisco ADSL WIC。NAT为IP地址简单化和保存设计。它启用使用未注册的IP地址连接到互联网的私有IP互联网络。NAT起作用该的路由器usuallyconnects两网络。它转换在内部网络的私有(在这种情况下10.0.0.0网络)地址对法律(在这种情况下172.18.0.1)地址,在数据包转发对另一网络前。作为分开此功能, NAT只配置通告一个地址(172.18.0.1)整个网络的。这样可以将整个内部网络有效地隐藏在该地址后面,使其更加安全。

NAT有在远程访问环境实现的对偶函数安全和地址保存。10.0.0.1的IP地址在Cisco ADSL WIC的以太网接口手工配置。Cisco ADSL WIC配置作为DHCP服务器。它租用IP地址到本地LAN设备附加对其以太网。

此配置显示为以太网和ATM接口配置的NAT。Ethernet0接口有10.0.0.1的IP地址与255.0.0.0子网掩码的。NAT为里面配置。这意味着接口连接对网络内部sthat对NAT转换被服从。ATM接口"Dialer0"有172.18.0.1的IP地址和255.255.0.0子网掩码。NAT为外部配置。这意味着接口连接对外部网络,例如互联网。

先决条件

要求

在您尝试此配置前,请保证您符合这些要求。要支持在Cisco2600/3600的ADSL WIC, thishardware要求:

  • 2600:机箱WIC槽, NM-2W

  • 3600:NM-1FE1R2W, NM-1FE2W, NM-2FE2W, NM-2W

    注意: Cisco3600,这些的t donot支持ADSL WIC :NM-1E1R2W, NM-1E2W, NM-2E2W。

要支持ADSL WIC,这些Cisco IOS软件版本要求:

  • Cisco IOS软件版本12.1(5)yb (仅加强版本)在Cisco2600/3600上。

  • 在Cisco 1700上的的Cisco IOS软件版本IOS 12.1(3)XJ或更高版本(仅加强版本或ADSL功能集)。ADSL功能集由镜像名称中的"y7"确定;例如, c1700-sy7-mz.121-3.XJ.bin。

    注意: 当您为Cisco 1700下载镜像时,确定您选择1700镜像名称。不要下载1720或1750镜像。功能不会支持ADSL WIC。

使用的组件

本文档中的信息基于以下软件和硬件版本。

  • Cisco 6400 UAC-NRP IOS软件版本12.1(3)DC1

  • Cisco 6400 UAC-NSP IOS软件版本12.1(3)DB

  • Cisco 6130 DSLAM-NI2 IOS软件版本12.1(5)DA

本文档中的信息都是基于特定实验室环境中的设备创建的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您是在真实网络上操作,请确保您在使用任何命令前已经了解其潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 要查找本文档所用命令的其他信息,请使用命令查找工具仅限注册用户)。

网络图

本文档使用此图所示的网络设置。

/image/gif/paws/12958/wicadsl_dhcp_1ip.gif

配置

本文档使用以下配置。

Cisco ADSL WIC
! 
version 12.1
service timestamps debug datetime msec 
service timestamps datetime msec 
! 
hostname R1 
! 
ip subnet-zero 
! 
ip dhcp excluded-address 10.0.0.1

!--- the DHCP pool  does not lease this address; 
!--- it is  used by interface FastEthernet0

!
ip dhcp pool poolname

network 10.0.0.0 255.0.0.0
 default-router 10.0.0.1
 
!--- default gateway  is assigned to local devices

! 
interface FastEthernet0
 ip address 10.0.0.1 255.0.0.0
 no ip directed-broadcast
 no ip mroute-cache
! 
interface ATM0 
 no ip address 
 no ip directed-broadcast 
 no ip mroute-cache 
 no atm ilmi-keepalive
 pvc 1/150 
  encapsulation aal5mux ppp dialer 
  dialer pool-member 1 
 !
 hold-queue 224 in 
! 
interface Dialer0 
  ip address 172.18.0.1 255.255.0.0    
  ip nat outside     
  no ip directed-broadcast 
  encapsulation ppp 
  dialer pool 1 
  dialer-group 2 
  ppp pap sent-username username password password

! 
ip nat inside source list 1  interface Dialer0 overload 
ip classless 
ip route 0.0.0.0 0.0.0.0 Dialer0 
no ip http server 
! 
access-list 1 permit 10.0.0.0 0.255.255.255 
dialer-list 2 protocol ip permit
! 

end

验证

当前没有可用于此配置的验证过程。

故障排除

目前没有针对此配置的故障排除信息。

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 12958