长距离以太网 (LRE) 和数字用户线 (xDSL) : 非对称数字用户线 (ADSL)

配置 Cisco 1700/2600/3600 ADSL WIC 与 RBE 模式的 Cisco 6400,以使用 RFC1483 桥接

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 11 月 12 日) | 反馈


目录


简介

思科 1700、2600 及 3600 系列路由器支持非对称数字用户线路 (ADSL) WAN 接口卡 (WIC)。三个平台都采用相同的方式配置。然而,有差异在硬件方面和在为每一个要求的思科IOSï ¿  ½软件版本。在本文中Cisco 1700/2600/3600称“Cisco ADSL WIC”。

此配置示例展示了连接至思科 6130 数字用户线路接入复用器 (DSLAM) 的 Cisco ADSL WIC。它在思科 6400 统一访问集中器 (UAC) 上终止。

Cisco ADSL WIC 配置了 RFC 1483 桥接。思科 6400 配置了路由桥接封装 (RBE)。

思科 6400 节点路由处理器 (NRP) 中的 ATM RBE 功能能够通过来自末节桥接 LAN 的桥接 RFC 1483 以太网流量为 IP 安排路由。

在路由网桥模式下配置的 ATM 接口上接收的桥接 IP 数据包通过 IP 报头安排路由。该接口会利用常用于进行 DSL 访问的末节 LAN 拓扑的特性。它通过集成的路由与桥接 (IRB) 提供更完善的性能和灵活性。

先决条件

要求

在您尝试进行此配置之前,请确保您满足以下先决条件。为支持 ADSL WIC,至少需要以下思科 IOS 软件版本:

  • Cisco IOS软件版本12.1(5)yb (仅加强版本)在Cisco2600/3600上。

  • 在Cisco 1700上的的Cisco IOS软件版本IOS 12.1(3)XJ或更高版本(仅加强版本或ADSL功能集)。ADSL功能集由镜像名称中的"y7"确定;例如, c1700-sy7-mz.121-3.XJ.bin。

    当您为Cisco 1700下载镜像时,确定您选择1700镜像名称。不要下载1720或1750镜像。功能不支持 ADSL WIC。

为在思科 2600/3600 上支持 ADSL WIC,需要以下硬件版本:

  • 2600:机箱 WIC 插槽、NM-2W。

  • 3600:NM-1FE1R2W、NM-1FE2W、NM-2FE2W、NM-2W。

    注意: 对于思科 3600,NM-1E1R2W、NM-1E2W 和 NM-2E2W 不支持 ADSL WIC。

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • Cisco 6400 UAC-NRP IOS软件版本12.1(3)DC1

  • Cisco 6400 UAC-NSP IOS软件版本12.1(3)DB

  • Cisco 6130 DSLAM-NI2 IOS软件版本12.1(5)DA

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 要查找本文档所用命令的其他信息,请使用命令查找工具仅限注册用户)。

网络图

本文档使用此图中所示的网络设置:

/image/gif/paws/12957/wicadsl_6400rbe_1.gif

配置

要从互联网远程登录到(或 ping)Cisco ADSL WIC,请在 ATM 接口上配置一个 IP 地址和一个 MAC 地址。对于IP地址来说 ,在ATM接口上配置与您在以太网接口配置相同的IP地址。对于MAC地址,请发出show interface eth0指令。记下MAC地址并且在ATM接口上配置同样的MAC地址。

当 Cisco ADSL WIC 桥接以太网接口和 ATM 接口上的 IP 时,这两个接口具有相同的 IP 地址。

注意在配置中的no ip routing指令。

Cisco ADSL WIC (R1)
Current configuration: 
! 
version 12.1 
service timestamps debug datetime msec 
service timestamps log datetime msec
! 
hostname R1 
! 
ip subnet-zero 
no ip routing 
! 
interface FastEthernet0 
 ip address 10.0.0.1 255.0.0.0 

!--- When the router is in bridge mode, the FastEthernet 
!--- and ATM interfaces can have the same IP address.

 no ip directed-broadcast
 bridge-group 1 
! 
interface ATM0 
 mac-address 0030.96f8.45bd

!--- This is the MAC address of interface FastEthernet0.
!--- Use the IOS command show interface fastethernet 0
!--- to get the MAC address. 

 ip address 10.0.0.1 255.0.0.0 
 no ip directed-broadcast 
 no ip mroute-cache 
 no atm ilmi-keepalive 
 pvc 4/100 
  encapsulation aal5snap 
 ! 
 bundle-enable 
 bridge-group 1 
 hold-queue 224 in 
!
ip classless 
no ip http server 
! 
bridge 1 protocol ieee 
! 
end

Cisco 6400 NRP
Current configuration:
! 
version 12.0 
no service pad 
service timestamps debug datetime msec
service timestamps log datetime msec 
! 
hostname NRP
! 
redundancy 
 main-cpu 
  no auto-sync standard 
 no secondary console enable 
ip subnet-zero 
! 
interface Loopback1 
 ip address 10.0.0.2 255.0.0.0  
 no ip directed-broadcast 
! 
interface ATM0/0/0 
 no ip address 
 no ip directed-broadcast 
 no ip mroute-cache 
 no atm ilmi-keepalive
! 
interface ATM0/0/0.4 point-to-point 
 ip unnumbered Loopback1
 no ip directed-broadcast
 atm route-bridged ip 
 pvc 4/100
  encapsulation aal5snap 
! 
! 
interface Ethernet0/0/1 
 no ip address 
 no ip directed-broadcast 
! 
interface Ethernet0/0/0
 no ip directed-broadcast 
! 
interface FastEthernet0/0/0 
 no ip address 
 no ip directed-broadcast 
 full-duplex 
! 
ip classless 
ip route 10.0.0.1 255.255.255.255 ATM0/0/0.4 
! 
end 

验证

当前没有可用于此配置的验证过程。

故障排除

目前没有针对此配置的故障排除信息。


相关信息


Document ID: 12957