交换机 : Cisco 6130 IP DSL 交换机

配置 Cisco 827 路由器,以使用 IRB、NAT、DHCP,并通过 RFC1483 桥接与 Cisco 6400 实现 IRB (aal5snap)

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 22 日) | 反馈


目录


简介

此示例配置演示一个连接到 Cisco 6130 数字用户线接入复用器 (DSLAM) 的 Cisco 827 数字用户线 (DSL) 路由器,该路由器在 Cisco 6400 通用接入集中器 (UAC) 上终止。

Cisco 827配置如下:

  • 使用集成路由和桥接(IRB)

  • 使用封装

  • 使用网络地址转换(NAT)

  • 作为将租用IP地址给其本地以太网客户端的动态主机配置协议(DHCP)服务器

Cisco 6400配置与IRB。

开始使用前

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

先决条件

本文档没有任何特定的前提条件。

使用的组件

本文档中的信息基于以下软件和硬件版本。

  • Cisco 827-4V客户端前置设备(CPE) IOS�软件版本12.1(1)XB

  • Cisco 6400 UAC节点路由处理器(NRP) IOS软件版本12.0(7)DC

  • Cisco 6400 UAC-Node交换机处理器(NSP) IOS软件版本12.0(4)DB

  • Cisco 6130 DSLAM-NI2 IOS软件版本12.1(1)DA

本文档中的信息都是基于特定实验室环境中的设备创建的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您是在真实网络上操作,请确保您在使用任何命令前已经了解其潜在影响。

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 要查找本文档所用命令的其他信息,请使用命令查找工具仅限注册用户)。

网络图

本文档使用下图所示的网络设置。

/image/gif/paws/12899/827rfc_dhcp_6400irb.gif

配置

本文档使用如下所示的配置。

Cisco 827
Current configuration: 
! 
version 12.0 
service timestamps debug datetime msec 
service timestamps log datetime msec 
!
hostname R1 
! 
ip subnet-zero 
! 
ip dhcp excluded-address 10.0.0.1
!
ip dhcp pool 
<pool name>
 
   network 10.0.0.0 255.0.0.0 
   default-router 10.0.0.1
! 
bridge irb 
! 
interface Ethernet0 
 ip address 10.0.0.1 255.0.0.0 
 no ip directed-broadcast 
 ip nat inside
 no ip mroute-cache 
! 
interface ATM0 
 no ip address 
 no ip directed-broadcast 
 no ip mroute-cache 
 no atm ilmi-keepalive 
 pvc 1/150 
  encapsulation aal5snap 
 !
 bundle-enable 
 bridge-group 1 
 hold-queue 224 in
! 
interface BVI1 
 ip address 172.16.0.1 255.255.0.0 
 no ip directed-broadcast 
 ip nat outside
! 
ip nat inside source list 1 interface BVI1 overload 
ip classless 
ip route 0.0.0.0 0.0.0.0 172.16.0.2 
no ip http server 
! 
access-list 1 permit 10.0.0.0 0.255.255.255
bridge 1 protocol ieee 
 bridge 1 route ip
! 
voice-port 1 
 timing hookflash-in 0 
!
voice-port 2 
 timing hookflash-in 0
!
voice-port 3
 timing hookflash-in 0 
! 
voice-port 4 
 timing hookflash-in 0 
! 
end

Cisco接入6400 NRP
Current configuration:
! 
version 12.0
service timestamps debug datetime msec 
service timestamps log datetime msec 
no service password-encryption 
! 
hostname NRP
! 
ip subnet-zero 
! 
bridge irb 
! 
interface ATM0/0/0 
 no ip address 
 no ip directed-broadcast 
 no ip route-cache 
 no ip mroute-cache 
 no atm ilmi-keepalive 
!
interface ATM0/0/0.300 point-to-point 
 no ip directed-broadcast
 no ip route-cache 
 pvc 1/150 
  encapsulation aal5snap 
 ! 
 bridge-group 1 
! 
interface Ethernet0/0/1 
 no ip address
 no ip directed-broadcast 
! 
interface Ethernet0/0/0 
 no ip directed-broadcast 
! 
interface FastEthernet0/0/0 
 no ip address 
 no ip directed-broadcast 
 full-duplex 
! 
interface BVI1 
 ip address 172.16.0.2 255.255.0.0 
 no ip directed-broadcast 
! 
no ip http server 
!
bridge 1 protocol ieee 
 bridge 1 route ip 
! 
end

为了确保,无线客户端能在他们中通信,请配置bridge-group 1命令在无线接口。

bridge-group 1命令在无线接口时发出,这些命令自动地发出:

  • bridge-group 1 subscriber-loop-control

  • bridge-group 1 spanning-disabled

  • 网桥组1块未知来源

请勿禁用这些命令。这些命令要求为了无线通信能发生。如果这些命令禁用,无线客户端可能不能彼此通信。

并且,如果bridge-group命令没有为VLAN配置,无线客户端不能从在其中一的动态主机配置协议(DHCP)服务器获得IP地址VLAN。

验证

当前没有可用于此配置的验证过程。

故障排除

目前没有针对此配置的故障排除信息。

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 12899