长距离以太网 (LRE) 和数字用户线 (xDSL) : 非对称数字用户线 (ADSL)

路由桥接封装基线体系结构

2016 年 10 月 27 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

使用路由桥接封装(RBE)功能Cisco 6400通用接入集中器(UAC)的本文描述端到端不对称数字用户线路(ADSL)体系结构。RBE开发寻址桥接问题,包括广播风暴和安全的已知RFC1483。除了事实在ATM完全运行, RBE功能相等地作用与半桥接。通过使用xDSL用户,独特的特性另外的可扩展性、性能和安全可以实现。

假定

使用ADSL论坛参考体系结构型号,基准体系结构设计。体系结构由网络接入提供商(NAP)包括不同的提供的业务和不同的方案用户数据流如何转发对网络服务提供商(NSP)。在此体系结构方面, RBE是Cisco 6400使用的假设的封装方法。本文内容根据现有部署,以及一些内部测试在体系结构被执行。对于增强功能和修改,参考思科IOSï ¿  ½软件新版本的版本注释。目前, Cisco 6400支持RBE, Cisco 7200及Cisco 7500平台。本文对关于Cisco 6400的讨论被限制。

技术简介

从网络的角度, ATM连接看起来象路由连接。数据流接收作为RFC1483数据包,但是他们是RFC1483以太网或IEEE 802.3帧。而不是桥接以太网或IEEE 802.3帧,如一旦桥接正常的RFC1483,路由器路由在第三层报头。除一些粗略检查外,网桥报头忽略。这在下一部分详细解释。

操作说明

/image/gif/paws/12917/routed_bridged_encap_1.gif

从可操作角度看,路由器运行,好象路由桥接口连接对以太网LAN。操作是下述用两种方式:为客户驻地注定的数据包起源于客户驻地的和数据包。

对于起源于客户驻地的数据包,以太网报头被跳过,并且目的IP地址被检查。如果目的IP地址在路由缓存,数据包快速交换到出站接口。如果目的IP地址不在路由缓存,数据包为进程交换排队。在进程交换模式,数据包必须路由的出站接口通过查找找到在路由表。在出站接口识别后,数据包通过该接口路由。这发生,不用网桥组或网桥组虚拟接口(BVI)的需求。

对于为客户驻地注定的数据包,数据包的目的IP地址首先被检查。目的地接口从IP路由表确定。其次,路由器在以太网报头检查地址解析服务(ARP)表关联与该接口目标MAC地址安置。如果没有找到什么都,路由器生成目的IP地址的一个ARP请求。ARP请求转发对仅目的地接口。与桥接对比,这是, ARP请求在网桥组中发送对所有接口。

对于一个方案使用未编号的接口(其中您可以找到相同子网的两个用户),路由桥接口使用代理ARP。例如, 192.168.1.2 (主机A)要通信与192.168.1.3 (主机B)。然而,主机A在相同子网作为主机B。

主机A必须通过派出ARP学习主机B的MAC地址广播对主机B。当在聚合设备的路由桥接口接收广播的此,将派出与192.168.1.1 MAC地址的代理ARP答复,主机A。它在其以太网报头将取得该MAC地址,安置它,并且发送数据包。当路由器收到数据包时,在正确接口丢弃报头并且查看目的IP地址,然后路由它。

RBE 优点

RBE开发打算解决RFC1483桥接体系结构面对的某些问题。RBE保留RFC1483桥接体系结构主要优点,当排除大多其缺点时。

  • 在客户端前置设备(CPE)的最小配置。

    因为在高水平协议,支持的人员不再要求很大数量的卡车卷和不再需要大量地投资服务提供商认为此重要。在网桥模式的CPE作为一个非常简单设备。最小的故障排除是包含的在CPE,因为自以太网进来的一切通过直通对广域网端。

  • 容易从纯桥接体系结构移植到RBE。没有更改要求在用户端。

  • 避免伪装的IP劫持和的ARP在典型的纯桥接体系结构方面面对的挑战。通过使用点对点连接, RBE也防止广播风暴。安全是主要缺点在纯桥接体系结构方面。

  • 与纯桥接体系结构比较, RBE提供优越性能由于路由选择实施在聚合设备。并且,因为没有网桥组限制, RBE更加可扩展。

  • 使用Cisco服务选择网关(SSG),支持第3层Web选择。

实施注意事项

要考虑的某些关键点在实现此体系结构前是相同的按照RFC1483桥接基线架构纸张所述。

推荐RBE,当:

  • 方案是相同的正如在现有桥接体系结构。

  • NAP要只执行CPE的最小管理。在CPE在用户的位置后,部署简单CPE的概念不要求最小或配置。

  • NAP不要安装和保养主机的主机客户端在桥接的CPE后。这些安装和维护任务增加部署费用和维护,包括帮助人员提供有客户端运作客户端软件和操作系统的知识的。

  • NAP要部署一个可扩展和被巩固的桥接网络使用在RFC1483桥接模式能只运行)的CPE (并且要提供服务选择功能。

下讨论如何解释RBE体系结构适应和缩放比例到不同的商业模式。

网络架构

/image/gif/paws/12917/routed_bridged_encap_2.gif

RBE网络架构类似于RFC1483桥接体系结构。在该体系结构上指定,聚合设备能在NAP或在NSP。如果使用端到端永久虚拟电路(PVC)体系结构, NSP终止用户并且配置RBE在聚合设备。如果NAP喜欢提供批发服务加上服务选择,可能选择终止那些用户和从一个本地动态主机配置协议(DHCP)服务器获得IP地址。一旦批发服务, NAP可能选择从NSP获得IP地址。这些方案在本文的IP Management部分详细报道。

RBE 体系结构设计注意事项

RBE排除主要安全风险涉及与RFC1483桥接体系结构。另外,因为子接口对待路由接口, RBE提供更加好的性能和更加可扩展。

此部分说明必须在设计RBE体系结构前考虑的某些关键点。对于用户端,设计原则在RFC1483桥接体系结构方面依然是同一样。

在RBE,分配单个虚拟电路路由、两套路由器或者无类域间路由选择(CIDR)子网。因此,可信的环境减少到在两套路由器的IP地址或CIDR块代表的仅单个客户驻地。ISP也控制地址分配到用户。这由配置在子接口的一子网完成对该用户。所以,如果用户不正确配置设备用一个IP地址已分配地址范围的外部(可能造成ARP数据包流至路由器),路由器生成“错误的电缆”错误并且拒绝输入不正确的IP到MAC地址映射到其ARP表。

使用仅点到点ATM子接口, RBE可以部署。它在多点子接口不可能部署。即使用户端桥接,您不需要定义网桥组或BVI接口,因为子接口对待路由接口。

ATM点对点子接口可以编号的接口或未编号的到一些其他接口。

根据定义,编号的接口是有一个特定IP地址分配到它与一个已修复子网掩码的接口。例如:

Interface atm0/0/0.132 point-to-point
ip address 192.168.1.1 255.255.255.252

如此示例所显示,当RBE配置有编号的接口,应该有每个用户的一个独立子网。应该为192.168.1.2配置在用户端的主机。只有一台主机在用户端。如果需求是支持超过一台主机,选择的子网掩码应该适应更多主机。

编号的接口给对用户在CPE后连接主机的数量的NAP控制。如解释以上,此缺乏控制是一个主要问题在RFC1483桥接体系结构方面。

然而,此方法消耗许多IP地址。您将需要分配每个用户一子网,使用一个IP地址ATM子接口和未使用的广播地址和所有的零地址。因此,有在CPE后的一台主机,您至少需要定义255.255.255.252子网掩码。就IP地址而论缺乏,除非NAP/NSP使用专用地址空间和执行的网络地址转换(NAT)到达外界,这可能不是可行选项。

为了保存IP地址,替代方案是使用未编号的接口。根据定义,未编号的接口是通过使用ip unnumbered命令,使用另一个接口的IP地址的接口。例如:

!
interface loopback 0
ip address 192.168.1.1 255.255.255.0
!
interface atm0/0/0.132 point-to-point
ip unnumbered loopback 0
!
interface atm0/0/0.133 point-to-point
ip unnumbered loopback 0

如以上示例所显示, IP地址和子网只应用对回环接口。所有ATM子接口是未编号的对该回环接口。在此方案中,在ATM子接口终止的所有用户(未编号的对loopback0)会是在相同子网作为那loopback0。这暗示用户会是在相同子网,但是通过不同的路由接口进来。在这种情况下,它变为路由器的一问题能识别哪个用户是在哪ATM子接口后。对于Cisco IOS, 192.168.1.0 (在IP管理图表中)通过interface loopback 0和它直接地连接从未发送通过其他接口被注定的到任何在该子网的主机地址流量。为了解决此问题,您需要明确配置静态主机路由。例如:

ip route 192.168.1.2 255.255.255.255 atm0/0/0.132
ip route 192.168.1.3 255.255.255.255 atm0/0/0.133

在此示例上指定,当路由器需要做出路由决策并且需要转发为192.168.1.2注定的流量,它将选择ATM 0/0/0.132作为流出接口,等等。没有指定那些静态主机路由,路由器将选择流出接口作为loopback0并且丢弃数据包。

即使未编号的接口将保存IP地址,要求配置在节点路由处理器的静态主机路由其它任务每个用户的。注意,如果用户有,例如,在CPE后的14台主机,没有要求有每台主机的静态主机路由。汇总路由可以为ATM子接口定义。

至今,此说明假设,在CPE后的主机为静态IP地址将配置。此假定不是真的在真实生活设计。在实用的世界, NAP要执行最小配置和维护CPE和主机的附加对它。使用DHCP服务器,为了达到那,主机应该动态地得到他们的地址。

为了动态地获得他们的IP地址,必须配置主机从DHCP服务器获得IP地址。当主机启动时,派出DHCP请求。这些请求然后被传递对适当的DHCP服务器,分配IP地址到从一个的主机在其以前定义范围。

为了转发从主机的初始DHCP请求到适当的DHCP服务器,您应该实施ip helper-address命令到接收广播的接口。在广播接收后, Cisco IOS查看ip helper-address的配置为该接口并且转发在单播信息包的那些请求对IP地址在ip helper-address指定的适当的DHCP服务器。在DHCP服务器回复用IP地址,它发送对接口的答复在最初转发请求的路由器后。这用于,因为出站接口发送DHCP服务器响应到最初请求服务的主机。路由器自动地也安装此地址的一个主机路由。

如果RBE在子接口启用并且是IEEE 802.3桥接协议封装单元(PDU),以太网封装在ATM网桥封装以后被检查。如果它是IP/ARP数据包,被处理类似其他IP/ARP数据包。IP数据包是快速交换的。如果它失败,为进程交换排队。

RBE的性能是一大成功。在转发决策可以做前,今天标准的桥接代码有要求数据包的两个独立的分类内在的问题。分类定义作为进程检查(在上行)并且正在修改(在下行)转发信息的信息包报头,相对昂贵。Layer2查找是需要的确定数据包是否需要路由或桥接。然后,在第3层,查找是需要的识别数据包应该路由的位置。此分类在上行以及下行方向完成,有在性能的一影响。

对于RBE,由配置预先确定数据包将路由在上行方向。所以,通过桥接转发路径是不必要的,是必要的一旦标准的桥接。

RBE 的关键点

CPE

CPE配置在标准的桥接依然是同一样。对CPE的更改没有要求部署RBE。

IP 管理

routed_bridged_encap_3.gif

当部署RBE的时编号的接口, IP地址分配对在桥接的CPE后的主机通过DHCP服务器通常被处理。如前面提到, DHCP服务器能位于在NAP或NSP。对于任一个案件,应该用ip helper-address命令配置被编号的ATM子接口。如果DHCP服务器查找在NSP, NAP聚合设备必须有到达的路由该服务器。NAP将使用其自己的DHCP服务器,并且IP地址范围是的唯一的方案,当要提供服务选择功能对用户时和那些用户是LAN附加对NAP。

如果NAP要使用NSP的IP地址空间,应该分配其中一个每子网的IP地址到ATM子接口。并且,应该有在NAP和NSP之间的某相互协议,以便NAP配置正确地址。当NSP的DHCP服务器分配IP地址时,此协议应该是到位保证服务器提供正确默认网关信息给主机。NAP能或者然后汇总所有那些地址的静态路由分配到用户,或者能选择运行路由协议以NSP通告那些路由。在多种情况下, NAP和NSP将喜欢不使用路由协议。提供静态路由是理想的选择。

这是在部署的RBE NRP要求的基本配置与编号的接口:

!
interface ATM0/0/0.132 point-to-point
ip address 192.168.1.1 255.255.255.0
ip helper-address 192.168.3.1
no ip directed-broadcast
atm route-bridged ip
pvc 1/32
encapsulation aal5snap
!
interface ATM0/0/0.133 point-to-point
ip address 192.168.2.1 255.255.255.0
ip helper-address 192.168.3.1
no ip directed-broadcast
atm route-bridged ip
pvc 1/33
encapsulation aal5snap

使用未编号的接口是保存IP地址的最佳方法。如前所述,当未编号的接口与DHCP一起使用时,主机路由动态地安装。这可能是最好的方法到部署RBE。DHCP服务器可能然后查找在NAP或NSP,至于编号的接口的。

这是在部署的RBE NRP要求的基本配置与未编号的接口:

interface Loopback0
ip address 192.168.1.1 255.255.255.0
no ip directed-broadcast
!
interface ATM0/0/0.132 point-to-point
ip unnumbered Loopback0
no ip directed-broadcast
ATM route-bridged ip
pvc 1/32
encapsulation aal5snap
!
interface ATM0/0/0.133 point-to-point
ip unnumbered Loopback0
no ip directed-broadcast
ATM route-bridged ip
pvc 1/33
encapsulation aal5snap

如何达到服务目的

到目前为止,本文讨论了基本访问技术使用RBE作为封装方法。然而,使用此体系结构, NAP/NSP能也提供多种服务和的NAP能转发用户数据流到NSP的不同的选项。这些概念在以下部分解释。

提供互联网访问

在此方案中, NSP的主要功能将提供高速互联网访问对于终端用户。由于NSP提供最终服务, IP地址管理变为NSP的责任。它能分配公共IP地址到其使用DHCP服务器的终端用户,或者能选择提供专用IP地址给用户然后执行NAT到达外界。

批发服务

如果NAP要提供批发服务到其他ISP,能如此执行。在此方案中, NAP通常不喜欢处理所有用户的IP地址另外NSPs的。NAP做某个安排以ISP提供IP地址给那些用户。这可以由转发DHCP请求的NAP达到来自DHCP服务器的用户在NSPs。NAP必须配置其与其中一个的ATM子接口从该范围的IP地址,并且需要通告那些路由到NSP。路由通告能是以任一的形式静态路由或若干路由协议在NAP和NSP之间。静态路由是NAP的更可取的方法,以及NSP。

公司接入

公司接入通常要求虚拟专用网络(VPN)服务。这意味着公司不会提供任何IP地址给NAP,并且不允许NAP通告在NAP的IP核心的公司IP地址空间,因为可能安全突破口导致。公司通常喜欢应用他们自己的IP地址对他们的客户端,或者他们通过获取的一些允许含义例如多协议标签交换/虚拟专用网(MPLS/VPN)或第2层隧道协议。

对提供安全的共同访问的另一方法是NAP提供初始IP地址给那些用户的地方。所以,用户变得连接LAN的对NAP。在用户有初始IP地址后,他们可以发起通道到公司通过L2TP在主机的客户端软件运行。反过来,公司将验证此用户并且提供从其IP地址空间的一个IP地址。L2TP VPN适配器使用此IP地址。这样,用户安排选项对连接到他们的互联网连接的ISP或通过一获取的L2TP通道访问获得访问对他们的公司。然而,这要求公司提供隧道目的地IP地址给用户,应该是可路由的通过NAP的IP核心。

服务选择功能

使用思科SSG的功能, NAP能提供多种服务选择功能。SSG提供提供的服务选择两个方法:通过(叫作PTA-MD)的Layer2和第3层Web选择。使用RBE,可以使用仅第3层Web选择方法。这要求用户是连接LAN的对NAP;即NAP提供初始IP地址给对Cisco服务选择控制板(SSD)的用户和提供访问。

一旦RBE体系结构,思科SSG的Web选择方法是占的好办法用户数据流。

结论

RBE提供更加好的性能和比标准的桥接可扩展。它也解决在标准的桥接面对的所有安全问题。RBE消除标准的桥接广播风暴问题。RBE为NAP提供要避免客户端主机软件维护,桥接相关的问题,并且想要部署费用的一个坚固的体系结构。使用RBE,所有这是可能的,当曾经现有桥接体系结构时。


相关信息


Document ID: 12917