路由器 : 思科 800 系列路由器

Cisco 827 路由器配置常见问题

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 22 日) | 反馈


问题


简介

本文讨论关于Cisco 827路由器配置的多数常见问题。

Cisco 827-4V前面板

827_4v_front.gif

Cisco 827-4V背板

827_4v_back.gif

Cisco 827前面板

827_front.gif

Cisco 827背板

827_back.gif

Q. 如何配置RFC1483桥接的Cisco 827 ?

!
no ip routing           

!--- Disable IP routing.
 
!
interface Ethernet0 
 no ip address 
 no ip directed-broadcast 
 bridge-group 1       
 
!--- Specify the bridge-group number the interface belongs to.

! 
interface ATM0 
 no ip address 
 no ip directed-broadcast 
 no atm ilmi-keepalive 
 pvc 1/35               
 
!--- VPI/VCI assigned to you by your provider.

 ! 
  encapsulation aal5snap
 ! 
 bridge-group 1         
 
!--- Specify the bridge-group number the interface belongs to.

! 
bridge 1 protocol ieee 
! 

Q. 如何配置桥接与集成路由和桥接(IRB)的RFC1483的Cisco 827 ?

!
bridge irb              

!--- Enable IRB.

!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 no ip directed-broadcast
!
interface ATM0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 bundle-enable
!
interface ATM0.1 point-to-point
 no ip directed-broadcast
 pvc 1/35               
 
!--- VPI/VCI assigned to you by your provider.

 !
  encapsulation aal5snap
 !
 bridge-group 1         
 
!--- Specify the bridge-group number the interface belongs to.

 !
interface BVI1          

!--- A routed interface from the WAN bridge-group to the
!--- nonbridged LAN interface.

!
 ip address 192.168.2.1 255.255.255.0
 no ip directed-broadcast
!
ip route 0.0.0.0 0.0.0.0 192.168.2.254  

!--- Configure the default gateway.

!
bridge 1 protocol ieee
 bridge 1 route ip      
 
!--- Enable IP routing to and from bridge-group 1.

!

Q. 当我的供应商为我配置可用的地址时,我如何配置Cisco 827,实现具有IRB和端口地址转换(PAT) 功能的RFC1483 桥接?

!
bridge irb              

!--- Enable IRB.

!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 no ip directed-broadcast
 ip nat inside          
 
!--- Establish the interface as the inside interface.

!
interface ATM0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 bundle-enable
!
interface ATM0.1 point-to-point
 no ip directed-broadcast
 pvc 1/35               
 
!--- VPI/VCI assigned to you by your provider.

 !
  encapsulation aal5snap
 !
 bridge-group 1         
 
!--- Specify bridge-group number the interface belongs to.

!
interface BVI1          

!--- A routed interface from the WAN bridge-group
!--- to the nonbridged LAN interface.

!
 ip address 192.168.2.1 255.255.255.0
 no ip directed-broadcast
 ip nat outside         
 
!--- Establish the interface as the outside interface.

 !
!
ip nat inside source list 1 interface BVI1 overload     

!--- Enable dynamic translation of addresses permitted by the
!--- access-list to the address specified in the BVI interface.

!
ip route 0.0.0.0 0.0.0.0 192.168.2.254  

!--- Configure the default gateway.

!
access-list 1 permit 192.168.1.0 0.0.0.255      

!--- Define a standard access-list permitting addresses that
!--- need translation.

!
bridge 1 protocol ieee
 bridge 1 route ip      
 
!--- Enable IP routing to and from bridge-group 1.

!

Q. 当我的供应商为我配置一组可用的地址时,我如何配置Cisco 827,实现具有IRB和网络地址转换(NAT) 功能的RFC1483 桥接?

!
bridge irb              

!--- Enable IRB.

!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 no ip directed-broadcast
 ip nat inside          
 
!--- Establish the interface as the inside interface.

!
interface ATM0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 bundle-enable
!
interface ATM0.1 point-to-point
 no ip directed-broadcast
 pvc 1/35               
 
!--- VPI/VCI assigned to you by your provider.

 !
  encapsulation aal5snap
 !
 bridge-group 1         
 
!--- Specify bridge-group number the interface belongs to.
 
!
interface BVI1          

!--- A routed interface from the WAN bridge-group to the
!--- nonbridged LAN interface.

!
 ip address 192.168.2.1 255.255.255.0
 no ip directed-broadcast
 ip nat outside         
 
!--- Establish the interface as the outside interface.

!
ip nat pool POOL-A 192.168.2.2 192.168.2.10 netmask 255.255.255.0

!--- Create a pool of global IP addresses for NAT.

!
ip nat inside source list 1 pool POOL-A overload

!--- Enable dynamic translation of addresses permitted by the
!--- access-list to one of the addresses specified in the pool.

!
ip route 0.0.0.0 0.0.0.0 192.168.2.254  

!--- Configure the default gateway.

!
access-list 1 permit 192.168.1.0 0.0.0.255      

!--- Define a standard access-list permitting addresses that
!--- need translation.

!
bridge 1 protocol ieee
 bridge 1 route ip      
 
!--- Enable IP routing to and from bridge-group 1.

!

Q. 如何配置RFC1483路由的Cisco 827 ?

!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 no ip directed-broadcast 
!
interface ATM0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 bundle-enable
!
interface ATM0.1 point-to-point
 ip address 192.168.2.1 255.255.255.0
 pvc 1/35               
 
!--- VPI/VCI assigned to you by your provider.

 !
  protocol ip 192.168.2.2 broadcast     
  
!--- Set the protocol broadcast for the IP address.
 
  !
  encapsulation aal5snap
 !
!
ip route 0.0.0.0 0.0.0.0 192.168.2.2    

!--- Configure the default gateway.

!

Q. 当我的供应商为我配置可用的地址时,我如何配置Cisco 827,实现具有PAT功能的RFC1483路由?

!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 no ip directed-broadcast
 ip nat inside          
 
!--- Establish the interface as the inside interface.

!
interface ATM0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 bundle-enable
!
interface ATM0.1 point-to-point
 ip address 192.168.2.1 255.255.255.0
 ip nat outside         
 
!--- Establish the interface as the outside interface.

 !
 pvc 1/35               
 
!--- VPI/VCI assigned to you by your provider.

 !
  protocol ip 192.168.2.2 broadcast     
  
!--- Set the protocol broadcast for the IP address.

  !
  encapsulation aal5snap
 !
!
ip nat inside source list 1 interface ATM0.1 overload   

!--- Enable the dynamic translation of addresses permitted by the
!--- access-list to the address specified in the ATM interface.

!
ip route 0.0.0.0 0.0.0.0 192.168.2.2    

!--- Configure the default gateway.

!
access-list 1 permit 192.168.1.0 0.0.0.255      

!--- Define a standard access-list permitting addresses that
!--- need translation.

!

Q. 当我的供应商为我配置一组可用的地址时,我如何配置Cisco 827,实现具有NAT功能的RFC1483路由?

!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 no ip directed-broadcast
 ip nat inside          
 
!--- Establish the interface as the inside interface.

!
interface ATM0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 bundle-enable
!
interface ATM0.1 point-to-point
 ip address 192.168.2.1 255.255.255.0
 ip nat outside         
 
!--- Establish the interface as the outside interface. 

 !
 pvc 1/35               
 
!--- VPI/VCI assigned to you by your provider.

  protocol ip 192.168.2.2 broadcast     
  
!--- Set the protocol broadcast for the IP address.

  !
  encapsulation aal5snap
 !
!
ip nat pool POOL-A 192.168.2.2 192.168.2.10 netmask 255.255.255.0

!--- Create a pool of global IP addresses for NAT.

!
ip nat inside source list 1 pool POOL-A overload

!--- Enable dynamic translation of addresses permitted by
!--- the access-list to one of the addresses specified in the pool.

!
ip route 0.0.0.0 0.0.0.0 192.168.2.2    

!--- Configure the default gateway.

!
access-list 1 permit 192.168.1.0 0.0.0.255      

!--- Define a standard access-list permitting addresses that
!--- need translation.

!

Q. 如何配置PPP over ATM的(PPPoA) Cisco 827与互联网协议控制协议(IPCP) ?

!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 no ip directed-broadcast 
!
interface ATM0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 bundle-enable
!
interface ATM0.1 point-to-point
 no ip directed-broadcast
 pvc 1/35               
 
!--- VPI/VCI assigned to you by your provider.

 !
  encapsulation aal5mux ppp dialer      
  
!--- Specify the encapsulation type for the PVC to be
  !--- aal5mux (PPP) and point back to the dialer interface.

  !
  dialer pool-member 1  
  
!--- Specify a dialer pool-member.

 !
!
interface Dialer1
 ip address negotiated  
 
!--- Configure a negotiated IP address.

 !
 no ip directed-broadcast
 encapsulation ppp
 dialer pool 1          
 
!--- Specify which dialer pool number you are using.

!
ip route 0.0.0.0 0.0.0.0 Dialer1        

!--- Configure the default gateway.

!

Q. 如何配置Cisco 827,实现Easy IP (Phase I),同时支持PAT和PPP/IPCP?

!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 no ip directed-broadcast
 ip nat inside          
 
!--- Establish the interface as the inside interface.

!
interface ATM0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 bundle-enable
!
interface ATM0.1 point-to-point
 no ip directed-broadcast
 pvc 1/35               
 
!--- VPI/VCI assigned to you by your provider.

 !
  encapsulation aal5mux ppp dialer      
  
!--- Specify the encapsulation type for the PVC to be
  !--- aal5mux (PPP) and point back to the dialer interface.

  !
  dialer pool-member 1  
  
!--- Specify a dialer pool-member.

 !
!
interface Dialer1
 ip address negotiated  
 
!--- Configure a negotiated IP address.

 !
 no ip directed-broadcast
 ip nat outside         
 
!--- Establish the interface as the outside interface.

 !
 encapsulation ppp
 dialer pool 1          
 
!--- Specify which dialer pool number you are using.

!
ip nat inside source list 1 interface Dialer1 overload  

!--- Enable dynamic translation of addresses permitted by the
!--- access-list to the address specified in the Dialer interface.

!
ip route 0.0.0.0 0.0.0.0 Dialer1        

!--- Configure the default gateway.

!
!
access-list 1 permit 192.168.1.0 0.0.0.255      

!--- Define a standard access-list permitting addresses that
!--- need translation.

!

Q. 我该如何为Easy IP (第2阶段)将Cisco 827配置为DHCP服务器呢?

!
ip dhcp pool POOL-DHCP
 network 192.168.1.0 255.255.255.0    
 
!--- Specify a range of IP addresses that can be assigned to
!--- the DHCP clients.

!
 domain-name cisco.com        
 
!--- Configure the domain name.

!
 dns-server 192.168.3.1       
 
!--- Configure the DNS server.

!
 default-router 192.168.1.1
 
!--- Designate the router as the default router and specify
!--- an IP address.

!
!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 no ip directed-broadcast
!
interface ATM0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 bundle-enable
!
interface ATM0.1 point-to-point
 no ip directed-broadcast
 pvc 1/35               
 
!--- VPI/VCI assigned to you by your provider.

 !
  encapsulation aal5mux ppp dialer      
  
!--- Specify the encapsulation type for the PVC to be
!--- aal5mux (PPP) and point back to the dialer interface.

  !
  dialer pool-member 1  ### specify a dialer pool-member
 !
!
interface Dialer1
 ip address negotiated  
 
!--- Configure a negotiated IP address.

 !
 no ip directed-broadcast
 encapsulation ppp
 dialer pool 1          

 !--- Specify which dialer pool number you are using.

 !
!
ip route 0.0.0.0 0.0.0.0 Dialer1        

!--- Configure the default gateway.

!

Q. 我该如何为Easy IP (第2阶段)将Cisco 827配置为DHCP中继呢?

!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 ip helper-address 192.168.4.1  
 
!--- Forward default UDP broadcasts including 
 !--- IP configuration requests to the DHCP server.

 !
 no ip directed-broadcast
!
interface ATM0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 bundle-enable
!
interface ATM0.1 point-to-point
 no ip directed-broadcast
 pvc 1/35               
 
!--- VPI/VCI assigned to you by your provider.

 !
  encapsulation aal5mux ppp dialer      
  
!--- Specify the encapsulation type for the PVC to be
  !--- aal5mux (PPP) and point back to the dialer interface.

  !
  dialer pool-member 1  
 
 !--- Specify a dialer pool-member.
 
 !
!
interface Dialer1
 ip address negotiated  
 
!--- Configure a negotiated IP address.

 !
 no ip directed-broadcast
 encapsulation ppp
 dialer pool 1          
 
!--- Specify which dialer pool number you are using.

 !
!
ip route 0.0.0.0 0.0.0.0 Dialer1        

!--- Configure the default gateway.

!

Q. 如何配置Cisco 827是与PAT的DHCP客户端?

!
bridge irb
!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 no ip directed-broadcast
 ip nat inside          
 
!--- Establish the interface as the inside interface.

!
interface ATM0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 bundle-enable
!
interface ATM0.1 point-to-point
 no ip directed-broadcast
 pvc 1/35               
 
!--- VPI/VCI assigned to you by your provider.

 !
  encapsulation aal5snap
 !
 bridge-group 1         
 
!--- Specify bridge-group number the interface belongs to.

!
interface BVI1
 ip address dhcp client-id Ethernet0    
 
!--- Use the MAC address of the Ethernet interface as 
 !--- the client ID when the DHCP request is sent.

 !
 no ip directed-broadcast
 ip nat outside         
 
!--- Establish the interface as the outside interface.

 !
!
ip nat inside source list 1 interface BVI1 overload     

!--- Enable the dynamic translation of addresses permitted by
!--- the access-list to the address specified in the BVI interface.

!
ip route 0.0.0.0 0.0.0.0 BVI1   

!--- Configure the default gateway.

!
!
access-list 1 permit 192.168.1.0 0.0.0.255      

!--- Define a standard access-list permitting 
!--- addresses that need translation.

!
bridge 1 protocol ieee
 bridge 1 route ip      
 
!--- Enable IP routing to and from bridge-group 1.

!

Q. 如何配置PPP over Ethernet的(PPPoE) Cisco 827 ?

A. 请参考RFC1483桥接的配置。

Q. 能否配置Cisco 827作为PPPoE客户端?

A. 是,但是Cisco IOS�软件版本12.1(3)XG或以上要求。请参阅配置Cisco 827路由器作为有NAT的一PPPoE客户端

Q. 如何配置基本VoIP的Cisco 827-4V ?

!
dial-peer voice 1 pots
 destination-pattern 1001	
 
!--- Define the telephone number associated with the port.

 !
 port 1				
 
!--- Specify the port number.

 !
!
dial-peer voice 10 voip
 destination-pattern 2...	
 
!--- Define the destination telephone number.

 !
 session target ipv4:192.168.2.8	
 
!--- Specify a destination IP address.

 !
 codec g711ulaw			
 
!--- Specify a codec if you are not 
!--- using the default codec of g.729.

!

Q. 如何配置语音的服务质量(QoS) ?

A. Cisco IOS提供优先级队列的单个PVC环境(使用CBWFQ)为语音和分段和交叉:

!
class-map VOICE			

!--- Configure a class for voice.

!
 match access-group 101	
 
!--- Associate the class with the access-list.

 !
!
policy-map POLICY		

!--- Configure a policy map.

!
 class VOICE			
 
!--- Specify the class for queuing.

!
  priority 480		
  
!--- Specify strict priority for voice traffic.

 !
!
interface ATM0
 mtu 300		
 
!--- Decrease MTU of ATM interface so that large 
!--- IP data packets get fragmented.

 !
 ip address 192.168.2.1 255.255.255.0
 no ip directed-broadcast
 no atm ilmi-keepalive
 pvc 1/35 		
 
!--- VPI/VCI assigned to you by your provider.

 !
  service-policy out POLICY	
  
!--- Associate policy map to PVC.

  !
  vbr-rt 640 640 10		
  
!--- Specify the service class.

  !
  encapsulation aal5snap
 !
 bundle-enable
!
dial-peer voice 1 pots
 destination-pattern 1001	
 
!--- Define the telephone number associated with the port.

 !
 port 1				
 
!--- Specify the port number.

 !
!
dial-peer voice 10 voip  
 destination-pattern 2... 	
 
!--- Define the destination telephone number.

 !
 session target ipv4:192.168.2.8	
 
!--- Specify a destination IP address.

 !
 ip precedence 5		
 
!--- Configure IP precedence 5 for voice packets.

 !
! 
access-list 101 permit ip any any precedence critical

!--- Configure access-list to match voice packets.

! 

语音和数据在不同的子网的多种PVC环境:

!
interface ATM0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 bundle-enable
!
interface ATM0.1 point-to-point
 ip address 192.168.2.1 255.255.255.0
 no ip directed-broadcast
 pvc 1/35			
 
!--- Voice PVC.

 !
  protocol ip 192.168.2.2 broadcast	
  
!--- Set the protocol broadcast for the IP address.

  !
  vbr-rt 424 424 5		
  
!--- Specify the service class.

  !
  encapsulation aal5snap
 !
!
interface ATM0.2 point-to-point
 ip address 192.168.3.1 255.255.255.0
 no ip directed-broadcast
 pvc 1/36			
 
!--- Data PVC.

 !
  protocol ip 192.168.3.2 broadcast	
  
!--- Set the protocol broadcast for the IP address.

  !
  encapsulation aal5snap
 !
!
dial-peer voice 1 pots
 destination-pattern 1001	
 
!--- Define the telephone number associated with the port.

 !
 port 1				
 
!--- Specify the port number.

 !
!
dial-peer voice 10 voip 
 destination-pattern 2...	

 !--- Define the destination telephone number.

 !
 session target ipv4:192.168.2.8	
 
!--- Specify a destination IP address.

 !
!

语音和数据在与虚拟电路捆绑的相同子网的多种PVC环境:

!
interface ATM0
 ip address 192.168.2.1 255.255.255.0
 no ip directed-broadcast
 no atm ilmi-keepalive
 bundle-enable
 bundle TEST 			
 
!--- Specify a bundle name.

 !
  protocol ip 192.168.2.2 broadcast
  encapsulation aal5snap
  pvc-bundle data 1/36 		
  
!--- Create a PVC for the data bundle.

  !
   precedence other		
   
!--- Set the IP precedence level other to the data bundle.

   !
  pvc-bundle voice 1/35 	
  
!--- Create a PVC for the voice bundle.

  !
   vbr-rt 424 424 5		
   
!--- Set the service class for the voice bundle.

   !
   precedence 5			
   
!--- Set the IP precedence level critical to the voice bundle.

   !
 !
!
dial-peer voice 1 pots
 destination-pattern 1001	
 
!--- Define the telephone number associated with the port.

 !
 port 1				
 
!--- Specify the port number.

 !
!
dial-peer voice 10 voip
 destination-pattern 2...	
 
!--- Define the destination telephone number.

 !
 session target ipv4:192.168.2.8	
 
!--- Specify a destination IP address.

 !
 ip precedence 5		
 
!--- Set IP precedence to critical for voice traffic.

 !
!

Q. 如何配置Cisco 827-4V向H.323网守登记?

!
interface ATM0
 h323-gateway voip interface	
 
!--- Identifies this interface as a VoIP gateway interface.

 !
 h323-gateway voip id GATEKEEPER ipaddr 192.168.1.2 1719
 
!--- Defines the name and location of the gatekeeper 
 !--- for this gateway.

 !
 h323-gateway voip h323-id GATEWAY 	
 
!--- Defines the H.323 name of the gateway, identifying 
 !--- this gateway to its associated gatekeeper.

 !
!
dial-peer voice 1 pots
 destination-pattern 1001	
 
!--- Define the telephone number associated with the port.

 !
 port 1				
 
!--- Specify the port number.

!
dial-peer voice 10 voip
 destination-pattern +.T	
 
!--- Define the destination number pattern.

 !
 session target ras		
 
!--- Specify a destination to be RAS.

!
gateway
!

Q. 如何配置在Cisco 827 ADSL接口的线路编码?

A. 登录到Cisco 827,并从激活模式发出Cisco IOS dsl operating-mode xxx 命令,其中xxx是您的线路编码类型。

注意: 默认情况下Cisco 827 ADSL接口处在自动发现模式,并将自动发现线路编码,以便在连接到您的网络服务提供商(ISP)时使用。

以下示例显示设置线路编码对G.LITE。

Router>enable 
Router# 
Router#configure terminal 
Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#interface atm 0 
Router(config-if)#dsl operating-mode ? 
ansi-dmt ANSI full rate mode 
auto auto detect mode 
itu-dmt ITU full rate mode 
splitterless G.lite mode 

Router(config-if)#dsl operating-mode splitterless 

Router(config-if)# exit 
Router(config)# exit 
Router#write mem 
Building configuration... 
[OK] 
Router#

以下配置示例在其以后显示Cisco 827配置为G.LITE。

Router#show running 
Building configuration... 

Current configuration : 1198 bytes 
! 
version 12.2 

interface ATM0 
 no ip address 
dsl operating-mode splitterless 

!--- This is G.LITE mode.
 
! 
end

检验Cisco 827 ADSL接口是否处于G.LITE模式的另一种方式是发出Cisco IOS命令show controller atm 0。在输出中您应该看到(G.Lite)。例如:

Router#show controller atm 0
.Snip 
.Snip 
.Snip 
15 Real bd=0x80BFD628 Status=0x0 Buf=0x1F0222E Len=14 Own=0 
16 Real bd=0x80BFD634 Status=0x2000 Buf=0x1F0222E Len=14 Own=0 
          ATU-R (DS)              ATU-C (US) 
Modem Status: Showtime (DMTDSL_SHOWTIME) 
DSL Mode: ITU G.992.2 (G.Lite) 

!--- G.LITE mode is indicated here. 

ITU STD NUM: 0x01                0x1 
.Snip 
.Snip
end

Q. 如何配置NAT和PAT支持内部网络服务器?

A. 请参阅配置网络地址转换和静态端口地址转换支持内部网络服务器

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 12879