交换机 : Cisco 6130 IP DSL 交换机

配置 Cisco 827 路由器,以实现单个 IP 地址、DHCP 以及 PPPoA

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 23 日) | 反馈


目录


简介

此示例配置演示一个连接到 Cisco 6130 数字用户线接入复用器 (DSLAM) 的 Cisco 827 数字用户线 (DSL) 路由器,该路由器在 Cisco 6400 通用接入集中器 (UAC) 上终止。Cisco 827路由器配置作为有点对点协议的一个动态主机配置协议(DHCP)服务器在ATM (PPPoA)。

开始使用前

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

先决条件

本文档没有任何特定的前提条件。

使用的组件

本文档中的信息基于以下软件和硬件版本。

  • Cisco 827-4V客户端前置设备(CPE) IOS�软件版本12.1(1)XB

  • Cisco 6400 UAC节点路由处理器(NRP) IOS软件版本12.0(7)DC

  • Cisco 6400 UAC-Node交换机处理器(NSP) IOS软件版本12.0(4)DB

  • Cisco 6130 DSLAM-NI2 IOS软件版本12.1(1)DA

本文档中的信息都是基于特定实验室环境中的设备创建的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您是在真实网络上操作,请确保您在使用任何命令前已经了解其潜在影响。

背景信息

在这种情况下,互联网服务提供商给用户单个IP地址(172.18.0.1) Internet连接的,但是用户有PCs小型网络并且要访问所有设备的互联网访问。

显示的解决方案此处实现在Cisco 827路由器的网络地址转换(NAT)。NAT为IP地址简单化和保存设计;它启用使用未注册的IP地址连接到互联网的私有IP互联网络。NAT起作用路由器,通常连接两网络,并且转换在内部网络的私有(在这种情况下10.0.0.0网络)地址对法律(在这种情况下, 172.18.0.1)地址,在数据包转发对另一网络前。作为此功能一部分, NAT只可以配置通告一个地址(172.18.0.1)整个网络的。此提供附加安全性,有效隐藏在单个IP地址后的整个内部网络。

NAT在远程访问环境符合安全和地址保存双重目的和典型地实现。在本例中, 10.0.0.1的IP地址在Cisco 827路由器的以太网接口手工配置。Cisco 827路由器配置作为DHCP服务器,并且租用IP地址到本地LAN设备附加对其以太网。

以下配置显示为以太网和ATM接口配置的NAT。以太网接口(指定Ethernet0在下面的网络图中)有10.0.0.1的IP地址,与255.0.0.0子网掩码。NAT为里面配置,因此意味着接口连接对是受NAT转换支配的网络内部。ATM接口(指定Dialer0在下面的网络图中)有172.18.0.1的IP地址和255.255.0.0子网掩码。在Dialer0的NAT为从外部配置,因此意味着接口连接对一个外部网络例如互联网。关于端到端异步数字用户线路(ADSL) PPPoA体系结构的更多信息,参考PPPoA基准体系结构

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 要查找本文档所用命令的其他信息,请使用命令查找工具仅限注册用户)。

网络图

本文档使用下图所示的网络设置。

/image/gif/paws/12880/827dhcp_1ip2.gif

配置

本文使用如下所示的配置。

Cisco 827路由器
! 
version 12.1
service timestamps debug datetime msec 
service timestamps datetime msec 
! 
hostname R1 
! 
ip subnet-zero 
! 
ip dhcp excluded-address 10.0.0.1

!--- The DHCP pool does not lease this address; 
!--- it is used by interface E0.

!
ip dhcp pool <pool name>
network 10.0.0.0 255.0.0.0
 default-router 10.0.0.1

!--- The default gateway is assigned to local devices.

! 
interface Ethernet0 
 ip address 10.0.0.1 255.0.0.0 
 no ip directed-broadcast 
 ip nat inside
 no ip mroute-cache
! 
interface ATM0 
 no ip address 
 no ip directed-broadcast 
 no ip mroute-cache 
 no atm ilmi-keepalive
 pvc 1/150 
  encapsulation aal5mux ppp dialer 
  dialer pool-member 1 
 !
 hold-queue 224 in 
! 
interface Dialer0 
  ip address 172.18.0.1 255.255.0.0    
  ip nat outside     
  no ip directed-broadcast 
  encapsulation ppp 
  dialer pool 1 
  dialer-group 2 
  ppp pap sent-username <username> password <password>
! 
ip nat inside source list 1  interface Dialer0 overload 
ip classless 
ip route 0.0.0.0 0.0.0.0 Dialer0 
no ip http server 
! 
access-list 1 permit 10.0.0.0 0.255.255.255 
dialer-list 2 protocol ip permit
! 
voice-port 1 
 timing hookflash-in 0
!
voice-port 2
 timing hookflash-in 0 
! 
voice-port 3
 timing hookflash-in 0 
!
voice-port 4 
 timing hookflash-in 0 
! 
end

验证

当前没有可用于此配置的验证过程。

故障排除

目前没有针对此配置的故障排除信息。

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 12880